
[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Heredis 2021 Windows English
User Guide Heredis 2021
PDF September 22, 2020

                                   1 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Table Of Contents

What can Heredis do? ................................................................. 5
System requirements .................................................................. 7
How to download Heredis? .............................................................. 8
How to find the downloaded software? ...................................................... 9
How to install Heredis' software? ........................................................ 10

How to update Heredis? ............................................................... 12
How to install again Heredis? ........................................................... 13
Your license ....................................................................... 14
Activating Heredis ................................................................... 16
I have a new computer or a second computer – what to do? ...................................... 22
Uninstall an older version of Heredis ...................................................... 25
Launch Heredis ..................................................................... 29
Create a new genealogy file ............................................................. 30
Rename a file ...................................................................... 34

Record a file ....................................................................... 36
Create a new Heredis file .............................................................. 40
What is a Heredis file? ................................................................ 41
The Heredis File and .hmw folder ........................................................ 43
How to save your file ................................................................. 45
Open an existing Heredis file ............................................................ 49
Open a Chart file .................................................................... 52
Close and reopen a genealogy ........................................................... 53
Find a file on your computer ............................................................ 55
Presentation of the Heredis' interface ...................................................... 58
The different tabs and panels ........................................................... 64
The different data fields ............................................................... 69
How the Heredis data is structured ....................................................... 73
How to find a person in your navigation history .............................................. 76
Customize Heredis - Heredis Preferences ................................................... 77
Create the first person ................................................................ 88
The Root Person .................................................................... 93
Genealogy numbering ................................................................ 94
Implex (duplicate branches) ............................................................ 96
Save time by inputting faster ............................................................ 99
Consistency Control - Error-free data entry ................................................ 101
Summaries ....................................................................... 105
Add persons ...................................................................... 109
Add an unrelated person ............................................................. 116

Add parents ...................................................................... 119
Untraceable Parents ................................................................. 122
Add spouses ...................................................................... 124
Add children ...................................................................... 129
Add witnesses and participants ......................................................... 133
Add other linked persons ............................................................. 138
Input a Family Group Data ........................................................... 144

(Windows) Permanent control for duplicates & Merge two persons ................................ 146
How to delete? ..................................................................... 157
Input events ...................................................................... 158
Dates ........................................................................... 165
Input notes ....................................................................... 169
Media ........................................................................... 173

                                   2 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Alternate names ................................................................... 187

Facts ........................................................................... 188
Census .......................................................................... 191
Sources .......................................................................... 200
The different mode for Sources & Citations ................................................ 210
Indexes: generalities ................................................................. 218
Import an index into a Heredis file ...................................................... 228

The Sources Index .................................................................. 232
Repositories Index .................................................................. 237
Media Index ...................................................................... 244
Places Index ...................................................................... 251
Geolocating Places .................................................................. 271
Geolocating Place subdivisions ......................................................... 277
Zoom in on the World – Zoom in on a Place ................................................ 284
Zoom in on the World – Family Tree Mapping .............................................. 289
Contribute to OpenStreetMap .......................................................... 298
Migrations ....................................................................... 300
My dashboard ..................................................................... 301
Search Tracking Tab ................................................................ 317
Search Wizard .................................................................... 322

Searching in Online Archives .......................................................... 327
FamilySearch ..................................................................... 334
Compatibility Heredis & FamilySearch ................................................... 343
Smart Search ..................................................................... 344
Find/Replace ...................................................................... 353
Find Relationships .................................................................. 357
Searching for persons ................................................................ 361
(Windows) Searching by theme (enhanced criteria) from Persons panel ............................. 368
Research of Branches ................................................................ 371
Search for Sources .................................................................. 373
Search for other data types ............................................................ 375
Search for Places ................................................................... 378
Search for Media ................................................................... 380
Photo Tool ....................................................................... 382
Slideshow ........................................................................ 387
Create and Edit Sheets ............................................................... 391
Create and Edit a Book .............................................................. 401
{XE "xxxxxxxxxx Names" } tags in your documents, what to do? ................................. 408
(Windows) Pre-established reports ...................................................... 409

(Windows) Customize your Reports ...................................................... 418
Custom Reports .................................................................... 428
The Dynamic Ancestors Wheel ......................................................... 437
XXL Family ...................................................................... 445
Location Tree ..................................................................... 452
(Windows) Unlimited size tree chart : ancestors, descendant and hourglass .......................... 457
(Windows) Save the tree chart .......................................................... 471
(Windows) Predetermined size tree charts : Single-page Chart, Designed Chart, Fan Chart ............... 474
(Windows) Print or export as PDF the tree chart ............................................. 485
Heredis Online .................................................................... 488
Publishing with Heredis Online ......................................................... 497
Export Heredis data ................................................................. 501
Import a Heredis file in an existing file .................................................... 505
What is a GEDCOM file? ............................................................. 508
Export a GEDCOM ................................................................. 512

                                   3 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

How to export your Family Tree from Ancestry.com .......................................... 519
Open a GEDCOM in a new file ......................................................... 522
Import a GEDCOM into an existing file ................................................... 530
Share on the local network ............................................................ 536
Synchronizing via USB ............................................................... 540
Transfering to a mobile device without WIFI ............................................... 542
Any concern or issue when sharing with Heredis? ............................................ 546
What to do if something goes wrong in Heredis? ............................................. 548
How to ask a question on the Heredis forum? ............................................... 551

                                   4 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

What can Heredis do?

Heredis will assist you managing your genealogy. Thanks to its multiple functions and Heredis’ ongoing development, you
can:

Entering

Data

Who were your ancestors? Heredis will help you find them. Through guided and intuitive progression, you enter all the
information which you have gathered on your family. You will note some odd facts: your grandfathers were cousins, a certain
great-uncle was a witness to all the marriages in the family, your great grandmother was very young when she lost her parents,
one couple had more than 50 years’ age difference...

A research assistant will help you every step of your quest. You have access to all the power of the Internet directly from
Heredis' software.

For further details, see Add persons, Input events, Save time by inputting faster and more...

Illustrations

You have found some photos or copies of acts? Every item of data will be shown directly in your genealogy. The Photo Tool
will help you a simplify management of your media.
Unfamiliar with the area of origin of this family branch? Geolocation will show you that they all lived in neighboring towns.

For further details, see Photo Tool, Media, Geolocating Places.

Family tree charts and other documents

Your work is taking shape, you cannot wait to print the results of your research.

Print trees

Heredis Family trees trace ancestors or descendants in a variety of different forms and adapt to all formats.

For further details, see (Windows) Predetermined size tree charts, (Windows) Unlimited size tree chart or (Mac) Unlimited size
tree charts, (Mac) Predetermined size tree charts.

Print reports, sheets, or fully illustrated books

All documents which the genealogist needs are available: working papers for refining your research, person or family sheets
for your filing system and even illustrated books for preparing a family monograph which will bring you pride and happiness
to your family.

For further details see Create and edit sheets, (Windows) Create and edit reports, (MAC) Create and edit a report, Create and
edit a book.

Making your work known to others

What could be more simple than the free online publishing of your work on the Internet? Wherever they may be, your family
and friends can visit your site and contact you to give you more details. With your family site hosted free on Heredis Online,
your family bonds are facilitated, your work valued and your data preserved.

For further details, see Heredis Online.

                                   5 / 555

https://help.heredis.com/en/add-persons/


[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Exchanging

Genealogy is an act of sharing. Heredis gives you all the tools which you need to communicate with other genealogists, give
and receive information and have your work available everywhere, on all your devices (desktop or laptop computer, Windows
or Mac, iPhone, iPad).

For further details, see Share your genealogy, Export Heredis data, Export a GEDCOM.
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System requirements

Important: Your licence is personal and confidential, you can use it 3 times. If you bought Heredis on our Shop, you can
manage your installations in My installations section of your Heredis account.

Windows

Windows from 8.1 to 10
500 MB disk space required
Screen 1366×768 minimum (11")
Local administrator account
Internet connection for research, publishing, integrated maps and dashboard

For an optimal use :

Windows 10
8 GO of RAM
SSD Hard Disk

Mac

Mojave (10.14), Catalina (10.15), Big Sur (11.0)
500MB disk space required
Screen 1366×768 minimum (11")
64 bits only
Internet connection for research, publishing, integrated maps and dashboard

For an optimal use :

8 GO of RAM
SSD Hard Disk

Other software to detain

A text processor managing the RTF and DOCX formats is necessary to edit documents such as sheets, lists or books. You can
open easily those documents with the main freeware and software text processors.

Adobe Flash Player and Adobe Reader are often used by Archives websites.
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How to download Heredis?

Visit Heredis'shop to buy and download Heredis' software.

You will receive an email with your licence code and the link to the shop to download the software.

(Mac users) You can also buy and download Heredis from App Store, the license is included, you will not see it, it requires to
be connected to your App Store account.

How to download again Heredis ?

If you bought Heredis already and want to install it on your second computer or install it again check this article: I have a new
computer or a second computer – what to do?
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How to find the downloaded software?

(Windows) Click on the search field in the Start menu or toolbar and write InstallHeredisWorld20xx.exe, press Enter.

You can also go to your Downloads folder.

See also How to install Heredis' software?

(Mac) Go to Downloads and search for InstallHeredisWorld20xx. Double-click on the file to install Heredis.

See also How to install Heredis' software?
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How to install Heredis' software?

Windows

Double-click on InstallHeredisWorld20xx.exe file.
Follow instructions, it will guide you through the setup process.
When setup is over, double-click on Heredis 20xx icon on your desk or access through Windows explorer (Programs (x86) –
BSD Concept – Heredis 20xx World).

Then login to activate your licence. For further information see Activating Heredis.

Mac

Click on the downloaded link. When the download of InstallHeredisWorld20xx.dmg is over, the installation windows opens. If
not, double-click on the downloaded file.

In the Installation window:

1. Drag the Heredis icon  in Applications

Example of icon to be dragged, according to your Heredis version, this image and version number may vary.
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2. Open the Applications folder and start Heredis. Drag and drop the Heredis icon to your dock to easily access Heredis.

Then login to activate your licence. For further information see Activating Heredis.

Launch Heredis

After activating your Heredis license (see Activating Heredis), click on Launch Heredis to start working. If you already have
Heredis' files from an old version, Heredis 20xx will convert them automatically on the first opening with the newer version.

(Windows) If you do not see your files on recent files, click on Open a genealogy in the home page and choose the file to
open. If the files are too old (before Heredis 11), they might not convert themself. Contact us through our Contact form and
will send you the procedure so we can convert it for you.

(Mac) Files previous Heredis 2014 might not convert themself, contact us through our Contact form and will send you the
procedure so we can convert it for you.

Uninstall my old version of Heredis

Each new version of Heredis is a full installation. So it is not necessary to keep your old version of Heredis. Your file will still
be on your computer. You can uninstall the old version to get some space on your computer.

(Windows) Uninstall your old version from the Control Panel then click on Uninstall a program. Choose your old version of
Heredis and click on Uninstall. Windows 10 you can make a right click on program directly on the program list, then choose
Uninstall.

(Mac) Drag your old version of Heredis from the Applications and drop it on the Trash Can.

See Uninstall an older version of Heredis for more details.
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How to update Heredis?

Heredis corrective updates (patches) are automatic and free (example : from Heredis 20.1 to Heredis 20.2). You do not need to
bother with this, a window opens when you launch Heredis to indicate that an update is available. Simply accept and the
download/install starts.

To be kept informed, simply be connected. When Heredis can be updated, just accept the downloading and installation of the
update.

(Mac) If you acquired the Heredis software via the App Store, you will be notified of updates.

Check the AppStore icon  in the dock. It shows the number of application updates available. Click to access the App Store
then follow the instructions to update.

Upgrading is not automatic. When you upgrade, your version changes (ex: Heredis 2019 and Heredis 2020), it has new
features, that is why it is not free.

Check for updates

If you ignored an update, you can check for updates by clicking on Help menu > Check for updates.

(Mac) Check for updates message

(Windows) Check for updates message

If a patch is available, validate the download and installation. It is important to download and install a corrective patch because
if we make corrections, it means there have been changes as a result of feedback from our users.
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How to install again Heredis?

If you acquired the software through the Heredis store, you may download the application from your Heredis'shop account in
My Keys section. See I have a new computer or a second computer - what to do? to see the full explanation.

(Mac) If you bought Heredis from App Store, you can download it directly from App Store as any application. (no licence
needed if you bought from App Store, just connect to your App Store account).

Once downloaded and installed, you will have to click on Login to connect to your Heredis' shop account with your email
address and password used to buy Heredis.

If you installed Heredis on a second computer, see the article on Share on local network to share your file with the second
computer.

You can also find the downloads of the software in Heredis.com.

Note: Your licence is available for 3 installations, if you need more, you'll have to buy an other licence. (Since Heredis 2019)
You can manage your installations and delete a computer you no longer use from the software. Click on the Help menu then on
Manage my installations.

You can also download from Heredis.com website.
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Your license

I have lost my license number?

Connect to your Heredis shop account and get your license number in My acccount > My keys.

 

 

My license is invalid

If your licence has been used too many times (3 are allowed), it will be invalid.

You can manage your license installations to detach one of your unused computer. Connect to your Heredis shop account and
click on My installations.

See Activating Heredis for further details.

How to register my Heredis number?

Since Heredis 2019, you do not need to input your license number, just connect to your Heredis account (the one you bought
Heredis with). Click the Log in button in the activation window when you first open Heredis. Your license will be activated
and associated to your email address.

If your computer is not connected to the web, at the installation of Heredis' software, input your license number by clicking the
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Enter button.

On how many computers can I install Heredis?

By accepting this EULA, you receive a limited license, personal, worldwide and free of copyright, nonassignable, not
resaleable, non-transferable and non-exclusive, for the use of this software. You are authorized to use one (1) copy of this
software for personal, non-commercial ends as a private user. One license only is granted for each unique home address
(“address”). You are authorized to download and install the software on one computer only. Users who have several computers
(e.g. one independent computer, a laptop and a netbook), may download the software on a maximum of three (3) units at the
same address. If you buy several licenses for this software, you may at any time, make as many copies as you own licenses.

I would like to receive more information on Heredis products.

Join the Heredis Facebook page and stay tuned on everything genealogy: you’ll get the most recent Heredis new updates, as
well as information shared by our users, new blogs, articles from genealogy magazines…
Subscribe to the Heredis Newsletter and preview all the news on your Heredis software and genealogy in general.
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Activating Heredis

Thanks to the new license activation process, as long as you are connected to the internet, you no longer need to enter your
license number.

All you need to do is log into the account you used to purchase Heredis (on our online store) and your license will be activated
automatically.

A heredis license for Mac is valid only for Mac. Similarly, a Heredis licese for Windows is usable only for Windows. If you
change your operating system, you'll need o acquire a license for the new system.

How to install and activate Heredis on a computer connected to the internet

Start with the purchase of a Heredis license on Heredis' Shop, then download and install the Heredis software on your
computer.

See also these articles to know how to download and install Heredis: (Windows) Install Heredis or (Mac) Install Heredis.

The first time you launch Heredis, it will display a page offering you to either try the software or to login to the account used to
purchase Heredis.
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When you login to your Heredis account, the license you have just purchased will automatically be assigned to the computer
on which you have just installed Heredis.

How to install and activate Heredis on another computer connected to the internet

Heredis can be installed on up to 3 of your own computers.

Download and install Heredis from your Heredis'Shop account (under My Licenses & Codes) onto your other computer and
log in to your account.

Note: when you reach the maximum number of installations allowed on your license, Heredis informs you that you can no
longer install this license on an additional computer and offers to help you manage your installations in order to potentially
detach a license from a computer you no longer use so you can then install it on another computer.
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How to install and activate Heredis on a computer that is not connected to the internet

Clicking on the Enter button will allow you to enter your license number and to get full access to your software and its many
features.
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Then enter your license number. It was sent to you right after your order of Heredis.
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Note: If this computer is later connected to the internet, the following time Heredis is launched you will be asked to log in to
your account to finalize the activation process.

How to manage my Heredis installations

Easily access the management of your installations, either from your account on our Heredis' Shop or directly from the
application by clicking on the Help scroll-down menu > Manage my installations. This window will display all the
information on your licenses, starting with the 2019 Heredis version, including the numbers of the licenses you purchased, the
related order number, date of purchase, and if your product is for Mac or Windows.

For each license you own, it is easy to see which computer(s) it is assigned to.

A History button will allow you to visualize all actions related to each license (assigning a new computer, detaching...)

How to detach a license

If you no longer use your Heredis software on a computer, uninstall the application from this computer then log in to your
account on Heredis' Shop, click on My Installations, and detach the computer you no longer use so you can install this license
on another device.

In case of problems
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Heredis needs an internet connexion to activate your license. Often, firewalls and antiviruses are too uncompromising and
block Heredis. It can provoque white pages while trying to activate Heredis' license, blocking the installation of the software...

Check that the antivirus/firewall installed on your computer or embedded in your internet box does not block Heredis. If so
desactivate it while installing Heredis and autorize Heredis to access the network, tell those software that Heredis is
trustworthy.
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I have a new computer or a second computer – what to do?

Heredis is a desktop software, which means that your files are saved on your computer. You are the only one who can retrieve
them, as we do not have access to your files. Which is why you should always back them up either on a USB drive, a cloud or
an external hard drive.

Downloading Heredis

Heredis can be installed on up to 3 computers you own.

Note: Once you have reached the maximum number of installations for a license, Heredis will warn you that you can no longer
install this license on another computer. Heredis will suggest you manage your installations to potentially detach a license from
a computer you are no longer using and install it on a new computer.

You can download Heredis from your Heredis store account.
Log in by clicking on the Sign In button, enter the email address and password you used to purchase Heredis. If you are
already logged in, click on the Hello… button.
Then click on My Keys.
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You will find a Details button allowing you to find the Download button.

Perform the installation as for any software and activate your license for this computer. See the Activating Heredis.

Your files

In order to find your files, be aware that on Windows, they are usually stored in Documents / BSD Concept / Heredis / Heredis
Files.

On Mac, there is no usual storage, you will find the file where you chose to put it. So use your Finder to find the .hmw file (it
is the Heredis format).

Before changing computers, remember to make a copy of your .hmw folder (see also The Heredis File and .hmw folder) on a
USB key or an external hard drive.
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After changing computers, if you made a copy on a USB key or an external hard drive, copy the (Windows) .hmw-folder/
(Mac) .hmw-file named after your genealogy and paste it into your computer (on Windows, into Documents / BSD Concept /
Heredis / Heredis Files) . Launch Heredis and click on Open a Heredis file.

If you have not made a copy but still have access to your old computer, you can share your file on the local network:
- turn both computers on
- check and make sure they are both on the same internet network
- launch Heredis (same version) on both computers
- on the old computer, click on the File dropdown menu, then select Share on Local Network...

Heredis will transfer your file from your old computer to the new one.

For more information, see the article entitled Sharing your genealogy with other devices on local network.

If you no longer have access to your old computer and have not saved your data to a USB key or an external hard drive, then
your file is lost. We have no access to your data.
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Uninstall an older version of Heredis

Each Heredis version you download is the full software itself. Therefore, it is unnecessary to keep your older versions of
Heredis.

To uninstall Heredis from your computer:

On Windows 10

Click on the Windows button then on the indented wheel  
Click on Apps
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3. Search in the lists of your apps the old version of Heredis. Click on it and then click on Uninstall button.
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On other Windows versions, uninstall old version of Heredis from the Windows Control Panel / Uninstall a program.
According to your Windows version, the access to the Windows Control Panel might be different. Make a search on the
internet with a search engine to learn more about how your Windows works. By using the Windows utility, your old version of
Heredis will be properly uninstalled.

On Mac

1. Open your Finder, click on Applications
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2. Drag your old version of Heredis and drop it into the Trash Can
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Launch Heredis

Double-click the Heredis icon  (it looks like a leaf, the color depends on the version you have) to launch the
application.

(Windows) For a quick access, slide the icon from BSD Concept Program menu to your taskbar, wherever it is convenient for
you.

(Mac) For a quick access to Heredis, select the icon  in the Applications folder, drag it to your dock, wherever it is
convenient, or drag it to the Launchpad icon.
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Create a new genealogy file

From the Home Page, click New Family File.

Windows' Home Page
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Mac's Home Page

Save your new genealogy, give it a name and specify the desired location for the file.

An empty Immediate Family screen appears, and you may now start entering your data by clicking on the Create the first
person link at the center of the screen.
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The proposed data entry screen is ready and easy to fill in. Enter all known information and thus you have created the
individual who is at the base of your genealogy: the root person.

You can also check you Create the first person article.

 

                                 33 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Rename a file

You need to be on the Heredis home page in order to rename a file.

A Heredis file is actually made out of several smaller files within the same folder (or “bundle”) entitled
nameofyourgenealogy.hmw.

If any of the smaller files is named differently from the others, Heredis will be unable to launch your file. You'll encounter an
error message telling you "The file nameofyourgenealogy.heredis jas been removed from its original folder or has been
renamed. To ensure proper use of your genealogy file, please relocate it in the nameofyourgenealogy.hmw folder or rename it
..."

To prevent this from happening, the Heredis team has created a specific tool: on the home page, click the indented wheel
located to the right of your genealogy name and select Rename file…

(Windows) Home page

(Mac) Home page
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Note: Computers are not very fond of files with long names, special characters and spaces, which can damage your data. Do
avoid using accents, cedillas, spaces, and other special characters. Think simple! In lieu of spaces, archives centers (among
others) use the _ (underscore) sign. For example: "file_of_francois".

See also (Windows) The Heredis file.
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Record a file

Consider regularly recording your genealogy during your work session. When the file has been changed, (Windows) a star
appears next to the file name, (Mac) a black dot appears in the file window closing icon; it needs to be registered.

A record overwrites the old version of your file, unlike a backup, which it is a photo of your file in the state at a time T. It is
always useful to make a backup at least once a month on external device in addition to the recordings. See also How to save
your file.

Manually

Click the Save 
button, or choose File> Save.

Automatically

For security you can program automatic recordings of your data.

(Windows) Automatic recording
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(Windows) 1. Select Preferences - Heredis Preferences in the Tools menu.
2. Click on the General tab and check the Activate every... You can specify the rate at which you want the data to be
recorded.
3. If you check the Confirm Saves box, Heredis will ask for confirmation with each automatic check-in.

(Mac) Automatic recording
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(Mac) 1. Choose Preferences from the Heredis menu.
2. Click the General tab and check the Activate box in the Automatic Record area. You can specify the rate at which you
want the data to be recorded.
3. Check the Confirm Saves box so Heredis will notify you before each automatic check-in.

Save a file under another name

If you want to make a copy of your genealogy, to create a copy or another version, you can save the file under another name or
in another location.

(Windows) Select the File menu > Save a Copy . Indicate the duplicate file's destination folder. Heredis creates a new .hmw
folder, containing genealogical data (file .heredis) and folder containing media or a .ha file if it is a tree file. Click the 
Save button.
Heredis launches the Windows Explorer and shows you where the copy was made. You can move it, open it or close the
window, depending on your needs. Your original file is still open and you can keep working.

(Mac) Choose File > Save as,then indicate a name and location.
The file with the new name is open on the screen. To work with the previous version, choose File > Open Recent and choose
the previous version in the sub-menu.

See also The Heredis file and .hmw folder.

(Mac) Back to the recorded version

Heredis gives you the opportunity to reopen your genealogy as it was the last time it was recorded. This possibility is very
useful when you have made an error importing a file, for example.
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Choose File > Revert to saved ... Heredis closes the active genealogical file without saving it and then reopens it as it was
before the last changes.

Info - All changes made after the last record are lost.

 

                                 39 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Create a new Heredis file

From the Home page, choose New Family File.

Choose where your file will be stored in .hmw format and click Open. On Windows, click Modify to change the default
location > (Documents > BSD Concept > Heredis > Heredis files)

Warning: NEVER change the different files included in the folder in .hmw,your genealogical file would be damaged and
unusable.

For more information, see What is a Heredis file?
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What is a Heredis file?

Heredis files come in the form of a .hmw folder stored at the chosen location when it was created. On Windows, they are stored
by default in aDocuments/BSD Concept/Heredis/Heredis Files folder of your documents. Documents

In this folder you will find various types of files: .bak, .hmw,media folder...

Do NOT change, move or delete files in this folder. Indeed, if you move, rename, modify these files, you may no longer be
able to use this genealogy.

To rename your files or know where they are stored, use the indented wheel from the Heredis homepage.

(Windows) To find out where your files are stored click Show the file location in computer.

(Mac) To find out where your files are stored click Reveal in Finder.

(Windows) Homepage indented wheel

(Mac) Homepage indented wheel
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Check out the article Find a file on your computer for more details.
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The Heredis File and .hmw folder

This article is usable for Mac too, however, Mac hides the inside of the .hmw folder. So the risk of making a mistake by
erasing something is low for Mac.

In Windows, your Heredis file appears as a folder with a .hmw extension. (for instance: Sample File.hmw).

Note: file extensions may not be shown, depending on your computer’s settings. We recommend modifying these settings
using Windows Explorer:
– from the « View » menu, by checking the option « File name extension », for Windows 8 operating systems and later
versions;
– from the « Folder and Search Options » menu, in the « View » tab, for operating systems older than Windows 8, by
unchecking the option « Hide extensions for known file types ».

• Important
Your genealogy file contains all the data you have entered (Sample File.heredis – Type: Heredis Genealogy) as well as a 
Media file in which all the media you have used have been copied. In order for your file to work properly, make sure to
neither separate nor delete the elements included in the file.

If you wish to move, copy, or save your genealogy to another location on your hard disk drive or on any other drive, make sure
to select the entire Sample File.hmw folder.

• Essential
If you have removed the Sample File.heredis file from the Sample File.hmw folder, you'll have an error message:

Move it back to the .hmw folder so you can use it.

CAUTION, when naming your files, keep it simple and avoid using special characters, accents, and such (,$§… computers hate
those. Rather use _ or – in lieu of spaces.

The Data file (Sample File.heredis) only contains graphic thumbnails of the media you’ve used. The Media file contains a
copy of all original media linked to your data (photos, scans, web documents, text…). Even if you have lost or moved your
original media, this folder, integrated within your genealogy, allows you to preserve, transfer, or save your genealogy media in
a high resolution.
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• Note
Your original media are still in the location where you had saved them. Heredis has neither moved nor modified them, they
have only been duplicated. Do no modify the content of the Media folder or your genealogy will not work properly. See also 
Media.
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How to save your file

(Windows) How to create a copy of your file

To duplicate the file open on your computer – so you can save or modify it:

Select Save a copy... from the File menu.

Give a name to this copy. Do not use names with special characters. Click on Modify to select a destination folder for
your duplicated file. Heredis will create a new .hmw folder which will include your genealogical data (.heredis file) and
a folder in which you will find the related media or a .ha file (for tree charts). It is safer to choose to store your copies
on a USB key, a cloud or an external hard drive disk instead of you computer's hard drive disk.
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Click on OK button to validate the storage place and again on OK to validate the copy.
Heredis will launch Windows Explorer to show you where the copy has been saved. You are free to move or to close
the window. Your original file remains open on your computer and you can keep working on it.

(Mac) How to create a copy of your file

To duplicate the file open on your computer – so you can save or modify it:

Select Save As... from the File menu.

Give a name to this copy. Do not use names with special characters. Click on the arrow near the storage place to select
a destination folder for your duplicated file. Heredis will create a new .hmw folder which will include your genealogical
data (.heredis file) and a folder in which you will find the related media or a .ha file (for tree charts). It is safer to
choose to store copies on a USB key, a cloud or an external hard drive disk instead of you computer's hard drive disk.
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 Click on the Save button.
Heredis will open the newly created file. You can close it and go back to your original file.

How to save a copy of your file on a USB flash drive or on an external hard drive

Besides creating a backup file on your computer’s hard disk drive, you can synchronize your  file on a USB key or external
hard drive. It is not like Save as, since it overwrites the previous version of the file.

Users without Wi-Fi or with computers kept at various locations should also sync their genealogy by connecting a removable
data storage device (USB flash drive or external hard disk drive) to their computer.

Click on File menu > Sync via USB
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In the synchronization window, select the external device you have connected, check the syncing direction (Send or Receive)
according to your needs, then click on Send.
Once the syncing is completed, you are free to connect the storage device to your other computer (Mac or Windows).

Whether you are working in Heredis or launching the program, Heredis will let you know that a new genealogy file – or a
more recent version of the opened genealogy file – is available on the external storage device you have just connected; you will
be offered to sync this file to your computer.

See Synchronizing via USB for more details.
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Open an existing Heredis file

There are several different ways to open a Heredis genealogy file.

Open a genealogy file if it is not in the recent file list

To open a file when Heredis is already running, choose File menu > Open. Choose the genealogy file in your file
directory, and then click Open.

(Mac) To open a file from the Home page, if you already have a file launched, click the Home  button. On the
home page, select Heredis File in the Open menu. Click OK and then select the file.

(Mac) To open a Heredis file from the Finder, double-click the file icon or drag it to the Heredis application icon.
You may open a Heredis file created with an older version of the software from the home page if they were created
with a version equal to or after Heredis 2014. Prior to Heredis 2014, the Heredis format was different. Contact us, we
can convert it for you for free.

(Windows) To open a file from the Home page, click on Open a Heredis file, select the file on your hard drive disk
and click on Open.

(Windows) You can open a Heredis file created using an old version of the software, you will need to change the file
type in the opened window. Indeed, before Heredis 2014, the file format had a different extension to each
version. Click the Heredis Files drop-down list and choose All Heredis Files. You will see the files in the old formats.
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Info • By default the last folder in which you saved a file will open. To select another location, select it in your file directory.

Info Windows and Mac • Files created after the 2017 version are identical, regardless of the platform your using: Windows,
Mac, iOS, Android. You can directly exchange data without any preparation or conversion.

For more details on opening a GEDCOM file, see Open a Gedcom in a new file, Import a Gedcom into an existing file.

Open a recently used file

To open a file you worked on recently, open Heredis' home page, (Windows) choose it on the recent files area, (Mac) select
the file from the Open Recent menu, select the file in the drop down menu and then click OK.

You can also select File menu > Open Recent. Choose the file and click OK

Mac Info • To delete the list of recently used files, choose File menu > Open Recent > Clear. The file will not be deleted
from your hard drive disk but won't appear in the Recent file list.

Windows Info • To delete a recently used file, click on the indented wheel near the name of the file you want to remove, then
choose Remove from Recent Files. The file will not be deleted from your hard drive disk but won't appear in the Recent file
list.

Important : Heredis is a desktop software, which means your files are on your computer's hard drive. You are the only one able
to access it, we do not have your files. That is why you need to save your work on an external device. If the file is missing
from the Recent Files list, just because it is no longer in the Recent Files list does not mean that it has been deleted! Heredis
never deletes your files! It’s just that the list of recent files has been cleaned.

To find your files, on Windows, they are usually stored in Documents > BSD Concept > Heredis > Heredis files. You can use
the Search on hard drive disk function on the Home page to launch a scan of your hard drive disk.
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On Mac, use your Finder to search for your files by indicating .hmw in the research bar after selected your hard drive disk in
the device list.
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Open a Chart file

You have edited and saved a tree chart created with Heredis? You can reopen it to further edit it or print it. A tree chart file is a
graphic file, it becomes independant of your Heredis file. It contains only the data of persons included in the tree chart. Data
can not be changed in this tree chart file to modify the Heredis file.

To open a tree chart saved when Heredis is already running, choose File > Open. Select the tree chart file your file
directory and click Open.

To open a tree chart from the Home page, click the Home 
 button and choose (Windows) Open a Chart file;

(Mac) Chart File from the Open menu. Click OK and then select it.
To open a tree chart file when another tree is already open, click (Windows) File > Open; (Mac) the Open button in
the tree chart toolbar. Select the file in your tree chart directory of files and click Open.

Read also (Mac) Unlimited size tree chart : ancestors, descendant and hourglass, (Mac) Save the tree chart, (Mac)
Predetermined size tree charts: Single-page Chart, Designed Chart, Fan Chart, (Windows) Unlimited size tree chart : ancestors,
descendant and hourglass, (Windows) Save the tree chart, (Windows) Predetermined size tree charts : Single-page Chart,
Designed Chart, Fan Chart
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Close and reopen a genealogy

Close a genealogy file

When you have finished working with a genealogy file, you can close it without leaving Heredis.
• To close the active document, choose File > Close. You can also click the Close button in the upper (Mac) left, (Windows)
right corner of the file.

• To close all open Heredis documents, press (Windows) Ctrl-Q; (Mac) the Option ( ) key, then click the Close button of
the active document.

Info • If you have made changes since you last saved the file, Heredis will invite you to save it.

Note: When you close Heredis, wait a few mintues before to shut down your computer, Heredis can take some time to close
properly. If you shut down too quickly your computer and Heredis didn't finish to save the modifications you made, you will
damage your file. It only takes a minute so please be patient. Computers are just like genealogy, they require patience ;)

Reopen a genealogy file

Select your genealogy from the (Windows) Recent Files, (Mac) Open submenu

or (Mac) double-click the file in the Finder.

(Windows) click on Open a Heredis file,

 (Mac) click on Heredis File on the Open section, then click on OK.
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If your file is not on the recent files, it doesn't mean it has been deleted! Heredis will never delete your file!

The recent files list might have been cleaned by your operating system or by you after a spring cleaning.

You file is stored on your hard drive disk. It can easily be found. However, you should make regular backups of your file in
case your computer crashes or you need to reinstall your operating system etc. Check out How to save your file article.

Windows Info: If you don't remember where to find your file on your hard drive disk, click on Search File on Hard Drive.
Heredis will scan your hard drive searching for all Heredis and GEDCOM file format.

Mac Info: If you don't remember where to find your file on your hard drive disk, open your Finder and write .hmw in the
search bar.
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Find a file on your computer

Heredis is a desktop software, which means that your files are saved on your computer.

Note: It is essential that your files are stored and launch from your computer's hard drive disk and not from a USB key or an
external drive or a cloud. If the device is disconnected for any reason even for a second, Heredis will shut down and your file
can be damage.

You are the only one who can retrieve them, as we do not have access to your files. Which is why you should always back
them up either on a USB drive, a cloud, an external hard drive (just use it to store a backup not open it).

Find your files in Windows

To find your Heredis files in Windows, look in Documents / BSD Concept / Heredis / Heredis files, as this is where they are
usually stored. If not, on the Heredis home page, click on the indented wheel near the name of your recently used file. Then
select Show the File Location in computer…

Heredis will open Windows Explorer to show you the content of your .hmw folder. Click on the folder before the .hmw folder
on the address bar.

You'll be able to copy the .hmw folder with a right click on it and click on Copy. Then Paste it on a USB key or external hard
drive.

Find files missing from your list of Recent Files

If your file is no longer showing in your recently used files, it does not necessarily mean that it has been deleted. It is simply
not displayed in the list of recent ones.
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Heredis will not remove genealogy files. If your files are no longer on the computer, it means they were manually deleted, e.g.
during a disk cleanup or by your antivirus software.

You can start a search from the Heredis home page to scan your entire computer for all potential genealogy files. It can be a
lengthy process.

From the home page, click Search File on Hard Drive on the left side banner.

How to find your files on Mac

From the Heredis home page, click on the indented wheel next to the name of your recently used file. Then select Reveal in
Finder.
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You'll be able to copy the .hmw folder with a right click on it and click on Copy. Then Paste it on a USB key or external hard
drive.

How to find files missing from your list of Recent Files

If your file is no longer showing in Recent Files, it does not necessarily mean that it has been deleted. It is simply not displayed
in the list of recent ones.
Heredis will not remove genealogy files. If your files are no longer on the computer, it means they were manually deleted, e.g.
during a disk cleanup or by your antivirus software or the list has been cleaned in the Mac system.

Open Finder
Enter .hmw into the search box
Launch the search
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Presentation of the Heredis' interface

Genealogy files

The genealogy file will open as a global screen. This screen can either occupy all available space, or occupy only a part, or be
iconized.

Each input of surnames, given names, occupations, sources, places, medias generates indexes. The generated information are
changeable by clicking in the menu "Tools / ... Index..." or in the concerned search panel.

(Mac) Display several working windows

Several views of the same genealogical file may be opened simultaneously: the main navigation screen, tool screens (Indexes,
Search for duplicates), tree chart screens, document screens, the Preferences screen...

Display several genealogies simultaneously

Several genealogies may be opened simultaneously with Heredis. Each file can display data differently: in Family, in Data, in
History or in Search. The list of open files and all screens open for each file is available in the Window menu. Click the name
of the file or screen you want to display in the foreground.

The Home Page

Windows's Home Page

It allows you to open an existing genealogy, to create a new one, to import a genealogy from a Gedcom file or a Heredis file 
(Windows) from the black banner on the left of the screen, (Mac) from the pop-up menus.

Mac's Home Page
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To find again this screen when you are already in a working session, click on the Home icon of the toolbar or choose File
> Home Page.

The main Screen of Heredis

Heredis' software reacts just like any other application / software. It can be resized, displayed full screen (Windows) or
iconized in your taskbar; (Mac) or iconized in the dock.

The Heredis' working space is entirely flexible to be adapt to your methodology and offer all the tools within reach.

The main screen Mac
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The main screen Windows

The Menu and Toolbar

At the top, menus and buttons provide access to all functions of the software. Buttons are different depending on whetever you
are managing data or building trees.

Menu

                                 60 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

(Windows)

(Mac)

Toolbar

Some buttons allow access to more detailed choices: Add (> Unrelated Person ...), Find (> Search Number ...), Indexes (>

Given Names ...). The toolbar may be modified at any time to meet your work needs: click Customize Toolbar  to add,
remove or rearrange buttons on this bar.

See the article Customize Heredis for further details.

The buttons

See the Buttons article.

The central part of the screen displays four tabs.

You visualize your genealogy better under the XXL Family view or you like to study their movements in Migrations. You
prefer to work on Descendants? Click on the Family tab or History tab to select the screen of your choice.

The Family tab allows you to choose between different views of the immediate family of the primary person. It develops as
and when you enter data, each person taking his/her place in the organization of the family.
The Data tab allows you to add information at any time concerning the primary person and his/her immediate family. Use the
Family Group Data to save time.
The History tab displays the migrations of the primary person.
The Search tab provides a helpful research tool to assist you in reviewing your work and evolving your genealogy. The top of
the screen shows the known or missing information. The bottom part of the screen allows you to send a search online on the
websites of your choosing in the main existing genealogy website. You can also use the Family Search button to access your
family search account and do a research on the primary person and find his/her ancestors and progeny.
The Graphs tab displays the dynamic ancestors wheel.

For more details, see The different tabs.

Search and Tool Panel

On both sides of the main screen, there are removable panels which provide access to data lists or tools.
Their presentation is customizable. Open and scroll the panels, (Mac) move them to improve your personal organization, add
columns to the panels, choose how they appear (one at a time or all visible at once) or hide them.
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(Mac) At the bottom of the Heredis screen, you can find the management button for the panels and all the key information
concerning the genealogy which is open.

Search Panel

This panel has five tabs allowing your to search inside your file: Persons, Branches, Places, Media and Sources. Additions,
deletions or changes are possible directly from this tabs, except the Branches tabs. You can use them to complete your
genealogy with drag and drop function. From the search panel you can also do your researches without using the Search menu.

Windows' Search Panel

Mac's Search Panel

Tools Panel

Some tabs are about the primary person (Kinship), the others contain tools (Dates, Bookmarks).

Windows' Tools Panel

Mac's Tools Panel
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For more details, see Customize Heredis/Customize the panels.

Navigating

Explore all the family branches and display the people you want to view, edit or print documents concerning to them.
Drag any person displayed on the screen to change their position: select a child and drag to the grandfather box. If this person
is indeed a grandfather, a new Immediate family appears.
Drag any person shown in the removable panels or on any data entry tab input or from one panel to another: a bookmarked
individual as the primary person, an uncle to the bookmarks, a person from any of the Indexes to the bookmarks, or as primary
person etc.

Display the Navigation panel  and use it as a compass. A simple click will navigate to the parent, the spouse, a
child or sibling. For a list of spouses, children or siblings, right-click their location on the panel.

Navigate according to Ahnentafel numbering with the Next Ancestor  - Previous Ancestor arrows.

Click Root Person on the toolbar to return to the person at the base of your genealogy.

To view any person according to his number, choose  Find (> Search Number...) and navigate directly to the person.

Use the Back  and Forward arrows to redisplay those already consulted. For a history of your browsing, position the
mouse on the relevant arrow and a list is displayed.

(Windows) For a history of your browsing, hold down the mouse on the arrow next to the button and choose from the list
displayed or select Navigation History.

(Mac) For a history of your browsing, position the mouse on the relevant arrow and a list is displayed.
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The different tabs and panels

The different tabs

Heredis memorizes the last viewed screen and will reopen the corresponding tab when you click on Family, Data,
History, Search, and Graphs.

Family tabs

They are used to navigate between the different family members and to create them if necessary.

The Immediate Family screen displays the family members who are close to the primary person (parents, grandparents,
spouses, children).

The XXL Family screen shows the family of the primary person, his/her parents, grandparents, spouses and children but also
every relative who possibly knew him/her and you will get an XXL view! For further details see XXL Family.

The Ancestors’ screen presents 4, 5 or 6 generations of ancestors of the primary person.

Change the number of generations displayed with the indented wheel  icon or you may start printing the ancestry
as it is displayed.
You can also display views of the ancestors' origins by town, county, state/province or country. For further details, see
the article Location tree.
This screen is dynamic; click the arrows at the end of the line for the following generations. If necessary, you can create
new ancestors.

The Descendants screen shows the number of generations of your choice.

You may configure its display fro mthe indented wheel , with the presentation of generations and the data format.
Implex highlighting allows you to easily identify consanguine marriages.

The information displayed for descendants as well as for its printing are also available from the indented wheel 
 icon. When you click on Print, choose the presentation you want in the 2 tabs of the displayed window and click on 
OK. Heredis will create a document that will open with your word processing software.

Data tabs

The Personal Data screen shows all the data entered and allows you to add or complete events for the primary person
or for the couple. You access the Personal Data tab for any person displayed by double-clicking on the name.
The Family Group Data screen provides a summary of the information entered for the primary person and allows you
to add all the members of his/her immediate family (parents, spouses, children, step-children) without having to exit
this screen. See the article Input a Family Group Data.

History tabs
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The Migrations screen positions on a map the places of the life of the primary person or any other family member. The
markers are numbered to display the sequence of movements. Each place marker indicates the list of events which took place
in this place. You can see simultaneously all the events of all members of the immediate family unit.

The navigation miniature, displayed at the bottom right in the map of Migrations tab and in Search Wizard (in Search Tab) in
Map tab, allow you to easily move on the map easily.

Select the frame with left clic of your mouse, by moving it, you will navigate on the displayed map.

Note: 

blue markers are the markers attached to the selected person on the right list of the map.
yellow markers represents events of other persons of the right list.
the + sign in a blue marker indicates that more than one event are registered at the place and concerns the selected
person.
since Heredis 2020, you can see the subdivision pins.

Searches tabs

The Searches tabs contain research tools for the primary person and your genealogy.
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In Search Wizard sub-tab, the upper part shows the known or missing information. The lower part of the screen allows
you to launch any online research with the operator of your choice. You can also restart a previous search, enter a
research note, check the details of sources, media, or geographic locations for known data. You can easily manage
linear research by using the Branches panel. Also consult Search Wizard article.
From this tab, you can also access Smart Search which allows you to find data of your genealogy by combining
different search criteria such as persons, relations, families, events. See also Smart Search article.
From the Find/ Replace sub-tab, you can also replace and modify data entered in a Persons, Families, or Events
section. For more details, see Find/Replace article.

Graphs tabs

From Heredis 2021   , you can, from Graphs tab, edit a dynamic ancestors wheel. See article The Dynamic Ancestors
Wheel.

The panels

Removable panels display data or tools.

The search panel is displayed in a hidden area on the left of the main screen. Heredis offers different tabs in Windows & Mac
version: Persons, Branches, Places, Media, and Sources.
The search panel and the results it displays are always available and provide direct access to the data for viewing or use to
complete the entry.

(Mac) Search panel

(Windows) Search panel

(Mac) Tools Panels
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(Windows) Tools Panels

Display or Hide panels

Click the icon (Windows)  or  , (Mac) 
or Show/Hide Panel at the bottom (or top for Windows) of the panel

columns, to the right and left of the Navigation screen, choose the Windows menu > Show/Hide Right or Left Panels.

(Mac) Click the close check box  on a panel to hide it. To display a hidden panel, click the Panel Options  button at the
bottom of the panel columns and select it from the list.

Add a column of panels, to the right or left of the navigation screen using the Panel Options 
, and then divide the panels

into the two columns. Delete a panel column with the same button.

(Windows) You can choose to unfold only one panel at a time by clicking on the Windows menu > Open one panel at a
time.

Resize the panels

The space allocated to the display of panels can be modified: click on the separation area between two palettes. The cursor

takes the shape of a cross  and you can enlarge or decrease the area displayed above.
Click the separation area between the panel column and the file display area to change the space allocated to the panels.

(Mac) Arrange panels

1. Drag and drop the panel.
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2. Click the top strip of the palette (example: Branches) and drag to the desired location for the panel in any column.

3. When the desired destination is marked with a blue line, release the mouse.

See the article Customize Heredis – Heredis Preferences.

 

                                 68 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

The different data fields

Identity fields

Some fields are not displayed by default. If you need to use them click on the indented wheel   to choose the Data Entry
mode adapted to your work. For further details, see Customize Heredis/Heredis' Preferences.

Surname

Type the surname of the person, without worrying about upper or lower case. Heredis includes various data entry aids which
allow you to save time and avoid errors. Each new surname entered is added to the Surnames Index, you can change the
formatting for any name from the Surname index.

See Customize Heredis/Heredis' Preferences and Indexes: generalities.

Prefix

The prefix is used to specify an attribute found often in an old deed, such as «Lord», «Sir», «Reverend»…, or in more recent
documents, such as «Professor», «Master», «Doctor»...

Suffix

The suffix specified is assigned only to the surname of the person being entered. You can add references such as «Senior» or
«Junior» or assumed names.

Given Names

Type the different given names of the person. The list of given names known to Heredis appears and is updated as and when
you type. Once you have located the given name in the list, use the down arrow to select it and then press Enter to select it.

If the usual given name is not the first given name, it can be highlighted. To do this, click the icon (Windows:  , Mac: )to
the right of the field for entering given names, and select the usual name in the list.
Info • The usual given name may also be highlighted by entering it with quotation marks.

Gender

The gender of the person is automatically filled in by Heredis, according to the given name entered. If you want to change it, or
if you typed a given name unknown to Heredis or for a multiple given name, type M for Male, F for Female, or leave ? for
persons whose gender is unknown. You can change the default gender for a given name by editing it in the Given Name
Index.  If you encounter multiple male Robin, choose by default the male sex in the Given Name Index. If you meet a woman
named Robin, it will be enough to change the sex only for her.

Info: if a given name is unknown to Heredis and add to the given name index, it will get the chosen gender of your first entry
to use by default.

Nickname

The display of a nickname will be preceded by aka.

Occupation

Enter the occupation of the person. This item should contain the sole or main occupation he/she held. You may also enter as
events any other dated and detailed occupations, for other activities. The list of recognized occupations with Heredis appears
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and is updated as and when you type. When you see the desired occupation in the list, use the down arrow to select it and press
Enter to select it.
In the Occupations field, recognized occupations are underlined. When you type a word not recognized as an occupation, you
may add it to the list of occupations available.

(Mac) Select the word or phrase with your mouse and click the arrow to the right in the input field. Heredis will add the
occupation to the Occupations Index. When you leave this field, you will find that the occupation is now recognized as it is
underlined.

(Windows) Select the word or phrase with your mouse and click the + button to the right in the input field. Heredis will add
the occupation to the Occupations Index. When you leave this field, you will find that the occupation is now recognized as it
is underlined.

Title

Indicate here any title of nobility or honorary title.

Personal number

This number corresponds to any personal numbering system you may wish to set up (numbering by genealogical areas,
identification numbers...).

Signature

Scroll down the Signature menu and select:

Yes if the person knows how to sign,
No if you have observed that the person does not know how to sign
? if you do not have any information.

You can choose which option is the default for each new person entered in Heredis > Preferences > Format, see Customize
Heredis/Heredis' Preferences.

Child status

Scroll down the Child Status menu to choose the appropriate option. If your ancestor was born out of marriage of an unknown
father, chose natural. Make you choice according to the data you found.

Flags and their use

Placed alongside the Child Status field, the clickable flags icons correspond to various characteristics of the person. They
allow you to enter additional information relevant to your genealogy.
You may change the flags assigned to a person or to a list of individuals.

Complete person

Click the  Complete person icon if you know you do not have any reasearch to do or if you do not want to search more on
this person even if the major events are not completed.

Untraceable Father

Click the  Untraceable Father icon if the person was born of unknown father or if you know you won't be able to find out
who he was (no more Archives left for example).
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Untraceable Mother

Click the  Untraceable Mother icon if the person was born of unknown mother or if you know you won't be able to find
out who he was (no more Archives left for example).

Note: the untraceable father and untraceable mother flags icons can be ticked both at the same time if both parents are
unknown. You will have to untick the flag icon in order to input a father and/or a mother if you found out who he/she was.

Childless

Click the Childless  icon if you know that the person had no offspring. This flag is grayed out if you input a child to the
primary person.

Unmarried

Click the Unmarried  icon if you know that the person never married. This flag is grayed out if you input a spouse to the
primary person.

Secondary Person 

Click the Secondary Person  icon to indicate that this person has only a minor role in your genealogy. Secondary
individuals in your file may be excluded from printouts, exports and publications. You may, for example, declare secondary all
children who died in infancy so that they are not in your tree charts.

Marked Person

Click the Marked Person 
 icon to highlight an individual and apply specific treatment to this person. A marked person may

be ignored when you export the file, may be selected with specific research tools, may or may not be printed in a tree chart or a
report.

Confidential Person

Click the Confidential Person  icon to avoid publishing information on this person in your printouts, exports and
publications.

Click again the icon to deactivate.

Use the Smart Search to change flags at once for multiple persons. For example, you want to make confidential all people born
after 1920. Use the Smart Search and apply the treatment to make them all confidential at the same time. See Smart Search
article for further details.

Facts

With Facts, enrich your genealogy with new data and attach witnesses, places, sources, medias and dates to it.
You can add as much as you wish, unlimited number, and you can organize them.
These facts are displayed in the central part of the screen Data > Personal Data in the Facts tab.
When a Fact is filled, the tab is marked with a blue spot.

Facts
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Read also Facts article.

Notes

Add specific details to your genealogy by using the available notes. You will find entry boxes for notes on persons, families,
events, media, sources, surnames, given names, occupations and places. The notes are equipped with formatting tools
integrated in the Heredis software. One may also paste formatted text from other applications (word processors, browsers,
desktop publishing tools, etc.) though images are ignored.

For further details, see Input notes.
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How the Heredis data is structured

Heredis manages all types of data related to genealogical research and organizes them logically, in order to deepen your
understanding of your ancestors.

Persons

Every individual mentioned in the genealogy file: ancestor, contemporary, witness, is known as a Person.

For each person included in the genealogy file, specify:

 Identity (surname, give names, nickname, occupation, etc.). If you wish to enter information that is not proposed by
Heredis, create your own user field.
Characteristics known as flags: childless, unmarried, confidential, etc.
A free note.
Each person is numbered automatically according to his/her position in the genealogy but you may assign a personal
number based on other criteria.
Various events in the person’s life, expanding his/her personal story, and citing sources of information.
Media (photos, videos or other documents) to illustrate the person, unions or events.
Personal ties, apart from family ties, Heredis allows noting that people had a special bond. Include friends, tutors,
mentors. Create «witness» links for those present at or quoted at an event.

Also see The different data fields and Add a person with no direct connection.

Relationships

As you build your family genealogy, you create new persons with their appropriate relationship. Any relationship can be
established retrospectively.

Relationships are of two types: the parent-child and spouse relationships.

Other family ties and the position of any person in the genealogy are determined automatically from these basic links. To
create brothers and sisters, you have only to create new children for parents.

• Create direct family links: father, mother or child.
• Create a spouse link (whether the union is official or not). Specify the status of the family: the spouses are married,
separated, divorced...? When a person has been married several times, Heredis will number them for easy access, as well as to
the children who resulted from them.
• Assign a note, pictures and events to each family created in your genealogy.

For more details, see Add parents, Add spouses, and Add children.

Events

To record important events in the lives of your ancestors, you may note person events (christening, military service, will...), or
events shared with a spouse, called family events (engagement, residence, etc.). If you cannot find events that are appropriated,
create your own definition of events.

• For each event, enter all known details (date, time, place, age stated on the record...) and add a note relating to the event.
• Specify the status of the source of information (No search record, Search Record or Untraceable Record), allowing you to
edit a report of all sources to be researched.
• Declare an event as private, not to be exported or published.
• Illustrate the event with various media (photos, documents).
• Assign a source to the event, to record the origin of your information.
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• Assign witnesses to the event (witnesses, registrars, godparents, etc.).

A visual cue  showing the status of main events (Birth or Baptism – Marriage – Death and Burial) appears in
the Persons and Branches panels, as well as in the status bar and in the Search screen.

To define the appearance of the icon, select the criteria that you feel are relevant: No missing, approximate or incomplete
date - Place mentioned - Source mentioned - No ‘Search Record’ status in the Preferences screen. According to the

criteria checked by you are met or not, the bar symbolizing the event in the icon  is in the top, middle or bottom.

In this icon  , for example, the Birth event is partially filled, the Marriage event is not specified, the Death event is
complete.

For more details, see Input events.

Sources

Heredis may assign any number of information sources to each event.

Each source is an independent element, which is then assigned to one or more events. Heredis allows you the flexibility to
create a source and then assign it to the events in question, or at the same time to create both the source and its link to the
event.

For further details, see Sources, The different mode for Sources & Citations.

Witnesses or participant

Each person involved in the lives of your ancestors can be entered, be part of the family or not. Heredis will assign persons to
events (the witnesses of a marriage, the registrar for a birth, a relative present at the ceremony for a decoration etc.).

Creating a witness or participant assigns an individual to an event concerning another person. A witness may be
assigned to one or more events, and each event can have one or more witnesses or participant.
Anyone entered in your genealogy plays a role, regardless of its importance and the degree of kinship. When you assign
a person to an event, specify the type of link (witness, godfather, declarant...), the age of the linked person at the time of
the event, and enter if necessary a suitable comment on the link.
The information entered for the witness or participant is the same as for any other individual: identity, flags, notes,
media…

For more details, see Add witnesses.

Linked Persons

Sometimes we know of a relationship which existed between two people, without being able to assign it to any event. You
know that Paul is the uncle of John, but you do not know if he is the brother of the father or mother of John, or the husband of
an aunt. You cannot create this link as a kinship. Create a personal link (Sundry Links) between Paul and John until you find
the information you need to create the kinship.

Create linked persons to declare a relationship between one individual and another person. Every individual may be
linked to several other persons.
The name of the link is determined by choosing the type of relationship and meaning of the link. You can also add a
comment to the link.

For more details, see Add linked persons.
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Media

You have photos or documents; use them to complement and illustrate your family tree.

You can assign a digital image (photograph, signature, seal, etc.) sound recordings (interviews, speeches), videos or any other
type of file (document prepared with a word processor or spreadsheet, PDF, HTML, etc.) to any data in your file.

Each item of media is identified by its name, to which you can add a date and a note.
You can make any media private if you do not want it to be broadcast.
Media may be assigned to all types of data: person, family, event, source, name, occupation, place.
The number of media assigned to any data is without limit and every item of media may be linked to several different
data.
All media are listed and may be managed in the Media Index or in the Photo tool.

For more details, see Media and Photo Tool.

Surnames – Given Names – Occupations – Places

In your genealogy, you will have names, occupations and places that sharpen your interest. When you know more about them
(photo of a place, story of a given name etc.), Heredis allows you to keep this information by completing each item.

The surnames, given names, occupations and places that you use in your genealogical file are automatically stored in the
Indexes.

Indexes are powerful tools that play several roles: retrieve data by how they are used, link different data by themselves,
illustrate your genealogy by management of your documents. Thus, you enrich your genealogy and understand all the better
the lives of your ancestors.

In each Index, the surnames and given names, occupations and places may be illustrated by a note or by media.
The Indexes can merge similar data. They allow you to declare variants within the same category of data: such spelling
of a name is a variant of another name in the file, such given name is a local variant of another given name, such a
name is a variant of another occupation saved in the file.

For more details see Indexes: generalities.
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How to find a person in your navigation history

Select Navigation History from the drop-down list located to the right of the   or buttons in the toolbar.

Windows Only

This window shows, in tabular form, all the persons you have displayed as the primary person since you started your work
session. Unlike in the dropdown list, each person is listed only once in the table.

Click the column header to display data in alphabetical or numerical order for the following fields: Name or Given Names or 
Occupation, Birth, Death or Changed. Another click in the header will reverse the displayed order. The arrow indicates the
sorting order.

Any person who has already been displayed as the primary person and whose data has been modified during your work session
is marked with a bullet point. This allows you to single out easily all modified persons.

Choose a person from the list and click on the Select button to view him or her as the primary person again. Click Cancel or
close the window to go back to the previous navigation screen.
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Customize Heredis - Heredis Preferences

You may adapt Heredis to your personal work methods.

Choose your color theme

You spend many hours in front of your Heredis screen? Select the color of the environment that is best suited to your eyes and
your taste.

Click Window(s) Menu > Theme

Click the Themes button to change the color of the main Heredis screens.

Select the Toolbar

Click Customize button  to select the tools you need. You can also choose the size of icons and to display or not the text.

To add a button in the toolbar,
 (Mac) Choose an icon, drag and drop it to your toolbar at the desired location.
(Windows) Choose an icon and either drag and drop it from left to right or click on Show to add it on your
toolbar.

To remove an icon,
(Mac) Drag it out of the toolbar. Click on Done to close the window.
(Windows) Either drag it from right to left or click on Hide.

To order the icons
(Mac) Drop the icons and place them in the order you want.
(Windows) Click on the Up and Down buttons or drag and drop on the list. Click on Close button to close the
window.

You can also add extra spaces between the buttons.
To display the buttons as they were when Heredis was first launched,

click on Default Set button.
drag the default set to the toolbar.

(Mac) Customize the toolbar
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(Windows) Customize the toolbar
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You need more space? Then change the display format of the icons.

(Windows) Tick or Untick Big Icons and Icons and Text.
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(Mac) Select Icon only from the Show pop-up menu and click Use small size.

Customize the panels

Display or hide the panels

Certain panels are of no use to you? Click the closure button and they will disappear from the column.

(Windows) You can hide or display the Search and Tools panels on one side or the other of the screen. Click the arrow at the

top of the panels  to open or close them or choose Windows menu > Show/Hide Tools Panels, or Show/Hide
Search panels, or One panel at a time. You can also swap the panels. You may alter column width and height of panels if
necessary.

(Windows) Available Panels

(Mac) Use the buttons  at the bottom of the screen to change the display of panels. The arrow button to the right or

left  will display the column, you can click on the cross button to hide the panel. The indented wheel  button at bottom
right will give you access to any panels which have been removed. A simple click will display the panel again.
The procedure for opening the panels may be different for each column. Select Open one panel at a time and the panel which
is open will automatically close when another panel is opened in the same column. Otherwise the panels will remain open as
long as you have not clicked the disclosure triangle.
Add a column of panels if you want to have more information simultaneously displayed.
You may reposition a panel in the column or to another column by drag and drop with the mouse. Its new position is indicated
by a blue line and then release the mouse to place it there.

(Mac) Available Panels
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(Mac) Display a hidden panel from indented wheel

Resize the panels

Panels are resizable in width. Click on the line between panel/navigation screen.

The cursor shape will change and turn into . You may increase or decrease the proportion of the screen allocated to the

panels. The display area of the panel is vertically adjustable in the same way. If your cursor shape becomes  or  , you
can change the size of the column or area.

Arrange the panels

(Windows) Panels may be positioned to the right or left of the navigation screen. You can change their position by using the 
Windows menu > Swap Tools and Search panels. Select Open one panel at a time in the Windows menu to save space on
your screen. Heredis automatically closes the open panel when you click the arrow to display the other panel.

(Mac) Move the panels by using drag and drop. Click the top bar of the panel and drag to the desired location for the panel in
any panel column. When the desired destination is highlighted by a blue line, release the mouse. Choose Open One Panel at a

Time by using the Options  panel button. Heredis automatically closes the displayed panel when you click the display
triangle of another panel. Use Window menu to Show or Hide right or Left Panels.
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Heredis' Preferences

Define your preferences

In the (Windows) Tools  menu > Preferences > Heredis Preferences, (Mac) Heredis 20xx menu > Preferences, you may
define the formats of all the various input fields. Choose how to display the names, places, numbers. Choose the default
options for creating events and set inconsistency alerts. Choices made in Heredis Preferences will apply by default for all new
inputs.

You can change them at any time.

Windows' Heredis Preferences
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Mac's Heredis Preferences
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Automatic formatting of data

When you enter a surname or given names, you can type them in either uppercase or lowercase. If the Uppercase option has
been selected in Preferences, a surname or a given name typed in lower case will be automatically converted to uppercase,
including accented characters. If the name contains a particle it will remain in lowercase.
If you have chosen in Preferences the Initial Caps option, the surname or given name’s first letter will be automatically
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converted to uppercase, including accented characters.

Choose the recognized places

Heredis integrates lists of places for most of the countries of Western Europe and North America, indicating their
administrative connections (county, state, country). These headings may be different from country to country.

Because your ancestors probably lived in your home country or are from a limited number of other countries, you can limit the
list of countries for which places will be suggested during the data entry.

To choose the countries for which you need input help, open Heredis' Preferences.
1. Choose Countries tab.
2. Check the different countries where you are likely to have places to enter. You can add more at any time.

Thanks to automatic entry, you have direct access to all the information for these places.

The places proposed during data entry in the Add screen, Personal Data, Family Group Data or Places Index tabs
will be limited to those countries. The locations already used in the file are displayed at the top of the list.
Use the arrow keys on the keyboard and confirm the selected location with the Enter key or click the selected location.

Heredis will show you all the location information in the free area above the topic or in the tooltip for the Data >Family
Group Data screen.

Info • The proposed geolocations relate to the whole world and are not limited to countries ticked in the Preferences menu.

This place database can be enriched of places you inputted. See also Places index and Geolocating Places.

Completeness of data

The icon  indicates whether or not essential information for major life events is complete (Birth/Christening,
Marriage/Union, Death/Burial).
This icon concerns the completeness of information for the primary person in the Status bar and in the Search tab. It appears
also in the Persons and Branches panels for all individuals displayed.

It also influences Search Tracking tool. See Search Tracking tab article.

The icon display is defined in Heredis' Preferences > Appearance. You can choose what information is required for an event
to be complete: the accuracy of the date, place, the presence of a source and the status of the search for the event. Tick the
boxes you believe are essential for you.

(Windows) Completeness setup

(Mac) Completeness setup
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Regardless of the information collected in Heredis, you may determine that certain individuals will not require further research.

Click on the icon  in Data tab > Personal Data or open the Search tab > Search Wizard and click the  Consider that
this individual is complete button. The icon changes color from grey to blue.

When using the Branches panel, choose the Complete Persons Only option, and the results take into account both the
completeness of the events and the individuals for whom you had determined that they be considered complete.

Select data entry method

Heredis allows you to display only the information that you commonly use. This visual selection mode in no way changes your
data, which are still preserved whether or not you display them. You can change the data entry mode at any time.

Depending on whether or not you have a complete deed or just a mention on a website, you will not need the same input fields.
This is why the Heredis data entry fields are modular.

There are three data entry modes (Basic – Comprehensive – Customized) that you may use in different ways depending on
the data input screen (Add screen, Personal Data tab, Family Group Data tab).

The Basic mode is displayed by default. This mode displays only the main fields. You can change the data input mode at any
time.

Choose between Basic, Comprehensive or Customized mode by clicking on the indented wheel  on top right of Add
screen, Personal Data tab or Family Group Data tab.

Prepare the data entry screen to your liking by using the Customized view.

Each data entry screen will then display the selected items. Every inputting screen can display a different mode. You can for
example choose Basic mode for Add screens and Customized mode for Personal Data tab.

Check the items not displayed 

If you choose the Basic or Customized display modes, it may happen that certain information entered does not appear. Heredis

alerts you by displaying an alert triangle  next to the indented wheel icon (Choose data fields you wish to use).
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Click the alert triangle : the display is changed temporarily and all saved data items are displayed.
When you navigate to another person, the data items are again hidden in accordance with the mode you have chosen.
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Create the first person

You have chosen to create a new genealogy: Heredis opens an empty Immediate Family screen, which will fill up as and
when you enter data. Now create the first person to start your new file.

Click Create the First Person in the center of the screen

or click on Add 
button of the toolbar > Add Unrelated Person

or choose Person menu > Add > Unrelated Person

The Entering New Person screen opens with the data boxes to complete. To move from one box to another, press the Tab key
or click in the next box.
Heredis includes data entry aids which will save you time and avoid errors.

Windows Entering a new person
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Mac Entering a new Person
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Surname
Type the name of the first person without worrying about upper or lower case. Each new name entered is integrated into the 
Surnames Index, making it available later for help with entering surnames.

Given Names 
Type in the given names of the person. The list of given names known to Heredis appears and is updated as you type. Once
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you locate the given name in the list, use the down arrow to select it and then press the Enter key to select it. If the usual given

name is not the first given name, it may be highlighted. To do this click the icon (Windows: ; Mac: ) which appears to the
right of the data input area, and select from the list the usual name, or enter the usual name in quotes.

Gender
Gender is automatically inserted by Heredis based on the given name(s). If the given name is multiple, Heredis leaves a ?.
For gender selection, click the arrow or type M for Male, F for Female. Your choice will be stored for future use of the same
given name. If you want to modify it later, you can do so in the Given Names Index, without changing the data that you have
already entered.

Occupation
Enter the occupation of the person. This section is for the sole or main occupation the person held. You may also enter 
Occupation events, dated and detailed for any other activities. The list of recognized occupations with Heredis appears and is
updated as you type. When you see the desired occupation in the list, use the down arrow to select it and tap Enter to select it.
In the Occupation field, recognized occupations are underlined. If you type a word that is not recognized as an occupation and
want to add it as an occupation, with the mouse select the word or group of words and click the arrow to the right in the box.
Heredis will create an occupation that is added to the Occupations Index. As you leave the field, you will find that it is now a
recognized occupation because it will be underlined.

Child status 
Scroll down the Child Status menu and choose the appropriate option.

Signature
Scroll down the Signature menu and select Yes if the person knows how to sign, No if you have seen that he/she cannot
sign, ? if you are not sure of the information.

Flags
They can enter additional information relevant to your genealogy.

Click the  Complete person icon if you have no more research to do for the person.

Click the  Untraceable father icon if the person was born of unknow father or you can not know the name of the
father (missing records...).

Click the  Untraceable mother icon if the person was born of unknow mother or you can not know the name of the
mother (missing records...)

Click the  Childless icon if you know this person had no offspring.

Click the  Unmarried icon if you know this person did not have a spouse.

Click the  Secondary Person icon to indicate that this person has only a minor role in your genealogy. Secondary
persons in your file may be excluded from printouts, exports and publications. For example you can declare as
«secondary persons» all children who died in infancy so that they will not appear in your tree charts.

Click the  Marked Person icon to highlight the individual and apply specific treatment to him/her. A marked person
may be excluded when exporting the file, or highlighted in a search, or may or may not be printed in a tree chart or a
list.

Click the  Confidential Person icon to prevent publication of information on this person in your printouts, exports
and publications.

Main events 
Heredis distinguishes main events (Birth - Death) from minor events (Communion - Retirement - Will, etc..). The Entering
New Person screen gives access to major events only. If necessary you can enter minor events in the Personal Data tab at any
time.

Birth
1. Click the Birth event title to bring up the pop-up menu and select Birth or Christening.
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2. Enter the date.
3. To enter the Place field, type the name of the town of birth or Christening. Once you enter the first letters of the place,
Heredis proposes a list of places that may match your entry. Select a place using the mouse or use the up and down arrows and
confirm the location selected with the Enter key. If there is no place relating to your entry, select New Place. Complete the
various boxes for the new location to be saved and confirm its creation by clicking OK.

Death
1. Click the Death event title to bring up the pop-up menu and select Death or Burial.
2. Proceed in the same way as for Birth.

Further information

To display further data fields, use the Choose Data Fields option . For further details, see Customize\Select data entry
method.

Validate the creation of the first person
Click the Add button to validate the first person in your genealogy, or press the Enter key. The person appears in the center of
the Immediate Family screen.

This individual is the starting point of your genealogy, the person called the Root Person and who will have the Ahnentafel
number 1. Continue your genealogy by clicking on the Add Father, Add Mother, Add Spouse or Add Child links to
complete the immediate family.

Later on, you can access the root person by clicking on the  button or from the menu: Find > View Root Person. The
Root Person can be changed at any time, see The Root Person article.
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The Root Person

The Root Person is the individual at the base of your genea¬logical research. By default, Heredis defines the first person
entered in your genealogical file as the root person and assigns the Ahnentafel number 1 to this person.

To access the root person

• Click the Root button  in the taskbar.
• Select Find > View Root Person.

To modify the root person

1. Display the new person to be at the base of the genealogy currently open in Heredis.
2. Select Person > Define as Root Person
The new root person will bear the Ahnentafel number 1 and all other Ahnentafel numbers will automatically be reassigned by
Heredis based on the new root person.
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Genealogy numbering

A genealogical research can lead to the processing of thousands of people, some bearing the same name and sometimes the
same given name over several generations.
In order to identify ancestors and position them with relation to other persons, various numbering systems have been developed
and are commonly used by genealogists.

Ancestor numbering

The method for numbering ancestors is called Ahnentafel. The number assigned to a person will identify the gender and
position of any individual in direct descent (it does not apply to collaterals).

The three basic rules for Ahnentafel numbering are:

1. Even numbers are assigned to men and odd numbers to women.
2. For every couple, the woman’s number is the equivalent of the number of the man + 1.
3. For every father, a number is assigned equal to twice that of his son or daughter.

The person whose ancestry is being researched bears the No. 1 (irrespective of gender). This is the person who is at the base of
the genealogy file. He/she is called the Root person.

The father of the root person is No. 2 (twice the No. 1), his mother No. 3 (No. 2 + 1). His paternal grandfather is No. 4 (double
the No. 2), his paternal grandmother No. 5 (4 + 1). His maternal grandfather is No. 6 (double the No. 3), his maternal
grandmother No. 7 (6 + 1), etc.

Thus each ancestor is traceable from his/her number: No. 599 is a woman (odd No.) and is the wife of No. 598. She is the
mother of No. 299, who is a woman, and who is the mother of No. 149, etc..

This numbering is displayed on the data entry and navigation tabs, in the panels and in the different documents and tree charts.
It is automatically calculated by Heredis.

Identifying the Ahnentafel lineage

You may identify persons who belong to the Ahnentafel lineage by the symbol preceding their names.

Heredis identifies each person with an icon indicating its gender (blue  for men, purple  for women and green for persons
whose gender is unknown). If the person is a direct ancestor of the root person, the head of the icon is yellow  or .

The primary person’s number is displayed in the status bar after the generation's number (G).

If a marriage between blood relatives in his/her ancestry has created a duplicate branch (implex), the primary person’s number
is followed by the ++ signs. Click the Ahnentafel number to display the list of all the number the primary person bears.

Navigating in the direct lineage

Use the compass  to naviguate in direct line from the tools panel.

If the primary person displayed is part of the direct lineage of the root person, the View previous direct-line ancestor

and View next direct-line ancestor arrow buttons allow you to move up or down the genealogy, generation by
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generation, without overlooking a single ancestor.

Descendant numbering

Heredis uses d’Aboville or Lettered numbering to treat individuals listed in a descending genealogy.

The three basic rules for d’Aboville numbering are:

1. Each child bears the number of his father or his mother followed by the number of his/her order of birth.
2. Then one proceeds by adding the order number of birth for each generation.
3. A letter distinguishes the different unions.

D’Aboville numbering allows you to know the number of generations separating an individual from his/her ancestor and from
which branch of the family he/she comes.

Thus you will identify the progeny of a person: the eldest is No.1, the next youngest No. 2, the very youngest No. 3, etc.. The
two children of the eldest are numbered No. 1-1 and No. 1-2. The child of the first husband of the youngest bears the number
No. 2-1a, those of the second husband are numbered No. 2-2b, N°.2-3b and No. 2-4b. The only child of the youngest is
numbered No. 3-1.

D’Aboville numbering may be displayed on the different descendant documents and tree charts.

Lettered numbering uses the same system but with letters instead of numbers.

Implex (duplicate branches)

The same person may appear several times in an ascendancy, and appear in several branches of a tree. This is due to
consanguineous marriages.

The ratio between the total number of ancestors and the number of ancestors that really exist (smaller) is called the Implex rate.
One person may therefore bear several Ahnentafel numbers.
Imagine that Jack marries Marianne. However, Jack’s father was the brother of the grandfather of Marianne. Jack and
Marianne therefore have common ancestors, which will appear in two different branches of the family tree.

Heredis manages the different numbers automatically and symbolizes it with ++ symbol after the Ahnentafel number. If you
click on the Ahnentafel number, you'll see all numbers corresponding to the same person.

In Descendants view (Family tab) ans in Search Tracking, the name of implex persons will appear in red.

See also Implex (Duplicate Branches)

 

                                 95 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Implex (duplicate branches)

The same person may appear several times in an ascendancy, and appear in several branches of a tree. This is due to
consanguineous marriages.

The ratio between the total number of ancestors and the number of ancestors that really exist (smaller) is called the Implex rate.
One person may therefore bear several Ahnentafel numbers.
Imagine that Jack marries Marianne. However, Jack’s father was the brother of the grandfather of Marianne. Jack and
Marianne therefore have common ancestors, which will appear in two different branches of the family tree.

Heredis manages the different numbers automatically and symbolizes it with ++ symbol after the Ahnentafel number.

In the Immediate Family view, if you click on the Ahnentafel number, you'll see all numbers corresponding to the same
person. Heredis will show you all Ahnentafel numbers for the person and the way to the root person for each number. Therfore
you'll see how the implex was created.

 

(Mac) Multiple Ahnentafel Numbering
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(Windows) Multiple Ahnentafel Numbering
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In Descendants view (Family tab) and in Search Tracking, the name of implex persons will appear in red.
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Save time by inputting faster

Data memorized

Heredis memorizes all your previous data entries, item by item, and will suggest the appropriate data as you type. To validate a
proposed entry, press Enter or Return keys. To choose among several propositions, use the arrow keys and then press Enter
or Return keys.

Prerecorded data

The application is supplied with databases of places, given names and occupations.
Choose from the propositions as they appear. If no proposition appears or if it is not appropriate, select New Place.
Each new given name entered is automatically added to the Given Names Index.
Each new Occupation will be added to the Occupations Index by clicking the arrow button in this section after selecting a
word or a phrase. The new elements will be proposed in subsequent data inputs.

For more details about Indexes, see Indexes: generalities.

Preferences

Whichever way you may have typed data, in uppercase or lowercase, Heredis will automatically format the entry according to
your predefined Preferences.

For more details on how to personalize Heredis, see Customize Heredis\Heredis' Preferences.

Automatisms

The Gender field is filled in automatically based on the given name entered, but it may be changed. Multiple given names will
be automatically entered according to your initial entry, but may be subsequently altered. Check out The different data fields
article.
Heredis calculates for you the date of birth of people based on their age at any particular event. It gives them an approximate
date which you may confirm later, when you know it. See also Consistency Control – Error-free data entry article.

Drag and drop

To speed up your data entries, complete your data by using drag and drop.
Add links to other people by selecting them in the various panels and deposit them in the data field if it is empty. Select a man
in the Persons panel and drop it as the grandfather in the Immediate Family tab. Select a woman from the (Windows) 
Kinship; (Mac)Relations panel and drop in Personal Data > Event > Christening to make this person the godmother.
In the same way, you may add information to the Events field. Select a source from the Sources panel and drop it on the event
you will have selected to associate it with this event. You may do the same for a place selected from the Places panel.
Add media already used for other data by choosing from the Media panel and drop them into the appropriate entry fields. A
group photo can illustrate both a family and a marriage event.

(Mac) Correcting spelling

Anything you type in the Notes data entry field will be subject to a spelling alert. Typing errors are underlined in red. Right-
click the underlined word so that the software may propose the correct spelling.

Census Grid

Heredis created a census grid to help you input all data found  in a Census at once. See our Census article for details.
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Consistency Control - Error-free data entry

In order to avoid errors, with each data entry, Heredis checks that the information entered is logical in relation to the persons
and events already known. It alerts you to any anomalies which you may either correct or confirm.
Heredis notifies you when you enter an event date which is later than that of the death of such person. You may fix the date
entered if you made a mistake, or confirm a post-mortem event, such as the transfer of ashes or an act concerning the
deceased’s estate.

Note: You can use and personalize a post-mortem event in order to avoid alerts like this. See also Input events article.

Heredis also checks for possible inconsistencies if you have created a link with a person bearing the same name as the person
you are entering: it will inform you, for example, if you link a possible father, that he was 143 years old at the birth of the
child, or if the wife assigned to the primary person had died before her wedding.

Consistency control

Permanent control for duplicates

You will be notified if any date or time appears inconsistent.

Any input which appears inconsistent will be highlighted by a red cross  in the Consistency button on the toolbar. Click
the button to be notified of the apparent inconsistency (due to a mistake of date, or the attribution of a link which is not valid)
and understand it. Consistency control is automatic and can not be turned off. When inconsistencies are detected, a message
pops up to alter you at the end of the input.

Review the summary of the inconsistencies shown for the primary person. These controls are only indicative and it is your
responsibility to rectify the anomalies detected or not.

To avoid the double entry of a person in your family tree, Heredis will display a list of existing name matches similar to your
entry for any new persons you may enter in the Add menu screens.
Simply select from the list and click Choose to choose that person instead of creating a new individual.

For further information, read (Windows) Permanent control for duplicates & Merge two persons, (Mac)Permanent control for
duplicates & Merge two persons.

Check all persons in the file

Heredis provides a tool for detecting all inconsistent data in your genealogy file.

Open the Persons panel.
(Windows) Choose the Enhanced Criteria then Inconsistent Data.
(Mac) Choose the Genealogical Criteria option then Inconsistent Data.
Double-click each of the persons displayed in the results list to verify their data.

You can also launch a Smart Search to find inconsistencies. Set up as follows: Persons > Consistent > No.

Mac Info • To do this at a later date, you may store the list obtained by marking all the people displayed. Click the Batches
button (indented wheel icon) on the Persons panel toolbar. Choose the Mark/Unmark > Mark All option. You may also keep
the results displayed by printing the list of incoherent persons. To do this select the Print List option.

No longer consider a person as incoherent

After checking the data of the primary person and to keep the information as it was entered, choose Person > Check

Consistency or press the Consistency button  on the toolbar and select the Mark as Consistent option.
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The Consistency button changes its appearance and displays a green tick mark . This person will no longer be displayed
in the list of a search for inconsistent information.

Change the consistency criteria

Heredis allows you to set your own criteria for checking the consistency of some data.

(Windows) Choose Tools > Preference > Heredis Preferences 
(Mac) Choose Heredis > Preferences
Open the Consistency tab.

Windows Consistency

Mac Consistency
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You may modify the limit value so Heredis will consider it consistent or not.
The controls relate to the age of spouses at marriage, age at death, parental age at birth of children, the gap between two
dates for successive births, the age gap between spouses.
Indicate the minimum or maximum values (expressed in years) you wish to apply to your genealogy file. It may be
interesting to change the maximum age at death to input contemporaries. It is frequent since the XXth century for men
to pass away after 90.

These amendments are effective immediately for the all file.

Validity Control

Heredis analyses all information and will block any erroneous data entry.

Dates

Dates should be entered properly.

See article Dates for possible formats.

Heredis notifies you when you enter an event date which is later than that of the death of such person. You may fix the date
entered if you made a mistake, or confirm a post-mortem event, such as the transfer of ashes or an act concerning the
deceased’s estate. You can use and personalize a post-mortem event in order to avoid alerts like this. See also Input events
article.

Heredis also checks for possible inconsistencies if you have created a link with a person bearing the same name as the person
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you are entering: it will inform you, for example, if you link a possible father, that he was 143 years old at the birth of the
child, or if the wife assigned to the primary person had died before her wedding.

Links

Links created between people must be consistent. Heredis prevents the entering of inconsistent links: one person cannot be
entered as the son of another if he is already his grandfather. A message will indicate why the link may not be validated.

Note: A message will pop up if you try to marry 2 persons of the same sex. You just need to validate the message if you didn't
make a mistake. There won't be any inconsistency. This message pops up only to make sure you didn't input a wrong
information.
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Summaries

Each person, source, place... has a summary in the Tools Panel usually on the down right of the Heredis screen. You will find
brief information and clickable links.

For example, click on a father's name, it will open the father's data.

Summary Heredis Windows before 2019's version
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Summary Heredis Mac before 2019's version
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Since Heredis 2019, improvement of the summaries

Since Heredis 2019, each summary has a foldable panel allows you to visualize or hide data so that you can customize your
display and view useful data only.

The display you have chosen for the summaries will be saved by the application and will remain unchanged until you decide to
modify it.

A Person’s summaries will allow you to see a vignette of the person’s preferred picture as well as a list of Family Events
along with other events and facts.

New Summary
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Add persons

Add a person in general

A click in the Immediate Family is enough to create the father, mother, spouses, children and even grandparents.

The family is simply growing.
A new person's input screen displays the most common information. Enter the name and first name to begin with. They get in
shape automatically.
As you input, you'll see a list of persons with the same name and first name appear in the right side of the screen. Heredis does
everything to prevent you from creating duplicates. Check the matching persons' list on the right and take a look at the
summary of the selected person. If you think you've spotted the person you want to add, don't keep imputing, but select it from
the list and click Choose .

See also Add Parents, Add Children and Add spouses.

(Windows) Enter a new person
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(Mac) Enter a new person 
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For more information on duplicates, see (Windows) Permanent control for duplicates and merge two persons, (Mac)
Permanent control for duplicates and merge two persons

If no one in the list of matching persons matches, continue filling in the fields.
Dates are displayed in full regardless of the entry format. Most locations in Western Europe or North America are proposed
while inputting. Select the location with the Enter button or create a new location.

See also Customize Heredis/Choose the recognized places, Dates and Places Index.

When the input screen is completed, click Add.
If you add a spouse, take the opportunity to provide all the information about the marriage: what type of marriage, the date and
place and the status of that union. See also Add spouses. Then click OK.

You can also work with other tabs in the method that suits you. Add parents in Ancestors tab,or other family members in 
Family Group Data tab and XXL Family tab. See also Add Parents. Complete or modify known information in Personal
Data tab.
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You can customize your input mode to have more or less graspable fields. Click on the indented wheel to customize the input
window.

For more details see Customize Heredis/Select data entry method.

Add a person with no direct connection

Each person in the genealogical file may be linked to other people by kinship, as a witness to an event, or as a related person in
another way.

Check out Add other linked persons to find out all about Heredis' other links.

Heredis allows you to attach an existing person to the genealogical file or create a new person with their kinship.

Click on  button then on . In the Entering New Person windows, enter the name and first name into the Personal
Data section. You see, in the matching persons column, the list of persons already registered with that name and first name.
As new letters are entered, the list of persons that can match becomes thiner.

(Mac) Entering New Person
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(Windows) Entering New Person
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Select a person from the list and see their summary. It allows you to better compare the different persons found.
If it turns out that the individual you want to add already exists, use the person already created by clicking Choose.
If you don't detect duplicates, you can then create a new person by completing the other input topics and then click Create.

Automatic filling of fields

Heredis provides databases of thousands of given names and occupations. On the other hand, Heredis memorizes the
information you have already entered, field by field.
Type in the first letters: immediately appears the list of data already saved that may match your input.
Continue with new letters, the list is becomes thiner.
Use the arrow buttons on the keyboard to select the desired value, and validate with the Enter button or click on the chosen
proposal with the mouse.
The auto-entry tool is available in all input fields, with the exception of notes and comments.

Delete an individual

Heredis removes:
- either the person. In this case the person will no longer exist in your genealogical file.
- or the relationship between the person and his/her relatives or an event in which he/she took part. In this case the person still
exists in your genealogical file.
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Info - The root person of the file, meaning the person with the Ahnentafel number 1, cannot be deleted. To remove this person,
you must first reallocate the number 1 to another person.

Place the person as a primary person.

Click the button  in the tool bar or choose Person menu > Delete > Primary person or link to remove.

For more details, check out the articles Add Parents, Add Children, Add Spouses, Add Witnesses and Participants, Sundry
Links.
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Add an unrelated person

When you want to create a new person without it being attached to the family displayed:
Select the Person menu- Add - Unrelated Person.

or click the button  and then the button in the  toolbar.

Type in his surname and given names.
Make sure the new person to be created doesn't already exist in your file by looking at the list of matching persons in your file
and the summary of any homonym. You can click on a person in the list of matching persons to see the information about
him/her in the Summary.

Once the person has been identified, select him/her with a simple click and then click the Choose or double-click on his/her
name in the list displayed.
He/She then appears as the primary person of a new Family screen.

If the new person is not on the list of matching persons, continue to fill the entry window with the information you have and
click the Add button.

If you want more input fields, click on the indented wheel to change the view mode.

(Windows) Add an unrelated person
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(Mac) Add an unrelated person
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Add parents

Add a new person

All tabs

1. Place the person for whom you want to add parents, as the primary person.
2. Create the link.
• Click the link in the empty boxes for the father or the mother.
• Choose Person > Add Father or Add Mother

• Click the  button (Add or link persons) on the toolbar and choose Add Father or Add Mother .
3. Enter the new person.
In the Add Father or Add Mother window, complete the entry fields with the information you have. Some items are prefilled
such as the father’s surname or gender of the father and mother.
• To change the surname, click in the field and enter another name. You can change the gender using by clicking in the Gender
box and changing it.
• (Mac) To change the gender, click the Do not specify gender lock.

(Windows) Add father

(Mac) Add father
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Info • Click the  indented wheel icon at the top right of the screen to change the display mode if all desired fields are not
displayed.

Before you add the parent, check the right part of the screen to make sure he/she is not already created. Click Add. The parent
is created as well as the link with the child.

Info • You can link the grandfather and grandmother in the same way.

Family Group Data entry

1. Click the  button at the bottom of the Parents entry field.
2. Choose Add Father or Add Mother. If this arrow  appears at the end of the line, it means Heredis detected a potential
duplicate. Click on it to compare the potential duplicate.
3. Continue the data input with the information you have. To validate the new individual, click outside the entry field.

Info • For more information on adding the spouse of a child in the Family Group Data tab, see Input a Family Group Data.

Link an existing person

During data entry

1 Place the person for whom you want to add parents as the primary person.
2. Create the link.
• Choose Person > Add Father or Add Mother

• Click the  button on the toolbar and choose Add Father or Add Mother .
• Click the links in the empty boxes for the father or the mother on the Immediate Family screen.

In the Add Father or Add Mother window, select the person to be linked from the list of Matching Persons to the right of
the screen. To limit the list displayed, you can enter the given name in the Personal Data area. Click Choose or double-click
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the name in the list.

Info • To access this screen from the Family Group Data tab, click the red arrow  that appears on the input line.

Drag and drop

1. Place the person for whom you want to add parents as the primary person.
2. Drag the father or mother from one of the side panels (Persons, Bookmarks, Relations…), and release on the display area
of the screen (Father or Mother box or Parent fields in the Family Group Data tab). The parent is then linked.

Info • Creating a link to the Father and a link to the Mother will automatically create a union between the father and mother,
even if no event has been entered.

Unlink a person and parents

When you detach a person from his/her parents, the individuals concerned will always remain in your genealogy file.

Info • After you have removed the parent link, you can assign a different mother or father to the primary person.

All tabs

1. Place the person as the primary person.
2. Remove the link with the parents.
• Choose Person > Delete > Father Link or Mother Link.

• Click the  on the toolbar and choose Unlink Father or Unlink Mother.

Family Group Data tab

1. Select the parent to be deleted in the Parents data entry fields.

2. Click the  button at the bottom of the field, and choose Unlink Father or Unlink Mother.
Info • If you select the Delete Father and All Links, or Delete Mother and All Links option, this will remove the person from
your genealogy, not just the link.
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Untraceable Parents

It is not uncommon to come across abandoned children or children born to unknown fathers when doing genealogical research.
In most cases, chances of finding out who the parents were are quite slim. You can now categorize such "dead ends" in a quick
and easy manner. Dead ends indicate that the paternal and/or maternal branch(es) cannot be traced. As a consequence, it is
apparently impossible to go any further on this branch.

For each person in your file, you can now use the label  Untraceable Father or  Untraceable Mother - or both if the
child has been abandoned.

This way, you can see right away whether more research is needed or not.

Create a new person with an untraceable parent

When you add a new person, various labels are displayed. Right then, you are free to click on Untraceable Father or
Untraceable Mother.

(Windows) New Person input screen

(Mac) New Person input screen

See also: Add Persons and The different data fields.

Declare an existing person’s parents as untraceable

Place the person as the primary person, click on the Data > Personal Data tab or on the Data > Family Group Data tab and
click on the appropriate button.

 Untraceable Father
 Untraceable Mother

(Windows) Personal Data

 

(Mac) Personal Data

See also The different tabs.

Identify Dead Ends

Heredis provides several tools to help you track your searches.

When you need to know where you are at, feel free to consult Search tracking. This tool allows you to identify your
“dead ends”. See Search Tracking Tab.
The Branches panel also allows you to filter Dead Ends only.

(Windows) Branches Panel

(Mac) Branches Panel

Dead Ends can be viewed on the various Heredis tree charts:
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The XXL Family now mentions untraceable fathers and mothers
The Immediate Family shows untraceable fathers and mothers
The Ancestors chart under the Family tab also displays untraceable parents
The Ancestors Wheel under the Graphs tab will also show any dead end. See the article entitled Dynamic Ancestors
Wheel for more details.

Untraceable father/mother data will be included in the Sheets as well.

Note: Our earlier printable tree charts do not include this data. Likewise, our automatically generated Books do not specify
when parents cannot be found.

Search persons whose parents cannot be found

If you wish to identify every person in your file whose father and/or mother are untraceable, use our Smart Search.

Click on the Searches > Smart Search tabs.
Set parameters to Persons > Untraceable father > Yes to search your file for persons whose father cannot be found.
Set parameters to Persons > Untraceable mother > Yes to search your file for persons whose mother cannot be found.
Set parameters to Persons > Untraceable father > Yes, click on the + button to add Persons > Untraceable mother
> Yes to search your file for persons whose father and mother cannot be found. Remember to change the filter to At
least one criterion if you are looking for persons with either a father or mother who cannot be found, or both.

See also Smart Search for more details on this search tool for your file data.

Attach a parent to a child with an untraceable parent

If, by chance, you end up finding one or both missing parents, uncheck the corresponding label in the Personal Data input
screen for this person.
Declaring a parent as untraceable can easily be cancelled.
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Add spouses

Add a new person

All tabs

Place the person for whom you want to add a spouse, as the primary person.
Create the link.

Click the + (xx spouse(s)) sign in the display field of the spouse on the Family tab.
Choose Person > Add Spouse

Click the  button on the toolbar and choose Add Spouse 
.

Enter the new person. Check the list of matching persons already in your file in order to not input duplicates.

In the Add or Choose Spouse screen, complete the input fields with the information you have.

Gender is prefilled. To change the gender in order to indicate a same sex union for example:

(Mac) click the Do not specify gender lock, and change the gender
(Windows) simply click in the gender box and change the gender

In case of same sex union, Heredis will alert you in order to make sure it is not a mistake. If it is not, just validate the message.

(Windows) Add a Spouse
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(Mac) Add a Spouse

Info • Click the indented wheel  or  icon (depending on which screen you are, the wheel doesn't look the same) at the
top right of the screen to change the display mode if all desired fields are not displayed. See also Customize Heredis.

Click Add.

(Mac) Enter information about the union.

Don't forget to enter the type of union: Marriage, Religious Marriage, Other marital link, Marriage Contract.

Family Group data tab

Click the  button at the bottom of the Families entry fields.
Choose Add Spouse.
Continue the input with the information you have about the union. To validate the new person, click outside the entry
field.

Info • For more information on adding the spouse of a child in the Family Group Data tab, see Input a Family Group Data.

Don't forget to enter the type of union: Marriage, Religious Marriage, Other marital link, Marriage Contract.

Link an existing person

During data entry

Place the person for whom you want to add a spouse, as the primary person.
Create the link.

Choose Person > Add Spouse

                                125 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Click the  button on the toolbar and choose Add Spouse 
.

Click the + (xx spouse(s)) sign in the display field of the spouse on the Family tab.

In the Add or Choose Spouse screen, enter the surname and given names in the Personal Data field. Select the person to be
linked from the list of Matching Persons to the right of the screen.

Click Choose or double-click the name in the list.

Info • To access this screen from the Family Group Data tab, click the red arrow  that appears on the data line.

Enter the information you have about the union. Don't forget to enter the type of union: Marriage, Religious Marriage, Other
marital link, Marriage Contract.

Drag and drop

Place the person for whom you want to add a spouse, as the primary person.
Take the spouse from a side panel (Persons, Bookmarks, Relations…), and release on the display area of the screen
(display area for spouses on the Immediate Family tab or the Families fields on the Personal Data and Family
Group Data tabs).

Information concerning the family

The data input screen for a marriage and the Families fields on the Personal Data or Family Group Data tabs show specific
fields to be completed, as well as a field for family media on the Immediate Family tab.

Indicate date and place of marriage and any other information you have on the family event.
Specify the family status in the pop-up menu.
Click OK: the spouse is created as well as the link to the primary person.

Family status

Status is additional information indicating the last known status of a union. Are the spouses still married, divorced, separated?
The family status is independent of union events. One may enter a marriage event, but not enter other events for the couple, but
clarify the family status as «Separated».

(Windows) Family Status

(Mac) Family Status
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Specify the family status in the Add or Choose Spouse screen or Families area of the Personal Data tab.

Family number

The family number, when there are several marriages, appears in the Family tab. It is assigned automatically according to the
dates of marriage. To change the family number, select a spouse and move him/her to the desired position.

Families order

Heredis enters unions based on the date of the main family event.
If you know the sequence of unions without knowing the dates, or if the chronology does not seem exact to you, you can
change the families order.

Change the families order

(Windows) Click Right on one of the spouses, then choose Order of spouses. Use the Before and After buttons to organize
and click Close.

(Mac) In Immediate Family, use drag and drop. Select the box or line of family to be moved, and release it at the desired
location.

A blue line indicates the destination position.

Windows - Leave Heredis determine the order

You may cancel a manual order change of families if you have made mistakes or entered new dates. Right-click the list of
families and choose Order of spouses, then tick the box Leave Heredis to determine the order.

Mac - To change the order again

As before, in Immediate Family, use drag and drop. Select the box or line of family to be moved, and release it at the desired
location.

Delete a family

Heredis allows you to delete:
• Either the person. In this case the person will no longer exist in your genealogy file.
• Or the family link that links two spouses. In this case both spouses remain in your genealogy file.

Info • If both spouses have had children together, you must first unlink the couple’s children for one of the spouses. When
you remove the bond of union, the events that were assigned to this family will also be deleted.
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All tabs

1. Place one of the spouses as the primary person.

2. Choose Person > Delete > Selected Spouse Link, or click  in the toolbar, then .

Personal Data tab

1. Select the spouse to be unlinked in the Families fields.

2. Click  (Unlink the selected spouse from the family) at the bottom of the Families fields.

Family Group Data tab

1. Select the spouse to be unlinked on the Families fields.

2. Click  (Unlink the selected spouse from the family) at the bottom of the Families fields.
3. Select the Unlink Spouse option.

Info • If you select Delete Spouse and All Links, you will remove the person from your genealogy file.
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Add children

Add a new person

All tabs

Place the person to whom you want to add a child as the primary person. Select the other parent.
Create the link.

Click Add Child in the display screen of the primary person in the Immediate Family tab.
Choose Person > Add Child.

Click the  button on the toolbar and choose Add Child 
.

Enter the new person.

In the Add or Choose Child screen, complete the entry fields with the information you have. The child’s surname is prefilled
with the surname of the father or the mother if you did not select a spouse for the mother.
To change the name, click in the box and enter another name.

(Windows) Add a Child

(Mac) Add a Child
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Info • Click the indented wheel  icon at the top right of the screen to change the display mode if all desired items are not
displayed.

Before you add the child, check the right part of the screen to make sure he/she is not already created. Click Add. The child is
created and the links with his/her parents too.

Family Group Data tab

Click the spouse who is the other parent of the child to select him/her in the Families data entry fields.

Click the  button at the bottom of the Children entry fields.
Complete the entry fields with the information you have. The child’s surname is prefilled with the surname of the
father or the mother if you did not select a spouse for the mother.

Info • If you made a mistake in selecting a spouse as the other parent, simply change the Family number in the first column of
the Children fields.

Continue the input with the information you have. The second part of each Child line contains data fields for the spouse
of the child.

For more information on adding the spouse of a child in the Family Group Data tab, see chapter Input a Family Group.

To validate the new person, click outside the entry fields.

Link an existing person

During data entry
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Place the person to whom you want to add a child as the primary person.
If the primary person has several spouses, click the spouse who is the other parent of the child to select him/her.
Create the link.

Choose Person > Add Child.

Click the  button on the toolbar and choose Add Child
.

Click the + (xx children) button Add Child in the display screen of the primary person on the Family tab.

In the Add or Choose Child field, enter the given name in the Personal Data field. Select the individual to be linked from the
list of Matching Persons to the right of the screen.
Click Choose or double-click his/her name in the list.

Info • Creating a Child link automatically creates a family with the father and mother, even if no event has been entered.

Drag and drop

Place the person to whom you want to add a child as the primary person. Click the spouse who is the other parent of the
child to select him/her.
Take the child from a side panel (Persons, Bookmarks, Relations…), and release on the display fields of the screen
(children display area on the Immediate Family tab or Children on Family Group Data tab). The child is then linked
to both parents (the primary person and the selected spouse).

Order of children

Heredis places children according to their date of birth.
If you know the order of the children without knowing their dates of birth, or if the chronology does not seem exact to you, you
may change their order of display.

Change the order of children

(Windows) Make a right-click on one of the children and select Order of Children.

(Mac) Use drag and drop. Select the line of the person to be moved, and release it at the desired location. A blue line indicates
the destination location.

Windows - Let Heredis determine the order

You may cancel a manual order change of children if you have made mistakes or entered new dates. To do this, right-click the
list of children and choose Order of Children, then tick the box Leave Heredis to determine the order/ Let Heredis
determine the order.

Mac - To change the order again

As before, in Immediate Family, use drag and drop. Select the box or line of the children to be moved, and release it at the
desired location.

Unlink a child and his/her parents

All tabs

Place the child or one of the parents as the primary person.
Delete the parent-child link.

If the primary person is a parent, select the child to be unlinked from the list of primary person’s children.

Choose Person > Delete > Selected Child Link or click the  button in the toolbar and choose Unlink
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Selected Child.

If the primary person is a child, choose Person > Delete > Father Link or Mother Link, or click the 
 button on the toolbar and choose Unlink Father or Unlink Mother.

Family Group Data tab

Select the child to be unlinked from the Children fields.

Click the  button at the bottom of the field, and choose Unlink Child.

Info • If you select the Delete Child and All Links option, you will remove the person from your genealogy file, not just the
link.
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Add witnesses and participants

Based on the act or document that you possess, indicate who are the persons who attended the event, or who are cited
(witnesses, those present, registrar, etc..).

Witnesses and participants are displayed on the Personal Data tab. For each selected event, you may access them by
clicking the Witnesses or Participants tab. If at least one person was linked to the event, a visual indicator (blue bar) is
displayed on the tab, in the list of events.

Add a new person

Add a witness

1. Click the Witnesses or Participants tab in the event information fields. The Witnesses tab becomes Participants if
the event is shared.

2. On the button bar at the bottom, click  (Link a witness or participant to the event).
3. The Assign a Witness or Participant to… screen opens. Enter the information you know about the person.
4. Click Add. The person is now available in the existing persons list of your file.

Link an existing person

During data entry for an event

1. Click the Witnesses or Participants tab in event information fields.

2. On the button bar at the bottom, click  (Link a witness or participant to the event).
3. The Assign a Witness or Participant to… screen opens. Enter the surname or first name in the Personal Data field

and select the person to be linked from the list of Matching Persons to the right of the screen. Click the Choose button
or double-click the name in the list.

4. Complete the information field on the link and press OK.

Drag and drop

1. Select the event concerned on the Personal Data tab.
2. Take the person to be linked from a side panel (Persons, Bookmarks, Relations…), and release him/her on the

information fields of the event.
3. Complete the link information fields and press OK.
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Add a new person with his/her witnesses

To add witnesses to an event during the data entry for a new person, use the Comprehensive or Customized display mode by

clicking the indented wheel  icon at the top right of the Add or Choose… screen. See also Customize Heredis – Heredis
Preferences article.

1. Add the person you want (see also Add persons)
2. Disclose the Witnesses field (click the disclosure triangle if it is folded).
3. In the button bar at the bottom of the Witnesses field, click the + button.
4. The Assign a Witness to… screen opens. Enter the information you know about the witness and click Add. Or select

an existing person and click Choose.
5. Provide information on the link with the witness and press OK. The witness is added to the Witnesses fields of the

input screen.
6. Enter another witness or continue typing the data for the primary person.

(Windows) Add a witness while adding a new person

(Mac) Add a witness while adding a new person
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Change a Witness or Participant link

Every person in the genealogy file may be assigned to one or more events. Enter the information known about his/her role in
the event.

Change or supplement this information on the Personal Data tab.

1. Select the event and click the Witnesses or Participants tab.

2. Select the Witness link to be changed and click the  Edit and modify the link with the selected witness or
participant button, or double-click the line.

3. Edit the information of the link.

Role

Specify the role of the person in the selected event: it may be a participant in the event (witness, religious officiant, godfather,
etc..) or be quoted as not having participated (deceased relative, lawyer who has registered a contract, etc. .).
Choose the role to assign from the pop-up menu.

(Windows) Witness role
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(Mac) Witness role

Age

• Age on record: many deeds indicate the age of the witness on the day of the event. Fill in the field Age/Record.
• Effective Age: to help you verify the choice of an existing person as a witness, Heredis calculates and displays their actual
age on the day of the event. If it is very different from the age on the record, you have probably selected a homonym. Cancel
the link and select another person or check the dates which may be incorrect.
If the witness or paticipant has no known date of birth, the age on the record allows Heredis to calculate the date of birth
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automatically.

Comments

Type a comment on the link between the person and the event. In most cases, you will use here references to occupation,
residence and kinship as shown on the acts.
Once you have validated the entry or modification of the witness or participant, the comment appears in the list of witnesses or
participants.

Unlink a witness or participant and an event

1. On the Personal Data tab, select the event and click the Witnesses or Participants tab.

2. On the bar at the bottom of the event, click  (Unlink the selected witness or participant from the event).
3. Press OK to validate.

The person is detached from the event but remains available in your genealogy file.
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Add other linked persons

The concept of a linked person allows you to specify a link between two persons when:

The kinship is uncertain. You know that Paul is the uncle of John, but you do not know if he is the paternal or maternal
uncle, or the husband of an aunt. Create a personal link between the two individuals until the exact kinship may be
determined.
There are no events to link the two persons. You know that Jane was a friend of Maria. Create a personal link Friend
between these two persons.

Linked persons are displayed on the Personal Data tab. Click the Sundry Links tab to add, edit or delete them with  

. When at least one person is linked, a visual indicator (blue spot) is displayed on the Sundry Links tab. The personal link
appears in the Personal Data tab of both related persons.

(Windows) Linked Persons

(Mac) Linked Persons

Add a new person

Put the person you want to add a related person as the primary person.

Click on the Sundry Link tab in the Personal Data screen. In the button bar of this tab, click the button  (link a person to
the primary person).

or Click the  Add / Add Link

The windows Linking a person opens. Enter the information you know about the person. Make sure the person doesn't
already exist in the matching persons list (in the list on the right). Select the possible duplicate and check out the summary.
Click on Add or select the matching person and click on Choose if the person is already in your file. You may access the
detailed data of that person later if you wish to expand on the information about the person.

(Windows) Linking a Person
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(Mac) Linking a Person
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In the Linking a person window,

Precise the link by unrolling the Type of Link menu and select friend, heir, cousin, etc.
Complete with a possible Comment of the link to indicate the nature or origin of the bond that unites these two people
as for example "maternal side".

Check the wording of the link at the top of the window and, if necessary, reverse the terms of the link with the 
 ?button. The related person then appears in the Sundry Link tab in the Personal Data tab. Its link will depend on its
gender, if you choose Uncle for example for a woman, then the bond will be Aunt.
Click OK to validate the creation.

(Windows) Creation of the link
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(Mac) Creation of the link area at the bottom of the Person information section window

Personal links with an existing person

Personal Data tab

1. Click the Sundry Links tab.

2. On the button bar at the bottom, click  (Add a link to the primary person).
3. The Linking a Person to… screen opens. Enter the surname and given name in the Personal Data fields and select the
individual from the list of Matching Persons to the right of the screen. Click the Choose button or double-click the name in
the list.
4. Complete the information fields for the link and press OK.

Drag and drop

1. Click the Sundry Links tab.
2. Take the person to be linked from one of the side panels (Persons, Bookmarks, Relations…), and release on the Sundry
Links tab.
3. Complete the information fields on the link and press OK.

Change a personal link

Every person in the genealogy file may be linked to one or more individuals by a personal link. Indicate the information known
about the nature of the link in the input fields.

Change or supplement the information in the Personal Data tab.

Windows' Links
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Mac's Sundry Links

1. Click the Sundry Links tab.

2. Select the link to edit and click Edit and modify the selected link , Mac: or double-click the line.
3. Edit the information concerning the link.

Type of link

Choose the type of link between the two persons from the pop-up menu.

Info • The position of the two persons may be meaningful (Mark is the heir of Peter therefore Peter is the testator of Mark), or
non-differentiating (Maya and Brenda are friends).

Meaning of the link

(Windows) Meaning of the link
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(Mac) Meaning of the link

Check the link in the window title (Is Mark really said to be the heir of Peter, or the testator?).

To change the link, click the Swap the link icon .

Comment

Type a comment justifying the link between these two people.
Once you have validated the entry or modification of the linked person, the comment will appears in the list of linked persons.
The appropriate type of link is specified in the Sundry Links tab for each of the two persons and the comment of the link is
identical.

Unlink a person

1. On the Personal Data tab, open the Sundry Links tab.

2. On the button bar at the bottom, click  (Unlink the selected person).
3. Validate with OK and the personal link between these two people no longer exists, but both persons remain available in
your genealogy file.
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Input a Family Group Data

The Data tab > Family Group Data tab is designed to add easily to expanded family groups and is particularly suited for the
entry of descendants.

Family Group Data

Each generation has an adapted data entry field: parents, spouses and children and their spouses may be entered one after
another.

Click on the  button to add parents, a spouse or a child.

Enter the surname and given name. Then type the date and place of the required events (Birth, Death or Marriage).

To avoid duplicates, Heredis will indicate with a red arrow , any existing person who may match the person you are
entering. Click the red arrow to see the list of potential duplicates. If you think you have identified the person you wish to add,
stop typing and select the person from the list and then click Choose.

Family Group Data  

If no person displayed in the list corresponds to your individual, continue filling out the data fields.

Each data input is validated as soon as you click outside the line. Thus, without displaying any other screen, individuals are
simply added generation after generation.

Each field of the Family Group Data tab is equipped with the same tools as the other input screens (modular input modes,
drag and drop input, automatic formatting, real-time duplicate control).

To delete a person from the family data group, simply select it and click on the  button.

To modify it use the  button in the selected line.

To add a spouse to a child, use the rings icon .
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To display the selected person, click on the button.

Note: As usual in Heredis, you can display more or less fields by using the  indented wheel and change the entering mode.

See also Add children, Add parents, Add spouses.
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(Windows) Permanent control for duplicates & Merge two persons

Permanent control for duplicates

When adding a new person to your genealogy, you may risk creating a duplicate, that is to say, create two distinct persons for
the same ancestor. Heredis provides a tool, available in all entry fields for individuals, to avoid creating a person already saved
in your file. Heredis will control for duplicates at all times during the entry of data. If the person already exists, select him/her
in the matching persons list and click on Choose to link the person instead of creating a new one.

Info • For even more pertinence, Heredis includes in the list of potential duplicates, those persons already entered bearing a
variant of the name you typed.

In the Add or Choose… screen

With the first letters typed in the Surname or Given Names fields, you see, in the Matching Persons column, the list of
individuals already entered who may match the person. Step by step, as you enter new letters, the list of duplicates is updated.

In the Family Group Data tab

When you type in one of the fields of this screen, the full name of a person already entered, the Enter New Data icon (gray

arrow) turns red . Click this icon to see a list of individuals who may correspond to the person.
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Family Group Data

Check if a proposed person is in fact a duplicate

Select the person from the Matching Persons list or check in the Summary panel. Here you have more information for more
effective comparison.
If it appears that the person you wish to create already exists, select him/her from the Matching Persons list and click the 
Choose button. This will cancel the creation of a new person, and thus avoids a duplicate in your genealogy.
If you do not find a duplicate, continue.

Search for duplicates in the file

Heredis controls while imputting but the importing of data from other genealogists, or a moment of inattention may create
duplicates. This powerful tool is essential for maintaining an impeccable genealogy file. Research and verification is carried
out in one click. The results are clearly displayed and indicate the probability of duplication.

The search for duplicate identifies persons entered several times in the genealogy file. The permanent control indicates
possible duplicates as you tip but duplicates can be made because of an import file or an unguarded moment.

Choose Find > Find Duplicates… or click  in the  button in the toolbar.

Setup parameters
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Select your search criteria for comparing the given name:

Ignore: the search will consider only surnames,
At least one of the Given Names is identical: a person whose given names are all included in the given names of
another individual with the same surname will be considered as a potential duplicate,
The First Given Name is identical: an individual with the same surname and the same given name as another
individual will be considered as a potential duplicate,
Tick the box One Given Name of One parent is identical: a person whose given names are all included in the given
names of another individual with the same surname will be considered as a potential duplicate. 
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Select your search criteria for comparing events:

Ignore Events:  the search will consider only given names and surnames,
Dates Strictly identical:  when an event has been detected and assumed to be an identical date, it must be displayed
exactly in the same way in both files (Birth about 1801 and 01/1801 may not be considered as two identical events),
Years Strictly identical: when an event has been detected and assumed to be an identical year for the event, it must be
identical in both files,
Define a Range of Years:  if you do not require exactly the same dates as the criterion for comparison, indicate how
many years from a date to be tolerated for considering two events as identical If you specify range as «10», events that
took place 10 years before or after another event may be considered as potential duplicates.
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You can limit the search for comparing surnames:

Tick the box Limit to a surname and its variants to limit the search integrating this criterion.
Click then on the magnifying glass to select the required surname.

Click Start Search

Results

The list of all potential duplicates identified in your genealogy is displayed in the Results tab. A person may appear several
times in the list if there are several possible duplicates.
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By clicking an individual, you display in the lower part of the column a summary of information concerning this person and in
the right column his/her potential duplicates. By clicking on one of them, you display opposing summaries of the two selected
persons.

You can use the following options for dealing with duplicates:

Delete a person: it removes the selected individual in the left column of the screen if you consider that the duplicate is
adequate and you do not need to merge them to obtain additional information.
Mark Duplicates: all the supposed duplicates matching your criteria for comparison are marked. Then just check and
delete the marked individuals if you wish.
Edit Duplicates Report: all the supposed duplicates matching your criteria for comparison are printed in the form of
an alphabetical list. Just check this list to delete all required individuals.

You may check it out in the summary about the persons concerned to check the data.

After selecting a person and his/her duplicate, you can click on Prepare merger of the two.

If there is indeed a duplicate, merge the two persons by selecting the most appropriate information on the Find Duplicates
screen.

 

Merge two persons
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If you find a duplicate in the genealogy file (the same person entered twice), merge the two persons to get a single person with
all the information recorded.

Heredis has a merging tool that allows you to choose what data to keep.

You can use two methods to merge two persons:

Use Search menu > Search for duplicates or click  in the  button in the toolbar to proceed to a search of all
duplicates in your file.

Use the Person menu > Merge with another person or click on the  button to merge immediately the primary
person with his/her duplicates already spotted.

Merge the primary person with another person

Display one of two supposed duplicates as the primary person.
Choose Person > Merge with Another Person…
Select one of the potential duplicates proposed by Heredis.

If there are no duplicates proposed by the software,

pull down the menu and select Choose another Person
enter a surname and/or a given name to search for corresponding persons throughout your genealogy file.

Click Prepare Merger.
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Merge as a result of a search for duplicates
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Start a search for all duplicates in the file.
Select the pair of individuals that are obvious duplicates in the list of potential duplicates.
Click Prepare Merger.
Select the data to be merged
Review carefully all the data in the merge screen to retain all relevant information.

Merging duplicates
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Pink = Heredis was unable to arbitrate, click one of the two persons to specify what data to keep and the data will be
lost.
Blue = The data will be stored in the merged person.

Only major events (birth, baptism, death and burial) are compared. For other events (residence...), you need to check by
scrolling on the second person, they are not directly compared. Make sure not to keep duplicates of these events. If you do,
you'll have to delete them one by one on the Personal Data screen.

The union is not always comparable if the spouse has also a duplicate. Heredis consider they might be homonyms so you'll
have to merge the 2 spouses too.

Same for parents, except that you'll have to choose which parents you want to keep. It is not possible to have 4 parents.

Important : Merging person is a long and tedious operation, it must be done sparingly. We advise you to do only 3 or 4
mergers, one after the other. If you have more, close your file and restart it. Thus the data to be kept will be saved on your file
without risk of damages. Closing the file allows for a more complete record of changes than just the automatic recording or
pressing the Save button.

Check the merged person

Heredis open the Immediate Family tab of the merged person.
If you were still in the Search for duplicates screen, you can continue the fusion of new duplicates.
1. In the Immediate Family tab, check that the merged person has the right persons as parents, spouses and children.
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2. Click the Personal Data tab to check all the information retrieved. Remember to click each event to check notes, sources,
witnesses, media.
3. Click to verify the different families, and the identity of the spouses.
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How to delete?

Delete a link or a person

Sometimes you need to fumble about, make mistakes, and be able to fix them. The toolbar has a Delete  button and offers
a list of persons to be “deleted”.

This feature actually allows you to unlink a person from the primary person without deleting it. The primary person is the only
one who can be (completely) deleted this way.

If the “father” is not the right person, you can unlink him from the primary person by selecting   Unlink father. You may
still link him as a father to another primary person at a later time. The same thing is true for any other person in your
genealogy.
In the same manner, you may delete a family link such as a spouse or a child.

Delete an item from an index

Open the index you are interested in and select the item to be deleted.

Click the  button (Delete). Confirm you want it removed from the index by clicking OK.

Info • Surnames, given names, and places cannot be deleted if they are in use.

Delete unused items from an index

You may choose to remove, in one simple process, all unused items in your genealogy file. As a precaution, start with
displaying a list of all unused items by checking the Unused […] box next to the Search field.

(Mac) Click the Options button in the toolbar of the index then select Remove all unused […]
(Windows) Click the Tools button of the index then select Remove all unused […]
Confirm their removal by clicking OK.

The – button to delete

Generally speaking, when you see this button , it means you will be able to delete data.

Delete a Heredis file

Your genealogy file is stored on your computer hard drive. Heredis needs it to be on the hard drive to be able to work properly,
you should not launch the file from a removable drive (USB drive or external hard drive).

You can delete a genealogy by placing the file in the recycle bin of your computer.

Heredis is a desktop software, which means that your files are saved on your computer. Only you can access it, we do not have
your files. This is why it is always necessary to make backups on USB drive or cloud or external hard drive.

To find your files, see the article Find a file on your computer.

 

                                157 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Input events

In the Personal Data tab, Heredis proposes a full list of events commonly encountered in genealogy: individual events and
shared events which may apply to the couple formed by the primary person and the selected spouse.

Add events with the buttons at the bottom of the screen. Major events have their buttons for direct entry. For any other event to

be created, click  Add an event button to select it from the list of events.

To facilitate your entry, Heredis will first display all the events already in use in your genealogy.

When an event is added, you may rename it by double-clicking on its name or select it and use the  button. Transform a
Diploma event by entering Master’s. The event will be available later as Master’s in a submenu of the Diploma event.

Add an event

Add a person event

Add a person event

1. Click on the  button on the bar below the list of events. To facilitate the selection of the event, Heredis displays at the top
of the list, the events already in use in your genealogy file, and finally the events not yet used in the Others group.
2. Select the desired event, for example, Will. Will is added to the list of events of the person.

Info • You can also add major events by clicking the B, C, D or BU buttons (Birth - Christening - Death - Burial) placed
below the events list. If these buttons are not visible, change the input mode of the screen.

Add a family event

1. Select the spouse of the event from the list of families.

2. Click the  button on the bar below the list of events.

Info • You may also add the main events of the family by clicking the M, RM, MC buttons (Marriage - Religious Marriage
- Marriage Contract) below the events list. If these buttons are not visible, check the display mode of the screen.

3. Select the desired event, such as Engagement. Engagement is added to the list of events of the person.

Info • The family events also appear in the input and navigation screens of the spouse.
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Create events not proposed by Heredis

You may add events that are not mentioned in the list of events proposed by Heredis.

1. Click the  button on the bar bellow the list of events.
2. Choose Others, then the neutral event called Event.
3. Double-click on the name Event that has appeared in the list of events. A window opens where you can rename the event.

Windows Customize event

Mac Customize event

4. Enter the new name of the event.
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Now this new type of event will automatically appear in the list of events to create. You may choose not to display it by
clicking on Customize and unchecking the events you do not want to see, or you may select it later by managing the list of
events. See the part bellow.

Info • If the nature of the event to create already exists, modify an existing type of event in the same way. For example, you
can create an Estate event by renaming a Will event. You will find this event in a submenu of the original event. By selecting
Will, you can choose between Will and Estate.

Share a person event

Heredis allows you to share a minor person event with other persons in your genealogy. This event and all information relating
to it will be automatically available to all participants in the event.

Select a person event in the list of events displayed in the Personal Data screen > Person event and then click the 
 button below this list. The Witnesses tab is replaced by the Participants tab and allows you to add the other persons sharing
this event.

It is possible no longer to share an event. With this operation, the event no longer to be shared remains associated with the
primary person on the screen. Other participants become mere witnesses and the “unshared” event no longer appears in their
list of events.
In the list of events for a person, the letter S, displayed in front of an event, indicates that this event is shared.

Info • the major person events Birth, Baptism, Death and Burial are not shareable. The Domicile couple event is also
shareable.

Customize the display of events

Heredis can present the list of available events according on your work habits. Thus, you will have easy access to the events
that you create most often.
The customization affects only the list of events to create and there is no risk to your data, events already created remaining
always displayed.

Modify the list of events displayed 

1. Click the  button on the Personal Data tab, in the events list.
2. Choose Others > Customize…
3. Untick rare events, those which you rarely use, to lighten the list when creating a new event.

Windows Customize Event

                                160 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Mac Customize Event
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Heredis always shows events which you have already used at the top of the list, and events that you have not yet used at the
bottom of the list. You see now that the other used events part no longer contains the items you have unticked.
You may always tick any new hidden events to make them reappear.

Information on the event

The detail of each selected event is available on the Personal Data tab. If you do not see all the events, change the display
mode of the Personal Data tab by clicking on the indented wheel. See the article Customize Heredis for more details.

Information of the event
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Date

To enter the date, numerous input options are available, whatever the period concerned, in four different types of calendars:
Gregorian, Julian, Hebrew or French Republican.

Time

Time may be specified as 05:30 or 5:30. To separate hours and minutes, you can type either : or H or h, with no spaces.

Age on record

Enter the age stated on the deed or record, if it is mentioned. You may specify the age with the words: years, months or days
(or y, m, d). No other word will be accepted. An age with numbers only will be considered as years.
If the birth date of the primary person is known, you may compare the age on the deed with the actual age shown in the list of
events.
If the date of birth is unknown, Heredis will automatically complete the field with an approximate date calculated from the age
on record that you entered.

Place

Indicate the location where the event took place.

Entering a new place
1. Type the name of the city in the Place field, not bothering about upper or lower case. With the first letters, Heredis proposes
a list of places that may match your entry.
2. Select a place using the mouse, or use the up and down arrow keys and confirm the location selected by pressing Enter.
3. If no proposed location matches, (Windows) fill in the case and click on the tab key to add this new place to the index; 
(Mac) select New Place in the list.
4. Complete the information on the new place to be recorded, and press OK. The new location will be added to the Places
Index. You may geolocate this place. See the article Geolocating places.

Assigning a place already in use in your genealogy
1. Unfold the Places panel.
2. Drag the place of the event and drop on the event being entered.

Info • Be sure to visit the place of your ancestor’s life by clicking the Map tab of the event.
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Place Subdivision

The Place Subdivision field is to specify a more precise location than the city: the hamlet, parish, district or borough of a large
city. Since Heredis 2020, you can geolocate the subdivision, see the details on Geolocating Place Subdivisions.

Cause/Information

The Cause/Information field allows you to specify the cause of the event (as for Death, Divorce, Professional transfer events)
or any useful precision.

Event Note

Enter your comments about the event directly into the note field. To embellish the entered text, click the pencil icon. Heredis
opens the note in a separate screen containing all the formatting tools. Tick the Private Note box to exclude the event note
from exports or printed documents.

Other elements linked to the event

The Details tab of events displays a Private Event box. When this box is ticked, all data in the event may be excluded from
exports or hidden in printouts.
To monitor your research, mark the event with its corresponding status of research. Choose No Search Record, Search
Record, or Untraceable Record. You may choose the default option for each new event in Heredis > Preferences > Format.

Each event may be completed with witnesses, sources, media and an interactive map showing where the event took place. Each
of these elements is available in a tab on the Event screen.

Delete an event

Simply select the event to erase and click on the  button at the bottom of the event list.
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Dates

Recognized calendars

Heredis treats dates entered in 4 different calendars: Gregorian, Julian, Hebrew and French Republican. The dates must be
between the year 4712 BC to the year 3454 AD of the Gregorian calendar.

The Gregorian calendar used today in most countries of the world, was promulgated in 1582 and applied at widely varying
dates in different countries (from the fourteenth to the twentieth century). Dates prior to the promulgation of the Gregorian
calendar are considered as being expressed in the Julian calendar.

The Julian calendar was abandoned in favor of the Gregorian calendar. Certain countries retained it until the twentieth century.

The Hebrew calendar is used in documents of the families of Jewish faith, regardless of the country where they live.

The French Republican calendar was used only in France and covers the period from September 22, 1792 to January 1, 1806.

Entry of dates

Heredis handles dates expressed in numbers (using the separators . or /, or spaces), or the dates expressed with the month in
letters (entered in full or abbreviated).

A date may be entered in the Gregorian, Julian, Hebrew or Republican calendars. If there is no month name which is
characteristic of a Hebrew or French Republican calendar, Heredis considers that the date entered is expressed in the Gregorian
calendar. To enter an incomplete date in the Hebrew calendar, precede it with the letter H (1987).

To enter a date expressed in Julian after December 10, 1582, precede it with the letter J (J June 23, 1654).

To enter a date expressed in the French Republican calendar, enter the year in numbers, Roman or Arabic, preceded or not by
the word «An». Enter comp for additional days (for example, «6 comp An III» for the sixth complementary day of the year III
of the Republic).

Recognized formats

For Heredis to decode the date according to your desired entry order, choose Windows: Tools > Preferences > Heredis
Preferences > Format; Mac: Heredis > Preferences > Format and select the order of elements of the date you want
Day/Month/Year or Month/Day/Year).

The date of «2 February, 1794» may be entered in the following way, if you have determined the order day/month/year.

Gregorian calendar
• 2 February 1794
• 2 Feb 1794
• 02/02/1794
• 02.02.1794

Julian calendar
• 22 January 1794
• J 22 Jan 1794
• J 22/1/1794
• J 22.01.1794

Hebrew calendar
• 2 AdarI 5554

                                165 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

French Republican calendar
• 14 Pluviôse an 2
• 14 pluv an II
• 14 pluv 2
• 14 pluviôse II

Info • For every printed document and for each exported file, tick the Use Gregorian Dates option. Some other genealogy
programs do not deal with the different calendars in their GEDCOM imports; it will thereby be compatible with all programs.

Interval of dates and approximate dates

Heredis manages the chronology of events according to the dates entered, exact or approximate. Use keywords to express
intervals of dates or approximate dates.

Before
Type the word before or the symbol < followed by a space or the symbol / with no space and then type the full date or not, in
numbers or in words.
• before 23 August, 1845
• < 23/8/1845
• /23.08. 1845

After
Type the word after or the symbol > followed by a space, then type the full date or not, in numbers or in words. Or type the
symbol / with no space after the date.
• after 6 June, 1774
• after 6/6/1774
• 6.6.1774/

About
Type the word about or the word circa or the abbreviation ca or the symbol ~ followed by a space, then type the full date or
not, in numbers or in words.
• about February 1811
• circa 2/1811
• ca 2.1811
• ~2.1811

Between / and 
Type the words between and then and or the symbols <> and & and then type the full date or not, in numbers or in words or
type the symbol // between the two dates with no spaces.
• between 11 October 1914 and April 1917
• between 11/10/1914 and 4/1917
• <> 10 November 1914 & 04 1917
• 11.10.1914//4.1917

From to
Type the word from followed by a space and then type the full date or not followed by a space and then type the word to after
the full date or not.
• from 1845 to 1846
• from 8/1845 to 9/1845
• October to September 1845
• from 23/8/1845 to 31/8/1845

Before any date, complete or incomplete, you may add the following keywords:
• Estimated or est to indicate that a date is a mere guess. In this case it is displayed preceded by the estimated or (est). It is
taken into account in chronology screening (eg. order of families, order of the children...) but it is excluded from printouts.

                                166 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

• Calculated or cal to indicate that a date has been obtained by calculation. For example if you do not know the birth date of a
person but you have found the age at death on the death certificate, the software automatically displays a calculated date of
birth. The user may also enter a date named calculated, being the result of deduction. The calculated dates are displayed and
printed preceded by the words calculated or (c).

Info • The dates entered in a valid format may be followed by any comment that may facilitate your work, provided it is
entered in brackets. You can specify 1875 (early summer) or June 1674 (TBC).

Automatic calculation of birth dates

Heredis automatically calculates the date of birth of persons whose age is known at any given event. The age of the father,
mentioned in a birth certificate, allows you to create or complete the father indicating the probable year of birth. This will
make it easier to find the birth certificate of the father, thus advancing your genealogy.

For the person living the event

1. Create an event and specify the date.
2. Add the witnesses (witness, declarant, etc.), and specify their age in the Age/Record field of the input screen for the link.
Info • Remember to choose the Customized or Comprehensive input mode to display this field by clicking on the indented

wheel .

Witnesses to an event

1. Create an event and specify the date.
2. Add the witnesses (witness, declarant, etc.), and specify their age in the Age/Record field of the input screen for the link.
If the date of the start of their life (birth or christening) already exists, your data remains of course unchanged. If the date of the
start of their life is unknown, Heredis adds a calculated date of birth.
Info • The dates calculated are shown in italics preceeded by a (c) in the list of events on the Personal Data tab.

Conversion tool for dates

To get the equivalent of a date expressed in a calendar which you are not used to, use the Dates panel.
1. Click the Converter tab of the Dates panel.

Date Converter
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2. Enter the date as you found it, regardless of the calendar in which it is expressed. Heredis displays the equivalents in the
other calendars.

3. To use one of the dates displayed, click the  Copy Date button to the right of the date you want.
4. To insert this version of the date in a data entry screen or in a note, click the insertion point and choose Edit > Paste.

The dates of movable feasts

Who has not found the words «Easter Day» or «two days after Pentecost» in an old document?
Heredis facilitates your genealogical research by indicating the dates of these moveable feasts for all the years between 325
AD and the year 2500.
1. Click the Movable Feasts tab of the Dates panel.
2. Indicate the year for which you are looking for this feast day. Heredis displays the dates of Christian, Jewish and Orthodox
movable feasts for this year.
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Input notes

Add specific details to your genealogy by using the available notes. You will find entry boxes for notes on persons, families,
events, media, sources, surnames, given names, occupations and places. The notes are equipped with formatting tools
integrated in the Heredis software. One may also paste formatted text from other applications (word processors, browsers,
desktop publishing tools, etc.) though images are ignored. A note is a text block, it is not made to integrate images.

(Windows) Input Notes

(Mac) Input Notes

Individual, family and research notes

1. Display the notes:
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(Mac) Choose Person menu > Edit Person Note or Edit Family Note.
(Windows) Choose Person menu > Edit Notes

or Click the ou  button in the toolbar if it is displayed.
Click directly in the Note field when displayed on the navigation or data input screens (input tabs, indexes, media,
etc..).

In the Data screens, click on the pencil  to access the note.

2. Enter the text of the note or paste the contents of the clipboard.
3. Use the formatting tools in the text editor.
4. Tick the Private Note box if you wish to keep this note excluded from export of the file, printing or publishing on the
Internet.

Windows Info • When a note is filled in, the Notes tab is preceded by a blue bullet and the button   displayed in the

toolbar changes its appearance to  .

Mac Info • When a note is filled in, the Notes tab is preceded by an icon  and the button  displayed in the toolbar

changes its appearance to .

Info • If the note is not visible on the data input tabs, change the data display mode. See Customize Heredis > Select data entry
method for further details.

Note of an event

(Windows) Note of an event

(Mac) Note of an event
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Type directly your comment in the text box of Details tab

or Click on the pencil  to open the text box in a new window. You can write and modify the format of your note.

They can be formatted with the usual word processing tools.

Info • If the note is not visible on the data input tabs, change the data display mode. See Customize Heredis > Select data entry
method for further details.

Options of notes

For each notes, you can add a specific format with the text editor:

(Windows) Options of notes
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(Mac) Options of notes

Typeface: Bold - Italic - Underline
Alignment: Align Center - Left - Right - Justify
Choose the font style and size
Manage the hypertext link
Cut - Copy - Paste - Print

You can make your note private by ticking the Private note box so it won't be published.
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Media

Whenever you see this  display area  you may add an illustration: the photo of your great-grandfather, the photo of your
baptism, the scanned image of a death certificate from 1715... These are not only images that you can attach to your data files
but also sounds, videos, PDF documents, files created with your word processor.

Nothing is easier than to associate media: select it from your hard drive (Mac) or in iPhoto and drag to the display area.

Assign to your data any type of media to illustrate your genealogy.

What media for your genealogy?

Besides the usual media (images, sounds and videos), Heredis can assign files that can be opened directly from your genealogy
software by launching the application that was used to create the media.

Assign a text file created with (Windows) any word processor ; (Mac) Pages and Heredis opens your word processor to
read it.
Assign a numbers document and either Excel or another spreadsheet program on your hard drive will open it to read it.
Integrate PDF files and Adobe Acrobat will open as soon as you double-click the media.
A Heredis tree chart effectively illustrating a branch? Assign the tree chart file to your ancestor. This tree chart may be
opened from the Media tab of the person displayed.

Note: files that are not image formats (.jpg, .jpeg, .png, etc.) will not be taken over when creating a document (Book, Sheets,
etc.)

What data can be illustrated?

A person: in the media display field of the primary person in the Immediate Family, XXL Family, Personal Data or 
Family Group Data tabs. You may also add media to the Personal Data field of Create or choose... screen.
A couple: in the Families field of the Personal Data tab.
An event: on the Personal Data tab, click the Media tab after selecting an event.
A surname: in the Surnames Index, either in the display field of the selected surname or directly in the Entering
Surname screen.
A given name: in the Given Names Index, either in the display field of the selected given name or directly in the 
Entering Given Name screen.
An occupation: either in the Occupations Index, either in the display field of the selected occupation or directly in the 
Entering Occupation screen.
A place: in the Places Index, either in the display field of the selected place or in the Entering Place screen.
A source: in the Sources Index, either in the display field of the selected source or in the Entering Source screen.

The profile media of a person once added will be visible in several screens.

For example:

In the input data file
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In the Immediate Family screen

In the Personal Data screen
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The quantity of media assigned to each item of data is unlimited. If you add multiple photos at different ages, for example, you
can define which one should be the main image. This main image will be the one displayed in the summary, in the trees, in the
documents… To choose your main media of the individual, double-click the image to open the photo tool. You will then see
all the photos attached to this individual. Select the photo you want to put as the main photo and click on the star at the bottom
of the list.

Each media may be assigned to several items of data.

When media have been assigned in your genealogy file, they are visible in the Media panel and in the Media Index.
A date and/or a note may be added to the media if you edit it by double-clicking on it.

Info • All media assigned to your genealogy are integrated into your file. You may synchronize your file with your mobile
phone or another computer without worrying about the media. They will be automatically transferred.

Import media to your file

You can add one or more media simultaneously to your genealogy file.

Adding media to the file is done either from the media display field for each selected data, or directly into the Media Index or
the Media panel. In this case the media are integrated into the file but not yet assigned to data. They are classified as Unused
Media.

(Mac) Drag and drop
1. Locate the media or several selected media to be imported on your hard drive or from the application that manages your
photos (iPhoto, Aperture, etc.).
2. Drag the file to import and drop on the media display field of the data or on the Media Index or Media panel.

With the Media field buttons

In the Media display field for each data item:

1. Click the  (Add to media) button.
2. Select the media to be assigned:

• Select (Mac) Drag from the Media Index / (Windows) Choose from media index if the media has already been
assigned to your data.
• Select Choose on Disk if the media to be imported has never been assign to your data.
• Select Past from Clipboard if you previously copied the media in the clipboard.

3. Select the media with the (Windows) Windows Explorer ; (Mac) Finder tools and click Open.

Info • To display the toolbar for media management, move the mouse over the display field of the media. Right-clicking on
the display field of the media also gives you access to the Add New Media option.
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In the Media panel or in the Media Index:

1. Click the  (Add New Media) button.
2. Select the media to be imported with the (Windows)  Windows Explorer / (Mac) Finder and then click Open.

Information on the media

Link between media and data

At any moment, you may assign new media to an item of data, or unlink media assigned by error. Heredis lets you also replace
one media with another.

Media details

For each illustrated data in your genealogy file, double-click the media displayed and view the multimedia screen to manage
all assigned media. In the Media Index or the Media panel, double-click the media to display the Photo tool screen.

Photo Tool for Windows

Date: The date of the media is a useful guide to illustrate the lives of ancestors, and allows the classification by date of the
various media assigned to a person.
Note: Enter your comments in the notes field. The note may be formatted with tools for text editing.
Private Media: Tick the Private Media box to exclude it from export of a file or printing of a document.
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Preferred Picture: Among all media assigned to the data, select the image that is displayed in the navigation screens and that
illustrates the tree charts and printed documents. Tick the Preferred Picture box if your choice is not of the first image you
have assigned to the data.

Photo Tool for Mac

Mac Info • You may change the Preferred Picture in the display field of any given media. Move over the area with the
mouse to display the toolbar for media management. With the Previous Media – Next Media arrows, display the image you

want to set as the Preferred Picture. Click the Preferred Picture button (shown as a star ).

Info • Find in this display field of the selected media its name, its size and original location of the media.

Info • Media are copied to the genealogical file. Their original location is given as an indication, there is no longer any
connection between the media at the original location and media in your genealogy file. You can, however, request an update
of the media file from the original media.

Display order of media

Heredis automatically classifies media according to the order in which you have assigned to the data. To change this order, file
them by date or name, or manually move the media in the order you want.

From the Photo Tool or the Media Index.

1. Open the multimedia screen of the data.
• Double-click the media field.

• (Mac) Click the pencil-shaped  bar in the media buttons.
2. Arrange the media.
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• Click the Sort (  icon) and select Sort by date or Sort by name.
• (Mac) Drag the media with the mouse to position in the desired display order. A blue line indicates where the media
will be dropped.

For further details see Photo Tool.

Searching for missing media

Check missing media

You have imported a file from an earlier version of Heredis or GEDCOM? If the original location of the media was changed at
the time of import, or if a folder containing the media did not accompany the GEDCOM file, the media may be missing. A
GEDCOM file only contain the name of the media and way to access the original.

They are displayed differently if Heredis had the thumbnails or not.

For a Heredis file where there was a displayed thumbnail, the words “original not found” follows the media name in
the media edit window, but you still see its representation.

For a file where there was no displayed thumbnail, the icon of the media not found  is displayed instead of the
media.

Find a group of media

Open the  Media Index.
1. Click the (Windows) Tools / (Mac) Options button (indented wheel icon) on the toolbar of the Index.
2. Select Check media…

Windows Check Media

Mac Check Media

Heredis reviews all the media in your genealogy and detects, if any:

media not found following deletion from the Media folder managed by Heredis
media of which the original has been modified by third party software other than Heredis
and finally, media for which the original has changed location and is no longer present on your computer.

In the Media check window, you can:
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in the Missing Media tab, designate a folder to search and update these media. Click on Choose folder and update.
Indicate the location of the media on your computer.
in the Original changed tab, select all or part of the media managed by Heredis to update them from the originals.
Click on Update the selection.
in the Missing Original Media tab, specify the folder where your original is located. Click on Choose a folder.

Note: If your media are stored in multiple folders, you will have to do as many times the manipulation to indicate which folder
you have folders.

(Windows) Media check window

(Mac) Media check window
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If your originals have changed their names, Heredis will not be able to reinstate them automatically. Indeed, the software
cannot know that you have changed the name of a media. In this case, see the paragraph below.

Unlinking, replacing or deleting media

Unlink media

In all the display fields for media, (Mac) right-click the media concerned and choose Unlink Media, or (Windows) click the 

 button on the toolbar for media management.

On the screen displaying all media assigned to a person or data:

• (Windows) Select the media in the left column, or click the  (Remove Selected Media) button at the bottom of this
column.
• (Mac) Click the media in the left column and then, in the display field of the media, right-click and choose the Unlink Media
from… option.

The media is unlinked from the person or data but remains available in the Media Index and may be assigned to other.

Replace media with other media

You may have assigned two different media but they were the same (an image of a source saved with two different names, the
same image on the selected hard drive and in iPhoto ...). You may only keep one assigned media but use it several times.

1. Open the 
 Media Index and select the media to be replaced.
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Media Index for Windows

Media Index for Mac
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2. Click Replace with another Media from...  or on the button bar of the display field and choose the duplicate image
in the index or the replacement image in its folder on your hard drive.

3. Select the media to be kept and click the Choose button.
The initial media has been replaced by the second for all its uses.

Delete media

Display the Media panel, or open the Media Index.

Select the media to delete

Click the 
 (Remove the selected media) button on the toolbar for media management.

(Mac) Right-click the media and choose Remove...
Confirm the deletion of the media with OK.

This will delete the media from your genealogy file. If it had been used, it will no longer appear in the illustrations of data or
persons to whom it was assigned.

Sharing media

Export a file containing media

Media are integrated in your genealogy file. When you export a part of your file by creating a new Heredis file, the media
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assigned to the exported data are integrated into the new file, unless you had unticked the Media box of the Heredis export
screen.

When you synchronize your genealogy file with your cellphone or with another computer, they are also integrated in the data.

Export media files

You can extract one or more media from your genealogical file for transmission to other people or for another use on your own
computer.

Double-click on the media to access the edition screen of the media,

1. (Mac) Choose Export This Media… in the right-click menu on the media, or (Mac & Windows) click on the Export

selected media 
button.

(Mac) Export selected media

(Windows) Export selected media
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2. Keep the same name or change it and choose the destination location for the exported media.

In the Media Index,

1. Make a selection of media using the display filters for different types of media or uses. Display for example images used for
sources in the submenus.
2. Click the (Windows) Tools / (Mac) Options button on the toolbar of the index and choose Export Displayed Media….

(Mac) Export media from Media index
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(Windows) Export media from Media index
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3. Select the destination folder for the exported media.

For further details, see Media Index.
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Alternate names

You can make a person’s data even more complete by adding alternate names (birth name, maiden name…) in your genealogy.
This type of data is displayed in the center of the Data>Personal Data screen, in the Alternate Names tab.

(Windows) Alternate names

(Mac) Alternate names

Once an other name has been entered, a blue symbol appears in the Alternate Names tab.

To add an alternate name, click on the  button.
Enter all the data you possess such as prefix, suffix, given names, nickname and select the corresponding type of name in the
pop-up menu.

Note: if none of the existing types corresponds to the data you are entering, choose Others to create your own type of data.
You can also choose to rename the existing types of names predefined in Heredis.

To delete an alternate name, select it in the list and click on the  button.

Note: in the Surnames and Given Names indexes, you will not be able to delete these alternate surnames and given names as
long as they are used by a person in your genealogy.

Alternate names associated with individuals in your genealogy are automatically processed when you import and export data in
GEDCOM or Heredis formats as well as during merges.
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Facts

With Facts, enrich your genealogy with new data and attach witnesses, places, sources, medias and dates to it.
You can add as much as you wish, unlimited number, and you can organize them.
These facts are displayed in the central part of the screen Data > Personal Data in the Facts tab.
When a Fact is filled, the tab is marked with a blue spot.

Facts

To add a Facts, click on the  button and select the fact to add then write directly in the Description area.

If you wish to complete this fact with other information, a date, a place, a source, a media… click on the pencil 
button displayed in the tab.

To delete a Fact, select it and click on the  button.

Note: If you confirm a delete, all information linked to this fact will be lost.

To organize the display of the facts of your genealogy, click on the indented wheel . Select the facts then click on
the Before and After to change the order of this field.

Create customized facts

You can add facts that are not already in the list proposed by Heredis.

1. Click on  button.
2. Choose Other and select Generic fact or an other fact you wish to add a subcategory to. (for example, Health to add

Surgical intervention)
3. Double-click on the name of the new fact in order to customize it. A window opens to edit and rename the fact.

(Windows) Customize facts
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(Mac) Customize facts

4. Enter a new title.

Now this new type of fact will automatically appear in the list of fact to be created. You will now be able to use this fact
anytime you need it.
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Census

Entering Data from a Census

During your searches, you may need to consult census records. As a matter of fact, such documents can help you narrow down
the range of a search period. Imagine you are missing the death date for one of your ancestors. If he/she appears on the records
of the 1830 census but is no longer listed on the 1840 one, then you can hypothetically presume that he/she passed away
between 1830 and 1840. Moreover, the census will provide data on the household composition, occupations, place of
dwelling...

To easily enter data from census records, click on the shortcut Census of your toolbar or from the menu Person > Census.

A window opens up so you can easily enter the data found on this type of documents. An area is available for you to add a
media. Click the + button to add the media from your hard-drive disk, from the media index, or from the clipboard.

(Windows) Entering data from a census

(Mac) Entering data from a census
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The usual Heredis tools are available so you can zoom in and out, add, delete, or edit a media.

In the lower area, several tabs are available for you to easily enter data from the census.

The Record Reference tab

First, start with the Record Reference tab. Select the desired Country. If the country is not listed, select Other in the scroll-
down menu. In the same way, you can modify the year in the Date field.

Enter the City.

You will probably notice that Optional entry fields will vary according to the year and country selected. Indeed, Heredis has
prerecorded for you the most frequent entry fields for each census, year after year, in the US and in some other countries. You
are given the possibility to modify them by selecting or unselecting each entry field according to your needs. Optional entry
fields are listed according to the place where the data you enter will be stored. As an example, you will be able to later find the
data on Nationality in Facts section.

(Windows) Record Reference Tab
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(Mac) Record Reference Tab

You may then enter the data related to the Source. As you will see, fields are partially filled out. You can modify them as you
please.

Source Tab

You are given the option to enter source details for your census. Some data are already filled based on what you previously
entered in Record References. You may change it if you wish.

(Windows) Source Tab
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(Mac) Source Tab

Then, go to Household tab.

Household Tab

Under the Household tab, enter the Address then the household Composition - in other words, the number of persons living
together under the same roof.
In the Persons area, click the + button to add a person; by default, the first person you enter will be considered the Head of
Household.
Specify his/her Surname and Given Names. Just like every time a person is entered in Heredis, the magnifying glass will turn
into a red arrow when the person is possibly already in the file. If you know he/she is in your file but his/her name is written in
a different way, click on the magnifying glass to select him/her. If you  don't and keep entering you'll create a duplicate.

Specify Occupation.
Select this person’s Household Status by clicking on the pull-down list.
Continue entering data according to the fields available for your census.
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(Windows) Household Tab

(Mac) Household Tab

Note: If necessary, entry fields can be added at any time by going back to the Optional Entry Fields.

Add the other persons. For each one of them, specify his/her Household Status in relation to the Head of Household.

Note: The persons who are not already part of your genealogy file are marked with an asterisk and will be created after the
census record is validated.

Mac only: You can drag and drop from the Persons panel in order to add a person to a household.

Make sure to check Family Links or to create them if needed.
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Family Links tab

Under the Family Links tab, double check the links between each person and the head of household. When entering data from
a census, Heredis will assist you in creating persons and the links between them.

If you do not find the appropriate link, select Other and specify, under the Family Links tab, the relationship between the two
persons.

Heredis allows you to specify the links between two persons, even if they are not blood related. Therefore, no data is lost and
you will be able to find them again under Sundry Links in the Personal Data tab.

(Windows) Family Links Tab

(Mac) Family Links Tab

Note: Pre-existing spouses/parents/children links in your file will not be modified – if necessary, an alert will notify you of a
conflict.

The non-existing links will be created for you automatically.
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Additional Info tab

Add any extra data you may have under the Additional Info tab.

Window Validation

When you are done entering data, click on Validate. Double check the data entered under the Persons area. If a  red
triangle appears, it means there is a conflict between the new data you have just entered and what was previously recorded in
Heredis: choose what suits you best by clicking on the list of suggestions.

(Windows) Validation Window

(Mac) Validation Window
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You are free to create a new source, to choose an existing source, or even not to create a source.
Remember to assign the source either to the census or to the events and facts related to the census.

On the right-hand side, you will see the summary of your recent data entry, which you can:

Save in the source note,
Save in the source transcription,
Save in the note or citation transcription if you work in Comprehensive Mode (see the The different mode for Sources
& Citations article),
Decide not to save.

You are also given the option to choose where the media should be saved: in the source, in the citation, or in the event.
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Then click on Validate once you are certain you are done.

Note: if you have several entries to make from a single census, all you need to do is click on the Next button.

Check out our online video on Census on our Youtube channel  for more explanations.

 

                                199 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Sources

The information gathered about your ancestors will be more or less reliable depending on their origin. Assign one or more
sources to each event, fact, or person in order to justify the information recorded.

Each source (an act, a website, a historical work...) may be detailed and illustrated at the time of its creation or later.

For each source, specify in the proposed boxes, the title, reference, author, quality of data.... A free text box allows you
to enter a note or record the transcript of an act.
You can mark a source as private in order not to export it when exchanging files, nor to publish it.
Each source may be illustrated with media.

Once a source has been created, you may assign it to one or more events. Each event can have one or more related sources.
When you assign a source to an event, add a comment indicating the link between the event and the source.

 

 

 

Create a new source and assign it to an event

Source tab

1. Select the event from the Personal Data tab.
2. Click the Sources tab.

3. Click the   button.

4. Click the (Mac) New Source button or (Windows) the  button in the Source index screen.
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5. Enter the information for the source and press OK. The new source is assigned to the event.

(Mac) Create a source

(Windows) Create a source
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At least enter : Source type, Title, Call#, Repository and Certainty.

Add media, note, transcription, make the source private by ticking the Private Source box.

Create a source from the source index to attach it later

Open the Source index, click the (Mac) New Source button or (Windows) the  button in the Source index screen.

Note: To save time, you can duplicate a source. Select the source you want to duplicate and click . Edit the source with 
 to edit the fields you want to edit. So if you have the same source but just a reference that is different, you can duplicate the
source and only change the reference. This is very useful when you create a source for a complete registry. See also The
different modes for Sources & Citations or see below.

 

Assign an existing source by drag and drop
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1. Select the event from the Personal Data tab.
2. Drag the source in the Sources panel and drop it in the display field of the event. The source is then assigned.

Assign an existing source from the Sources tab of the event

1. Click the  (Link a source) on the button bar to open the Entering source… screen.
2. Select the source from the list then validate by clicking OK. The source is assigned to the event.

Create Person Sources

You can link sources directly to a person, click on the Person Sources tab in the middle of the screen Data > Personal Data.

The association of a person source works exactly as the association of a source for an event.

Information for the source

The input/modify screen for a source is composed of fields to be completed, a Note field that can be used for full or partial
transcription of the document and a display field for the media assigned to the source.

Type: Specify the type of information that allows you to advance in your genealogy. Is it a deed? A family document?
A historical work? Etc.
Source Name: Type a pertinent title for recognizing the document. The title of the source appears in the Sources panel
and in the Sources tab of events, as well as in the genealogy documents you may print.
Document: Specify the type of deed (death certificate, marriage contract, etc.) or what document, official or private,
which contains the information (census, invitation, family book, etc.).
Repository: Indicate where the original source is archived or the body where you found the information.
Call Number: If the document is from an archive or library and is listed, enter this here. Specify the volume and page
number if it is a published book.
Date: Enter the date of the document that allowed you to find the information. Indicate the date of publication for a
book, the date of dispatch for correspondence.

Info • Remember to specify the date of the source if it differs from the date of the event to which it relates (date of birth
certificate issued 20 years after the event).

Author: Enter the author of the document that allowed you to find information. The author of the source can be very
different depending on the source. Quote a journalist for an article in a magazine, an amateur genealogist for a
GEDCOM file, a ministry department or local authority for an administrative document, a parent who took a photo…
Email: Note the email of the person or organization that holds the information.
URL: Specify the address (URL) of the Internet website where you found the information.
Medium: Select the medium where you store information or where you saw it. Do you have the original family book?
Do you have a copy of the original or do you have a scanned image of the deed? Have you seen the information by
consulting a microfilm? Have you found the information in an online genealogy?
Archive: This section concerns only you and allows you to specify where the document is in your personal archives: in
a specific file, in a specific folder of your hard disk, etc.
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Quality of Data: To qualify the validity of the information, set the certainty of the source by using the cursor, from 0
(not sure) to 3 (completely certain).
Note: In the Note and transcription field, enter the information on the source: the details of the genealogist who gave
you the information, the circumstances when you collected it by interviewing an old aunt, etc. You can type in the
partial or complete transcript of the act. You have available the text editing tools for formatting.
Tick the Private Note box to exclude the note from exports or from printed documents.

Transcript your sources

Heredis understands the difficulty of your work in deciphering the acts and proposes a Display mode get the best possible
display of the media and of the note. Click on Display mode button of a source or citation to view the media next to the
transcription text block.

Click the Horizontal Display button to visualize the entire width of the scanned document, even if you have zoomed the
image. You may enter text below the displayed lines.
Click the Vertical Display button to visualize the document as a whole, including marginal notes. You may enter text to the
right of the displayed image.

Generalities

All sources entered are managed by the Sources Index 
.

Warning: Any modification in a source will be applied to all its uses.

(Mac) Source index

(Windows) Source index
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When you attach a source, add a comment to indicate the connection between the event, the facts or person and the source.

You can also register the quality of the proof you have, click on the displayed list in Evidence column and select the
appropriate value according to the detained certificates.

(Mac) Source tab

(Windows) Source tab
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Direct: the source responds to the searched question by itself.

Indirect: the source is relevant but needs more information.

Negative: the source is relevant by the lack of information it should contained.

Note: When you add a source to an event, the proof is automatically fixed to direct. You can change this setting in Format tab
of Heredis’s preferences. (Mac) Heredis menu > Preference > Format tab > Evidence, (Windows) Tools menu >
Preferences > Heredis Preferences > Evidence, choose the option that matches best to your work.

Report to Source index and Indexes: Generalities for more details.

Managing citations in comprehensive mode

Heredis allows you to enrich the note associated to the sources in order to make it a full citation.

To switch in comprehensive mode,

(Mac) click Heredis menu > Preference > Format tab,
(Windows) Tools menu > Preferences > Heredis Preferences,
Tick the Comprehensive mode box and check the “Comprehensive mode” alternative in the Default source citation
options.

New options appear allowing you to register the quality of the source and the information.

Original: the source is in its original form.
Derivative: the source is extracted, transcribed, translated or derived from the original.
Primary: the source comes from a person who did have direct knowledge of the event or person.
Secondary: the source comes from a person who did not have a direct knowledge of the event or person (local history,
tradition, family history…).

Source's Preferences
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In comprehensive mode, when you want to associate a source to an event, Heredis display a citation windows allowing you to:

link the citation to a generic source, a specific record for example
qualify and eventually declare as private citation
add the certificate that you detain as media of the citation
transcribe this certificate and add a note

(Windows) Source Citation

(Mac) Source Citation

                                207 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Duplicate a citation of a source

If you want to duplicate the citation and all the elements which compose it in another event, use the copy & paste 
buttons.
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Summary of the source

In the Data screen > Personal Data, next to the list of Events, click once on any source under the Sources tab: a summary of
the source – or of the source citation if you have selected the Comprehensive mode under the Default Source Citation Options
– will be displayed in the Summary panel.

Source Citation

For further details, see The different mode for Sources & Citations
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The different mode for Sources & Citations

The information gathered about your ancestors will be more or less reliable depending on their origin. Assign one or more
sources to each event in order to justify the information recorded.

Basic Mode

This source management mode is set by default in Heredis. It corresponds to 1 source = 1 deed. The source can then be used
for the information resulting from this deed.

Add a source to an event by clicking  button on Sources tab. See also Sources.

(Windows) Source's Basic Mode

 

 

(Mac) Source's Basic Mode
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Each source (an act, a website, a historical work...) may be detailed and illustrated at the time of its creation or later.

For each source, specify in the proposed boxes, the title, reference, author, quality of data.... A free text box allows you
to enter a note or record the transcript of an act.
You can mark a source as private in order not to export it when exchanging files, nor to publish it.
Each source may be illustrated with media.

Comprehensive Mode

To switch in comprehensive mode,

(Mac) click Heredis menu > Preference > Format tab,
(Windows) Tools menu > Preferences > Heredis Preferences,
tick the Comprehensive mode box and check the “Comprehensive mode” alternative in the Default source citation
options.

The comprehensive mode allows to have a generic source associated with a citation for several uses, 1 source = several deed.
For example a source created for a registry and a citation per deed inside of this registry.

In comprehensive mode, when you click  on Sources tab of an event, you can associate a source already in your Source
Index or create a New source if not already created.
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(Windows) Source's Comprehensive Mode
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(Mac) Source's Comprehensive Mode
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New options appear allowing you to register the quality of the source and the information.

Original: the source is in its original form.
Derivative: the source is extracted, transcribed, translated or derived from the original.
Primary: the source comes from a person who did have direct knowledge of the event or person.
Secondary: the source comes from a person who did not have a direct knowledge of the event or person (local history,
tradition, family history…).

 

Source's Preferences
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In comprehensive mode, when you want to associate a source to an event, Heredis display a citation windows allowing you to:

link the citation to a generic source, a specific record for example
qualify and eventually declare as private citation
add the certificate that you detain as media of the citation
transcribe this certificate and add a note

You can modify the Source by clicking on the  eye button. Be aware that if you do modify it, it will be changed for all the
utilisation of this source.

(Windows) Source's Comprehensive Mode

(Mac) Source's Comprehensive Mode
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Indexes: generalities

As you input data, Heredis groups the data by type and creates the corresponding indexes: surnames – given names –
occupations – places – sources – media – repositories.

Each Index groups all data entries of the same type, and provides tools to illustrate, edit or delete data throughout the
genealogy file.

Below are the general information for all indexes. Consult the articles Sources Index, Media Index, Places Index, Repositories
Index for specifics related to these indexes.

Accessing Indexes

Indexes are permanently available.

From the toolbar, click on the Indexes button then select the one you want to open.
From the Tools menu then choose the index you want to open.
Click on the corresponding panel of the Search panel. You can access Places, Sources, or Media Index.

Exploring the Indexes

You may use the indexes for finding any data, modify or complete them, and simply navigate throughout your genealogy. Each
Index gives you an overview of your data, indicates where they are used and permits you to edit them throughout your
genealogy file.

As you enter all data, Heredis will record the details to the right place in the appropriate Indexes: names, occupations, places,
sources, media.

(Mac) Given names Index
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(Windows) Given names Index
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You may consult the list of assignments for every item of data and (Mac) the relevant statistics by period.

Edit by double-clicking or selecting and clicking on the pencil , comment in notes, illustrate your data in the Index for
transmitting throughout your genealogy.

Change the spelling of «SHELITO» to «SHILLITO» so that it applies to all holders of this surname. Change the default gender
assigned to all new «Lindsey» given names which you may enter. Consult the list of all the «Master builders» and navigate
throughout their families. Show photos of the places where your ancestors lived and refine their geolocation. Enter a transcript
of an old deed, which you may then consult in each event where the source is assigned. Import folders of photos to the Media
Index so that you have them to hand for associating by a simple drag and drop.

Indexes allow you to apply overall treatment for any data of the same type: spelling, specific formatting, associating of
variants,notes, illustrations, replacement by another given item of data.

Search and sort

Search for an element in an index
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Each Index has a search field at the top left of the screen. Enter the word or phrase to be searched. The search is performed in
real time and the displayed list is updated.

(Mac) Click the Search   icon to select the Search mode: «Search Contains» the word, or «Search Starts With» the entered
letters.

You also have display filters to refine your search. You can display items that are not used in your genealogy by ticking the 
Unused… box and then delete them from (Windows) Tools button; (Mac) Option Button.

(Mac) Sorting indexes

(Windows) Sorting indexes

In the Media Index, choose from the pop-up menu to display media type (Image - Video - Missing...) and use (Sources -
Persons...).

Only results that match your search criteria are displayed.

The counter (Mac) below the search box, (Windows) in the title of the index window, indicates the number of results
compared with the total number of elements in the Index.

Manage the displayed results

You can sort the list of elements in the Index according to the type of information.

Click the column header to rank sites by county, to classify sources by type, classify occupations according to the presence of a
note, classify media according to their private character...

The Media Index may be displayed sorted either by file name or by date. Click the buttons on the toolbar of the list.

Display all the elements of an index

To see the complete list of all items in an index, make sure you have no active search criteria or filters.
To cancel a search, click the Delete icon to the right of the search field.
To cancel the filter, uncheck the options. In the Media Index choose All Media and Whole Index in the pop-up menus.

Consulting usage

You can easily visualize the various occurrences of a specific item in your genealogy and conveniently navigate from the
indexes.

Open the index you are interested in.
Select the line corresponding to the item you want to research.
(Windows) In the bottom part, the number of occurrences (Usage) will be displayed either directly or under a tab,
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depending on the index you are using. In the right end column or at the bottom, depending on the index, you will see
the variants, attached media and/or notes

(Mac) Click on the Usage tab in the lower part of the window.

Double-click on the person’s name to display the person’s data.

In some indexes, you can view variants, media path, or other information in the right column.

(Mac) Surnames index
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(Windows) Surnames index
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All indexes allow you to see where the information is attached. For example: If you want to know who of your family
was a doctor, you click on doctor in the occupation index and you will see who had this occupation.

Each item of the index is analyzed so you can improve your knowledge of your genealogy.

(Mac) Click on the Statistics tab to consult usage stats on the item you selected. Heredis will display a graph showing the
number of occurrences over a time period.

(Mac) The index window will remain open until you close it. You can go back to it at any time to switch to another usage or to
do another search.

Modifying data throughout the file

You have mistakenly added the occupation «Lawyer» instead of «Solicitor»? You want the given name of «LaToya» to be
written with a capital T? You realize that you have entered two different sources for the same document?

No need to spend time editing each person in your genealogy. By using the Indexes, you manage globally Surnames, Given
Names, Occupations, Places, Sources and Media, and any change is automatically applied wherever the element is used in
your file.

1. Select the item to be modified. If necessary run a search or sort to find it easily.
2. Edit the item:

• (Mac) by entering directly on the right of the Index screen,
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• by double-clicking on the line,

• by clicking the Edit and modify… button  on the toolbar of the list to open the editing screen.

Modify upper or lower case

Most data managed in the indexes are automatically formatted when entered. The automatic formatting is defined in 

(Windows) Tools menu > Preferences > Appearance; 
(Mac) Heredis menu > Preferences.

You can choose to display the surnames, given names and places in uppercase, or with only the first letter in capitals. However
Heredis allows you to change the formatting for a single item and then apply the changes to all uses of this element.

You want to make an exception for a surname, a given name or a place where the spelling is unusual.

1. Open the index and find the item in question to be changed.
2. Open the editing screen and tick Handle Characters Manually.
3. Edit the item. You may type upper and lower case wherever you want for the word. The automatic formatting will not

apply to this element that will keep the format that you have chosen.

(Mac) Handle Characters Manually

(Windows) Handle Characters Manually

Replace an element with another

After many data entries, you may have created duplicates: this source is identical to another, such an occupation was spelled in
two different ways. Tidy up in the index in question by using the Replace… function.

1. Open the index and find the item in question to be replaced.

2. Click the Replace…  on the toolbar of the list.
3. Select the replacement item in the list. Click Choose to confirm the replacement.

The element is replaced in the Index, and therefore wherever it has been used in your genealogy. The Index now contains one
element less than before.
Info: An element with variants can’t be replaced. You first have to unlink the variants.

Manage variants

The notion of a variant allows you to assign several elements to an Index entry. You can define variants of Surnames, Given
Names, Occupations and Places.
Place names have sometimes changed over the centuries. As part of your genealogical research, you may find a number of
variants for the same place. «New Amsterdam» was renamed «New York» in 1665, «Philipstown (Leinster)» became
«Daingean» in 1929. Similarly, you may encounter a name spelled differently depending on the date of the certificate found:
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the «Taylor» family is sometimes noted with the spelling «Taylour» or «Tayler».

Specify the variants

Open the index in question.
Select the surname, given name, occupation or place you choose as the standard version.

In the variants field at the bottom right of the screen, click the  (Link a variant…).

(Mac) click on the  button in Variants area.

(Windows) click on the link Edit, then on  button in Variants area.

(Windows & Mac) Select the item to be the variant and press the Choose button.

You can repeat this as necessary to add several variations to the main element.

Choose the main variant

You can choose the main variant for a surname, given name, or occupation. Select the variant you wish to see as the main and

click on the  button. The main variant appears with a grey star  and its variants with a white one .

To change the main variant, select the element to be the main element, then click on the  button.

Unlink variants

To unlink a variant, select Variants in the screen and click the  (Unlink the selected variant) button.
To remove all variants of a group: click the indented wheel icon in the Variants field, and choose Remove this group of
variants.
To remove all variants from your genealogy file, click the Options button on the toolbar and choose Unlink All Variants...

Info • Deleting a variant does not remove the item from the index. Only the link of the element in the index is deleted.
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Delete unused data from an Index

You can delete at one go all the elements that are not used in your genealogy file.
As a precaution, review first the list of unused data by ticking the Unused… box in the search field.
1. Click the (Windows) Tools / (Mac) Options button on the toolbar of the Index and select Remove All Unused…
2. Confirm the deletion by clicking OK.
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Import an index into a Heredis file

You have studied surnames, places or occupations. Heredis allows you to share your indexes with another file, so you don't
have to re-enter everything in your wife's file, for example. Convenient when working with someone who has researched the
origin of your family names or locations. You will be able to add to your own file one of the indexes in the Heredis file
someone provided you.

Open the file in which you want to add the index.
Click on the File > Import > Indexes menu and choose from the indexes suggested: Surnames, Given Names,
Occupations, Sources, Places.

(Windows) Importing an index

 

(Mac) Importing an index
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(Windows) Choose the .heredis file that matches the one containing the index to be imported.
(Mac) Choose the .hmw file that matches the one containing the index to be imported.

(Windows) Heredis file selection

 

(Mac) Heredis file selection
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Confirm by clicking on Open. You will be asked to open the corresponding index or not once the import is complete.

Important: The Heredis file must be in the same version as your file. Heredis 2021 will be able to import a Heredis 2021 file.
If the file is not in the same version of Heredis format, a message will invite you to do the conversion. Click OK to validate the
message. Then open the file with your version of Heredis, it will convert on its own and you can then return to your file in
which you want to import that index.

(Windows) Import alert message impossible if the file is not of the same version

 

(Mac) Import alert message impossible if the file is not of the same version
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The Sources Index

The Sources Index includes all sources associated with events entered into the genealogical file.

To manage the sources stored in the genealogical file, select the Tools menu > Sources Index.

New sources can also be entered using the  button in Sources tab of an event, or directly in the Sources Index. Read the 
Sources article for more details on creating a source.

Check out the article Indexes: Generalities for the tools available in all indexes.

Open the sources index

Open the Sources Index:

from the Tools menu,

via the toolbar by clicking on Indexes button then on  Sources Index button in the toolbar,

(Mac) by clicking  on in the Sources panel.

(Windows) Sources Index

(Mac) Sources Index
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Duplicate a source

Save time and duplicate a source when you only have the reference to change for example.

Select the source to duplicate.

Click the button  at the bottom of the source list.
Edit the duplicate source, it has no use.
Change the data to get a new source.

Search the sources

In the search area, type a word contained in any input topic of the search source.

The number of items found that match your search is displayed under the search area.

(Mac) Click on the Magnifying glass icon to choose the search mode: the search "contains" the entered word, or the search
"starts with" the letters entered.

To undo a search on a word, click the erase icon (  Windows,  Mac) to the right of the search area.

See the list of events in which this source is used in the lower part of the window.

To find a source registered in the Sources Index:

Click directly on the source in the list displayed.
or Tap the arrow keys of your keyboard to access them.
or Enter the first letters of one of the items from the searched source in the Search area. You can search for a source by
name, origin, rating, etc.

You can refine the list of sources displayed:
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To limit the list to unused sources, check the corresponding box.
(Windows) To view only private sources, check the corresponding box.
Click in the column header to see the sources recorded in alphabetical or numerical order of the Title or Repository or
Document or Call #, etc. A new click in the header reverses the order displayed. An arrow appears in the column on
which sorting is performed. Columns N, T, M, P allow you to sort sources with a Note, Transcript, Media or the Private
ones. Click on the header of these columns to see the sources sort as you see fit.

When you select a source from the list, the detail of that source appears on the right (title, name of repository, document,
private source, ...).

(Mac) You can change the fields of the selected source directly from the detail on the right.

Uses of this source are displayed under the source list.

(Windows) Uses of a source

(Mac) Uses of a source

Double-click on one of the uses to navigate directly to the event or the person concerned.
This source is selected and can be deleted or modified. If you modify it, the changes will be made for all the uses of this
source.

Merge two sources

You may have recorded several sources in the Sources Index that corresponds to the same reference: for example, you created
a source with the digitized certificate and created another with the transcript of the certificate.
You can create a single source that will replace the two sources currently in the index.

Select source A to be eliminated.

Click the  button.
Select source B to keep.
Click the Choose button.

Heredis indicates the number of changes that will be made.

Confirm the replacement of source A with source B by clicking the Yes button. All events to which source A was
attached will be changed.

Delete a source
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Select the source from the source list.

Click the  button.
Heredis warns you when the source is being used. If you confirm the deletion, the source will no longer appear in the
list of sources of events to which it was assigned.

Delete unused sources

To remove all unused sources in the genealogical file, select Remove All Unused Sources in the drop-down menu (Windows)
Tools, (Mac) Options.

Multi-selection

To process multiple sources in a single operation:

(Windows) Press the Ctrl or Maj button and, while keeping that key pressed, click on the different sources you want to
select.
(Mac) Press the Command or Maj button and, while keeping that key pressed, click on the different sources you want
to select.
Then choose the appropriate action, deletion, replacement or printing of the list (from Print button on Windows, from
Options button on Mac).

Swap two columns

This feature allows you to easily exchange the values of 2 headings from a source.

Select one or more sources, via multi-selection
(Windows) Click the Tools button > Swap, then choose the 2 topics to trade.
(Mac) Click the Options button > Swap, then choose the 2 topics to trade.

Change the value

To change the value contained in one topic by another possible value for this topic:

Select one or more sources, via multi-selection,
(Windows) Click the Tools button > Change the Value > select the section > choose the new value for this topic.
(Mac) Click the Options button > Change Value > select the section > choose the new value for this topic.

Note: Before applying the changes, Heredis displays a confirmation message telling you how many sources are impacted by
the desired change. Click the Yes or No button to apply the changes or not.

(Windows) Print buttons

Print the source sheet

To print the listing for the selected source in the index, click the button  in the index toolbar.
You'll find all the topics of the source, its uses, and the transcripts you've entered if you wish.

Print the index

The Print button allows you to edit all the sources stored in the file as they are displayed.
If you have done a search, only the results of this search will be printed. Also, Heredis will keep the sorting order you have
chosen by clicking on the columns corresponding to the different topics of the sources.
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You can also launch a list of all the sources stored in the file from the Reports menu > Custom reports > Sources Reports.
If you no longer need to refer to the index, return to the viewing screen by clicking the Close button.

Print Lists of Sources

(Mac) Click the Options button > Print and choose the type of list you want to print.

(Windows) Click the Tools button > Print and choose the type of list you want to print.

Check out the articles Custom Reports, (Mac) Create and Edit a Report, .(Windows) Create and Edit Reports.
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Repositories Index

A repository corresponds to who holds the original document. It may be your aunt who keeps the family documents or the
State Archives which keep the originals of the registers of civil status.

 

Every new entry is inserted in the Repository Index. Heredis verify every data in the repository section.

To manage all repositories registered in your genealogy file

select the Tools Menu > Repositories Index
or directly from the Sources index,
click on (Windows) Tools button / (Mac) Option (indented wheel) button then select Repositories Index;

or from the toolbar click on the  button in the Index  button.

See also Indexes: generalities.

Create a new repository

When entering a new source, the Entering repository screen automatically opens if the repository doesn't already exist in your
file.

Windows Entering Repository 
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Mac Entering Repository
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To add a new repository from Repository Index :

Click on the  button to enter a new repository.
Write all the data you dispose of on the new repository in the sections: name, address, call #, email, website.

You can also add a note: write directly in the word pressing, and use the toolbar if you wish to edit.
Check the Private Note box to exclude this note from file exports and publishing.

Access to a repository

Click directly in the Repository index in the displayed list.
or Press the arrow touch of your keyboard to access it.
or Enter the first letters of the repository in the search bar. You can reduce the repository list by ticking the box “unused
repositories” to see only the unused repositories and eventually delete them.
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When you select a repository in the list, find directly to the right the entered information: name, address, call #, email, website
and note.
The sources using the repository are displayed under the repositories index.
Double-click on one of the use to display directly the detail of the concerned source.

Modify a repository

Heredis allows you to modify a repository at any time.

Select the repository to modify then click on the pencil  button.
Or double click on the displayed repository in the list.
Modify directly the sections you want. If you change the name of the repository, Heredis will impact this modification on
every source linked to this repository.

Windows Modify a repository

Mac Modify a repository
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Merge 2 repositories

You may have save duplicates in the Repositories Index, merge them to keep only one in the Index.

Select at first the repository to erase

Click on the  button
Select then the repository to keep
Click on the Choose button

Windows Merge 2 repositories

                                241 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

 

Mac Merge 2 repositories
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Erase a repository

Select the repository to delete

Click on the  button. If you erase a used repository, it will also be erased from the linked source.

Multi-Selection

To treat multiple repositories at the same time:

Press the (Windows) Ctrl or Maj / (Mac) Cmd or Maj key and, while holding this key down, click on the different
repositories you wish to select.
Then choose the appropriate action, erasing or replacement.
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Media Index

Read also the article Indexes: generalities for tools available on all indexes.

Open the Media Index from the Tools menu, from the toolbar  , (Mac) or by clicking the  Index button in the Media
panel toolbar.

• In the Search section, type in the name (or part of the name) of the media you are looking for. The number of items matching
your search is displayed right underneath the Search section.

(Windows) Media Index

(Mac) Media Index
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(Mac) Click the Magnifying Glass icon to select the search mode: “Search Starts With” or “Search Contains” the letters typed
in.

In order to delete or replace the searched word, click on the (Windows)  or (Mac) , which appears in the input area.

The search can be limited to a single type of media by selecting it from the first pull-down menu: Image files, Audio
files, Video files, Other types, Missing Media, Private.
Filter your search according to the type of data the media is assigned to by selecting in the second pull-down menu: 
Persons, Families, Sources, Events, Surnames, Given Names, Places, Unused Media, etc.

To better identify the selected media:

Sort the list or icons according to the name of the media or to the date you have entered.
Change the media display mode – List or Icons – by clicking on the related buttons. You can also enlarge the icons
using the zoom cursor.

Info • The results displayed as a list can be sorted according to the presence of a Note (N), of a Private media (P), or according
to their name, by simply clicking on the column header.
If a media is selected on the list, you can consult the data it is related to by clicking the Usage tab. Double-click the data you
are interested in and it will be displayed in a new window.

For more details, please consult the Media article.

Searching for missing media

Check missing media
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You have imported a file from an earlier version of Heredis or GEDCOM? If the original location of the media was changed at
the time of import, or if a folder containing the media did not accompany the GEDCOM file, the media may be missing. A
GEDCOM file only contain the name of the media and way to access the original.

They are displayed differently if Heredis had the thumbnails or not.

For a Heredis file where there was a displayed thumbnail, the words "original not found" follows the media name in the
media edit window, but you still see its representation.

For a file where there was no displayed thumbnail, the icon of the media not found  is displayed instead of the
media.

Find a group of media

Open the Media Index.
1. Click the (Windows) Tools / (Mac) Options button (indented wheel icon) on the toolbar of the Index.
2. Select Check media…

Windows Check Media

Mac Check Media

Heredis reviews all the media in your genealogy and detects, if any:

media not found following deletion from the Media folder managed by Heredis
media of which the original has been modified by third party software other than Heredis
and finally, media for which the original has changed location and is no longer present on your computer.

In the Media check window, you can:

in the Missing Media tab, designate a folder to search and update these media. Click on Choose folder and update.
Indicate the location of the media on your computer.
in the Original changed tab, select all or part of the media managed by Heredis to update them from the originals.
Click on Update the selection.
in the Missing Original Media tab, specify the folder where your original is located. Click on Choose a folder.

Note: If your media are stored in multiple folders, you will have to do as many times the manipulation to indicate which folder
you have folders.

(Windows) Media check window
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(Mac) Media check window

                                247 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

If your originals have changed their names, Heredis will not be able to reinstate them automatically. Indeed, the software
cannot know that you have changed the name of a media. In this case, see the paragraph below.

Replacing or deleting media

Replace media with other media

You may have assigned two different media but they were the same (an image of a source saved with two different names, the
same image on the selected hard drive and in iPhoto ...). You may only keep one assigned media but use it several times.

1. Open the Media Index 
 and select the media to be replaced.

Media Index for Windows
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Media Index for Mac
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2. Click Replace with another Media from...  or on the button bar of the display field and choose the duplicate image
in the index or the replacement image in its folder on your hard drive.

3. Select the media to be kept and click the Choose button.
The initial media has been replaced by the second for all its uses.

Delete media

Display the Media panel, or open the Media Index.

Select the media to remove

Click the 
 (Remove the selected media) button on the toolbar for media management.

(Mac) Right-click the media and choose Remove...
Confirm the deletion of the media with OK.

This will delete the media from your genealogy file. If it had been used, it will no longer appear in the illustrations of data or
persons to whom it was assigned.
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Places Index

Heredis attaches considerable importance to the places where your ancestors lived. By its structured data entry, it identifies
places in many countries and views them on an inter-active map. You get closer to the lives of your ancestors by discovering
their geographical environment. Did they live in a forest, near a river, in a large city or small village?

Info • You were using a software that did not have a defined structure for places? Heredis studies your GEDCOM file and
identifies the largest possible number of locations, offering you this essential feature for effective knowledge of your past.

Places assigned to events are displayed in the Personal Data screen by selecting each event. You can consult the list of all
places in your genealogy in the Places panel or in the Places Index. Places referring to immediate family members appear in
the History > Migrations tab as well as in the Search tab.

See also Indexes: generalities article to know more about tools available for all indexes.

Assign an existing place to an event

Drag and drop

1. Select the event from the Personal Data tab.
2. Drag the place from the Places panel and drop it on the display area of the event. The place is displayed in the Place field.
Other details of the location are displayed above the Place field.

(Windows) Drag a place from Places panel > drop in the event 

(Mac) Drag a place from Places panel > drop in the event 
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In the Details fields of the event

1. Type the name of the place in the Place field, without bothering about upper or lower case. With the first letters, Heredis
displays a list of places that may match your entry. The displayed list offers in the upper part, places already registered in this
genealogy, and below the places recognized by Heredis.

(Windows) Input a place in Details tab of an event

(Mac) Input a place in Details tab of an event
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2. Select a place using the mouse or use the up and down arrow keys and confirm the place selected with the Enter.

Create a new place and assign it to an event

If no proposed place matches the place you want to enter,

(Windows) fill in the case and click on the tab key to add this new place to the index
(Mac) select New Place at the top of the list.

A window opens, complete the various administrative details of the new place, use the automatic research (available in Map
tab on Windows) to locate the place. Once the data completed and press OK. The new place will be added to the Places Index.

(Mac) New Place window
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(Windows) New Place window
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Note: Sometimes cities have changed their names or disappeared. Enter the old name and then in the New Place window, enter
the current name of the city in the suggestions area. Launch the search and choose the one that suits you. You can click Fill up
to keep the old name.

 

Create a new place to be assigned later

1. Display the Places panel or open the  Places Index.

2. Click  (Add New Place).
3. Enter the name of the place. With the first letters, Heredis proposes a list of known places which may match your entry.

By choosing one of these known places, the different administrative fields and geolocation of the place will be filled in
automatically.

4. Click on Fill up to complete the fields or on Replace to replace all fields.
5. If no place corresponds to the place you want to enter, complete the input field with the various administrative levels of

the new place and press OK.

A new place has been created but it is not yet assigned to an event. This place will now be proposed in the list of existing
places when you type in the Places field of an event. It will also be in the Places index and Place panel.
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(Mac) Enter new place for old name of city

(Windows) Enter new place for old name of city

                                256 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Note: You can create the old cities that have been merged with other cities. Geolocate the current location and click on Fill up
to indicate the coordinates only. Add to your index the current place and add to it in variants the old city's name. (Windows)
Edit the place in Place index, (Mac) Select the place in Place index,  click on the + to add and select the common
variant. This is also how you can indicate the old spellings of a place.

(Mac) Add a variant
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(Windows) Add a variant
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Information for the place

The input and modify screen of the place contains items to be filled in, a Notes field, an assigned media field, a display field
for a map, and a field reserved for geolocation if it is not known.

Input fields for the place

Each administrative item has a separate input field. This organization method allows you to edit documents by town, region,
country and facilitates the geolocation of the place where your ancestors lived.
Complete the fields City – Postal Code – County – State/Province – Country.

If you know them, you may also complete the Latitude and Longitude fields. However they will be filled automatically when
the geolocation of the town will be done.

(Mac) Administrative item
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(Windows) Administrative item

Tick Handle Characters Manually box if you don't want the default Heredis Preferences to apply for formatting the place.

For further details on automatic filling of places, see Heredis' Preferences\Choose the recognized places.

Place Note

Enter information about the place in the Note field, for example the history of this place. You have available the text editing
tools to format the note.
Tick the Private Note box to exclude exports of the note or printed documents.

(Mac) Place's Note 
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(Windows) Place's Note 

Media assigned to the place

To assign one or more media to a place:

• Click the  (Add a Media) button in the display field of the media.
• (Mac) Drag and release the media selected from Media panel or from the Finder.

(Mac) In Place index, area to add a media
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(Windows) In Place index, area to add a media

Mac Info • The right-click menu in the display field of the media provides access to the Add New Media option.

Subdivisions

Subdivisions tab inform you of subdivision attached to the selected place.

(Windows) Places index
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(Mac) Places index
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By clicking on the pencil  button, you can geolocate the selected subdivision.

The button  allows you to replace a subdivision by an other one, if for example, you entered "main street" and "Main
Street".

Also check Geolocating place subdivisions.

Geolocate a place

When the place is recognized by Heredis, it is geolocated. In this case, the latitude and longitude are inserted automatically and
the map of the location may be displayed.

(Windows) Entering a new place
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 (Mac) Entering a new place
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Info • View places not geolocated in the  Places Index by clicking on the Latitude or Longitude fields. If these fields are
empty, you will have to create the geolocation manually.

1. Double-click the place in the Places Index or click the pencil  icon (Edit and modify the selected place) to open the
enter/modify screen of the selected place.
2. Click the Search button in the geolocation field. Heredis will consult various databases of global importance to find the
place you entered.

Info • This function is only available if you are connected to the Internet.

3. Click each of the proposals and observe the map that is displayed to clearly define which corresponds to the place you
entered.
4. Edit your entry.

• Click Fill up to geolocate the place with the appropriate proposal while retaining the elements that you had already entered.

(Windows) Fill up Places index data
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(Mac) Fill up Places index data
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Info • This will retain your original entry for the old name of a province or administrative division that has been changed.

• Click Replace should you have entered incorrect data for this place. Heredis replaces the contents of input fields with the
information found online.
Validate the input/modify screen by clicking OK to complete the changes to the geolocation of the place.

(Windows) Replace Places index data
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(Mac) Replace Places index data
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For further details see Geolocating Places.

Delete a place

Select the place to delete

Click on the  button

Heredis checks if the place is used, if so you won't be able to erase.

Variants

As for surname, given names and occupation, you can add variants to a place. Just double-click on the place you want to add a

variant then use the  button in the variant area to choose a variant. Don't forget to choose the main variant by clicking on

the  button. To delete a variant click on the  button.

For further details see Indexes: generalities.
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Geolocating Places

Consulting Places maps

Heredis does everything for you to visualize the places where your ancestors lived.
The Places Index will display an interactive map for the selected place. If Heredis has been unable to identify the place, you
can yourself indicate where it is by using the geolocation tool.

Visualize the map

Display the Map of selected place from the Map tab in each event or in the Places index.

Open the 
 Places index.

(Windows) The map is displayed on the bottom right of the index when you have selected a place.

(Mac) Click on the Map tab on the right part of the screen when you have selected a place.

Browse the map using the navigation tools. Zoom or reduce to get a better understanding of the geography of the place.

(Windows) Map
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(Mac) Map
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Geolocate unrecognized places

Edit the place by double-clicking on it or by using the pencil  button after selecteing the place to edit.

If no map appears on the Map, you must specify the coordinates of the place. If no latitude and longitude are available,
Heredis will not be able to localize this place. For example, you can enter the old name of a city in the city field and search the 
Suggestions field with the current name. Heredis launches a search in OpenStreetMap and will geolocate the current location.

Click on Fill up to complete the missing data or click on Replace to modify the fields entered by the OpenStreetMap
indications.

 

(Windows) Geolocate unrecognized places
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(Mac) Geolocate unrecognized places
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See also Places index article.

Info • You may also access the map of the place in the History > Migrations tab, in the Search > Search Wizard > Map tab
and in the Data > Personal Data tab. Click the Map tab for each event provided that a place has been entered.
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See also Geolocating Places subdivisions, Zoom in on the World - Family Tree Mapping.
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Geolocating Place subdivisions

Place subdivisions can now be geolocated. The Place Subdivision field is intended for specific details on a place, such as an
exact address, a hamlet, or any other place name.

Edit

To access this feature, select an event under the Personal Data tab. Click on the Details tab then on the pencil  button
displayed to the right of the Place subdivision field.

(Windows) Details tab for an Event

(Mac) Details tab for an Event

You may also access it from Places Index > Subdivision then click on the pencil  button.

(Windows) Places Index
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(Mac) Places Index
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You can enter the name and coordinates manually or paste a place’s data (in its entirety or only the coordinates) by clicking on

the  button.
See the article entitled Zoom in on a Place for more details.

Search

If the subdivision name is precise enough, Heredis will perform an automated pre-search. Browse through the list of
propositions.

If your subdivision cannot be located – for instance « at her grandma’s house » - Heredis will not be able to offer any potential
geolocation. You should therefore modify the field content under Suggestions then click on Search to launch the search again.

Note: Avoid using commas and unnecessary spaces at the end of the text in the Subdivision field to ensure that the automated
search will be able to find the designated places.

Edit a non-geolocated subdivision
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In the same way you search for a place’s geolocation (please refer to Geolocation), click on:
• Fill up to keep the subdivision name and add coordinates,
• Replace to replace all data previously entered for the subdivision.
Click OK to validate.
If you know where the person’s grandmother used to live and prefer to leave « at her grandma’s house », then drag and drop
the marker or right-click on Position the marker here.
Coordinates (latitude and longitude) will then be displayed.

(Windows) Edit an unrecognized subdivision
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Display

From the Places Index

In the list of places, the S column will display markers to indicate whether there is one subdivision or more. When they are not
geolocated, the marker is black . When at least one subdivision has been geolocated, the marker is yellow .

(Windows) Places Index – The S Column
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(Mac) Places Index – The S Column
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From maps

Subdivisions are visible thanks to yellow markers on the Events maps, Zoom in on a Place maps, as well as on Migrations
maps (under the History tab).

You can right-click on any of the Heredis maps and Copy the coordinates. You will then be able to click on the Paste 

button in the Place subdivision field under Events. However, to be able to do so, make sure a name has been entered in the
subdivision field – otherwise the button will not be activated.

 

                                283 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Zoom in on the World – Zoom in on a Place

Zoom in on the World  provides several tools that will assist you in locating your ancestors.

Heredis will help you get a better understanding of your ancestors’ environment by offering an array of miscellaneous
information related to places.

To access Zoom in on a Place, all you need to do is either click:

• on the  button, from Data > Personal Data > Events > Details tab,

• on the  button, from Family Tree Mapping > Places tab,
• from the Tools menu > Zoom in on the World > Zoom in on a Place,

• on the  Zoom in on a Place button in the toolbar,

• from the Places Index or the Places panel, on the  button.

In the upper part of the side panel, under Heredis Data, you will find the information for the location currently displayed in
Heredis. You can tick or untick the box entitled Display place subdivisions to show or hide the subdivisions of your genealogy
file that are linked to this place on the map.

Change places by clicking on the magnifying glass . Open the Places Index by clicking on the button . The button 
 allows you to zoom back on the place indicated under Heredis Data if you have been navigating on the map of a bordering
place.

Please see the paragraph entitled Bordering Places.

Details tab

Under this tab, Heredis will display the information on this place found on the internet in OpenStreetMap’s and Wikidata’s
databases, as well as a map zoomed in on this place. Administrative levels such as city, county, state/province, or country are
clickable links that will allow you to modify the zoom level on the map.
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Heredis is also defaulted to display on this map every subdivision already geolocated in the current genealogy and linked to

this place. Yellow markers  indicate their position on the map.
With just one click on a marker, the data related to this subdivision will be displayed.

You can untick the box entitled Show place subdivisions to hide the geolocated subdivisions markers.

Toponyms tab

Under this tab, you will find every toponym available in the OpenStreetMap database. The color of the marker, grey  or

blue , indicates whether the toponym has been selected in the list of toponyms.
Click on a toponym’s marker to visualize its data and to copy it, if you wish to, by clicking on the Copy button. Such data will
allow you, for instance, to precisely locate an event in your genealogy.

Click on a toponym to copy and paste its name and coordinates into Personal Data > Events > Details, by clicking on 
 next to the Place subdivision field (all data or coordinates only).

For more information on geolocating subdivisions, please consult the article entitled Family Tree Mapping subdivisions.
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Note: yellow markers  indicate subdivisions that have already been located in your current genealogy.

Bordering Places tab

Heredis will display the places bordering a city. You might be able to finally locate the impossible-to-find death certificate of
your ancestor in one of these bordering places. Indeed, it is quite common to hit a wall when desperately looking for an event
in the place where your ancestors’ family resided while sometimes all it takes is to search in a neighboring village.

Click on Bordering Places. On the map, Heredis will display all registered cities that are on the same administrative level and
directly surrounding your ancestors’ place.
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Note: Heredis can only display bordering places that are on the same administrative level as the place you have selected. Other
bordering places may be on a different administrative level and therefore will not be highlighted.

When you select a city on the list, its city limits will be outlined. Click on the city displayed on the map and some concise data
will pop up.

You can click on the Detail button to obtain more detailed information on this place. Heredis navigates on the Details tab in
Zoom in on a Place and zooms in on this place on the map. You can access the various toponyms for this place under the 
Toponyms tab.
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Click on the button  under Heredis Data to zoom back on the place you had selected in your Heredis file.

Right-clicking on the map of bordering places enables you to Copy coordinates and paste them in the Place subdivisions

field of an event by clicking on  (all data or coordinates only).

For more information on geolocating subdivisions, please consult the article entitled Geolocating Place subdivisions.

Updating your data and options available in Zoom in on the World

You can leave Zoom in on the World open and simultaneously work on your genealogy. For your latest data entries to be

accounted for, click on the button .

The button  allows you to access various options and create a customized display:

choose where you want the side bar and its various tabs to be located – you can either display it on the left- or right-
hand side.
decide whether you want to display boundaries at the various administrative levels (Borders), if such data is available in
the OpenStreetMap database.

Contribute to OpenStreetMap

OpenStreetMap is a community database. Should you notice any missing data, e.g. some toponyms, feel free to add them
yourself.

Click the Contribute to OpenStreetMap button and follow the instructions in the article entitled Contribute to
OpenStreetMap. Heredis frequently updates its data from OpenStreetMap’s. Data reported by worldwide users will then be
integrated.
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Zoom in on the World – Family Tree Mapping

Zoom in on the World  provides several tools that will assist you in locating your ancestors.

Heredis will help you get a better understanding of your ancestors’ lives, geographical implantations, and migrations.

Select the Tools menu > Zoom in on the World > Family Tree Mapping or click on the  button in the toolbar for the
various events of the persons in your genealogy to be displayed on interactive maps.

You can zoom in and out on the maps and play them in a slideshow to view the geographic mobility of the persons in your
genealogy through time and generations.

When you first open Family Tree Mapping, Heredis is defaulted to display the main events of the primary person’s ancestors.

You can simultaneously work on your file and leave this tool open.

Filters and display options

At any time, you are free to modify the filters in the window’s side bar and choose to display every person in your file, or the
primary person’s ancestors or descendants only, or the persons you have marked beforehand in your genealogy.
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If you have just entered new events or new persons in your genealogy, click on the button  to retrieve this data in Family
Tree Mapping.

Heredis is defaulted to preselect the Density representation mode when displaying your data. If you wish to get a preview of
the mobility of the persons in your genealogy, select the By period representation mode under the Tools tab in Family Tree
Mapping. A timeline will be displayed above the map, with intervals starting and ending at the most extreme dates in your

file. Click on the Play 
 button and watch the events appear on the map through each time period. Before to press play, make

sure to zoom out so you can see all the markers displayed on the map. Press the Pause button to be able to zoom in and zoom
out as you please and study the mapping.

Note: the display and reading pace of the timeline are automatically calculated based on the most extreme dates in your file. If
you prefer to study a specific time period, move the sliders at each end of the timeline to select the desired intervals. The map
will then only display the events on the time period you have selected.
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Heredis also offers a representation mode By generation which is operated the same way as the By period mode. You only
need to select ancestors or descandants of the primary person in the Persons tab to use it. The dates intervals above the map
are simply replaced by the number of generations.

Map display

Several types of maps are available for you to display your data. Select the theme that will best highlight your data on a map by

clicking on .

To easily zoom in and out on the map, simply click on the + and – buttons or use the scroll wheel on your computer mouse. It
will allow you to get a closeup on a specific geographical area or, on the contrary, to go back to a wider view of the map by
zooming out.

To move around on the map, hold down the left mouse button (or the mouse wheel) and drag the mouse in the desired direction
in order to center the map on another area.

Right-clicking on the map will let you Copy coordinates so you can paste them into the Place subdivision of an event. Please
refer to the article entitled Geolocating Place subdivisions for more information.

You may notice markers of various colors and sizes displayed on the map. The size of the marker is directly linked to the
number of places it is indicating.

Smaller size markers  or  indicate events located in one single place. If you click on this type of markers, a popup

                                291 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

window will open to show the exact place and the list of persons with events in this one place.

Larger size markers  or  indicate events located in a grouping of places. If you click on this type of markers,
Heredis will automatically zoom in to show you a more detailed map.

The number of events held in a place or in a grouping of places is indicated on each marker.

Search lists

Search lists displayed in the vertical side panel allow you to do searches on places or persons.
In these lists, to the right of the place’s or person’s name, Heredis specifies the number of events that were found.
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Select the Places or Persons tab and enter a name in the search field to obtain a selective list of the matching places or persons.
The list displayed below is automatically updated as you enter the name.

Navigating from the Persons or Places tabs

Places and persons displayed in the floating panel or in the popup windows are clickable links that will allow you to access
directly, with just one click, the Places Index or a person’s family tree, without closing Family Tree Mapping.

It will, for instance, enable you to correct or complete a person’s data, modify or geolocate a place (for more details on how to
geolocate a place, please consult the article entitled Geolocating Places and Geolocating Place subdivisions) and then to

display this updated data in the Family Tree Mapping window by clicking on the button .

Legend

 or 

Geolocated place

 or 

Grouping of geolocated places

Note: the color blue indicates that at least one place has been selected under the Places tab in Family Tree Mapping or in the

floating panel of a person (by clicking on the button ). The number displayed on the marker indicates the number of events
linked to a place or to a grouping of places.
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Persons tab

Under this tab, if you click on one of the names on the list, Heredis will display a floating panel listing every event that has

been geolocated for this person. Click on the button  in this floating panel to zoom in on the location of the selected event

on the map. The marker will turn from yellow  to blue  .

Feel free to use the proposed filters to display every person in your file, or the primary person’s ancestors or descendants only,
or the persons you have marked beforehand in your genealogy.

Click on any person on the list to display markers for related places. A list of all places and events linked to this person will
pop up.

The numbers displayed on the markers indicate the number of events from the persons’ list that are located in this place.

Clicking on the marker will open a popup window listing every event that took place in this location. Click on the name of a
person or on one of the events listed in this popup window in order to navigate onto this person or event in Heredis.
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Places tab

Under this tab, if you click on one of the names on the list, Heredis will zoom in on this place on the map; every event linked
to this place will be listed in the floating panel anchored on the map.

Search filters are available. Heredis is defaulted to preselect the All places filter. You can switch to another filter by using the
dropdown list at your disposal and choosing from:

Most represented places: places are listed from the highest to the lowest number of events found for each place
Geolocated places
Non-geolocated places: places displayed on this list have no geolocation coordinates and therefore cannot be mapped.
To complete the data for these places, click on the place name in the floating panel
Visible places: this list only shows places that can be seen on the map currently displayed on the screen.
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Note: If you double-click on a place under the Places tab or if you select it and click on the button at the bottom of the panel 

, the place will be displayed under the Zoom in on a Place (for more details on this feature, please consult the article
entitled Zoom in on a Place).

Updating your data and options available in Zoom in on the World

You can leave Zoom in on the World open and simultaneously work on your genealogy. For your latest data entries to be

accounted for, click on the button .

The button  allows you to access various options and create a customized display:

choose where you want the side panel and its various tabs to be located – you can either display it on the left- or right-
hand side.
decide whether you want to display boundaries at the various administrative levels (Borders), if such data is available
in the OpenStreetMap database.

Printing Map and create Tiny Tafel Report

You can edit and print the map you are seeing on your screen by clicking on the Map button in the Tools tabs.

(Mac) Click on PDF button at the bottom of the printing windows or click on Print to launch your printer.

(Windows) Setup the parameters of the PDF export (size of the page, orientation) then click on OK button. A PDF will open
so you can print it.

Create a Tiny Tafel Report by clicking the button Tiny Tafel Report. Setup the Tiny Tafel parameters.

See (Windows) Create and Edit a Report or (Mac) Create and Edit a Report for further details.
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What to do in case of a slowdown or malfunction issue?

If your data is not displaying correctly, click on the Tools tab then on the Reset button.
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Contribute to OpenStreetMap

Internet Data in Zoom in on the World are coming from OpenStreetMap.

OpenStreetMap is a community database. Should you notice any missing data, e.g. some toponyms, feel free to add them
yourself.

To be able to contribute, you need to create an free account on openstreetmap.org. Do not worry it is without commitment.

Connect to your account.

Click the Edit button. Then, if you need assistance on your first contribution, click on Start the Walthrough. Follow every
steps to contribute.
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If you need to get the tutorail again in the future, click on Edit button, on the right column, click on 
, then you will find

the button .

Heredis frequently updates its data from OpenStreetMap’s. Data reported by worldwide users will then be integrated.
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Migrations

Migrations place the living places of the primary character or another family member on a map. The markers are numbered to
know the chronology of movements. Each location marker shows the list of events listed in that location. You can see the
movements of all members of the immediate family at the same time.

The number of events displayed is now dynamically managed.

The navigation thumbnail, displayed at the bottom right in the Migrations tab map and in the Search Wizard of the Search
tab, allowsyou to easily move around.
Select the frame with the left click of the mouse, by moving it, you navigate through the viewed map.

Use the indented wheel  to choose whether or not to display the events of immediate family and/or, from Heredis 2020,
the subdivisions you have geolocated.

Note:
Blue markers are those associated with the person selected from the list displayed to the right of the map
orange markers correspond to the events of other persons on this list
the star displayed next to a blue marker indicates that several events have been recorded at a location that concern the selected
person.
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My dashboard

The Heredis dashboard is a tool that allows you to control your family tree on a daily basis. The different available indicators,
whether quantitative or qualitative, give you a global vision of your genealogical data and also inform you about the progress
of your work.

The dashboard can be accessed from the Tools > My Dashboard menu. You can also add the  button to your toolbar if
customized. (See Customize Heredis\Select the toolbar)
It consists of four tabs: My Dashboard, File Info, Statistics and Search Tracking in which Heredis displays indicators, also
called widgets, presenting the current state of your family tree.

My Dashboard Tab

When you access the dashboard, it opens directly on the My Dashboard tab.

This tab is customizable, you can add widgets of your choice, delete those that do not interest you or reorganize them.

To add one or more widgets:

Click the  button.
Click on the widget you’re interested in
Click add

My dashboard
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The widgets are added after those already on your dashboard.

To remove a widget, click the  button in the title of the widget. A notification informs you instantly that you have

removed the widget from the tab. To see it again, just click the 
 button to display the widget.

Note: You can also add or remove a widget from the other tabs of the dashboard. You can choose your favorite widget. Click

on the grey star  to add the widget. The star is now yellow , if you click again, it will be removed.

To rearrange the widgets to suit you, click on the widget banner and without releasing the mouse, drag it to the desired location
and then release the mouse.

Heredis automatically reorganize your dashboard space even if you resize the window.
If you wish to, you can display all widgets in the Dashboard tab.

The information displayed in the dashboard is by default your entire file, such as the title at the top of the page, as well as the
data added today (see example, in the PERSONS widget, the indication «Recently Added»).

To change these options, click the indented wheel button  at the top right of the page and select the filters that best fit your
way of working:
• Filters showing recent additions: Today / Less than a week ago / There is less than one Month / Less than a year ago.
• Filters on persons: Entire file / Direct line ancestors/ Ancestry.
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Then click on the Validate button, all widgets in the dashboard are updated based on the options you have chosen.

The widgets have a simple view and a detailed view. From the simple view, click the Detail button at the top left to display the
detail view. From the detail view, to return to the simple mode, click the Back button on the top left.

Some widgets like NAMES or SOURCES do not have a detailed view. However, you can directly access their respective
indexes by clicking the Open the index button. This allows you to easily find additional information.

Simple widgets

Simple view of the Source widget

Widgets in simple view display a limited amount of information. Their size is variable based on what you display. They feature

a button to export the contents of the widget displayed in PDF or PNG format.
Info • Note that as you hover over certain widgets, you have more accurate information. For the widget NAMES for example,
when you pass the mouse over a surname, it immediately displays the number of times it has been used in your family tree.

Detailed widgets

Detailed view of the Person's widget
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The detailed version of a widget displays additional information about the current status of your family tree.

Each detailed version widget can be exported to PDF through the PDF button . You can then print or transmit it very
easily.

If you are working with a large screen or with two screens, you can keep the dashboard open constantly in order to control the
progress of your family tree in real time.

When you add a data, click the refresh button  to update your dashboard and have the latest information entered in your file.

File Information Tab

From this tab, you have an overview of persons, events, sources, places, surnames, given names, occupations, media of your
file as well as your Heredis Online data. This general view allows you to know how far you are in your work.

To access this page from the dashboard, click the File Information button or select the menu Documents > File Information

or, if you personalized your toolbar, click directly on the File Info button .

HEREDIS ONLINE Widget

To view the content of this widget, you must be logged in to your account. If you already have an account, click on Sign in  

button and enter your username and password otherwise, create one. (see the article "Heredis Online")
Once connected to your account, this widget displays the date of the last publication of your file. You can access it directly by
clicking the link “Visit Website”.

You can see it has been a while since the last publication? You can publish at any time from the dashboard by clicking the 
Publish button.

The detailed view shows you some new information. The first section shows you what you have recently be done on the open
file: the last time you published it, the number of persons, of unions, of sources it contains.

All sections are foldable, just click on the title banner of the section to hide or display it.
If you work on multiple genealogies, the next section lists the other publications and the online photo albums  with a preview
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of published pictures.

DEVELOPMENT OF MY FAMILY TREE widget

Simple view of Development of my family tree

This widget shows you the evolution of your file in time:
- The date when you started your work, referring to the first person you created or imported in Heredis.
- The date of the last modification
- The number of ancestors (direct line) and persons found.

In the detailed view, a first chart shows the evolution of the number of ancestors and persons on a fixed time scale. The second
chart shows the same data but on a variable time scale based on the date of the establishment of the persons in your file.
You can also check in this view 2 lists of persons, the list of the 10 last persons you added, and the one of the 10 last persons
modified.
By clicking on these persons, you navigate on them in the Immediate Family.

PERSONS widget

This widget shows the total number of persons in your file and those added recently.
In the simple display, a graph shows the distribution of persons by gender.

Simple view of the Persons' widget
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By entering the detailed mode, you can access:

The «Progress» chart, which informs you about the quality of your family tree and in particular on the percentage of
complete persons.
“3” is for the persons with the 3 main events completed, meaning you found the birth, marriage and death dates.
“2” is for persons with only 2 main events completed
“1” is for the persons for whom you completed 1 main event
“0” is for the person for whom you have not found any event

The notion of complete is directly related to Heredis’ preferences. From the menu Heredis>Preferences> Appearance, define
what a complete event is for you. Heredis will then take these parameters into the «Progress» chart to determine if an event is
complete or not.

To the general information that will allow you to easily answer questions on your family history: who is the oldest
person or the youngest among your comtemporaries? Who had the longest or shortest life? Who was the youngest or
the oldest when they got married? Which couple had the largest family...

Every section is foldable, just click on the title banner of the section to hide or display it.

EVENTS widget

Simple view of Event's 
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The simple version displays the total number of events, the total number of major events and the total number of family events.
The detailed version offers a zoom on the major events and displays in addition to the total number, the oldest event and the
most recent event. For each event you can browse the person concerned with a single click.

SOURCES widget

The Simple Source Widget presents, in addition to the total number of sources and those recently added, a ring graph that
allows you to analyze the quality of your sources.

Simple view of Sources' widget
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In this graph, we distinguish sources without media nor note, sources having only a note, sources with only media, and sources
with a note and media.
To access the list of all your sources, click the button Open the index.

PLACES Widget

In this widgets, the frequency is shown by a word cloud. In this type of representation, the most commonly used places, for
example, are displayed with a font size which varies according to the number of uses. When hovering with the mouse, an info
bubble indicates the number of uses.

Places widget
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If you click on a place, Heredis opens the Index with this selected place and displays all information on it.
The Place widget also indicates the total number of places in your file and the places that were not geolocated (places without
latitude and longitude information).
You can directly access the dictionaries by clicking on the button Open the index.

NAMES, GIVEN NAMES, OCCUPATIONS and MEDIA widgets

These widgets indicate the frequency of given names and occupations, as well as the number of uses in the genealogy file.

Names, Given names and Occupations' widget

For the Names, Given Names, and Occupations widget, the frequency is represented by a word cloud, just like for Places.
The Media widget  is a ring-shaped chart indicating used and unused media. For all of these widgets, you can directly access
the indexes by clicking on the Open the index button.
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Statistics tab

In this tab, Heredis offers various genealogical and demographic analysis.

Statistics' tab

To access this function, from the dashboard, click the Statistics button or select the Documents > Statistics menu or click on

the statistics button directly from the toolbar, if you personalized it.

The different analysis available are grouped into several widgets, Births and Deaths, Surnames and Given names, Families 
and Generation count...
In the simple version, these widgets present a simplified graph on births / deaths, the most common surnames, the average age
at the first union and the ancestors count of the root person or the central person of your file.

You can easily export each chart displayed in PDF or PNG format by clicking on button  located in the title bar, to share it
or document your genealogical work.

In the detailed version, each widget gathers different analyzes and displays the graphs and data tables associated with them.

In order to use this data outside Heredis you can:
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• export all the charts and data tables of the widget by clicking on the button , located in the title bar of the widget.
Heredis displays an overview of the widget you can save to PDF.

• export a specific data table by clicking Details then on the button  in the title bar of the data table. Heredis suggests that
you save this data in Excel format on your computer. You can then analyze them using your spreadsheet.

BIRTHS and DEATHS widget

Births and Deaths' widget

This widget contains the following analyses: distribution of births and deaths, life span and census.
You can choose between one display per period with different possible intervals or one display by month according to what
you want to highlight from your analysis.

In the Census widget, Heredis displays the number of persons who have lived in each period, based on their main events of
birth and death on the one hand and the maximum age at death of the general preferences of Heredis on the other.

ANCESTORS ORIGIN widget

Ancestors Origin's widget
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This widget allows you to visualize the distribution by country, state/province, and county of the persons in your genealogy.

If you have selected Entire File as the Scope, the analysis will include every single person in your file. You can choose to
narrow it down to the ancestors of the root person or of the primary person in your genealogy by setting the Scope to Direct-
line Ancestors or Ancestors. To modify this option, click on the indented wheel in the upper right corner.

In the simple view widget, Heredis groups the persons according to their place of birth and displays a ring graph showing the
most representative data by country, state/province or county.

If you click on the Detail button, Heredis will provide a full analysis by country, state/province and county along with a table
indicating the number of persons found and the start/end years for the Period of appearance.

AGE GAPS widget

Age Gaps' widget
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This statistical analysis focuses on the age difference between spouses and on the age gap between siblings in your genealogy.
Just like in the previous widget, the scope of persons included in this analysis is set by you in the General Options of the
dashboard.

In Simple view, Heredis displays a line chart showing the average age difference between spouses.
In Detail view, this same line chart is displayed along with a table filled with matching data and with another chart showing the
average age gap between the first and last born among siblings.

Note: These charts only include couples with a minimum of one union entered with a date (Marriage, Religious Marriage, or
other type of official marriage) and marital unions with at least two children properly entered with a date of Birth or
Christening.
The default analysis interval is set to 50 years but you are free to modify this interval if you wish to adjust the data displayed in
the charts and tables.

SURNAMES and GIVEN NAMES widget

Surnames and given names' widget
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This widget provides you with a distribution of the most common surnames and given names of your genealogy that you can
filter by gender.
On the graph, Heredis displays a selection of surnames, the most common given names and regroups all the others in the
category «Other». For each surname / given name we specify on the graph, the number of holders and the percentage that it
represents on the total names or given names of the file.

FAMILIES widget

Families' widget
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This widget contains the following analyses: average age at first union, number of children per family and the number of
families.
You can choose between one display per period with different possible intervals or one display by month according to what
you want to highlight from your analyses.

GENERATION COUNT widget

Generation Count widget
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In this widget, Heredis offers to analyze the direct ancestors and descendants of root person of your file, if you selected «Entire
File» or «Direct ancestor line» in the options of the dashboard, if not then the ascendants and descendants of the primary
person if you selected «Ancestors».
The display, by generation, of the number of ancestors and descendants, found and distinct, makes it possible to highlight
duplicate branches in your family tree.

What is a duplicate branch? Everyone, in their family tree, has a real number of ascendants that is lower than the theoretical
number of ascendants because we descend several times from a same person because of marriages between more or less close
cousins, we are then in the presence of a case of duplicate branches. Hence the importance of putting forward the distinct
ancestors or descendants: when they are inferior to the found ancestors or descendants, it is because there is a duplicate branch.

Note: Changing the period and the analysis interval applies to all charts of the widget.
All events with a calculated date are excluded from statistical analysis.

Search Tracking

For all details on Search Tracking, see Search Tracking tab Article.
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Search Tracking Tab

Search Tracking Tab

Heredis displays, by generation, indicators of progress concerning the persons found and the level of completion of their major
events, birth, union and death.

To display the Search Tracking,

from the dashboard, click on the Search Tracking page
or select Tools menu > Search Tracking

or from Heredis' toolbar click on the  button.

Search Tracking Tab

Click on the indented wheel  on top right corner to change the scope of search tracking.

If you selected «Entire file» or «Direct line ancestors», in the general options of the Dashboard, Heredis lists the ancestry by
generation of the root person of your file if not then the ancestry of the primary person if you selected «Ancestors».
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Each generation has a synthetic view and a more detailed one. You can switch from one to the other  by clicking on the arrow

on the left .

The search tracking function can stay open while you continue to work in Heredis. 

Remember to refresh the information of this page by clicking the  button, so the changes you just made are included.

 

Synthetic view

 

On each generation, the following information is displayed:

the number of the generation, G2 for generation number 2 for example
the number of ancestors you found
the number of ancestors that can be found. You found only half of the findable ancestors in generation 4, ie 4 ancestors
out of the theoretical 8; therefore, you will be able to find only the parents of these 4 ancestors: either 8 potentially
findable ancestors instead of the 16 theoretical. If, during your research, you find additional ancestors at generation 4,
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Heredis will automatically update your calculation.

from Heredis 2021 , untraceable parents are deduced from the findable ancestors and found ancestors.
the duplicate branch (implex) of the generation, if there are any. Heredis shows here the number of persons appearing
several times in the generation (shown with a ++ before the anhentafel number in the detailed view).
the progression in the search for major events of persons. The orange progress bar, Search progress, allows you to see
the progress of your research by making a report of the information you hold about the major events of found ancestors
in all of the information you should collect on these found ancestors for them to be considered complete. Heredis takes
into account your preferences. Set up what you think is important to consider a complete event in Heredis Preferences.
(Windows) Tool menu > Preferences > Heredis Preferences > Apprearance ; (Mac) Heredis menu > Preferences >
Appearance.

the percentage of ancestors found. A purple progress bar Found Ancestors indicates the percentage of ancestors found
in relation to findable ancestors.

Detailled view

At a given generation, if you notice that the number of found ancestors is less than the number of findable ancestors, unfold the
previous generation and locate the gray filiations icons. They tell you about individuals with no parents, who are therefore not
found and which will not figure in the next generation.

When you click on a generation to display its detailed view, Heredis lists all ancestors ordered by Ahnentafel number. If you
selected «Ancestors» as the scope in the dashboard options, this number may not be entered.

Other information displayed in detailed mode are:

The surname and given name of the person. In the case of a duplicate branch, they are displayed in red.

The filiation icon  indicating the presence or not of the parents of the person. Blue indicate the presence of the
father, violet of the mother. 

The absence of colour indicates the absence of the parents. Since Heredis 2021 , when a parent is declared

untraceable, the icon has a blue cross for  untraceable father or pink for untraceable mother. See also the article 
Untraceable Parents.

 

Dates, places and sources for major birth, union and death events.
The note icon which indicates the presence or absence of a search note. By clicking on this icon you can view, edit or
add a search note.
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The date of the last modification of the person. Click on the header of this column for it to be sorted in descending
order, you will thereby know on which individual you worked recently.

Note: Remember to refresh the information of this page by clicking the  button, so the changes you just made are included.

Heredis helps you to visualize distinctly and quickly the events considered as complete from those incomplete, based on the
preferences you defined on the sofware. Heredis colors automatically the events boxes so called complete.

Note: You know you will never find the information you need on a person and you declared it complete (Search Tab> Search

Help> Button 
or since Heredis 2021  from Data > Personal Data tab), it will appear visually as complete in the

search tracking with this button  displayed in front of the name of the person to report that you have forced his status to
complete. This person will also be counted in the percentage of completion.

A Common-Law Union is considered by Heredis as a complete union event.

The last column indicates the last time you updated that person. This information is useful to know what was the latest ancestor
you worked on. You can sort out the column by decreasing date to have the latest date first.

Heredis proposes by default in the preferences a maximum age at death fixed at 90 years for men and 100 years for women. If
one of your male ancestors is still alive after 90 years, it will not be considered complete. Your Search Tracking will indicate
that it is missing the date of death. Simply change this in «Preferences - Consistency» to increase maximum age at death for
your entire file.

Filter

Since Heredis 2021  , it is possible to filter

By Treetops, to display only individuals on top of a branch and know where you need to search

By Dead Ends, to identify the branches where you will have to search in specific archives or completely stop searching.
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Click on the desired filter in the upper left corner. Heredis unfolds the first generation affected by this filter and colors in blue
the other generations where you will find Treetops or Dead Ends.

Export Search Tracking

The table «Search Tracking» can be exported

in Excel format: click on the button .

in PDF format: click on the button .

Of course, the data in this Excel table or PDF will not automatically update.

This function has a simplified view in the My Dashboard page, where you can display a progress graph of search progress and

ancestors found limited to the first 15 generations. Click the  button to export this chart to PDF or PNG.
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Search Wizard

Visual cues tell you whether or not a search is necessary for the primary person displayed, based on the criteria you set in 

Heredis' Preferences, see Customize Heredis for more details on data completeness. The completeness icon  appears in
the status bar, in the Searches tab, in the Persons and Branches tabs in the search panel.
It tells you whether, for the main life events (Birth or Baptism - Union - Death or Burial), the information entered is complete,
incomplete or missing.

Click on the Search tab > Search Wizard.

Primary Person data

Heredis allows you to see events that have been experienced or of importance to your ancestor's history and gives you
the age he was if he were alive. You see the data of the primary person and his/her loved ones (Parents, Spouses,

Children, Fratrie), click on the indented wheel at the  top right to change the display. Choose to view only the
primary person's data by unchecking all the crossover events, or select which events you want to see.

The search wizard also displays:

the completeness icon of major events   
blue chips if you have a Note, a Source, a Witness, a Media attached to the event

the primary person's event search status. Click on the icon to change the search status to 
 No Search Record,  

 Search Record or  Not Found. You will then be able to see which event requires research.

Indicate manually that a person is complete by clicking on  if you do not have more data to search for. Since Heredis 2021,
this icon is also available in Data tab > Personal Data.

Click on  to display the branch of the primary person in the Branches panel.

The lower area of the search wizard

To complete your analysis of the searches to be undertaken, check out the tabs located in the lower area of the screen.
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Sources attached to all the events mentioned above may contain a crucial element for your approach.
Media allows you to view documents that may have clues.
The Map will allow you to see if the cities mentioned in the events displayed are close to each other or not.

Don't hesitate to fill out the Research Note by indicating which track you want to focus on. You will be able to resume your
steps later and continue your reasoning.

Start a search on the Internet

In the lower area of the Search Wizard,you can search one or more websites with a publishing database.

Click on the Web Search tab to select which data to take into account and which operator you want to search on.

1. Choose the search operator. Unroll the Search Location menu to select Heredis Online or another site suggested in the 

indented wheel .
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2. Choose the criteria from those available from the selected operator. Some criteria may be grayed out if they are not usable in
the operator's search fields.

Keep the surname of the primary person or type in another surname.
Choose a given name or all given names from the list on the drop-down menu. The given name selected by default is
the usual given name.
Check the Place box to include this data in the search if the chosen operator can manage it. Choose a location in the
drop-down menu: a common one that corresponds to events related to the primary person, department or country.
Check the Spouse box to include this data in the search.
Choose a spouse from the drop-down menu if the primary person has more than one. To search with a new spouse, type
his/her surname and given name into the entry fields.
Check the Period box to indicate a range of dates. Validate or change the start and end years for online search.

3. Click Search to send your search criteria to the selected operator. Heredis opens your Internet browser and displays the
requested site. It's up to you to complete the search based on any additional tools available at the default selected operator.

If you want to add a search operator or change the proposed list, click on the indented wheel  icon.
Check or uncheck the boxes to see, in the drop-down menu, the sites you are interested in. Some websites are available in
several languages, they are offered by default in English.
You may be familiar with other websites that may help you find information about your ancestors. You can add websites,
which will always appear in the drop-down menu of the operator's choice.

To add a personal website:

Click on the indented wheel  icon.

Click the button 
 at the bottom of the Web Sites window.

In the first column, type the name of the website as you want to see displayed in the list of available operators.
Open your Internet browser and log on to the search page of this site.
Copy the URL address in your browser's address bar and paste it in the URL area of the Web Sites window.

To remove a website added by you, select it from the bottom of the Web Sites window and click the button —.
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Relaunch a previous search

Haven't found the information you need? Didn't have time to study all the data on the genealogical website you were looking
at? You can, at any time, restart a search you've already done.

1. Click the History button. All previous searches for the primary person can be found in this window.
Rank them by date, or by operator name by clicking on column headers.

2. Just click the button  to restart the same search, with the same criteria.
Click the Clear History button to clear the list of previous searches for that person.

(Windows) Search history
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(Mac) Search history
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Searching in Online Archives

The Search in Online Archives 
 tool allows you, from your software, to access the Online Archives portal. Heredis

facilitates your research and also allows you to integrate acts you have found and cut into your family tree, by creating the
event and the associated source for example.

Click on the button 
or choose from the menu Find > Search in Online Archives...

Access and navigation in Online Archives sites

Heredis displays the Online Archives search portal in a real web browser.

Online Archives Portal

Online Archives

You have a button bar with the following options:

Archives Button: displays the home page of the online archives.
Bookmarks Button: lists the sites you have added as bookmarks and allows you to manage the list of bookmarks.

Previous, Next Navigation buttons: they give you an indication of the history of your browsing and allow to
re-display pages already consulted.

Update Button: updates the page displayed on the screen.
Capture Button: Captures the whole page displayed in the browser. If you have already made a capture, this

button opens a menu either for you to make another capture, or see the list of already captured but not processed sites.

As in any internet browser, you can add a new tab by clicking (Windows) on the little tab, (Mac) on the + button on right side.
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(Windows) New tab

(Mac) New tab

Close a tab by clicking the cross to the right of the title of the displayed tab.

The Archives portal concerns a a lot of countries. If you do not find a country, check on Other Countries section.

By clicking on the  button on the button bar, you return to the home page.

Use the   navigation buttons to navigate as on a website.

If a website appears to be missing from the list, share it via the  button at the bottom right of the footer
band. Each proposal will be submitted to the Heredis team. If accepted, it will appear on the portal and will be permanently
accessible to all users. We add website if screenshot can be made of records.

Your research will often focus on a given territory: select the sites you visit most frequently and add them by clicking the 

button > Add Bookmark. To make changes to your bookmarks, click > Edit Bookmarks: you can add other sites
and delete them with the + and - buttons. By clicking on a line, you may change the name or address of the sites.

Capture images

Once the certificate found, Heredis allow you to make a screenshot of this certificate. Click on  Capture button.

Online Archives Capture
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When you capture a deed or any other document, you capture all of the displayed page in the browser.

Once your certificate captured, rename the picture by clicking on Rename button. Otherwise, it will be difficult to find your
picture in Media index.

You can edit the capture by clicking the  Edit button. Your image is displayed in the Photo tool and you can edit the image
to make the document more readable (see the article on Photo Tool to see the details of this feature). Once the editing
parameters are right for you, close this window and treat your captures.

Crop the image to remove unwanted parts with the  button: when you click this button, your mouse cursor changes shape.
Place your cursor at the spot where the picture should be adjusted. Hold down the left mouse button and slide the selecting
window to encompass the desired area. When you release the mouse, the Crop button appears on the image; then click this
button. Your image is now framed.

When you have captured several images, the Previous and Next buttons allow you to scroll through the list of your
captures. You'll need to rename, edit, and crop every capture you make.

We advice you to keep a copy on your computer, click the  Save button and choose the location on your computer.

The  Delete button will delete the capture displayed in this window.

Info • All the captured images are declared as being private by default in order to respect the terms of use of the Archives.
Remember that if you close the Archives Online tool without managing your captures, they will be retained in the list of
captures only as long as the Heredis session is still open.

If you have managed to capture all of the act, click Process my capture, or on the Capture the rest of the act button in order
to cover the act in its entirety.

Processing captures
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Heredis allows you to process the capture of acts to associate them with an event of your genealogy and save the information
concerning the act.

Online Archives Capture

Multiple choices are available to you for treating these captures:

Save only in the media index

If you do not have the time, tick the Save only in the media index box for treating it at a later date.

Link to an event/person 

Since Heredis 2020, you may Link to a person the image you just captured.

Select (Mac) Link to an event / a person or (Windows) Associate with an event / Link a person.

Click on Select the person to select or create the person whom the captures are to be associated. Then, in case of a link to an
event, unfold the dropdown list to select an existing event or create one if it has not already been created.

You can choose between different option to save the source and the media. To do so, choose between Create a Source, Do not
create a source and Choose an existing source. Make sure to choose to save the media in the source or the event by unfolding
the dropdown list to Assign media to.

Note: If you use Comprehensive mode of sources, you can add the citation in Comments area and assign the media to the
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citation. If you choose Not to create a source, the media will automatically go to the event.

(Windows) Processing capture

(Mac) Processing capture
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When you click Validate, Heredis opens the source and prefills known information, the type of the source, the title of the
source, the Archive depository, the nature of the source, its quality, the website and automatically associates the capture or
captures with the source. Fill in any missing information if necessary and click OK to create the source.

See our MOOC on Online Archives for more explanation.

Enter data Census

Since Heredis 2019, you can also Enter Data from a Census. It will open the Census Grid feature. Please see Census article
or see our MOOC for further details.

Launch Online Archives from an event

The Online Archives search tool may be launched directly from the file of the person.

Events
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From the Personal Data entry tab, select the event you want to complete. Start the online archives search by clicking

the  Online Archives button below the list of events. Heredis displays directly the list of available archives of the country
for the selected event provided you have previously entered this information. When you have found and captured the act of the
event to be completed, Heredis prefills the treatment of captures with the relevant information on the person and the event
selected in the Personal Data entry tab.

It remains for you to validate and possibly complete the missing information for the source.
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FamilySearch

Heredis integrates various functions that allow you to search, compare, link, and import persons from FamilySearch universal
Family Tree.
Click on the Search > FamilySearch tab if you wish to access it.

Important: Verify the compatibility of your Heredis version and FamilySearch.

Note: for an easy access to theses functions, customize your toolbar by adding the button .

Connecting to FamilySearch

In order to enjoy these features, you must connect to your FamilySearch account directly from Heredis.
If you are new to FamilySearch, you can create a free account online.

Family Search account

Primary Person

In this tab, you can compare, link or unlink a person from your Heredis genealogy file to a person found in FamilySearch.
The banner under this tab in Heredis displays:

the primary person’s data, as saved in your Heredis genealogy file, his/her surname, given names, dates and places of
birth and death.
the person’s first name and last name, his/her FSID if the primary person is already linked to a person in FamilySearch,
as well as the current status of any family ordinance request.

                                334 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Other content in this tab varies according to context.

Heredis primary person for Family Search.

1) The primary person is not linked to a FamilySearch Person

You must find the Ancestor’s Name in FamilySearch’s International Genealogical Index (IGI) that corresponds to your
primary person so you can link the two together.

Heredis displays a search form that includes the surname, given names, dates and places of birth and death for the primary
person. These fields are automatically prefilled with the data already entered for this person in your genealogy.

If you click on the More criteria button, additional search fields for the primary person’s parents and spouse will appear,
which should allow you to refine your search on FamilySearch. The Reset button will delete the content of all search fields
displayed on the screen.

Click on the Search button, Heredis will directly access FamilySearch servers and display the list of persons found.

If you click on a person in the list of results, detailed information on the FamilySearch person you selected will be displayed in
the Summary side panel.

If a person listed in the results seems to correspond to your primary person, click on the Compare button at the end of the line
to compare the Heredis and FamilySearch persons in details.

Compare Heredis to Family Search.
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To make it easier for you to compare the two, Heredis displays the Heredis primary person’s immediate family next to the
immediate family of the FamilySearch person you selected.

If you click on the Link button, Heredis will attach the FamilySearch person’s ID number to the primary person in your
Heredis genealogy file.
The two persons are now linked.

If you do not wish to link the two persons together, click on the Back button.

2) The primary person is linked to a FamilySearch Person

If the individual displayed as the primary person in Heredis is already linked to a person in FamilySearch, Heredis displays a
window showing the data already saved for this person in Heredis next to the corresponding data saved in FamilySearch.

Family Search Linked Person. 
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3) The primary person is linked to a FamilySearch person who has been deleted

Heredis informs you in the banner of the Primary person tab that the FamilySearch ID number was not found.

If you wish to link this person to another FamilySearch person, click on the Unlink button displayed in the banner.

Consult the History

Directly from Heredis, you can consult the history of modifications that have been made to the FamilySearch record of the
linked person. Click the History button to access it.
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Note: Modifications made in FamilySeach after your import is processed will not be automatically updated in your file.

Import

From this tab, you can import a FamilySearch branch into a Heredis genealogy file.

To access it:
Click on the following tabs: Search > FamilySearch > Import
or select from the menu: File > Import > FamilySearch...

Family Search Import.
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 1) Set the parameters for your import

Source Person

Yourself: select this option to recover all or a portion of the genealogical data you have already entered in
FamilySearch.
Primary person in Heredis: if the individual displayed as the primary person in Heredis is already linked to a person in
FamilySearch, you can select this option and thus complete his/her ancestors or descendants thanks to the data already
gathered in FamilySearch’s global tree.

Note: if the primary person is not linked to a person in FamilySearch, this option is greyed out.

FamilySearch ID number: enter a person’s FamilySearch ID number in order to retrieve a FamilySearch branch that
will complete your genealogy.

Additional Options

Choose the number of generations for ancestors and descendants (limited to 5 maximum).
Tick Import Children of ancestors to retrieve the primary person’s siblings, uncles, aunts, etc.
You may also tick Import Alternate Names to retrieve additional names that might have been entered in FamilySearch.

Note: if you set the number of generations for ancestors and descendants to 1, the import will include the Source person and
his/her spouse(s).
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2) Imported data

When you click on the Import button, the following information is retrieved from FamilySearch’s global tree:

persons
events
notes
sources

All the persons imported into your Heredis genealogy are linked to in FamilySearch’s global tree and are recognizable thanks
to their FamilySearch ID number.

Rules applied during data import from FamilySearch to Heredis:
When importing persons from FamilySearch, you may face a number of situations such as:

the person to be imported is already in your genealogy with the exact same FamilySearch ID (FSID): this person will
not be imported again to prevent the creation of duplicates; the import process will move on to the ancestors’ or
descendants’ branch, according to your import settings.
the person to be imported is already in your genealogy but does not have a FamilySearch ID (FSID) number or the
FSID number is different: this person and his/her ancestors’ or descendants’ branch will not be imported to avoid
creating inconsistent data.

Notes: If the person to be imported is already in your genealogy – without a FamilySearch ID number – and if he/she is not
linked to the branch being imported, he/she will be added to your genealogy as a homonym.
The data imported from FamilySearch will never overwrite personal data in your Heredis file.

Persons in Heredis linked to Persons in FamilySearch

In Heredis, various functions are available to help you find persons in your Heredis genealogy file who are linked to
FamilySearch persons.

1) Search by numbers

Search Menu > Search by number
Enter the FamilySearch ID number you are interested in and Heredis will automatically take you to the matching person, who
will be displayed as the primary person.

2) Advanced search

The advanced search will allow you to apply filters to your list of persons in order to only display the persons linked to
FamilySearch.

From the Persons panel, on Windows in the <Enhanced criteria> replace <None> with < Persons linked to FamilySearch>.
On Mac, select <Genealogical Criteria> and replace <None> with <Persons linked to FamilySearch>.

(Windows) Family Search Enhanced Criteria.
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(Mac) Family Search Advanced Criteria.

3) Smart Search

To access it, click on the Search>Smart Search tab.
Select <Persons> and replace the <Surname> field with <Linked to FamilySearch> then click on the Search button to start
searching. All persons linked to FamilySearch are displayed just below the Results area. Refer to our Smart Search section for
more details on this feature.

(Windows) Smart Search.

(Mac) Smart Search.
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Note: if the primary person in your genealogy is directly linked to a person in FamilySearch, Heredis will display his/her
FamilySearch ID number in the status bar. This number is also displayed in the Summary panel, under the person’s name.
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Compatibility Heredis & FamilySearch

Heredis integrates various functions that allow you to search, compare, link, and import persons from FamilySearch universal
Family Tree.

However, FamilySearch regularly makes major changes in their database, only the current commercial release is compatible
with their latest updates.

To know more on FamilySearch functionnalities, see FamilySearch.
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Smart Search

Smart Search

This function allows you to find specific data in your genealogy by combining different search criteria; you may then modify
or process the data you have found.

To access Smart Search:

choose Smart Search in the Find drop-down menu
or select the Search > Smart Search tab

or click on the Find icon and select  Smart Search in the drop-down menu

The Smart Search tool is composed of a “Criteria” field, a “Results” section, and a “Processing selected results”
section. (Mac) This screen is also linked to a specific side panel entitled “Results”.

Search Criteria

The Heredis default display shows <Persons> as the first search criterion, then the <Surname> field, and the <Begins With>
operator. In the entry field to the right of <Begins With>, type in the first letters of the surname you are looking for and click
on the Search button to find all relevant persons in your genealogy.

The initial search criterion will determine what the next field options are.

(Windows) Selecting criteria

(Mac) Selecting criteria
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Click on each of the fields and specify the type of information you are looking for in your genealogy. You can combine criteria
such as Persons, Relations, Families, Events, Facts to build more or less intricate searches depending on the number of
criteria you have selected.

The  button to the right of the <Choose a search model> pop-up menu allows you to remove all existing criteria
and to clear the list of results.

The  and 
 buttons to the right of a criteria line allow you to add or remove a criterion. Note that the  button

won’t be displayed unless you have already added at least one criterion.

Additionally, you can organize the combination of your criteria by clicking on the pop-up menu located below the criteria
selection area.

(Windows) How to combine search criteria

(Mac) How to combine search criteria

The default search mode is set on <All criteria>. This option allows Heredis to search all data that match at least one of the
criteria you have selected. You can also narrow your searches down to specific parts of your genealogy or use the entire file.
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Click on the pop-up menu that reads <the entire file> and select <direct-line ancestors>, <the ancestors>, or <the
descendants>.

(Windows) How to limit the search

(Mac) How to limit the search

Existing models

Heredis provides pre-saved search models to help you create your searches step by step.

Click on <Choose a search model> and select the model you are looking for.

The fields associated with the model you choose are automatically prefilled. You can modify a search model by changing or

adding criteria and save these modifications by clicking on the  Save As button located to the right of the field entitled
<Choose a search model>.

To manage your models or to reload the saved search models, click on <Choose a search model> and select Manage saved
search models.

(Windows) List of saved search models

Mac List of saved search models
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Additional options for research

A phrased version of your search is automatically displayed below the criteria fields area. This allows you to verify that the
search you have created matches your needs. A message alerts you in case the search you are creating is incorrect.

Other options are available from the indented wheel  in the upper right corner. If you tick Search in variants, the
searches will be extended to the variants you entered in your genealogy. If you activate the Comprehensive mode, two
additional buttons will be displayed to the left of the Search button: Search in results and Add to results.

Extra buttons in Comprehensive mode in Smart Search

Search in results allows you to research data within the results of your previous search in order to refine your results.

Add to results allows you to add your search results to the results of your previous search. Thanks to this option, you can build
a list of results, adding up data from a series of searches.

If you enable Comprehensive mode, two additional columns appear on the left in the search results: you can select the row
and sort by gender.
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Note: When you consider your research is complete, hide the Criteria area (Mac) by clicking on the Criteria banner 
(Windows) by clicking on the arrow on the right side. This will leave more space available to display the results from searches

and processing. More space can also be freed by deactivating the phrasing of your search: click on the  indented wheel in
the upper right corner and untick Show the edit.

Since Heredis 2021

Since Heredis 2021 , it is possible to search one or multiple words in all notes : media, sources (or in transcription), events
in addition to the notes of persons or unions previously present.

Example of search for note in media

You can also easily search for

persons of the Ahnentafel line (Persons > Ahn. Number > Is Ahn. number > Yes or No) or those who are not
persons who are in duplicate branch also called implex (Persons > Ahn. Number > Duplicate Branch > Yes or No)
persons of the Ahnentafel line between generation X and generation Y (Persons > Ahn. Number > Between
Generations > X and Y)

Search for all persons you indicated to have father and/or mother untraceable...

Search results

When you click the Search, Search in results or Add to results buttons, Heredis displays the data found under the Persons,
Families, Events and Facts tabs.

Within each tab, a number (in brackets) indicates how many persons, families, events and facts were found.

(Windows) Display of Smart Search results
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(Mac) Display of Smart Search results

Open the Summary panel. To verify the results displayed in the list are correct, click on any line in the list of results and the
details will appear in the Summary panel. The data displayed in this panel varies according to the tab you selected under 
Results.

Should you notice a mistake to be corrected, double-click on the line in the list of results to directly access the person’s
Personal Data in your genealogy file.

Mac Specificity: Results panel

The results of your smart search are also available in the Results panel.

Results Panel – List of found persons
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You can navigate in Heredis while keeping your search results on hand. Use the <Persons> pop-up menu to select and display
results from the Families, Events or Facts tab. At any point, you can go back to the Smart Search screen by clicking the

button  to the right of the pop-up menu.

From this panel, select a person and use the drag and drop feature to easily complete your genealogy.

Processing results

Now that you have found persons, families, events or facts in your file, you may want to update this data, share it with a
cousin, or even publish it in a document.

The Processing feature allows you to do this and much more, based on the data you have selected in the Results section under
the current tab.

Note: in Comprehensive mode, by clicking the  indented wheel in the upper right corner, checkboxes appear at the
beginning of each data line so you can select the data you wish to process. All lines are selected by default; you can untick, one
at a time, the lines of results you do not want to include in your processing. Or you can decide to Deselect all and then tick the
data lines you want to include in your processing. If you want to go back to including all results, click Select All.

Unfold the Processing section, by clicking on the Processing selected <persons>, <families>, <events>, or <facts> banner:
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action buttons related to the Results tab you selected will be displayed.

(Windows) Processing results

(Mac) Processing results

Processing selected persons

If the Persons tab is highlighted in the Results section, you may then decide to:

Modify a series of additional information for the persons you selected
=> declare them as marked or unmarked, confidential, secondary, unmarried, childless, consistent, complete
=> change the field value under Child Status and Signature
=> add an identical text to all selected persons using Add to note
=> link a common source to all selected persons
Create a Custom report, chronological or alphabetical report listing the persons you selected (Edit by Date or by
Name). See also Custom Reports, (Mac) Create and Edit a Report, (Windows) Pre-established reports.
Export the selected persons as a Heredis or Gedcom file

                                351 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Delete the selected persons
Launch Find/Replace screen. See also Find/Replace article.

Processing selected families

If the Families tab is highlighted in the results section, you may then decide to:

Modify a series of information for the families you selected
=> change the field value Family Status in the scroll-down list.
=> add an identical text to all selected families using Add to note
Create a report listing the families you selected (Edit report)
Launch Find/Replace screen. See also Find/Replace article.

Processing selected events

If the Events tab is highlighted in the results section, you may then decide to:

Modify a series of information for the events you selected
=> change the field value under Search Status
=> declare them as private or not private
=> share or no longer share them
Add an identical text to all selected events using Add to note
Link a common source to all selected events
Create a report listing the events you selected (Edit report). See also Custom Reports, (Mac) Create and Edit a Report, 
(Windows) Pre-established reports.
Since Heredis 2021, you can delete all events of the smart search at once by clicking on Delete button. Warning, this
action is irreversible.
Launch Find/Replace screen. See also Find/Replace article.

Processing selected facts

If the Facts tab is highlighted in the Results section, you may then decide to:

Modify a series of information for the facts you selected
=> change the field value under Search Status
=> declare them as private or not private
Add an identical text to all selected facts using Add to note
Link a common source to all selected facts
Create a report listing the facts you selected (Edit report)
Launch Find/Replace screen. See also Find/Replace article.

Note: the Processing section banner indicates the type of data you are about to process (Persons, Families, Events, Facts) and
the number of records you have selected.
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Find/Replace

The Find/Replace feature allows you to find a specific text entered under Persons, Families, Events, or Facts and to replace
it with a new text, which you can type in directly.

(Windows) Find/Replace

(Mac) Find/Replace
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You can search for text entered under:

one of the following Persons fields: Prefix, Suffix, Nickname, Title, User Number, Person or Research Note.
a Family Note for a Spouse
one of the following Events or Facts fields: Place Subdivision, Description/Cause, Note or Name.

You may access this feature:

from the drop-down menu Find > Find/Replace
or by selecting the Search tab and the Find/Replace sub-tab

or by clicking on the Find 
 icon then on the Find/Replace  button.

Searching for Text

Enter the text you are looking for in the Text field.

Note: if you leave this field blank, Heredis will look for all empty fields.

Use the Item pop-up menu to select the type of data you wish to edit.
Specify where to search for the text you have just entered: In the entire file or In Smart Search results.
(For more details on this feature, refer to the Smart Search section).
Check the Case sensitive box for Heredis to distinguish upper- and lower-case. It will be able, for instance, to look for
”honest” and replace it with “Honest”.
Check the Entire word box to prevent modifications within a word. This way you can replace, e.g. in the Place
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Subdivision field, the abbreviation “st” with “Street” without affecting words such as “Newcastle”.
Click the Find button to display all relevant matches found in your genealogy. The number of found occurrences is
mentioned between parentheses in the Matches banner.

(Windows) Matches

(Mac) Matches
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Right below the list of matches, the searched text is displayed in red within each occurrence that was found. By default, all
matches are selected – but you can uncheck, one by one, matches you do not want to modify. Conversely, you may prefer to
click Deselect all and then check (only) the matches you want to modify.

Replacing text in your genealogy

Enter your new text in the field entitled Replace with.
Click the Replace button to apply your changes to all the matches you have selected.
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Find Relationships

The Find Relationships feature scans all the connections in your genealogical file to find out how two people can be linked,
even if they're not directly related or allied.

Click on the Find > Find Relationships menu.

or Click the button  and then the  button.

The primary person is proposed by default as the first individual to analyze. You can change it by clicking on the magnifying 

 glass.

Under the title Second Person, then click on the magnifying glass  to choose the second person from the matching list or,

from Heredis 2021 , click on Root Person or Primary Person button for a faster choice. Finally click Search to start
searching for relationships.

(Windows) Find Relationships

(Mac) Find Relationships
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Common ancestors

In the Search Results area, Heredis looks for possible common ancestors. By selecting one of the common ancestors found, a
table shows you the parallel paths leading each of the two persons to this ancestor.
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In case of implex due to inbred marriages, several paths can lead a person to the common ancestor. The number of paths is
specified at the top of its column. Click on the lines of the different links to see the different parentages that lead to the
common ancestor.

Other Relatives

Heredis then searches whether they are related by parentage or marriage: maternal great-great-uncle, brother-in-law of the son-
in-law, spouse of the second cousin.

Select the link or unroll the menu to see all the links and select another one. The table shows the parentages and alliances that

connect the two persons. Each link is named. To make it easier to understand the link, you can click the button  (Change
the meaning of the reading).

                                359 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

All links representation tables are printable by pressing  .

Other Relationships

Heredis is finally looking for all the non-kinship ties: do they have in their relationship a person who witnessed marriage,
declaring death?

Regardless of the type of link, it is represented in the form of a table in which each line names the relationship: son of, mother
of, witness of death, etc. This makes it easy to find the thread that connects the two persons.

As for relatives, eventually click the button  (Change the meaning of the reading) to better understand the link.

Click on any person mentioned in the links table to view their summary in the right part of the Find Relationships window.

Click the print button  to start your word processing software and print out the detail of the selected link as well as the
summary of all the links found.
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Searching for persons

Find the Root Person

The Root Person is the individual who lies at the base of your genealogical research and who bears the Ahnentafel No. 1.

Click  Root on the toolbar.
Choose Find menu > View Root Person.

See also The Root Person for more details.

Search by Name

Select Find menu > Search by Name

or click the Find  button on the toolbar and then click  Search by Name.

(Mac) Search by Name window

(Windows) Search by Name window
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1. Type the first letters of the Surname in the Surname input field. Heredis will display all persons with this surname and
variations that you will have defined in the Names Index.
(Windows) The search is carried out in the mode you have chosen. To change it, select Tools menu > Heredis
Preferences. Select the Search option on the first letters of the name (Search Starts with) or Search the name (Search
Contains) in the General tab.

2. In the Given Name box, type the first letters of the given name to narrow your search.
3. Tick the boxes M, F or ? to limit the search to men, women or persons of indeterminate gender.
4. Tick the Direct-Line Ancestors box to limit the search to direct ancestors.

Info • In front of each individual, a colored square indicates the gender of the individual: blue for men, pink for women and
green for individuals whose gender is not determined. If a square appears with yellow in the center, it is that of a direct
ancestor bearing a Sosa number.

To be sure to correctly identify the person you want, select him/her and check all the information that appears in the Summary
area. Click View or double-click the name to display the selected individual as the primary person in a new Immediate Family.

Search for a direct ancestor

If the person is a direct ancestor in the lineage of the Root Person, Heredis has automatically assigned an Ahnentafel number
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to this person.

(Mac) Search by Ahnentafel number

(Windows) Search by Ahnentafel number

Click Find  > Search by Number  on the toolbar or choose Find menu > Search by Number.

Click the Ahnentafel Number tab and type the number to be searched.
You can type any one of the numbers carried by the person you are searching for if there is more than one (implex).
Click OK to display the person corresponding to the selected number as the primary person.

If no person corresponds to the number typed, try another number. Click Cancel to abandon the search.

Search for a person by his/her personal number or FamilySearch number

You may perhaps have indicated a personal number to some persons in your genealogy. You can find these people with this
number.

Info • Use the Comprehensive or Customized input mode to view the User Number input field.

1. Click the Find > Search by Number  button on the toolbar or choose Find menu > Search by Number 
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2. Click the User Number or FamilySearch Number tab and type in the number to search.
3. Click OK to display the person corresponding to the number as the primary person.

(Windows) Search by number

(Mac) Search by number

Search for a bookmarked person

Open the Bookmarks panel that will display a temporary list of persons you require to access frequently.

Double-click a person in the list to view as the primary person.

Info • To add a person to the Bookmarks list, use drag and drop, or click the  (Add primary person to bookmarks) button
on the panel toolbar.

(Windows) Bookmarks
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(Mac) Bookmarks

 

Search for family connections

Open the Relations panel. It displays all the persons who are directly linked to the primary person: they are related, they are
cited in one of the events, they played a role in his/her life or you have established a personal link between them.

Unfold the fields according to the type of relation linking the individual and the primary person: Parents-in-Law, Cousins,
Grandchildren, etc.

(Windows) Relations Panel
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(Mac) Relations Panel

Info • When a category contains persons connected with an event (godfather, declarant, witness...), it is marked with a blue
symbol in Sundry Links tab of personal Data screen. See also Sundry Links.

Level 1 Information 

Open the top level to see the names of parents or persons related to the primary person.
Consult the list of direct relatives, persons connected to an event for the primary person (godfather, best man, etc.) or those for
whom you have created a personal link.

Info • The step relations (aunts and uncles by marriage, step-brothers and sisters, etc.) are shown in italics under the name of
their spouse. Half-brothers and sisters are shown in grey.

Level 2 Information

If additional information is available, click the disclosure triangle next to their name to unfold this level.
Double-click the person sought to display him/her as the primary person on a new Immediate Family screen. Double-click the
event to open it directly in the Personal Data tab.
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Look for links between two individuals

Heredis allows you to search for links between two persons. For further details, see Find Relationship article.

Search for duplicates in the file

The search for duplicate identifies persons entered several times in the genealogy file.

For further details, see (Windows) Permanent control for duplicates & Merge two persons, (Mac) Permanent control for
duplicates & Merge two persons.
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(Windows) Searching by theme (enhanced criteria) from Persons panel

Heredis offers a simple and rapid search for persons based on their Surname, Given Names and Gender. If this research does
not easily isolate the person you are looking for, you have available other search criteria corresponding to all the information
you have entered. These advanced research criteria are grouped in the Persons tab and are classified by research theme
(Personal Data, Relations, Events, etc.).

1. Open the Persons tab in the Search panels.
2. Enter if needed the Surname, Given Names and Gender.

Refine the search by Surname, Given names, Gender

When the list of results is too long and fails to isolate the search person, click the Show/Hide Enhanced Criteria 
 arrow

to unfold the advanced search criteria.

Search in Persons' panel 
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Select from the drop-down menu which data is to apply to the search: Search Entire File, Search Ancestors, Search
Descendants, Ascendancy and Descendancy, Inconsistent data, Smart Search Results, Last added or modified
persons.

Indicate a place, name of spouse and define a range of years.
Apply a filter by Any event, Birth, Marriage, or Death.
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Tick the Without source box if you wish to search for person with event without source.
Make limitations on Direct-Line ancestors (Anhentafel line)
Choose to display only Childless Family, Single-Parent Family, Parents Unknown or Linked to FamilySearch.

Since Heredis 2021 , it is also possible to search for untraceable parents.

To display the persons corresponding to these Enhanced criteria, click the Search button to update the list.

The list of corresponding individuals is updated as you enter details. When you click the name of a person in the list, his/her
summary appears in the Summary Tool panel. To view a person as primary person in a new Immediate Family, just double-
click the name. To start a new search, click  Remove criteria icon. All individuals in the file are displayed again.

 

                                370 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Research of Branches

The Branches panel allows you to memorize the different family branches as a base for your research and its evolution.

If the Branches panel is not open, it will be displayed and updated by clicking

the  Display Family Branch icon on the Search tab > Search Wizard of the primary person displayed.
or click on  on the left of the name of the person whose branch is displayed.

This function allow you to work through each family branch and carry out all the necessary research.

Click the  Ancestors or  Descendants button to display the required lineage in the Branches panel.

Each person displayed in the branch has an icon showing the completeness of data for the three main life events: Birth or

Baptism in violet  / Marriage in yellow / Death or Burial in black . Double-click any person to display the details. A simple
click displays the summary in the summary panel.

You have a display filter available in a pop-up menu. You may choose between All people, Treetops, Hide Complete
Persons, Search Status is ‘Search Record’, Complete Persons Only and Sort by Change Date. As an example, you will
display Complete Persons Only to display a positive status of your work on this branch. If you Hide Complete Persons, you
will have a clear idea of the work still to be done on the branch.

(Mac) Display criteria in the Branches tab.

(Windows) Display criteria in the Branches tab.
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If you decide that there is much more work to be done on the descendants of a given ancestor, you may select Memorize This
Branch from the pop-up menu.

The list of persons displayed in the pop-up menu corresponds to the family branches you will have memorized, both ancestors
and descendants. Select the name to redisplay the memorized branch.

When you select a memorized branch from the pop-up menu, it will replace the previous branch displayed. You may also
display the branch of the primary person by clicking the button to the left of the pop-up menu.

Do not overlook to suppress the memorized branch once you have finished your research of this lineage. Open the pop-up
menu and select Clear This Branch.
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Search for Sources

Find a source simply among all the sources assigned to events in your file.

With the Sources panel

Use the Search box in the Sources panel to type a word contained in any input field for the source selected: the document, the
name of the author, the call number, etc.

The number of items found matching your search is displayed at the bottom of the panel.

To cancel a search on any word, click the (Windows)  (Mac)  Delete icon to the right of the search box.

Refine the search by selecting sort criteria from the pop-up menu: Recently Used Sources, Unused Sources, Private Sources,
Sources Linked to Primary Person. The list is updated according to the selected criteria.

Windows Sources Panel Filter

Mac Source Panel Filter

To cancel the sort criteria, select All Sources from the pop-up menu.

With the Sources Index

Open the Sources Index from the Tools menu, or by clicking the button Sources Index on the toolbar.

In the Search box, type any word contained in any input field of the source desired.

The number of items found matching your search is displayed beneath the Search box.

(Mac) Click on the magnifying glass icon   to select the search mode: Search Contains the word entered, or Search Starts
With the entered letters.
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To cancel a search on any word, click the (Windows)  (Mac)  Delete icon to the right of the search area.

You will limit the search to unused sources by checking the Unused Sources box.

The results can be classified by the presence of a note (N), media (M), private source (P) or Title, Document, Origin... by
clicking on the column header.

See the list of events in which this source is used in the (Windows) Entries (Mac) Usage field at the bottom of the screen.
Double-click the line of the event to navigate and view this person and this event.

See the Sources Index and The different mode for Sources & Citations articles for further details.
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Search for other data types

The indexes list the information you have entered and display the uses for each type of data. By using the Indexes, you can find
sources, places, media, but also occupations, surnames, given names and repositories . Each item of data can be illustrated or
commented, which brings infinite richness to your genealogical research. What village was part of the «Pencader Hundred»?
What was the family crest of «Bolgan»? What is the origin of the name «Andrew»? What was a «balancer»? You have taken
care to note this information relating to the life of your ancestors and you will find them by searching in the index in question.

Open each of these indexes, from the Tools menu, or clicking the Indexes button on the toolbar.
Scroll the contents of the Index or use the search box to limit the number of items displayed.
Type all or part of the search item. The number of items found matching your search is displayed beneath the search
box.

Mac

Click on the magnifying glass   to select search mode: Search Contains the word entered, or Search Starts
With the entered letters.
(Mac) Click the Statistics tab to see periods of use of the element.

Click the Usage tab and check the list of persons for whom you typed the given name, the surname or occupation.
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Double-click the line to display the individual as the primary person.

Windows

Select the desired item from the list and consult all the details you entered.
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Click the Entries tab (or consult them in the lower part of the index depending on the type of index) and check the list
of persons for whom you typed the given name, the surname or occupation. Double-click the line to display the
individual as the primary person.
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Search for Places

You know that the person has lived in this city or region? Consider using the event places to find someone in your genealogy.
To find a place among the places of your file, you have several options:

With the Places panel

Use the search box on the Places panel to type a word in any entry field for the place you are looking for: the city, postal code,
county, state, country.
The number of items found matching your search is displayed at the bottom of the panel.

To cancel a search on one element of the place, click the (Windows)  (Mac)   Delete icon to the right of the Search box.

Refine the search by selecting sort criteria from the pop-up menu: Unused Places, Places Linked to Primary Person. The list
is updated according to the selected criteria.
To cancel the sort criteria, select All Places in the pop-up menu.

(Windows) Places Panel

(Mac) Places Panel

With the Places Index

Open the Places Index from the Tools menu, click  the Index button   on the toolbar or (Mac) click on the book symbol 

 on the Places Panel.
In the Search box, type a word in any input field of the source being searched.
The number of items found matching your search is displayed (Windows) in the Title of the Index (Mac) beneath the search
box.

(Mac) Click on the magnifying glass  to select the search mode: Search Contains the word entered, or Search Starts
With the entered letters.

To cancel a search on elements of the index, click the (Windows)  (Mac)  Delete icon to the right of the Search box.

You will limit the search to unused places by checking the Unused Places box.
(Mac) The results can be classified by the presence of a variant (V), note (N), media (M), or City, County... by clicking on the
column header.
See the list of events/facts in which this place is used by clicking the Usage tab. Double-click the line of the event to navigate
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and view this person and this event.

See the Places Index article for further details.

Heredis also has tools to Geolocating Place subdivisions, Zoom in on a place, Zoom in on the World-Family Tree
Mapping,consult these article to know all details.
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Search for Media

You have several tools available for finding an item of media for assignment to data or for replacement.

With the Media panel

1. Open the Media panel.

2. Type the name or partial name of the media sought in the search box. Cancel the search by clicking on the (Windows) 

 (Mac)  Delete icon to the right of the search area.
3. Refine the search by selecting sort criteria from the pop-up menu: Recently Used Media, Unused Media, Private Media,
Media Linked to Primary Person, Missing Media. The list is updated according to the chosen criteria. To cancel the sort
criteria, select All Media on the pop-up menu.
4. To better identify the media selected, change the display mode for the media, as a list or in thumbnail images, by clicking
the corresponding buttons. You may also enlarge the thumbnails by using the zoom slider.

Windows Media Panel - Search Criteria

Mac Media Panel - Search Criteria

The number of items found matching your search is displayed at the bottom of the panel.

The media may be easily assigned to a data item of your file by drag and drop.

In the Media Index

Open the Media Index from the Tools menu, click the Index button  on the toolbar or (Mac) click on the book symbol 

                                380 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

 on the Media Panel.

In the Search box, type all or part of the name of the desired media. The number of items found matching your search
is displayed (Winsdows) in the titel of the Media Index oder (Mac) beneath the Search box.

(Mac) Click on the magnifying glass  to select the search mode Search Contains the word entered, or Search Starts
With the entered letters.

To delete or replace the search word, click the (Windows)  (Mac)  Delete icon to the right of box.
Limit the search to a type of media by selecting from the pop-up menu: (Windows) All Media, All Pictures, Other
Media, Missing Media, Private Media (Mac) All Media, All Image Files, Audio Files, Video Files, Other Types,
Missing Media, Private. 
Limit the search based on the type of data to which the media is assigned by selecting from the second pop-up menu: 
Whole Index, Persons, Families, Events, Facts usw...

To better identify the media selected,

Sort the thumbnails or (Mac) the list by the name of the media file or the date you entered.
(Mac) Change the display mode of the media, as a list or thumbnails, by clicking the corresponding buttons in the first
pop menu.

Info: You may also enlarge the thumbnails by using the zoom slider.

Mac Info • The results displayed in a list can be classified according to the presence of a note (N), a private media (P) or by
the file name or date, by clicking the column header.

When media are selected from the list, see the data to which the media are assigned in the table at the bottom. (Mac) Double-
click the data for display in a new screen.

For further details, see Media Index.
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Photo Tool

Heredis offers an ideal tool for enriching your Genealogy. Very simple to use, it allows for example, for all genealogists to
identify persons in a group photo or in an act and capture faces or signatures.

If the pictures or captures of acts are not perfect, you may correct them with the photo editing tool.

The photo tool is available in your software from the Immediate Family, XXL Family, Personal Data and Family Group
Data tabs but also from the Media research panel and from the various indexes.

Select for example the Immediate Family in the Family tab and double-click on the media of the primary person

or click the button  if it is in your toolbar
or click on the Tools Menu > Photo Tool

Photo Tool 

This tool consists of four tabs, Media, Edit, Details and Identification, a display area for the image and input fields to
complete media information.
You have information concerning a photo: enter in the input fields the date and notes to clarify the context and thus
complement your genealogical data.
If necessary, indicate that this is a private media. Thus, you can avoid transmitting it when exporting or publishing your file:
tick the Private Media box.

The Media tab

A list of media appears in this tab in the form of photo thumbnails. This list will depend on the context of launching of the
photo tool.
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For example, if you run the tool from the thumbnail of the Primary Person in the Immediate Family, the media displayed will
be those of the Primary Person.

If you run the tool from a picture of the union in the Personal Data tab, Heredis will only list the media for that union.

A zoom slider at the bottom of the tab to the right of media counter allows you to adjust the size of the thumbnail displayed.

You have a series of buttons to act on the media displayed:

Button : You can add a media from the hard disk, the index or the clipboard.

Button : press this button to detach the media of the Primary Person without removing it from the Media index.

Info •  and  buttons are not displayed if you launch the photo tool from the Media index.

Button : the star symbol identifies the photo you have selected as a favorite. It is this photo which will illustrate the
person in question in all documents. Select a thumbnail from the list and click this button to place it as the favorite.

Show all media linked to primary person 
 button: this button will display all the media concerning the person

and you will see the wedding picture or pictures of the Primary Person, as well as those associated with his or her
name...

Info • the Star and All Media buttons only appear when you display the media of the Primary Person.

  button: to find a media more easily in the displayed miniatures, you can sort them by name or date.

  button: if you have made a mistake in adding a media, click this button to replace it with another media on your
computer.

  button: you have made changes to a photo which do not suit you and you want to go back to the original version of
this photo: click the Reload button. Heredis will automatically reload the original picture saved on the computer.

  button: You can save a copy of the displayed picture to the Photo tool on your computer.

The Edit tab

Editing is possible for images media: . jpg, . jpeg, .png... It is not possible to touch up a PDF or a .docx. It is therefore
preferable to put image-type media even for your deeds rather than PDFs.

If your photo is not perfect, you can easily modify it.

For example, crop the image to remove unwanted parts with the Crop  button. When you click the button, a selection box
appears on your capture. Adjust the dimension with your mouse cursor by stretching or narrowing one of the 4 corners of the
selection area. The cursor changes shape when you position it on the dotted lines of the selection area: hold down the left click
and drag the window to move it. When the selection area is adjusted, click Crop. Your image is now well framed.
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If you want to orientate your photo in any other way, rotate the image in the right direction by using the orientation

buttons Rotate Left  Button, Rotate Right  button. You may flip the image horizontally with the Horizontal

Flip  button but also vertically with the Vertical Flip  button.

With Heredis, you do not need any other software to embellish your photos. You can adjust brightness, contrast, or definition
to sharpen an image to its true value.

You can also change a color photo to black and white by clicking the button but also reverse the colors of the photo by

clicking on the button .

Do not hesitate to try different changes, because you can always return to the original photo with the Cancel button.

Once your image is satisfactory, you may confirm the changes by clicking the Apply button.

The Details tab

With this tab, Heredis informs you of the different uses of the image displayed and shows you where the original is located on
your computer. If you click on the displayed path, (Windows) Windows Explorer / (Mac) Finder will open.

See also Media Index and Media articles.

The Identification tab

From this tab, you can identify persons in a group photo or persons named in an act by cutting out their photos or signatures. If
you then navigate through your software, you will see that the cut portraits or signatures illustrate persons with whom they are
associated.

Using your mouse, enclose the people on the picture in the display area.
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Position the mouse cursor over a person, hold down the left mouse button and draw a cut-out frame around the person. When
you release the left click, Heredis instantly offers to search the index of persons of your genealogy for the person in question.

If you know this person, type in the given name or surname or both. Immediately Heredis displays the list of persons with this
name and forename or variations in your file. Select the person from the list and click (Windows) Choose; (Mac) OK.

Identification

If you know this person, but he is not present in your genealogy, click the  Create Person button to create the person
directly from this screen.

If you do not recognize this person, click the  Unknown Person button to indicate that this person is an unknown person.
Should you publish this group photo at a later date, an internet user may identify this person and communicate the information
to you. Check out the Heredis Online article to learn how to create and set up an album.

A frame appears around the person. You can always adjust this frame at any moment.

When you place the mouse pointer on the contours of the frame, it changes its appearance. By holding down your mouse, you
can move the frame. By touching the corners of the frame, you can enlarge it or reduce its size to make it fit perfectly.
To the left of the photo, the list of numbered frames appears progressively as you identify the different persons in the photo.

An indented wheel  appears when you move your mouse over the media in the list. If you click this button, you have
access to the following functions:

Remove the Frame: you have made a mistake, select this menu to simply remove it. Note that all the frames are
automatically renumbered.
Rename the framed picture : Heredis automatically assigns a name to the media which you have just created and if
the name does not suit you, you can change it.
Re-Identify: if you have identified a person as unknown or you have made a mistake concerning the person, you can
always assign to this frame the right person in your genealogy file.
Export the framed image: You can save the newly created image managed by Heredis to your computer.

All images are stored directly in the Media Index. They are also assigned automatically to the media of the identified person.
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Click the  Show all picture frames button at the bottom of this tab to display only the frames numbers in the display area
of the image.

You can print the picture as displayed in the image display area by clicking the Print button. Specify the print options and
click OK. The document opens in your usual word processor.

Take this printed document along with you during visits to your family: the people around you will enjoy your work and
perhaps identify unknown persons in the group photo.

Once you have identified all persons in a group photo, share it in your online photo album on Heredis Online through the 
Publish button.

Info • When you browse and launch the photo tool for a person with whom you have associated a signature for example,
Heredis indicates above the display area of the image that the media selected has been cut from another picture. If you click the
Display the Original link, it will be displayed in the image display area. If you want to hide it, click the Hide Original link.

You cannot recut a picture that has already been cut out.

Some editing functions are not available for a group photo if you have already identified persons in this picture.
If you close your genealogy file without saving, all edits, cut-out photos and signatures... will be lost.
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Slideshow

With Heredis, the slideshow scrolls through the life of your ancestors in images. This tool presents your photos in a family
album, composed of different chapters resuming life of the primary person and his/her immediate family.

In this function, Heredis displays the media of the primary person and his family and more specifically the media:

of the primary person

of his/her spouses

of his/her children

of his/her brothers and sisters

of his/her parents

of his/her grandparents

For all, Heredis shows the person's media, union media, individual events, union and shared events, media of names, forst
names, occupations, places. If they have already been displayed for the primary person, they won't appear again.

Launch Slideshow

To launch it, place the wanted person as the primary person:

click the Slideshow  button under the screen of the primary person from the immediate family tab, or the person’s
data entry tab.
click on Reports menu > Slideshow

Let the pages of the photo album scroll through and enjoy your work.

Click the Pause  button on the top right of the screen to stop on a picture and read the comments on the photo, for
example.
Click the Chapters menu to display all the chapters of your album. By clicking on one of the chapters, you navigate

directly to the selected chapter and you can then restart the slideshow by clicking the Play  button at the top right.

Slideshow
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Change Slideshow Theme

By default, the slideshow appears with the Retro theme but you can change it according to your tastes. Click the Themes
menu and choose another theme from the selection.

Each theme has an associated music. It is not editable.

At the bottom of the screen, you have an audio player for playing music. As you watch this family slideshow, the photos

parade with the music. Click the Sound  icon to cut the sound.

Filter the images of the slideshow

By default, all media of the primary person and his/her close family are displayed.

Click on the indented wheel and choose the images you want to see for the primary person, his/her children, his/her
spouse and unions, the other persons (brothers, sisters…) etc.

Filter images of Slideshow 
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Note: other photos are those attached to places, surnames, given names, occupations, sources, and linked to the primary
person.

A box to tick allows you to exclude from this slideshow all private images of your genealogy.

Export the slideshow

Now you wish to share this sideshow, click on the Export  button. Heredis creates, in the location of your choice, a folder
with the photo album of the primary person, the way you set it. Share this folder with your relatives: they can play it by simply
clicking the HTML page created in The photo album of […].html and even if they do not have the Heredis software.

You can also copy the folder to a USB key or an external hard-drive and plug it to your TV, computer or any other USB
outlet… to visualize the slideshow with your family.

Important: You need to copy the entire folder if you want the Slideshow to work.

(Mac) Slideshow's folder in Finder
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(Windows) Slideshow's folder in Windows Explorer

To exit the slideshow, simply click the Exit  button at the top right.
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Create and Edit Sheets

You can edit individual or couple sheets.

Creating sheets

Choose (Windows) Reports / (Mac) Documents  > Sheets or click the Sheets button in the toolbar.
Select the document type from the list on the left.
Select the appropriate graphic theme in the viewer

(Mac) Choose the type of sheet then the theme

(Windows) Choose the type of sheet then the theme
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Click on the different tabs to choose the appropriate construction parameters for your document. See paragraph below.

 

Composing a sheet

(Windows) Sheet's Layout
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(Mac) Sheet's layout
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The presentation and content options can be selected from the various tabs. Changes made to a theme are memorized for future
use of the same theme.

Click on the Structure tab
check the information to be included in the form: different family members, photo album, notes, private data,
etc.
choose how to manage sources.
choose the person(s) to be treated.
Note: If you want to edit the sheets of several persons in your file at the same time, you must first mark these

persons using the flag  of Personal Data screen. You can mass mark according to one or more search
criteria through smart search. For example, you can search for all persons with the Thomas name and then click
the Marked >Declare marked button in the processing area. See the Smart Search article for more
details. Then select Print Marked Persons Sheets. You will get all the relevant sheets at the same time. 

Be careful, the more persons you put, the longer the edition will be. Avoid putting too many people at the same time not to
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block Heredis for many hours if your file is consequent.

(Windows) Structure tab

(Mac) Structure tab

Click the Persons tab.
Choose the surname and given name formats.
Check the boxes to add Prefix, Suffix and Nickname if you entered these fields.
Check the boxes to include the information in the sheet: preferred picture, number, occupation, title, child
status, signature, flags (confidential, childless ...), notes.
Check the corresponding boxes to include in the document the spouses of each child and whether or not they
have descendants.
(Mac) Check here the box to add Facts.

(Windows) Person tab
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(Mac) Person tab

 Click the Events tab to select which events to include:
minor events (other than birth, death and marriage event), cross-events (events in which the person
participated as a witness, for example).
Choose the format of date of events.
Check the Dates in Gregorian calendar box to display all dates in this calendar, regardless of the calendar in
which they were entered.
Choose the place style from the drop-down menu. Select which elements of the places you want to display in
the document from the ones you have entered.
Check the box Include subdivision to give more precision to the place.
For each event, specify if you wish to mention witnesses and notes.
(Windows) Choose to add the Facts of the person.
If you selected the Biography document, check Show Missing Data to have your family complete it.

(Windows) Events/Facts tab
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(Mac) Events tab

Click the Style tab and choose the formatting of the form:
type of font,
text size and color,
specific colors for men, women and numbers,
colors of the titles
colors of background fills
color and thickness of the borders of the document.

(Windows) Style tab
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(Mac) Style tab

Click the Page tab and set your print options:
indicate the text to include in headers and footers,
paper size and orientation,
setup the document margins.

(Windows) Page tab
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(Mac) Page tab

(Mac) Select the word processor with which you want to edit the document. Heredis shows you all programs that
enable editing and are installed on your computer.
(Windows) The sheet will open in your default word processor for .docx file formats that is installed on your
computer. If you do not have a default word processor for this type of file, Heredis will not be able to open the
file. Remember to check in Windows system, if you have a default application for .docx.
Click Edit to start the word processor.
Click Export if you want to use it differently and create a .txt document to be open in raw text format.

Important: Once your sheet is created it becomes an independant document from Heredis. You can modify it in your word
processor. If you encounter {XE} tags in your sheet, it is not due to Heredis, see {XE “xxxxxxxxxx Names” } tags in your
documents, what to do? article.

Save a Sheet

A sheet edited in your word processor becomes an independent document from the Heredis software. This document can be
saved for later reprinting or modifying. To keep the document displayed in your word processor, use the saving feature of your
software. It is generally found in the File menu.
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To change the name proposed by Heredis for the document, or the location of the file, choose File > Save As. These
commands are generally the same in all word processors.

Print Sheets

You will start printing from your word processor, having made changes if required.

Usually, you can find the Print options in File menu > Print but it depends on your word processor software. Refere to its user
guide to know exactly how.
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Create and Edit a Book

Your family tree has grown and you wish to share your findings with your family. The Ancestors or Descendants books are
perfect for getting the interest of cousins or other relatives, even if they know nothing about genealogy.

You can edit Filiatus written books to tell your genealogy. From the information you have gathered in your file, Heredis
generates a complete book in written form and automatically adapts the vocabulary to the data type. This book includes cover
page, dedication, acknowledgments, preface and introduction.

The written books offered in Heredis are elaborated according to the recommendations of the author of the Filiatus software.
The presentation and the writing are particularly careful. Written in the style of the genealogy dictionaries of olden times
(Father Anselme or Dictionary of the nobility), their presentation is nevertheless friendly and comprehensible by all, even
neophytes on the subject.

The ancestors of each character are analyzed in all seams, to detect possible cousinings and to create the branches and sub-
branches corresponding to the family structure studied.

Heredis puts two types of book at your disposal, books written from the primary person and books of the type «dictionary»
based on all your genealogy.

The books written from the primary person

Ancestors by generation
Descendants by branch
Clan: in this document, Heredis builds up the close family around the primary person: spouses, parents, uncles and
aunts, grandparents, brothers and sisters, cousins, children, grandchildren ...

Diagram of the individuals included in the Clan
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The “dictionary” type books

Patronymic dictionary: Heredis searches all men at the beginning of branches, classifies them by surname and
generates their patronymic descent (this dictionary is inspired by René Jetté’s «Genealogical Dictionary of Families»).
Genealogical dictionary: Heredis takes all individuals from your genealogy file, sorted alphabetically.
You can attach to these books, genealogical tables and a complete index of individuals, professions and places
mentioned.
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Creating a Book

1. Choose (Windows) Reports menu > Books; (Mac) Documents menu > Books; or click the Books  button in the
toolbar.

2. Select the document type from the list on the left.
3. Select the appropriate graphic theme in the viewer.
4. Click on Detailed options button and view the different tabs to choose the appropriate construction parameters for your

document.

(Windows) Books choices
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The tabs and options are the same on Mac and Windows. The only difference is the color of the selections because the Mac
system highlights in blue color what Windows puts in gray.

Detailed options

 

The presentation and content options can be selected from the various tabs. Changes made to a theme are memorized for future
use of the same theme.
By default, the book construction screen opens in simplified mode. Only the most common options are displayed. To view all
available options, click the Detailed Options button at the bottom of this screen.

Note: In detailed mode, the label of this button changes to Simplified Options, allowing you to return to simple mode at any
time.

Click the Structure tab.
Check the information to be included: photo album, header and footer data, private data.
Choose where to place notes, at the bottom of the page, at the end of the section or in the text.
Limit your document. Indicate the number of generations desired, limit to a surname, place, edit your document
in several volumes.
Choose how to present sources: Quoting sources, Complete sources, or No Sources
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Note: Depending on the type of document selected, some of the options mentioned above do not appear.

Click the Front Cover tab.
Check the boxes for the information to be included on the cover.
Modify the title, add a subtitle, indicate who is the author.
Insert a picture to customize the cover, click on + button at the bottom right to add a picture.

Click the Persons tab.
Choose the surname and given name formats.
Check the boxes to add Prefix, Suffix and Nickname if you entered these fields.
Check the boxes to include the following information: pictures, child status, signature, notes, sundry links,
calculated data (ahnentafel number, duration of marriage, Stepfamilies, Consanguinity degree precise the
maximum wantred degree).
Tick the corresponding boxes to include in the document the spouses of each child and whether or not they have
descendants.
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Click the Events/Facts tab
Choose the date format. Check the Use Gregorian Dates box to display all dates in this calendar, regardless of
the calendar in which they were entered.
Choose the place style from the drop-down menu. Select which elements of the places you want to display in
the document from the ones you have entered. Check the box Include subdivision to give more precision to the
place.
Select which events to include: minor events (other than birth, death and marriage event), facts.
For each event, tick the corresponding boxes to specify witnesses, age at the event and notes.
Check the option Show Missing Data to have it completed by your family.

Click the Style tab
Tick the box to Divide text into Colums by page for your book.
Choose the formatting of the book: font, text size
Click on the colored button to choose colors for general data (Color), title, specific colors for men, women and
numbers
Click on the colored button to choose the color of title background, color and thickness of borders of the
document.
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(Mac) Select the word processor with which you want to edit the document. Heredis offers you all programs that enable
editing and installed on your computer.

(Windows) Heredis will launch the software by default for .docx files. Make sure you have a word processor by default
overwise the document won't open. It will be saved in Documnets > BSD Concept > Heredis > Heredis Genealogical Reports
but won't open. You'll be able to open it once you'll have a word processor.

Click Edit to start the word processor.

Important: Once your book is created it becomes an independant document from Heredis. You can modify it in your word
processor. If you encounter {XE} tags in your book, it is not due to Heredis, see {XE “xxxxxxxxxx Names” } tags in your
documents, what to do? article.

Info • Indexes are not directly integrated with books because each word processor handles them in a specific way. However,
index entries are marked so that you can generate an index after the document is created and opened in your word processor.
Put the cursor where you want and generate the index:

in Word, menu Insert > Tables and Index or References> Insert Index
in LibreOffice, menu Insert > Indexes and Tables

Mac Note: The text editor Page doesn’t manage index.

Print or Export Books

Once the book is created, you can print it from your word processor. Generally, then click on the File menu > Print.

From your word processor, you can save in a format other than . docx, for example in .pdf. Click the File menu > Save As,
change the format (the operation differs from one word processor to another), choose the save location and click Save or OK
depending on the software.

For more details, refer to the user manual of your word processor or printer for printing configuration.
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{XE "xxxxxxxxxx Names" } tags in your documents, what to do?

Once edited, Heredis documents will automatically open in your default word processor.

These documents are independent from Heredis and cannot be edited in Heredis but in your word processor instead.

Make sure you have a default word processor (LibreOffice, Word, OpenOffice ...) available on your computer for .rtf and
.docx files.

To remove {XE "xxxxxxxxxx Names"} tags in your document, you must disable tags in your word processor.

Do so by clicking on the corresponding button.
These tags will not show on the printed document.
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(Windows) Pre-established reports

All documents you view and print with Heredis will open in your word processing. This way of operating puts you in a
familiar environment, facilitates the manipulations you want to perform, allows you to completely reshape the presentation of
the data and to record, if you wish, the documents displayed as independent files.
If no word processing is up and running on your computer, you can download free word processing, such as LibreOffice. Make
sure your system has an application by default for .rtf, .xlsx, and .docx files.

Use the Reports menu to access the various editions offered by Heredis, with the exception of indexes entries that can only be
accessed in indexes.

For more details on old Ascentors, Descendants and Persons Custom report, see (Windows) Customize your reports. For
Custom Reports included since Heredis 2019, see Custom Reports.

The different types of pre-established reports

Ancestors reports

They are built from the primary person displayed on the navigation screen.

The Default Ancestors report
The By Men Ancestors report (agnatic line)
The By Women Ancestors report (cognatic line)

Descendants reports

They are built from the primary person displayed on the navigation screen.

The Default Descendants report
The By Name Descendants report

Persons reports

It displays and prints all persons registered in the file regardless of their kinship or role, ranked in order of surname and then
given name.

Families report

It displays and prints all the unions recorded in the file regardless of the type (marriage, civil or religious, cohabitation,
extramarital relationship...).

Tiny Tafel report

This report is a review of genealogical researches. It lists all the surnames recorded in the file based on where the surnames
were found and the period during which they appeared.
For each surname and place, it counts the type of acts found: Birth - Baptism - Marriage - Death.
The Tiny Tafel report is the preferred mode of exchange within genealogical societies.
It allows you to immediately see if bearers of the surnames you are interested in have already been identified by other
genealogists, where and when they have been spotted.

Events report

It displays and prints all events, individual or family, recorded in the file, ranked chronologically, with the date and location of
the event.
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Facts report

It displays and prints all the facts recorded in the file, arranged in alphabetical order. For each fact, its description, the person
to which it is attached and the place when this information is provided are displayed.

Research Status report

It review of your researches and prints all the persons for whom you are looking for an original certificate in order to confirm
your data. The list can be edited for the entire file or place by place, or for an entire County or State.

To get this report, you need to activate the landmark button  (Research Status) in the Data >
Personal Data screen, or in the event entry area of the Add a Person window or in the Search Wizard, by clicking on the

magnifying glass. To activate it, change the display mode with the indented wheel  of the Personal Data.

Anniversaries Report

It displays and prints events, individual or family, based on a "historical" selection: events that took place on a particular day of
the month, or in the following week or month.

Indexes lists

They allow the full content of each of the indexes generated by Heredis to be published.
The Surname List,the Given Name List,the Occupations List and the Places List show the list with the variants and the
number of uses.
The Source List displays and prints all the sources cited in the events, specifying the persons related to them and the events
involved.
These lists can be obtained directly from the corresponding indexes. In the index, click on the Print button.

The choice of data to display

Click on the Contents tab. According to the chosen report, you may not have always the same options.
Check the options for selecting the persons to be displayed in the report (men, women, witnesses, etc.) based on their
genealogical role.
Specify the limits to be made to the list (confidential, Direct-line Ancestors, Period, Places...).

Options vary depending on the type of report requested.

Persons Report (By Name or Alphabetical) - Contents
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The layout of the reports

Click on the Layout tab.
Determine the layout of each report using the different settings proposed for the header, font, format, field styles, and
colors.

Persons Report (By name or Alphabetical) - Layout
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Font

For each edited state, select a font and character size.

Header

Each page of each state reproduces a header where you post:

A personal text entered in the header area
The total number of items on the report
The date of the report edition
The name of the genealogical file
The number on the page.

Margins and Page

You can change several elements of the page format:
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The margins of the document.
The printing of the grid. Check Print grid to frame the areas assigned to the different types of information in the cards
or separate each of the persons listed.
The layout. Click the Print Setup button to select a printer, choose the orientation of the paper (portrait or landscape),
choose the size of the paper. The paper sizes suggested depend on the type of printer you have selected.

Field Styles

You can choose for each person displayed in the requested document, different layout options.
Click on the drop-down menus and find out all the statement possibilities that are available to you for:

Given names

All Given names
Only the first given name
Only the usual given name (in the absence of a common declared given name, Heredis will take the first given name)
The first given name followed by the initials of others.

Check the option include nickname if necessary.

The name order

Different possibilities are proposed to place the surname, particle and given names. Check the option include suffix and 
include prefix if necessary.

Dates

Digit separated by a point (with or without the display of 0)
Digit separated by a slash (with or without the display of 0)
Month in letters (in full or abbreviated)
Month in letters and the day of the week (whole or abbreviated)
Only the year.
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In each of these cases you can check the Dates option in the Gregorian calendar to view and print the dates in Gregorian
format regardless of the calendar in which they were entered.
The Show Headings option precedes each date by the symbol corresponding to the type of event: ° for Birth, b for Baptism, x
for Marriage, xR for Religious Marriage, xP for Other Union, mc for Marriage Contract, † for Death, (†) for Burial.

The places

Name of the city only
Name of the city and postal code
Name of the city, postal code and subdivision of the place if there is one
Full place name.

                                414 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Sources (for some documents such as Biography)

either they are ignored,
or Heredis indicates the names of each of the associated sources,
or Heredis details the description of each of the associated sources,
or Heredis takes up the entirety of each of the associated sources, including the text of the deeds.

Private data

If you exclude private data, notes, events, sources, media for which the Private box was checked at the time of entry will not
be printed in the requested document.

Colors

Differentiate each of the important elements of the edited state by assigning it a color. Select it from the drop-down menu.
Items differ depending on the type of report requested.
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Click OK to validate the creation of the document in .rtf format.

Note: This format opens with any word-processing software. Make sure you have a default software for files with the .rtf
extension. Check out the Windows user manual or online tutorials to learn more.

Create a report of persons or events from Smart Search.

It is also possible to edit the result of a selection obtained with Smart Search as a report.

Search for one or more criteria from the Search > Smart SearchTab. Check out Smart Search article for more details.

Click the Edit button in the processing selected persons area.
Select the type of report of Persons or Events based on the tab selected in the search results.
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Exporting documents

The various documents, reports or sheets, are exportable in text format (.txt).
Click the Export button to create a .txt document or click on OK to create a .rtf document. Give the new document a name and
specify its location before registering it.
Then open this document in any type of adapted software: word processing, spreadsheet...
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(Windows) Customize your Reports

This function existed prior to Custom Reports included since Heredis 2019. See also the new custom reports article.

All documents you view and print with Heredis are open in your word processing. This way of operating puts you in a familiar
environment, facilitates the manipulations you want to perform, allows you to completely reshape the presentation of the data
and to record, if you wish, the documents displayed as independent files.
If no word processing is up and running on your computer, you can download free word processing, such as LibreOffice.

Create a custom report

You can compose several types of custom reports: Persons, Ancestors or Descendants.

Click on the Reports menu to access the various editions offered by Heredis. Choose the type of list (Ancestors,
Descendants, Persons) and then click Custom Report...
All selected settings will be memorized and offered by default when you'll next open the same type of report.

All Ancestors or Descendants custom reports will be built from the primary person displayed.

Choose list settings for Contents and Layout in tabs of the same name.

Contents tab
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Layout tab
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Click the Modify button to change the default report or create your own report.

To build a custom report, you have the following:

Columns: You can build your report with as many columns as you like, assign them a width, a title, and include the
fields you want in each column. It is possible to insert or remove columns.
Fields: Most of the fields in the Data> Personal Data screen are usable, as well as certain calculated fields (age at
death, number of children, etc.).
The layout of the columns: Each of the fields you put on the report can be shaped (attributes, alignment, etc.).
You can also assign a suffix and a prefix to each selected field.
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When you first open a custom report, Heredis displays a default report that you can use as is or change.

Custom reports as you have drawn them can be saved and recalled for future use. For example, you can create several themes
for each type of reports (persons, ancestors, descendants).
The custom report offered by clicking on the New Report button is fully composed by you.

Columns

Add columns

The lower area of the window allows the columns to be displayed. It represents the useful width of the page. The columns are
divided between the two margins in the same proportions as on the screen regardless of the print format chosen (portrait or
landscape).
You can create up to 32 columns within the space available for printing.

Click the Add button in the Column area to create the number of columns you need for the report to build.
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Swap columns

Click in the column to move.
Click the Left arrow or Right arrow button until the column has reached the desired location.

Delete a column

Click in the column to select it.
Click the Delete button in the Columnarea.

Give a column a title

Click in the column to select it.
Type in the title chosen for the selected column in the Title input area.
Include the alignment chosen for the column title by checking the Left, Centered or Right boxes.
Also indicate the alignment chosen for the contents that will be contained in this column.

Change the width of the columns

Position the mouse on the right edge of the column you want to enlarge or reduce.

The cursor then turns into a double  arrow.
Hold the left button on the mouse.
Move the right edge of the column to reach the desired width.

Fields

Position the fields in the columns
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Depending on the type of information to be placed in the column, click on one of the tabs containing the data for the person,
his/her father, his/her mother, his/her unions, or the calculated data.

Choose on the list of fields on the one you want to set up and click on it.
Click the Add button in the Field area to fit into the selected column.
or Double-click on the name of the field in the list to fit into the selected column.
Include for the added field any formatting attributes to apply to it by checking the Bold, Italic or Underline boxes.

The fields will be presented side by side in the edited document unless you have inserted a line break.
To spread the fields across different lines in the same column:

Select the field.
Click the Line Skip button.

The total number of fields and line breaks is limited to 32 per column. For delete and move options, line breaks should be
treated as fields.
To switch the order of fields on the same line or within a column:

Select the field to move.
Click the Up or Down Arrow button until the field has reached its new location.

Delete a field in a column

Select the field to remove.
Click the Delete button in the Field area.

Add a suffix or prefix to a field

Select the field to edit in the column.
Click in the Prefix area and then type in the prefix to be applied to this field.
Position yourself in the Suffix area and then type the suffix to apply to this field.

For example, to indicate the age at death of a person:

Select Ageat Death in the column.
Click in the Prefixbox, type "at the age of".
Click in the Suffix box, type the word "years."

You will thus get the mention: at the age of < age at the death > years.

Create a Custom Persons Report from Smart Search.
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It is also possible to edit the result of a selection obtained with Smart Search as a personalized list.

Search for one or more criteria from the Search > Smart SearchTab. Check out Smart Search article for more details.

Click the Edit button in the results processing area.
Select Custom Persons Report.

Save a Custom Report layout

Change an existing report

Each time the same custom report (persons, ancestors or descendants) changes to the construction of the reports, it is
memorized.
To create a custom report theme with the layout you've set:

Click the Save button.
Name the custom list theme you're creating. He'll wear a .hp18 extension.
Heredis records this theme in the Documents folder - BSD Concept - Heredis - Heredis Custom Reports.
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This theme can then be called and used in any type of custom report.

Create a new custom report

To create a new blank list theme:

Click the New Report button to access a new blank list, to be completed with the desired fields and columns. The
number of columns proposed by default is 4.

Open a custom report theme already registered

To recall all the custom report themes you've created:

Click the Open button.
Select the existing theme to reuse. Custom report themes have a .hp18 extension.

This theme will appear on the screen for use or modification and will be the list theme that will open by default when the next
request of the same type of list is set.

Launch the edition of the custom report

Click the OK button to validate the layout of the built list.
Click the Cancel button to return to the setting screen without changing the custom report theme used.
Click the OK button on the setting screen to launch the text processor that will display the custom report.
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Export the contents of a custom report

Click the Export button in the setting screen to export the data in the custom report to Plain Text Files (.txt).

This data can then be used in a database, spreadsheet or word processor.

Exporting documents

The various documents, lists or sheets, are exportable in text format (.txt).
Click the Export button to create a .txt document or click on OK to create a .rtf document. Give the new document a name and
specify its location before registering it.

Then open this document in any type of adapted software: word processing, spreadsheet...
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Then once open with your word processing software or text reader software you can save, modify ... the document becomes
independant of Heredis.
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Custom Reports

Starting with Heredis 2019, this feature offers various reports models that can be fully customized according to your needs.

Click on the menu (Windows) Reports > Custom Reports; (Mac) Documents > Custom Reports and select the type of
report you are interested in among the default models included in the application: Ancestors, Descendants, Persons, Events,

Places, Sources. You can also use the shortcut in the toolbar.

The selected report opens up in a new Heredis window, which allows you to consult the data in your file while continuing to
work on your genealogy.

Note: you can also open several custom reports at the same time if you wish to.

Ancestors Custom Report

The data thus displayed depends on the type of default report selected:

Persons Reports allow you to display all the persons in your genealogy
Ancestors Reports display the primary person and his/her ancestors, grouped by generation
Descendants Reports display the primary person and his/her descendants, grouped by generation
Events Reports allow you to display all the events saved in your genealogy

And, starting with Heredis 2020:
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Places Reports display all the places saved in your genealogy
Sources Reports allow you to view each and every source in your genealogy.

Each report includes the following elements:

a toolbar
a data table
a status bar

Starting with Heredis 2020, in each report, you can click on a person’s name and navigate onto this person in Heredis.

The Toolbar

Add Button

Select the information you want to add to your report by clicking on the different sections available (Personal Data, Media, ...)
You can select one or more fields among those suggested. If you click the OK button, additional columns are automatically
added to your report to let you view the data you deem relevant and important.

Note: You can also group multiple fields into a single column. Select the desired fields and check the “Group in a single
column” box. Validate your selection and do the same thing again for each column in which you want to group several fields.
For instance, “Birth Date” and “Place of Birth”.

 Options Button

Based on the type of report, you are given several options, grouping, and filters to refine the displayed report.

– Persons Report:
This report is built based on all the persons saved in your genealogy. If you wish to display or hide marked, secondary,
confidential, contemporary persons or private data, check or uncheck the corresponding boxes.
Heredis is defaulted not to apply any grouping of persons in this report but you can set up your own display of data: classify by
Name or Birth.
You can also choose to display Males or Women Only, and to list Direct-line Ancestors only.
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– Ancestors Report:
This report is built based on the primary person displayed on the navigation screen.
If you wish to display or hide marked, secondary, confidential, contemporary persons or private data, check or uncheck the
corresponding boxes.
Heredis is defaulted to supply a complete list of your ancestors over 10 generations in this report but you can modify these
options to display a report by Male Ancestors (agnatic) or Female Ancestors (cognatic). You can also increase or decrease the
Number of Generations to be displayed.

– Descendants Report:
This report is built based on the primary person displayed on the navigation screen.
If you wish to display or hide marked, secondary, confidential, contemporary persons or private data, check or uncheck the
corresponding boxes.
Heredis is defaulted to supply a complete list of your descendants over 10 generations in this report but you can modify these
options to display a report showing Name Holders Only. You can also increase or decrease the Number of Generations to be
displayed and choose the type of Numbering Method to display in your custom report (d’Aboville or Lettered).

– Events Report:
This report is built based on all the events saved in your genealogy.
If you wish to display or hide marked, secondary, confidential, contemporary persons or private data, check or uncheck the
corresponding boxes.
Heredis is defaulted not to apply any grouping of events in this report but you can create your own way of displaying data:
classify by Dates, Persons, Type of events, or Places.
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– Places Report:
This report is built based on all the places saved in your genealogy.
You can choose to limit to a city, a state...

– Sources Report:
This report is built based on all the sources saved in your genealogy.
You can change options to display private sources only, used only...

Layout Button

You are given layout options for the following:

Surnames, Given Names, Dates
Font size displayed in the report
Colors for males, females, direct-line ancestors, and implexes – since Heredis 2020. (Colors are displayed on the screen
but cannot be exported to .xlsx and .csv formats.)
Major events
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Save Button

Click the Save button and name your report so it is saved with your custom options and preferences.

Find it again later in the menu (Windows) Reports > Custom Reports; (Mac) Documents > Custom Reports, right
underneath the default model supplied by Heredis.

Starting with Heredis 2020, you can manage your custom reports models. Please refer to the paragraph below for more details.

 

Delete Button

From the menu: (Windows) Reports > Custom Reports; (Mac) Documents > Custom Reports, open the model you do not
wish to keep, click the Delete button, and confirm you want to delete the model. You can also delete from the model
management tool. Please refer to the paragraph below for more details.

 

Refresh Button

Custom reports open in an independent Heredis window so you can continue working on your file while leaving a custom
report open. If you make modifications or additions to your genealogy, all you need to do is click the Refresh button to update
the content of the report displayed.

 

CSV / XLSX Buttons

You can export the data from your report to a CSV or Excel format so you can use them later outside of the Heredis
environment. The file will become independent from Heredis and you will be able to work on the data from your usual
spreadsheet software.

Data Table

The various reports provide data presented in a multiple-column table ; content varies according to the type of model you
choose.
You can sort data by clicking on a column header. An arrow displayed next to the header title indicates the type of sorting that
has been applied: ascending, descending, or no sorting if no arrow is displayed.
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Note: some columns cannot be sorted; this is the case, for instance, of columns in which several types of data have been
aggregated. A message in red will inform you that the column cannot be sorted.

You can also

Reorganize the way data is displayed by moving columns, for example: click the header of a column and hold the click
down while moving the column to the desired location, then release the mouse click.
Delete a column: click on the 3 dots displayed on the column header and select the Delete option.
Modify the content of a column: click on the 3 dots displayed on the column header and select the Edit option. An Edit
Column window opens up, it allows you to:
– modify the column title
– add/modify/delete fields in this column
– add and customize column data separators to display between 2 column fields

Edit or Delete a Column

Organize data

Status Bar

In the status bar, Heredis shows the total number of pages for the report being displayed, as well as the range in which the
current page is located (the indicator is displayed in the bottom right). Easily navigate through the different pages of a report
by clicking on the First / Last Page, Previous Page / Next Page arrows. You can also move directly to a given page by
entering its number.

Custom Reports and Smart Search

Custom reports are also accessible directly from Smart Search.

From the Search tab > Smart Search, launch a search.
In the Results area, select the Persons or Events tab you are interested in.
In the Processing area, click the Edit button > (Mac) Custom Report / (Windows) Customizable Reports and select
the report model you want to use to display the results from your search.

Smart Search and Custom Report
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Manage your models

Starting with Heredis 2020, you can manage your custom reports models.

(Windows) Click on the Reports menu > Custom Reports > Manage my models… to open the model manager.

(Mac) Click on the Documents menu > Custom Reports > Manage my models… to open the model manager.

(Windows) Manage custom reports models
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(Mac) Manage custom reports models

Select the report model you wish to modify and click the  button to rename this report model or the  button to delete the
model.
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The Dynamic Ancestors Wheel

Starting with Heredis 2021, a new tab is now available: the Graphs tab.

There, you will find a wheel-shaped graph.

Click on the Graphs > Wheel tab or, if you have already added it to your toolbar, click on the icon . The wheel is built
around the primary person currently displayed on your other Heredis screens (Immediate Family, XXL Family, Personal
Data...)

Depending on the generation, the information displayed as well as its format will vary so it can fit in the box.

Navigate

You can navigate the wheel by changing the primary person. Right click on the person you want to place in the center of the
wheel and choose Move to Primary Person.

The wheel automatically recalculates the ancestors of the new primary person, who will also be displayed under the other tabs
(Family, Data, Search).

Double-click on a person's box to go directly to this person’s Personal Data screen.

Left click and hold your mouse button to move the wheel around on your screen. Click on the  button to re-center the wheel
on your screen.
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Right-clicking also allows you to view a person’s relatives. Clicking on one of the relatives’ name modifies the wheel by
placing this relative as the primary person.

To zoom in or out, you can use :

the scroll-wheel on your mouse,
the + and – buttons in the top left-hand corner of the wheel screen.

Set the wheel’s display format

A foldable Options panel is at your disposal in the top right-hand corner to set up the wheel’s parameters. To give yourself

more space when viewing the wheel, click on the cross  in the Options panel.

To re-open the Options panel, click on the hamburger  button.

The Options panels allows you to choose:

the Shape of the wheel. You may prefer to view the wheel at a different angle than the default one of 360 degrees.
Click on the graph icon that suits you best.

the Number of generations to be displayed. You may choose from 4 to 12 generations. The more generations you have
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selected, the longer it will take for Heredis to display the wheel.

Tip: The speed at which the wheel is displayed also depends on the power of your computer and the current use of your
computer's memory. Avoid using other programs simultaneously if you want the wheel to be displayed at a faster rate.

Coloring. You may choose to color the wheel by:
Generation. Each generation will have its own color.
Gender. Men and women will be highlighted in two different colors.
Quarter. Quarters start from the grandparents’ generation. The paternal grandfather’s and grandmother’s, the
maternal grandfather’s and grandmother’s quarters can each be highlighted in a different color.
Person declared as Complete. This coloring option gives you an opportunity to visualize the persons whose
conditions of completeness for major life events are met. See Customize Heredis > Completeness of data.
Marked Person. If you have marked persons based on one or more criteria, they can be assigned a different
color than those unmarked. E.g., if you want to identify all persons born in the same city. See The different data
fields > Flags and their use, and Smart Search for information on how to tag or “mark” persons.
None. No wheel coloring at all.

Depending on the selected color format, one or more sliders will appear so you can choose the color to be applied. Left-click
on the black slider and move it over the color bar to apply the desired color. Once you have chosen which color to apply,
release the left click. The color will then be applied to the wheel.

Coloring by quarter, color selection by grandparent
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You can choose whether to display empty boxes. To view a full wheel or simply to visualize the work left to do, check Display
empty boxes.

In genealogy, it is not uncommon to come across consanguineous marriages. These marriages involve the repetition of
branches, which is called an implex. You can view implexes by checking Show duplicate branches. The text inside the boxes
of the persons who appear more than once in the wheel is then switched to red. You can then right-click on one of the implex
boxes and choose Show all Occurrences to visualize all the boxes for this same person in the wheel. Heredis will highlight the
boxes so you can easily spot them.
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To stop highlighting occurrences, right-click again on one of the boxes and select Do not show all occurrences.

To go back to default settings (6 generations, coloring by generation, 360° wheel shape, hide empty boxes and implexes), click
on the Default parameters button.

Highlight a branch

Do you wish to highlight a branch so you can show your maternal family the section of the wheel that will be of interest to
them?

Right-click on the box of the person at the base of the branch you wish to view. Select Highlight the branch.
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Colors will be brighter and the branch will be shaded, thus highlighting it on the screen.
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Export for printing

The Dynamic Ancestors Wheel was designed as a printable document.

Click on the indented wheel  then click on Export to PDF format for printing.

A setup windows opens. In it, the wheel is previewed as it was set up in the Graphs tab.
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The wheel’s title is automatically generated using the primary person’s information.

Before exporting to PDF, set up your print format. The preview will show you the number of pages needed for printing based
on the chosen format.

Click on Hide Page Breaks to no longer see them.

Click on the Page Setup drop-down list to select your settings. If none of the suggested paper sizes suits your needs, select 
Customized. Then enter the desired width and height in cm.

Note: The PDF format allows you to create a document with a maximum size of 5 by 5 meters. If your wheel is larger and
your printer has a paper roll larger than 5x5 m, remember to “delete assembling link-up zone”. This way, when printing, the
document won’t show any breaks.

Change orientation from Landscape to Portrait if necessary.

The number of pages depends on the paper size you selected. Modifying the number of pages will decrease or increase the
print factor. If you decrease it too much, the data entered in your wheel may not be legible.

Tip: Before printing, make sure that your data is legible by opening the PDF file and setting the zoom to 100%. If you can’t
read what is inside the boxes located the furthest from the center of the wheel, do not start printing.

Once your parameters are set, click on the Export PDF button. Choose where to save the file on your computer and name it.
The file is now independent from Heredis and can be opened by anyone with a PDF reader software (Adobe reader...).
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XXL Family

Not only can you visualize the primary person’s family – parents, grandparents, great-grandparents, spouses, children – but
also all the relatives that might have been around him/her: you’ll get to display a true XXL view!

Persons displayed

Access the XXL Family by clicking on Family tab then XXL Family.

All persons are always displayed clearly distinguishing their affiliation or not to the main line. The primary person has a bigger
box, centered on your screen. Background colors of the boxes change according to the affiliation or not of the person to the
main line of the primary person. The other ones are usually grayed.

XXL Family View

Around the primary person, you will see, generation by generation:

In ascendance:
- His/her great-grandparents,
- His/her grandparents, their brothers and sisters (great-uncles and aunts of the primary person), their other spouses,
- His/her parents, their brothers and sisters (uncles and aunts of the primary person), their other spouses (father-in-law,
mother-in-law of the primary person).

Note: sometimes the siblings will not be displayed chronologically, unlike in other parts of the tree, because a parent’s
sibling(s) cannot be inserted between the two parents - otherwise the tree chart would not be legible.

In descendance:
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- His/her children, children from another union, his/her nephews and nieces,
- His/her grandchildren, those of his/her brothers and sisters, half-brothers and half-sisters and cousins

Since the 2019 version, his/her great grand children.

Note: You can also display the descendants of other spouses, grandparents and great-grandparents.

Concerning generation of the primary person:
- His/her spouses, brothers and sisters, half-brothers and half-sisters, stepbrothers and stepsisters, and cousins,

You can fold the left or right panels to gain more space and reveal the XXL Family.
If one of the ancestors of the primary person (from the generation of grand-parents) has had several spouses his/her box and
that of his/her spouses are marked by a colored band, except the one in direct-line of the primary person. For a question of
clarity of the tree, the other spouses are staggered. So you quickly see the direct ancestors of the primary person. 

The revealed tree includes persons you do not want to display? Click on the indented wheel  button to hide some persons:
the great-grandparents, relatives, children unrelated to the primary person’s bloodline, the descendants of cousins or
grandchildren.
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Available information

"Focus" or "unfocus" in this dynamic tree for more or less details for each displayed person. In order to do that, use the mouse
wheel, press the + or – button on your keyboard or click on the + and – buttons in the upper right corner of the window.

According to the focus level, Heredis display every person:
- his/her main media,
- his/her surnames and given names,
- his/her occupation,
- his/her birthdate, birthplace, deathdate and deathplace and age at the death,
- the icon indicating if the person is part of the Ahnentafel line.

If the displayed person is an additional spouse that you found, the information on the main union event will be displayed in the
banner at the bottom of the box.

Note: Heredis memorizes all your settings to allow you to display the XXL Family format that satisfies you the most.

Navigation

From XXL Family, a simple click on a displayed person allows you to put this person as the primary person or to navigate to
his/her relatives.
As everywhere in the software, you can also navigate from a person to another thanks to the Navigation panel or from the 
Person’s index by double-clicking on one of them.

If all family members are not shown on the screen, you can navigate in the tree by pressing and holding down the left mouse
button and by moving the cursor to the right or the left, up or down, then let go of the mouse button.

You can also move in that tree thanks to the preview displayed at the right bottom of the navigation thumbnail. Select the pink
frame with the left mouse button, by moving it, you navigate in the tree.
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Since 2019 version : Hide or display media and silhouettes

The XXL Family displays the main media for each person in the tree. You can decide to hide the media by clicking on the

indented wheel button , then Hide all media. If some persons are without a media, Heredis is defaulted to display a
silhouette instead. You can choose to hide them or to display them again at any time from the indented wheel by clicking on 
Display/Hide Silhouettes.

Since 2019 version : Adding spouses and children to the primary person

Heredis allows you to add spouses and children to the primary person directly from the XXL Family view. To do so, click on
the + sign located below the primary person’s box.
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The other actions in the contextual menu

When you click the right button on a person, you can also:

move to primary person
print his/her individual sheet.
define him/her as the Root person.
add him/her as a favorite in the bookmarks.
see his/her relatives
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To add membership at this family, click on the add button from the toolbar or directly in the tree, or click on the  button
displayed in this view, to complete the direct ascendance.

Export XXL Family

Your tree is ready. You hid the persons that you do not wish to show. You applied the focus level that convinces you in order
to display the information you believe are essential, export this tree so you can print it.

Click the indented wheel 
Choose to Hide the Navigation Panel
Click Export to PDF format for printing

A new window opens to preview your tree. You can access to the regular printing settings such as the pages’ display or the
recovery, the choosing printing format, orientation of pages or the possibility to change the height and width of the pages.

Choose the Page Setup and orientation of the paper
Activate or not the assembling link-up zone. The assembling link-up zone allows you to make the assembly by leaving
a white area on the beginning and end of the page.
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Finally, click on the PDF file button, and you can save the file at PDF format to print it from home or with a professional’s.

Important: Note that you can generate customized size, but be carefull, PDF format allows only 200? x 200?. If your XXL
Family is bigger and your printer can print on a paper roll, then click on the assembling button to delete assembling link-up
zone. (it is desable when you see Use assembling link-up zone)
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Location Tree

Under the Ancestors dynamic view, Heredis will automatically color code the banner of each box in the family tree, based on
the place of birth of the persons displayed.
Heredis will also let you see the criteria on which the color coding is based, that is either the persons’ City, County,
State/Region, or Country of birth.

How to display the Location Tree

Standard Ancestors Tree Chart

• Click on the Family tab > Ancestors, then on the indented wheel .
• You can now select Location Tree. Heredis is defaulted to color code each banner based on each person’s City of birth but
you can, if you wish to, switch to another option such as County, State/Region, or Country of birth by clicking on the

indented wheel  in the upper right corner of the screen and selecting > Location Tree.

The New Location Tree
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Note: When no data has been entered for the person’s place of birth, his/her banner is displayed on a white background.

You can choose to increase or decrease the number of generations displayed in this Location Tree by clicking on the wheel 

and selecting the desired option.

Printing the Location Tree

You can also choose to print the Location Tree by clicking again on the indented wheel  and then on Print.

(Mac only) The printing format will depend on the size of your screen.

The Print window of your operating system pops up.

(Windows) Print window

                                453 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

(Mac) Print window
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Export to PDF

(Windows) If you wish to export to PDF, instead of choosing your printer, select Print-to-PDF or any other PDF add-on
installed on your computer.

(Windows) Export to PDF
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(Mac) Click the PDF button in the lower left corner of the Print window then select Save as PDF.

(Mac) Export to PDF
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(Windows) Unlimited size tree chart : ancestors, descendant and hourglass

You can create as many graphical representations of your genealogy as you wish. A tree chart may be saved with the data it
contains and its layout. It can then be reopened, modified in its presentation, printed again. It has become independent of the
Heredis data file.

Choose from the different types of tree charts proposed in the Charts menu or click Charts on the toolbar to visually
select the tree charts proposed by Heredis.

Edit a tree chart

The printing of a tree chart takes as its starting point the primary person displayed and will display his/her ancestors,
descendants or both as an hourglass tree chart.

Choice of tree chart

In the Charts menu or in the displayed selection screen, choose the type of tree to build from the list to the right.

Choose a tree chart

Heredis proposes various types of tree charts of unlimited size. Whatever the type of tree chart selected, you can print it or
have it printed over several pages or a single long strip of paper.

When a tree exceeds the size of your printer, each page is printed with an overlap to facilitate mounting of the chart.

Choice of theme

Choose a theme
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Click a theme in the viewer. To facilitate your choice, Heredis displays an overall preview of the tree to be edited with this
theme or a preview of a box. Scroll through the different themes by pressing the arrow keys or with the mouse. The last used
themes are preset for each type of tree chart. After testing the different themes of tree charts, you may define your favorite

themes. Click the Add to Favorite 
 button and the theme is marked with a heart icon that allows it to be recognized.

Info • You have a search filter for favorite themes. Thus, you can display only the themes that you commonly use.

Chart Settings

Specify the construction parameters that suit you for the selected theme: number of generations, people to be displayed or not
on the tree chart.

1. Indicate the number of generations. It is unlimited for ancestors as well as descendants.

Unlimited Chart
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2. Choose the orientation of the tree chart, building from bottom to top, from left to right or from right to left.

Choose Orientation & Layout

3. Choose a method for automatic construction according to the space you want to allocate to the tree chart.
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• The Default tree chart is built with all boxes of the same size, that is to say that the box of the central character has the same
size as that of persons shown in the third generation or 10th generation. In this tree chart, generations will be located one above
the other without overlapping.

• In the Optimized tree chart, boxes gradually decrease in size with the higher generations and they slightly overlap.

• In the Minimized tree chart, the boxes will diminish in size and content and their position can be rotated at the end of the
branch to save even more room.

4. Select the persons for inclusion on the tree chart. By default all persons appearing in the ancestry or descent of the primary
person are displayed on the tree chart. You may untick secondary persons, or marked and confidential persons, for them not to
be displayed on the tree chart. You may also hide all the data you have declared to be private (events, pictures, etc.).

Click OK to start the construction of the tree chart according to the theme selected and with the chosen parameters.

Tree Chart Screen

Heredis displays a tree chart representing the lineage of the primary person and which is printable immediately. If you want to
make changes to the tree chart, you have tools in the specific Tools panels of the various tree charts.

Toolbars and menus

When the tree chart is displayed, the menus and buttons are different from those for data management. You may use the

buttons for normal actions:  Save,  Pages, Add,  Layout,  Print. Display only the buttons you use
most often by choosing Windows > Customize Toolbar.

Use the tree chart menus to manage also the layout of the screen or the selection of people on the tree chart.
Info • You can open another previously saved tree chart while the tree chart is already open on the screen choose File > Open.

Persons displayed in the tree chart

The Search panel of the tree chart contains a list of all persons included in the chart. Clicking a person in the list previews that
person’s box in the tree chart. A double click navigates through the tree, if its size exceeds that of the screen, to display the
box for a selected person.

To quickly find a person in the list of individuals on the tree chart, enter the surname or given name. Refine the search by
selecting from the drop-down menu, the gender of the person sought if the name is multiple.

When there are marriages between blood relations (implex) on your tree chart, certain ancestors may be included more than
once. By default, Heredis will only display one complete branch and duplicate branches are cut off. If you want to repeat the
implex branches, tick the option in the settings screen of the tree chart prior to construction.

Click the name of the ancestor in the Search panel and Heredis displays the various positions of the person in the tree chart.
Click on the first position to see the entire branch displayed. The different boxes for the ancestor have identical lettering.

Info • In Search panel of the tree chart, click the name of a person in the list, his/her summary appears in the Summary panel.

Preview of the selected box

The Tools panels displays the selected box. At the opening of the tree chart, Heredis displays a complete view of the
document, whatever its size. The preview is very useful in large tree charts, when the content of the boxes is not readable on
the screen. This visualization immediately displays any changes that you apply to the box.
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Tree chart formatting

You may modify the unlimited tree charts to give them a more personal graphical appearance. In the fixed size tree charts, the
changes apply only to the content of the boxes. The overall environment is not editable.

The different Tools panels allow either changes to be applied to the whole tree chart or changes to a given selection (one or
more boxes).

Display screen

The central area of the screen shows all the boxes of the tree chart, the title of the tree and any images that you have added.

To help you check and estimate the size of your tree chart, materialize the pages on the screen.

In the toolbar, click Pages > Show/Hide Page Breaks 
 or in the menu choose Display> Show/Hide Page Breaks.

The number of pages depends on the chosen page format for your printer. To change the format and page orientation in your
printer, click the Page Setup button in the Print panel.

To move around the tree chart, use the horizontal and vertical bars, or change the zoom factor or double-click the name of a
person from the Persons panel to display his/her box directly.

Zoom

You can increase (zoom in) or reduce (zoom out) the display of the tree chart. It is often necessary to reduce the display of a
tree chart to visualize all required generations. Choose Display > Zoom > Increase Magnification or Decrease
Magnification. To return to the actual size of the tree, choose Display > Zoom > 100 %.

You may also select different levels of zoom on the bottom bar of the tree chart screen.

• Click the arrow and select a value from the drop-down menu or use the slider to change the zoom level. Heredis indicates the
factor used to reduce or enlarge to the left of the bar.

• Click the 100% button to return to the real size of the tree.

• Hold down the Alt key. With a left click, the tree chart grows, with a right click, the tree chart is reduced. You may also use
the mouse wheel up or down to enlarge or reduce.
Info • Remember to fold back the Search and/or Tools panels to have the maximum available space for display of the tree
chart.

Selection

Before making changes to a tree chart, first select the boxes to which they will apply. Depending on the type of change to be
made, make individual selections or selections of a genealogical order.

• To select all boxes of the tree chart, choose Select > Select All. From anywhere in the tree chart, you can right-click the
mouse and choose Select All.

• To select one or more boxes of the tree chart, drag the mouse cursor over the boxes to be selected.

• To select more boxes that are not contiguous, select the first box, and then, holding down the Shift key, the additional box or
boxes To make genealogical selections from any box in the tree, right-click the mouse and choose Select Men Only (or 
Women Only, or Person and All Ancestors, or Person and All Descendants or Generation).

                                461 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Info • Persons corresponding to the selected boxes are also selected in the Search panels.

Format the tree chart

To make changes, use the tools in the tree chart Tools panels. To go further in the formatting of the boxes, make your changes
in the Layout panel.

Layout Panel
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Modify the contents of selected boxes

• Choose the content formats that suit you for surnames, given names, dates, places and genealogical headings from the drop-
down menus.

• Tick the Show Ahn./User Number and Show Preferred Picture boxes to add this information, if it exists, in the selected
boxes.

Change the text formatting

Without delay, change the font, size, color and text alignment with the drop-down menu, the cursor and the buttons of the 
Layout panel.
Info • Do not forget that you can make a selection of all men in the tree chart, then all women, to apply different text colors.
For this, use the Select menu or right-click of the mouse.

Hourglass Chart

Change the layout of the tree

1. In the Layout panel, change the spacing between boxes or the spacing between generations by clicking the arrow buttons.

2. Tick the Display Empty Lines box for all boxes to be filled with the same number of lines, even if you do not have
information.

3. Click the Pages > Center Tree Chart button to reposition it optimally after modifications.
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Move elements in the tree chart. After selecting boxes, several methods for moving them are available. Choose the one that
suits you best

• Mouse: Drag the selection to its destination by holding the mouse button pressed.
Info • Hold down the Shift key to prevent any movement off the generation axis. Each box moved will remain aligned with the
other boxes in the same generation.
• Arrow keys: press the arrow keys to move to the position you wish to select.

To cancel the moving of the selection, press Ctrl-Z or choose Edit > Undo. To restore the move, press Shift-Ctrl-Z or choose
Edit > Redo.

Change the design of the tree chart

Change the graphical appearance of your tree charts with a few clicks. Some graphical changes apply to the whole tree chart,
others apply only to the boxes you selected.

1. Select the boxes to be modified or choose Select > Select All.

2. In the Layout panel, change the overall font, size, alignment and text color.

3. The display of boxes on the tree chart is defined by three elements: box styles, content types and connecting line styles. The
different themes that come with Heredis contain several presets for each of these elements. They are available in the Tools >
Layout panel of the tree chart.

Choose a preset to be applied to the selected boxes in the dropdown menus A preview screen shows you the appearance
of available presets.

You can change each preset of box styles, contents or connecting lines. Click the Layout button in the toolbar, use the
right-click menu on the selected box, or click the Edit... box shown as a pencil to the right of each menu to access all
the changes.

Info • By clicking on the pencil, you open the setup screen of the preset. To change the presets of box style, contents and
connecting lines at the same time, click the Layout button.

The box preview contains a tick box in the top left of the preset edit screen, for applying a modification to the males
and females simultaneously.

Change the box style
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Change the Box style preset displayed or choose a different preset from the Box Styles drop-down menu to form a base for
your custom formatting.

1. Click the border of the box to change border, shading, box background, orientation and size of the box including padding.

2. Click on an item, eg. name, to access the formatting of this item. When a line contains two distinct elements, they may be
changed independently of one another, for example Surname – Given Name or Date - Place.

3. Click on the picture to determine its size, its border and its eventual position in the box.
Info • One can only change the borders of the drawn boxes If you choose an image for the box background, the outline must
be included in the image.

All changes are immediately displayed in the preview of the box.

Info • To see better the changes made in the preview box, use the zoom slider at the bottom of the window or click the
magnifying glass icon and choose a zoom percentage.

Click OK to apply the changes to all selected boxes on the tree chart.

Modify the content
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Change the Content type preset displayed or choose a different preset from the drop-down menu as a base for your custom
formatting.

Click on each item displayed in the box to change the data formats. For example, click the name to indicate management of the
particle, whether to include the prefix and suffix of the name. Click on a date to indicate the desired format (long, short, in
numbers or letters, etc.).

Info • One can materialize the presence of a source for each event mentioned in the boxes. Select the date field and tick the
Mention source box to add the symbol (s) following the dates shown.

Click OK to apply the modified contents of the selected boxes on the tree chart.

Modify connecting lines

                                466 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Modify the Line style preset displayed or choose a different preset from the drop-down menu as a base for your custom
formatting.

1. Click the border of the box or on the connecting line to display the Line tab.

2. Choose the type of line to connect the selected boxes from the dropdown menu: right angles, rounded corners or curves.

3. Specify the width of the connecting line with the cursor and click the color box to choose a color.

Click OK to apply the modified lines to the selected boxes.

Edit the text of a box

                                467 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

1. Right click on the box to be edited and choose Edit Text to open the editing field.

Info • You can only edit one box at a time.

2. Enter changes to the displayed text.

3. Click OK to apply changes.

Edit the tree chart title

                                468 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

The tree chart title is a modifiable text zone.

Heredis proposes a title containing the name of the primary person. Double-click the title to open the text editor and make the
necessary content changes and formatting of the text.

Add a Picture

Select the Edit > Add Picture menu or click the Add 
 button on the toolbar to add a graphic illustration to your tree

chart.

The picture is added at the top left of the tree chart displayed

It is possible to add several pictures. If they must overlap, there are options for stacking images. Right-click the image
to move the selected image forward, backward or to the background if it is a background image for the tree chart.
Whatever option chosen, the boxes of the tree chart remain in the foreground
When the picture is enlarged or reduced manually with the mouse, it is possible to restore the proportion between the
picture and its frame by using the right-click Resize Image Proportionally option.
The right-click Resize Image to Fit Frame and Default Picture Size options allow to resize the image in its display
area.

The image is an object that can be formatted. Click the  button on the toolbar or select Modify Properties from
the right-click menu on the image. Only box style changes are possible As with the tree chart boxes, you have available
presets applicable to the surround of the image.

You can also consult our articles (Windows) Print or export as PDF a tree chart, (Windows) Save a tree chart.

                                469 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

                                470 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

(Windows) Save the tree chart

Save the tree charts created with Heredis. You may modify or print them later. The tree chart file can be reopened, changed
and saved, as a

Saving a tree chart for the first time

Click the Save button, choose File menu > Save.
In the File name field, change the name of the tree chart if necessary.
Choose the location where the tree chart should be saved, if you do not want to save it in the default folder.

Click Save

After saving your tree chart for the first time, click again the Save button to save it as you work.

Save a copy of the tree chart

This action allows you to keep the displayed tree to continue its formatting and to duplicate it to apply other different changes
or save it.

To obtain a copy of the tree chart and make further changes, select File menu > Save a Copy...

It doesn't open automatically the copy of the tree chart. You can keep working on the original tree chart.

Reopen a saved tree chart

To reopen a saved tree chart:

From the Heredis home page, click on Open a chart file.
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Choose the location in your Windows Explorer and click Open.

From your Heredis file, select the File menu > Open. Select the location of the tree file to open on your computer and
make sure you have selected the Charts Files type. Heredis allows tree opening saved from version 11. Select the file
you want to open. By default, Heredis saves the tree charts you created in the Documents/BSD
Concept/Heredis/Heredis Tree Charts folder. If the tree chart was saved in another folder, select it in Windows
Explorer.
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Click Open button.
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(Windows) Predetermined size tree charts : Single-page Chart, Designed Chart, Fan
Chart

You can create as many graphical representations of your genealogy. A tree chart may be saved with the data it contains and its
layout. It can then be reopened, modified in its presentation, printed again. It has become independent of the Heredis data file.

Choose the fan tree chart from the different types of tree charts proposed in the Charts menu or click Charts on the
toolbar to visually select the tree charts proposed by Heredis.

Choice of tree chart

In the Charts menu or in the displayed selection screen, choose the type of tree to build from the list to the right.

Choose a tree chart

Heredis proposes various types of predefined size tree charts (from A4 to A0 or Letter to Quad demy). Whatever the type of
tree chart selected, you can print it or have it printed over several pages or a single long strip of paper.

When a tree exceeds the size of your printer, each page is printed with an overlap to facilitate mounting of the chart.

Edit a tree chart

The printing of a tree chart takes as its starting point the primary person displayed and will display his/her ancestors.

Choice of theme

Theme of illustrated charts
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Click a theme in the viewer. To facilitate your choice, Heredis displays an overall preview of the tree to be edited with this
theme or a preview of a box. Scroll through the different themes by pressing the arrow keys or with the mouse. The last used
themes are preset for each type of tree chart. After testing the different themes of tree charts, you may define your favorite

themes. Click the Add to Favorite 
 button and the theme is marked with a heart icon that allows it to be recognized.

Info • You have a search filter for favorite themes. Thus, you can display only the themes that you commonly use.

Chart Settings

Specify the construction parameters that suit you for the selected theme: number of generations, people to be displayed or not
on the tree chart.

Click OK to start the display of the tree chart.

Fan tree chart
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Tree Chart Screen

Heredis displays a tree chart representing the lineage of the primary person and which is printable immediately. If you want to
make changes to the tree chart, you have tools in the specific Tools panel.

Toolbars and menus

When the tree chart is displayed, the menus and buttons are different from those for data management. You may use the

buttons for normal actions:  Save,  Pages,  Add,  Layout,  Print. Display only the buttons you use
most often by choosing Windows > Customize Toolbar.

Use the tree chart menus to manage also the layout of the screen or the selection of people on the tree chart.
Info • You can open another previously saved tree chart while the tree chart is already open on the screen choose File > Open.

Persons displayed in the tree chart

The Search panel of the tree chart contains a list of all persons included in the chart. Clicking a person in the list previews that
person’s box in the tree chart. A double click navigates through the tree, if its size exceeds that of the screen, to display the
box for a selected person.

To quickly find a person in the list of individuals on the tree chart, enter the surname or given name. Refine the search by
selecting from the drop-down menu, the gender of the person sought if the name is multiple.
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Info • In Search panel of the tree chart, click the name of a person in the list, his/her summary appears in the Summary panel.

Preview of the selected box

The Tools panels displays the selected box. At the opening of the tree chart, Heredis displays a complete view of the
document, whatever its size. The preview is very useful in large tree charts, when the content of the boxes is not readable on
the screen.

Tree chart formatting

You may modify the content of the boxes. The overall environment is not editable.

The different Tools panels allow either changes to be applied to the whole tree chart or changes to a given selection (one or
more boxes).

Display screen

The central area of the screen shows all the boxes of the fan tree chart, the title of the tree and any images that you have added
in the background.

To help you check and estimate the size of your tree chart, materialize the pages on the screen.

In the toolbar, click  Pages > Show/Hide Page Breaks 
 or in the menu choose Display> Show/Hide Page Breaks.

The number of pages depends on the chosen page format for your printer. To change the format and page orientation in your

printer, click the  button in the Print panel.

To move around the tree chart, use the horizontal and vertical bars, or change the zoom factor or double-click the name of a
person from the Persons panel to display his/her box directly.

Zoom

You can increase (zoom in) or reduce (zoom out) the display of the tree chart. It is often necessary to reduce the display of a
tree chart to visualize all required generations. Choose Display > Zoom > Increase Magnification or Decrease
Magnification. To return to the actual size of the tree, choose Display > Zoom > 100 %.

You may also select different levels of zoom on the bottom bar of the tree chart screen.

• Click the arrow and select a value from the drop-down menu or use the slider to change the zoom level. Heredis indicates the
factor used to reduce or enlarge to the left of the bar.
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• Click the 100% button to return to the real size of the tree.

• Hold down the Alt key. With a left click, the tree chart grows, with a right click, the tree chart is reduced. You may also use
the mouse wheel up or down to enlarge or reduce.
Info • Remember to fold back the Search and/or Tools panels to have the maximum available space for display of the tree
chart.

Selection

Before making changes to a tree chart, first select the boxes to which they will apply. Depending on the type of change to be
made, make individual selections or selections of a genealogical order.
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• To select all boxes of the tree chart, choose Select > Select All. From anywhere in the tree chart, you can right-click the
mouse and choose Select All.

• To select one or more boxes of the tree chart, drag the mouse cursor over the boxes to be selected.

• To select more boxes that are not contiguous, select the first box, and then, holding down the Shift key, the additional box or
boxes To make genealogical selections from any box in the tree, right-click the mouse and choose Select Men Only (or 
Women Only, or Person and All Ancestors, or Person and All Descendants or Generation).

Info • Persons corresponding to the selected boxes are also selected in the Search panels.

Format the tree chart

To make changes, use the tools in the tree chart Tools panels. To go further in the formatting of the boxes, make your changes
in the Layout panel.

Layout Panel
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Fan tree chart layout panel
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The changes apply to the selected boxes. The formatting of the text is customizable, but the visual environment cannot be
changed.

Modify the contents of selected boxes
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• Choose the content formats that suit you for surnames, given names, dates, places and genealogical headings from the drop-
down menus.

• Tick the Show Ahn./User Number to add this information, if it exists, in the selected boxes.

Change the text formatting

Without delay, change the font, size, color and text alignment with the drop-down menu, the cursor and the buttons of the 
Layout panel.

Info • Do not forget that you can make a selection of all men in the tree chart, then all women, to apply different text colors.
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For this, use the Select menu or right-click of the mouse.

Modify the fan tree charts

The fan tree charts offers the particular feature allowing the number of generations to be displayed (from 4 to 12), varied
graphic charts and formatting according to the generations, the quarters of ancestry or the gender of persons, as well as
limitations on the individuals to be displayed.

1. Select the fan theme from the Templates drop-down menu.

2. Choose the number of generations and the angle. The angle may vary between 180° and 300°.

3. Choose the color base for the theme.

• Click the By Quarters box to materialize the quarters of ancestry. If the By Quarters option is ticked, the number of
Quarters to differentiate in the tree is editable. This number can range from 4 (for a 180 ° angle) to 16. To change this, move
the cursor.

• Click the Males/Females box to distinguish the box color by gender.

• Click the By Generations box to apply a different color to each generation.

• Tick the Gradient Fill box to spread the colors at start and at end that you have selected throughout the fan chart. If the 
Gradient Fill box is not ticked, click on each zone of the fan chart to select the color to be applied to it.
Info • When you have made personal changes to a template, the formatting is saved until the next personal change you may
make to the fan chart. You may test the different models but also return to Latest Layout in the Template drop-down menu.

4. Format the contents of the boxes of the tree chart.

• Change the data format (names, dates, places) with the drop-down menus.

• Display boxes containing more or less information by selecting 4 lines or 6 lines in each box of the tree chart.

• Change the text formatting depending on the type of data (males, females, other text). Click OK to display the fan chart
according to your determined layout.

Edit the tree chart title

The tree chart title is a modifiable text zone.

Heredis proposes a title containing the name of the primary person. Double-click the title to open the text editor and make the
necessary content changes and formatting of the text.

Add a Picture
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Select the Edit > Add Picture menu or click the Add 
 button on the toolbar to add a graphic illustration to your tree

chart.

The picture is added at the top left of the tree chart displayed

It is possible to add several pictures. If they must overlap, there are options for stacking images. Right-click the image
to move the selected image forward, backward or to the background if it is a background image for the tree chart.
Whatever option chosen, the boxes of the tree chart remain in the foreground
When the picture is enlarged or reduced manually with the mouse, it is possible to restore the proportion between the
picture and its frame by using the right-click Resize Image Proportionally option.
The right-click Resize Image to Fit Frame and Default Picture Size options allow to resize the image in its display
area.

The image is an object that can be formatted. Click the  button on the toolbar or select Modify Properties from
the right-click menu on the image. Only box style changes are possible As with the tree chart boxes, you have available
presets applicable to the surround of the image.

You can also consult our articles (Windows) Print a tree chart, (Windows) Save a tree chart.
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(Windows) Print or export as PDF the tree chart

You can create as many graphical representations of your genealogy as you wish. A tree chart may be saved with the data it
contains and its layout. It can then be reopened, modified in its presentation, printed again. It has become independent of the
Heredis data file.

Choose from the different types of tree charts proposed in the Charts menu or click Charts on the toolbar to visually
select the tree charts proposed by Heredis. The tree chart will be created from the primary person.

Printing mode

First, choose between Local Printer or PDF File in the Print Setup panel.

Then, you'll be able to setup the page setup as you wish.

Adjust the size of a tree chart.

Before printing, you must make sure that the size and orientation of the paper are set as you wish. This setup will be different if
you chose Local Printer or PDF file.

Paper size

After choosing the print mode and before printing the tree, indicate the paper size your printer uses (A4 – A3…) and the
orientation of the paper you want (portrait, landscape).

Choose File > Page Setup or click Page setup  in the Print Setup panel.
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A window opens and may be different according to your printer. Choose the orientation and paper size.

Select the printer you will use in the Name menu.
Choose a standard paper size in the corresponding menu.  In PDF file Mode, if you want to select a customized paper
size, choose Personalized Paper Size in the drop-down menu.
Click the round button corresponding to the desired orientation.
Click OK to confirm the print size.

Note: If you want to print through a professional printer, export to PDF. The PDF format can go up to 200" x 200" , if your
tree is larger and your printer has rolls larger than 200", consider removing the assembling link-up zone (see PDF Export part
of this article).

If the tree is too large, you may change its size by reducing the number of pages in the Print Setup panel, but make sure to be
able to still read what will be print (click on 100% focus button to see if you can read on your screen).

Select Display > Show/Hide Page Breaks or click the Pages > Show/ Hide Page Breaks  button Heredis
displays how many pages corresponding to the selected paper size will be needed to print the tree chart.
Change the number of pages in width and/or height.
To enlarge or reduce the overall size of the tree chart, enter a percentage in the Scale field or move the cursor. A value
below 100% reduces the size of the tree chart, a value greater than 100% enlarges it.

It only remains to launch the printing of the tree chart.

Launching the print-out

Depending on the printer you are using, you can print the tree on one page or series of pages to be assembled together.

Click the Print  button on the toolbar or choose File > Print.
Select the printer you want to use from the list of available printers. If your printer does not appear, select Find Printer
in the Windows Print screen.
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Info • For more information on adding a printer, type Add Printer in Windows Help.

Click OK to start printing.

Export a PDF tree chart

Export the displayed tree to get it printed by a professional or share your Heredis trees with people who do not have the
software. Heredis constructs a tree chart using a file format that is likely to be used on other computers or devices in the form
of a readable file.

Choose Edit > PDF File Mode or choose PDF File from the Print Setup drop-down menu.

The Print button changes form and name. Click the Export  button on the toolbar.
Before to export the tree chart, make sure to setup the paper size format and orientation. Click on Page Setup button in 
Print Setup panel.

Choose the location where the tree file in PDF format will be saved, if you do not want to save it in the default folder. If
necessary, change the name of the tree proposed by Heredis in the File Name field.

Important: Note that you can generate customized size, but be carefull, PDF format allows only 200? x 200?. If your XXL
Family is bigger and your printer can print on a paper roll, then click on the indented wheel near the PDF file mode (or
assembling link-up zone of the new charts as the XXL Family for example) and chose Delete assembling link-up zone.

Click Save.
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Heredis Online

Heredis includes the creation of a personal online website for displaying your genealogy. No need to use a service provider,
your data is hosted for free on Heredis Online. You have a real website dedicated to your genealogy, searchable by your
family, friends and other genealogists, who will all have an overview of who your ancestors were, places where they lived and
the various documents that you have found concerning them. In addition, Heredis allows you to be contacted by any person
who is interested in your genealogy.

Manage your Heredis Online account

Heredis Online is a free online service that allows you to search millions of Heredis Online data from your Heredis software
(using Search Wizard). You can publish for free and get a website out of your Family Tree file. You can manage your account
and define the parameters for your publications...

If you bought Heredis from Heredis' Shop, you already have an account. Connect to with the ID/password used on Heredis'
Shop. Once connected, you can manage your Heredis account from Heredis.

Heredis Online

Heredis Online Connection page
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Create a Heredis Online account

If you bought Heredis from Heredis' Shop, you already have an account. Connect to with the ID/password used on Heredis'
Shop. If your email address changed, DO NOT create an other account, go to shop.heredis.com and connect with your old
ID/password and change your email address in My personal information section or contact us if you don't remember your
password and have no more access to your old email address.

If you didn't buy Heredis on Heredis' Shop, you must create a Heredis Online account before publishing your genealogy,
allowing you to access your account, to modify or delete published genealogies and to be identified as a person hosted by
Heredis Online.

1. Click the Heredis Online 
 button or choose File menu > Heredis Online > Manage My Account.

2. Click the Register button. Enter your email address, a username and a password. Please do not use special characters in your
password. Complete the identification data and check out the Heredis Online Terms of Service and then tick the box.

Create a Heredis online account
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3. Click OK, your account is created.

Managing account information

Log in by entering your username and password. Do not forget to tick the Remember me box for the data to be stored for

future use. Once connected to your Heredis account, the button will be  (2 blue leaves) instead of 
(a grey and a blue

leaf).
The Account Management screen allows you to change your login information and your address. Click the Edit or Change
password button to access it.

You can publish your file by clicking on  Publish button in Heredis. Once you have published genealogies, they will
appear in the lower part of the window. See Publish on Heredis Online for all details on publications.

Managing your publications
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Click on Manage my account . According to the version of Heredis you have, the color of the button can change.

Then click on the Visit Website link to view your online genealogy. You will see it as any other people. You can not make
changes online. To change data, launch Heredis' software and change the data, click on Publish to refresh your publication.

Click the indented wheel  icon to change your settings for publication. There is no need to republish in order to view notes
in your online genealogy, or to hide data which is less than 150 years’ old. Once you have changed the settings, they are
applied to your personal website.

Click on the  button to delete the genealogy from your personal website.

Info • You can carry out these operations remotely, even if you do not have your computer to hand, by connecting to your
Heredis Online account from any Internet browser.

See Publish on Heredis Online for all details on publications.

Publish a genealogy to Heredis Online

Click the Heredis Online button and choose  Publish.

Customize your site by giving it a name. Heredis will place by default that of your genealogy file. You may change the name
because it will be included in the URL that you will communicate to your relatives and friends.

From the Your Website tab, add an illustration to your homepage to make it more attractive. You can display the main image
associated with your root person, or select a photo from your hard disk: the village where your ancestors originated, a shield.
Browse your hard disk to select an image.

Customize your Heredis online website settings
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Fill out the host text area; anyone who connects to your site must have an idea of what he will find there!

You have the choice of data you publish from the Privacy tab:

Manage the display of contemporary persons by choosing the number of years to set the privacy level and decide if you
want to display the full given name and surname only or not to display at all.
Display or not individuals who are declared as confidential or private in your genealogy file (individuals, events, notes
...)
Choose to display or not all notes
Display or not all sources

You may also tick the Protect this publication with a password box, and enter a password in the corresponding text box and
click OK. Thus, only the holders of a visitor password can access your publication. Other visitors will contact you by email to
get the password.

Heredis Online displays a list of your published genealogies. You may follow the progress of moving your genealogy to your
personal website. When publishing is complete, click on the link to launch your Internet browser and visit your site.

You will arrive on the home page of your genealogy. Click the Facebook button to share your genealogy on your Facebook
page or click the Email button to send an email and share your genealogy website with your family and friends.

High-resolution photos on Heredis Online

The first time you connect to your Heredis Online account, a message will inform you that the photos you publish online are
displayed in high resolution.

In the  Media Index, the Sent and Not Sent filters, as well as the media status displayed under the Information tab,
allow you to visualize the list of the media that are online or not.
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When you publish a genealogy on Heredis Online, each media has a status (that you can see in the Details tab from the Photo
tool) that allows you to clearly identify its current situation: File is online / File is too large / File error / File waiting to be sent
/ Unauthorized file format / Missing file / File being sent / Unverified file.

Note:
• In the software preferences, using the menu (Windows) Tools > Preferences > Heredis Preferences > Advanced
; (Mac) Heredis World 20xx > Preferences > Advanced, you can indicate whether you want a copy of your media to be
uploaded.

You can also choose to adjust the uploading of these media based on your internet connection. By default, the uploading is
based on an ADSL connection type with a 50% usage. These parameters can be modified and personalized at any time but
won’t be applied until you restart your software.

• In your Heredis Online account:

You can choose whether your media should be displayed in a publication: click on the  indented wheel button, then click
on the Privacy tab, then make your selection in Show photos.
The media that are not linked to any publication can be deleted; to do so, click on the Online Medias tab in your Heredis
Online account.

• If you realize the media are not uploading properly and that the status of your files reads "File error" or "Unverified file", you
can force send them from the Media Index by clicking (Windows) the Tools button / (Mac) on the indented wheel Option
button and selecting Reset sending of online media. You will need to quit and restart Heredis for the uploading of the media
to resume.

• Files with the following extensions cannot be uploaded: «exe», «app», «bin», «zip», «rar», «sit», «cab», «ace», «arj», «lha»,
«lzh», «lzx», «zoo», «arc», «ice», «ics», «7z», «tar», «gz», «gzip», «tgz», «z», «bz», «bz2», «hqx», «sit», «sea», «uue», «apk»,
«dmg», «bat», «sh», «asp», «php», «js», «jse», «iso», «iss», «msi», «jar», «war», «bak», «sav», «old», «log», «pif», «py»,
«pyw», «rb», «ged», «heredis», «mdb», «sqlite»

• Files over 4294967295 octets (~4.2 Go) cannot be uploaded either.
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Publish group photos to Heredis Online

Heredis allows you to publish group photos on your personal site, as you do for your genealogies.

You will certainly have photos in which you have not been able to identify all the persons present in the photo. Heredis offers
tools for identifying these persons and then for publishing the photo in a photo album.

This online album may be viewed by your family, your friends and other genealogists. Thus, visitors to your site may not only
view your photos but contact you if they have recognized people in the photo.

In Heredis, you access this functionality from the Identification tab in the photo tool (for details on this tool, refer to the
section Photo tool).

Create and set an album

Once you have identified all the persons in a group photo, you may now share your photo album online by clicking the 
Publish Button at the bottom right on the Identification tab.
A simple interface allows you to connect to your account or create it if it is the first time you use Heredis Online.

When first published, you can change the title of the photo in the Title field. If you want to publish this photo in another
album, unfold the dropdown list and choose the appropriate album, or create a new one by using the + button.

To personalize this album, click the indented wheel to the right and you can:

give it a name that will be included in the URL that you will communicate to your family or to other genealogists. Do
not worry about spaces, Heredis replaces them automatically by underscores.
add artwork to make your homepage more attractive.
give details of the content of this album in the Description text box. The person who visits your site will have an idea
on what he or she will find in it!

You can protect your album by a password. Net users who know the password may view your album online and others will
contact you by email to get the password.
When all the settings of your publication are satisfactory, click the Validate Button. Your photo is now published on Heredis
Online.

Info • When you publish a photo which has been declared as private in Heredis, a message alerts you and asks for
confirmation before continuing the publication.

Settings and management of your albums

You can at any time access the albums published from the Album tab in your account with Heredis Online.

Click the  indented wheel to change the publishing settings for an album or on the cross to delete it. Please note that you
will delete all the photos attached to this album.

Info • You can carry out these operations from a distance, even if you do not have your computer to hand, by logging into
your Heredis Online account from any Internet browser.

Click the album name to display a list of all the photos in this album. You can edit or delete each picture individually.

Consult an album

By clicking on the link Visit album, Heredis opens the home page of the album selected in your internet browser.

                                494 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

Consulting an album on Heredis Online

In the left sidebar, you have the name of the album and its author, a clickable link to contact the author and immediately below,
two tabs Photos and Persons.

In the Photos tab, a list of photos in the album is displayed and the total number of photos, (in brackets) next to the name of
the tab.

In the Persons tab, the list and the number of persons identified in the various photos in the album are displayed, specifying,
for each identified person, the number of times he/she has been identified in the various photos of the album. You also have a
search box to locate any person in the list.

The central part allows for 3 different views of the album based on the tab selected in the upper part.

From the Home tab, you get an overview of your album where you will find the description text, any selected artwork and the
pictures of the album in the form of thumbnails. To the right, Heredis displays the date of the last update of this album as well
as a list of your genealogies and other albums already published on Heredis Online.

A single click allows you to open a new tab in your browser with the publication of the selected album.

The Photos tab displays each photo in the album in full screen. To the right of the photo, you find the list of numbered persons
and below, the commentary and the date if they have been added from the Heredis program.

A button under the photo, also allows you to hide or show the frames numbers on the photo. Hover the mouse over any person
identified in the photograph and the list shows the person concerned and vice versa.

Clicking on a person allows you to display him/her in detail in the Persons tab. You will then see the information collected for
that person and a link to the publication if he/she is present in a genealogy previously published on Heredis Online, as well as
photos, in the form of thumbnails, in which he/she has been identified.

When you click on a photo from the Photos tab in the left sidebar, Heredis automatically switches to the Photos tab in the
central area and displays the details of the photo. If you are on the Person tab in the left sidebar, click on any person and you
will move to the central area of the persons tab this time to display all known information concerning this person.

To go back to the general presentation of the album, click Home in the banner at the top.
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Sharing an album

If you want to invite your family and friends to check out an album, send them the URL by email, or share it on Facebook. Use
the Buttons located in the upper right panel.
As a visitor to a Heredis Online album, you can easily send additional information or indicate an error to the author of the
photo albums. Perhaps you have recognized an unidentified person. Click Contact the author in the left sidebar under the
ALBUM area or in the footer and you will thus advance the work of the author.

Private access

You may protect your Heredis Online site with a password. Only visitors who know the password will be able to view details
of your online genealogy. When any new web user visits your site, we will invite the person to contact you to obtain your
password.
To implement this password: from your Heredis Online account, select the publication concerned and click the indented wheel
to access the settings for this publication. Then, tick the Protect this publication with a password box, enter a password in the
corresponding text box and click Validate.
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Publishing with Heredis Online

Launch your Heredis software and select the tree you wish to publish.
Click the Heredis Online button in the Heredis toolbar.

If you are not connected, the icon will be grey and blue . If you are connected, the icon will be fully blue .

Click on Publish to start publishing your tree on Heredis Online.

Then, if you are not connected, sign in to your account via the Heredis Online window.
Enter the same username and password you use when logging in on the Heredis Shop.

• Tip •
Tick the Keep me logged in box to avoid entering them again next time you need to sign in.

Type in a name for your website along with a brief description. Select a picture to illustrate your homepage if you wish to.
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Make sure you set up your Privacy options.

Reminder: French regulations do not allow the publication of personal data that is less than 100 years old; European
regulations provide the same restrictions with data that is 120 years old or less. Make sure not to publish recent data according
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to your country laws regulation.

Setting up Contemporaries

Under “Consider persons born less than XX years ago as contemporaries”, you are given the option to show all of their
data, part of it, or none of it.

Be careful! This setting will only apply to persons entered with a birthdate. If you entered your first-degree cousins without
their birthdates, their data will be displayed.

In such a case, you may want to use the Confidential Person label under the Data tab>Personal Data in Heredis. If you
need to label a large number of persons as confidential, remember you can use Smart Search to make your job easier. For
further details, feel free to consult the articles entitled The different data fields and Smart Search.

Setting up Other Data

Show private and confidential elements: pretty much everywhere in Heredis, you will notice Private boxes – for an
event, a media, a source, a note, etc. If you tick the box “ Show private and confidential elements”, this data will be
shared and available for all to see. If you untick this box, all data for which you have checked the Private box and/or all

the persons marked as Confidential will not be shown. No one will be able to see them.
Show all notes: if you tick this box, all of your notes (except the private notes – that is if you have unticked the above-
mentioned box) will be published and visible to all.
Show all sources: if you tick this box, all of your sources (except the private ones – that is if you have unticked the
above-mentioned box on private and confidential elements) will be published and visible to all. Sources allow you to
validate your work and allow other genealogists to locate the original document.
Show photos: choose between Do not show, Thumbnail size (low resolution), High quality (Heredis 2018 at least).
If your photos are checked as Private, and if you have unticked the Show private and confidential elements box, your
photos will not be displayed.

Protect your publication with a password. It will thus allow you to publish all of your data while limiting access to your site
only to the persons who have been given the password. It is up to you to regulate who may or may not access your site.
Check the box and enter your password in the empty field that pops up.

Once you are done with your settings, click on OK.

The progress bar will help you visualize the progression of your genealogy being published. Once transfer is complete, click on
the Visit website link to open it. Your tree is online!

You may now share it with your relatives and loved ones via email or Facebook, using the share buttons  located in
the upper right corner of your website.

Heredis Online creates a website on your behalf, hosted for free, so you can present your family tree. With just a few clicks,
you’ll get a site for your entire family to consult and enjoy.

 

By simply clicking the Contact Author link, they will all be able to bring you extra details, directly from your website.

Manage your Heredis Online account directly from your software or from your internet browser. Modify the display of your
tree by clicking on the indented wheel located under Settings (at the end of the line) under Online Trees, or delete your tree by
clicking on the cross.
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To learn more, feel free to consult other articles on Heredis Online.
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Export Heredis data

You export your data to exchange them. To share with other users of Heredis or to create branch files for your own use, use the
Heredis export.

If they are using an older version of Heredis, use the GEDCOM format.

In a Heredis export, you can select what data to export: exclude confidential persons, limit to a branch or exclude alive
persons.

1. Choose File > Export > Heredis File.
2. Identify the persons and types of data to be exported.
3. Click Export.
4. Name the new file and choose where the file should be saved.

The options for the exported file in GEDCOM or Heredis format are identical. They concern the persons included in the file
and the type of data considered.

Select the branches concerned

1. Select branches from the export screen: All People - Ancestors - Descendants – Ancestors & Descendants.
2. Choose the number of generations of ancestors, of descendants, or both.
3. Specify the number of collaterals for the ancestor branches. Heredis goes back down the branch line for each direct

ancestor to include them in the exported file.

0 = only direct ancestors are exported (with spouses).
1 = you export the direct ancestors with all their children and their spouses.
2 = you export the direct ancestors, their children and grandchildren, along with their spouses.
3 = you also add their great-grandchildren, etc.

Info • Remember to check who is the primary person displayed before making a branch export.
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(Windows) Select the persons to be included in an export file

1. Export All Persons: export all persons included in your file or in the concerned branch.

2. Exclude Marked Persons: marked persons, the one with the  tag ticked in their personal data, will not be included.
3. Export Marked Persons Only: only the persons marked will be included in your export file.

4. Hide all data for confidential persons: persons with the  tag tick in their personal data are exported with no
details.

5. Tick the box Exclude Secondary Persons to exclude from the export the persons considered as secondary   because
they do not present a big interest to your family tree (children who died in infancy, persons with no links, persons on
whom you do not want to make researches).

For further details on tags confidential, marked or secondary, see our article The different data fields.

Note • It is possible, just by marking a person , to ignore a branche. Using the marked tag has multiple purposes : cut a branch,
erase duplicates, delete stillborn child, not show alive persons... You can use the Smart Search to identify persons of one or
more criterias and mark them, tag them as secondary or confidential. Consult our Smart Search article for further delails.

Careful, if your primary person or root person is concerned by these limits (confidential, secondary, or marked), you file will
be empty. It is not possible to export a file is the main person is not in it.

(Windows) Heredis export
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(Mac) Select the persons to be included in an export file

1. Tick all the boxes to include all persons saved in the file.

2. To prevent the export of certain types of people, untick the appropriate boxes. For further details on tags confidential,
marked or secondary, see our article The different data fields.

Marked persons are the ones with the  icon ticked in Personal Data of the person. It allows you rto exclude or
take only the marked ones.

Secondary persons are the ones with the  icon ticked in the Personal Data of the person. They usually are the
persons on which you do not specifically want to do researches.

Confidential persons are the ones with the  icon ticked in Personal Data of the person. They usually are the
alive persons.

3. To export data partially, make your selection from the export screen.

Confidential  Persons: you may export all the information of confidential persons, or their surname only, or
their surname and given names. You can also export all people by hiding the data. The recipient of your file will
only know that such a person in a given place in the line existed, without knowing any information about
him/her.
Persons Born Less Than … Years Ago: select the number of years to be considered for export of
contemporaries. Type a value or use the arrows to change the proposed value. To prevent the export of 
Persons Born Less Than … Years Ago specify the value and untick the box.

 

Info • It is possible to exclude a branch from the exported file. Declare the person at the base of this branch as Marked, then
untick Marked Persons in the export screen. Using the marked tag has multiple purposes : cut a branch, erase duplicates,
delete stillborn child, not show alive persons... You can use the Smart Search to identify persons of one or more criterias and
mark them, tag them as secondary or confidential. Consult our Smart Search article for further delails.

(Mac) Export Heredis file

Select the types of data for export
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1. Tick the boxes to include the different types of data in the exported file.
2. Untick the boxes to exclude a type of data.

Do you want to export:

Notes/Transcriptions
Sources/Citations
Witnesses and linked persons (of Sundry links tab in Personal Data, see Add other linked persons article)
Minor events (everything else that Birth/Baptism, Union, Death/Burial)
Facts
Media
Private data: they are all data you ticked the "Private" box, it can be events,  facts, sources, media...
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Import a Heredis file in an existing file

Importing Heredis data to an existing file allows you to connect a new branch created in a separate file by yourself or by a
family member.

1. Choose File > Import > Heredis File.

Note: A message will alert you that it is irreversible, so please make sure to make a copy of your file in case the result doesn't
please you.

2. Select the Heredis file. Only files created with the same version of Heredis may be merged (Mac file or Windows folder
with the extension .hmw).
3. Click Open. Choose if you want to import or not medias and sources. (Windows) Click on Next. (Mac) Click on Import.

(Windows) Import Options
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(Mac) Import Options
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4. If you desire to associate a common source of data from the import, tick the box Assign a new source to and select in the
list where you want this source to be assigned. Fill up the fields of this new source. You will be able to modify it on your 
Sources index later. After importing the new data, you must create links that will connect the imported persons to those
already present in the main file.

See also (Windows) Permanent control for duplicates and Merge two persons, (Mac) Permanent control for duplicates and
Merge two persons.
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What is a GEDCOM file?

You want to share your genealogical data with other genealogists who don't use Heredis, or with some who uses an old version
of Heredis, use the GEDCOM format.

A GEDCOM file is an exchanging format for genealogy, it was made by Mormons 25 years ago and make it compatible to
most genealogy software.

The GEDCOM exchange format stands for Genealogical Data Communication. Almost all genealogy software programs
recognize this universal format.

The GEDCOM file must have the extension .ged to be recognized by Heredis.

Some data are normalized as for names, major events... but some are not. So each software tags the data as it pleases them
(minor events, facts...), these tags are called Owner Tags and can be very different according to the software used to create the
GEDCOM file. So some software might not be able to read the data.

This is what a GEDCOM file looks like when opened without a genealogical software.
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Note that a GEDCOM do not contain media. It only keeps the path to the original media and its name. So when you create a
GEDCOM, make sure you create a folder with your media on your hard drive disk (or external drive if you wish).

If your GEDCOM contains media data, you will have to tell Heredis where to find the media.
As previously said, a GEDCOM file only keeps the path to the original media. When you import the GEDCOM in Heredis,
just tell Heredis the path to the original of your media on your computer. Click Yes to locate your media.

You can check for media in the Media index.

See Media Index at the "Check missing media section". If your media didn't change names, Heredis will find them.

If Heredis do not recognize some tags, it will ask you what to do : Import or Do not import.
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Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.

Some owner tags of Heredis

Here are some owner tags you might found if you create a GEDCOM with Heredis.

_ARCH = Archiving the Source
_CLS = Person without descendants
_EVID = Quality of the proof
_FIL = Child Status
_FNF = Father not find, untraceable (from Heredis 2021)
_FNA = Search Status of an event
_FSFTID = FamilySearch Identification Number
_INFO = Quality of the information
_MNF = Mother not find, untraceable (from Heredis 2021)
_PRIM = Defined if the media is primary
_QUAL = Quality of completed citations
_SEC = Secondary person
_SHAR = Link for shared events
_SOUR = Quality of the source

                                510 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

_SUBMAP = Geolocation of subdivisions
_ULS = Unmarried person
_UST = Union type

This is a non-exhaustive list.
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Export a GEDCOM

You're exporting your data to exchange them. If you wish to submit your genealogy to a correspondent who does not have
Heredis, or an older version of Heredis than yours, or you wish to keep a version of your data to be used by any software, you
have to export your file in a Gedcom file.

It is a text format file, it contain only text, no media. See also What is a GEDCOM file?

Important: If you are making limitations on persons (marked, confidentials...) and the root person (for entire file export) or the
primary person (for the export of a branch) is included in the limitation, your GEDCOM file will be empty! You can't create a
file of ancestors or descendants or both if the person at the base is excluded.

Export all your file in GEDCOM format

Choose File > Export > GEDCOM File.

Choose to export (Windows) Entire file ou (Mac) All People.
Choose what data to export (media, notes...). If you export notes, choose if you wish to Preserve text format or No
formatting text. Some softwares can not read text formatting. To be sure to get all the data in your notes, we advice
you to choose No formatting text.

Info • If you want to export media, tick the Create a folder for media box to accompany the GEDCOM file with a folder
containing all media attached to the exported data. The paths of the media listed in the GEDCOM file match the media in this
folder. If you don't create a folder, only the way to the media ans its name will be kept in the GEDCOM.

Heredis manages different calendar as for Hebrew, French Republican or Julian calendar. Some software can't. Tick the
Use Gregorian Dates box in order to make sure all dates will follow and be read by the other software.
Heredis allows to share an event between many persons, this way you won't have to enter the event on everyone. This
function is specific to Heredis. Tick the box Convert shared events to individual events so Heredis will copy the
event to every person concerned.
Complete the information concerning the sender of the file. This allows the person receiving the file to identify you and
to be able to contact you if necessary.
Choose the character set for data to be exported:

Mac: characters readable by all Mac software.
Windows (ANSI): use this format if you know the recipient of the file uses Windows software.
UTF-8: use this format to preserve all special characters. This is a recent universal file format. But note, some
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genealogy software programs do not support this format.

Info • Use UTF-8 characters, which is an international language for computer encoding if the software that opens the
GEDCOM is less than 6 years old.

You can add your contact information so the person who will read the GEDCOM will know where the data comes
from.

(Mac) Select the persons to be exported

1. Export All people: export all persons contained in your file.

2. Export Marked Persons Only: only the persons with  ticked in their personal data will be exported.
3. Marked Persons: if ticked, the marked persons will also be included.

4. Secondary Persons: if ticked, the persons with  ticked in their personal data will be exported.

5. Confidential Persons: you may export all the information of confidential persons (those with  ticked in their
personal data), or their surname only, or their surname and given names. You can also export all people and blur the
confidential persons' data. The recipient of your file will only know that such a person in a given place in the line
existed, without knowing any information about him/her.

6. Persons Born Less Than … Years Ago: select the number of years to be considered for export of contemporaries.
Type a value or use the arrows to change the proposed value. To prevent the export of Persons Born Less Than …
Years Ago specify the value and untick the box.

Info • It is possible to exclude a all branch from the exported file. Declare the person at the bottom of the branch you do not

want to export and tick the  in his/her personal data. You can also tag as , ,  a lot of persons at once with Smart
Search. See Smart Search and The different data fields articles.

(Mac) Export GEDCOM screen
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Click Export.
Give a name to the new file and choose where the file should be saved.

Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.

(Windows) Select the persons to be exported

In the Limits section, choose to :

Export All persons (export all persons contained in your file) or Export Marked Persons Only (only the persons with

 ticked in their personal data will be exported) or Exclude Marked Persons (the marked persons won't be
included).

Export Confidential Persons (you may export all the information of confidential persons, those with  ticked in
their personal data), or Exclude Confidential Persons (they won't be included), or Export surname only
(Confidential persons will be exported with only their surname), or Blur all data for confidential persons (all the data
of confidential will be blured), or Hide all data for confidential persons (all the data of confidential persons will be
hidden).

Exclude Secondary Persons: if ticked, the persons with  ticked in their personal data won't be exported.

Info • It is possible to exclude a all branch from the exported file. Declare the person at the bottom of the branch you do not

want to export and tick the  in his/her personal data. You can also tag as , ,  a lot of persons at once with Smart
Search. See Smart Search and The different data fields articles.

(Windows) Export GEDCOM screen
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Click Export.
Give a name to the new file and choose where the file should be saved.

Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.

Export a branch of your file

As previously, choose File > Export > GEDCOM File.
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Choose the branches to process

Choose the person you want at the base of your GEDCOM file and put him/her as the primary person of Heredis'
screen.
Choose to include Ancestors or Descendants or Ancestors & Descendants.
Choose the number of generations of Ancestors, of Descendants, or both.
Specify the number of collaterals for the ancestor branches. Heredis goes back down the branch line for each direct
ancestor to include them in the exported file.

0 = only direct ancestors are exported (with spouses).
1 = you export the direct ancestors with all their children and their spouses.
2 = you export the direct ancestors, their children and grandchildren, along with their spouses.
3 = you also add their great-grandchildren, etc.

Info • Remember to check who is the primary person displayed before making a branch export.

Choose what data to export (media, notes...). If you export notes, choose if you wish to Preserve text format or No
formatting text. Some softwares can not read text formatting. To be sure to get all the data in your notes, we advice
you to choose No formatting text.

Info • If you want to export media, tick the Create a folder for media box to accompany the GEDCOM file with a folder
containing all media attached to the exported data. The paths of the media listed in the GEDCOM file match the media in this
folder. If you don't create a folder, only the way to the media ans its name will be kept in the GEDCOM.

Heredis manages different calendar as for Hebrew, French Republican or Julian calendar. Some software can't. Tick the
Use Gregorian Dates box in order to make sure all dates will follow and be read by the other software.
Heredis allows to share an event between many persons, this way you won't have to enter the event on everyone. This
function is specific to Heredis. Tick the box Convert shared events to individual events so Heredis will copy the
event to every person concerned.
Complete the information concerning the sender of the file. This allows the person receiving the file to identify you and
to be able to contact you if necessary.
Choose the character set for data to be exported:

Mac: characters readable by all Mac software.
Windows (ANSI): use this format if you know the recipient of the file uses Windows software.
UTF-8: use this format to preserve all special characters. This is a recent universal file format. But note, some
genealogy software programs do not support this format.

Info • Use UTF-8 characters, which is an international language for computer encoding if the software that opens the
GEDCOM is less than 6 years old.

You can add your contact information so the person who will read the GEDCOM will know where the data comes
from.

(Mac) Select the persons to be exported

1. Export All people: export all persons contained in your file.

2. Export Marked Persons Only: only the persons with  ticked in their personal data will be exported.
3. Marked Persons: if ticked, the marked persons will also be included.

4. Secondary Persons: if ticked, the persons with  ticked in their personal data will be exported.

5. Confidential Persons: you may export all the information of confidential persons (those with  ticked in their
personal data), or their surname only, or their surname and given names. You can also export all people and blur the
confidential persons' data. The recipient of your file will only know that such a person in a given place in the line
existed, without knowing any information about him/her.

6. Persons Born Less Than … Years Ago: select the number of years to be considered for export of contemporaries.
Type a value or use the arrows to change the proposed value. To prevent the export of Persons Born Less Than …
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Years Ago specify the value and untick the box.

Info • It is possible to exclude a all branch from the exported file. Declare the person at the bottom of the branch you do not

want to export and tick the  in his/her personal data. You can also tag as , ,  a lot of persons at once with Smart
Search. See Smart Search and The different data fields articles.

(Mac) Export GEDCOM screen

Click Export.
Give a name to the new file and choose where the file should be saved.

Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.

(Windows) Select the persons to be exported

In the Limits section, choose to :

Export All persons (export all persons contained in your file) or Export Marked Persons Only (only the persons with

 ticked in their personal data will be exported) or Exclude Marked Persons (the marked persons won't be
included).

Export Confidential Persons (you may export all the information of confidential persons, those with  ticked in
their personal data), or Exclude Confidential Persons (they won't be included), or Export surname only
(Confidential persons will be exported with only their surname), or Blur all data for confidential persons (all the data
of confidential will be blured), or Hide all data for confidential persons (all the data of confidential persons will be
hidden).
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Exclude Secondary Persons: if ticked, the persons with  ticked in their personal data won't be exported.

Info • It is possible to exclude a all branch from the exported file. Declare the person at the bottom of the branch you do not

want to export and tick the  in his/her personal data. You can also tag as , ,  a lot of persons at once with Smart
Search. See Smart Search and The different data fields articles.

(Windows) Export GEDCOM screen

Click Export.
Give a name to the new file and choose where the file should be saved.

Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.
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How to export your Family Tree from Ancestry.com

Your Family Tree is stored on Ancestry.com? You want to get it back in order to use Heredis? Follow the steps.

Connect to your Ancestry.com account.

Open your family tree.

Under the menu bar, next to your tree's name, there is a drop-down arrow, click on it and choose Tree Settings.

Click on Export Tree.
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It might take a few minutes to create your GEDCOM file.

When its ready, click on Download your GEDCOM file.

Your GEDCOM file is stored on your computer, you can now launch Heredis to open it. See how to open a GEDCOM file on
the article Import a GEDCOM file in a new file. Do not forget to get your media back from Ancestry. Click on Media Gallery
then do a right clic on each media to Save as on your hard drive. Do not change the name even if it is not a good
one, because your GEDCOM has this name on it to identify the media.
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Note: A GEDCOM file is a text format file. It means your media are not include in it, a GEDCOM file only includes the names
and paths to your media. When you export a GEDCOM from Ancestry.com, think to download your media from the Media
Gallery to your hard drive's computer. Then, use Heredis' media index to Check your media and tell Heredis were to find your
media. See also the article Media to understand how to check missing media.

If your media from Ancestry has strange names, do not rename them. Heredis would not find them automatically if you do so.
And if Heredis can't recognize them after Checking missing media, contact us here.
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Open a GEDCOM in a new file

You have already created a genealogy file or you have been given one created on another application? Importing a GEDCOM
file, the recognized standard in the world of genealogy, is very simple.

Though, importing a GEDCOM or opening it for the first time, takes time. Do not validate too quickly, you won't be able to
change the import afterwards.

(Mac) Import a GEDCOM in a new file.

From the Heredis Home Page, choose the GEDCOM File in the Open menu and click OK.
The GEDCOM file must have the extension .ged to be recognized by Heredis. Select the file and click Open.

Give it a name.
Choose where to store it on your hard drive disk. Use the arrow on the right to access to all folders on your computer.
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Validate by clicking on Save and wait while Heredis analyzes the data.
Check the information found in the GEDCOM file (quantity of data, structure of places). All softwares do not manage
all data of places the same way. Click on Select Appropriate Place Elements if you need to reorganize the data and
click on the headings of columns to change them.

Data are identified in a GEDCOM through the Tags. Every software has its own way to manage some data in GEDCOM
format, so some tags are called Owner Tags and might not be read by other softwares (see also What is a GEDCOM file?). If
Heredis doesn't know a tag, it will ask you what to do with it : Import or Do Not Import. If you do not recognize the meaning
of an owner tag (those with a _), ask the editor of the software used to create the GEDCOM. Choose what you want to do with
those unknown tags in the Heredis screen.
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Choose for each tag to Import or Do not import. If you do not import, the data won't be in Heredis.

Choose to import or not medias and sources and how to manage given names in quotes. Be aware that a GEDCOM file 
never contains media, only the name and way to the original of the media. So even if you choose to import a media,
you'll import only the name and way to the original.
You may add a source common to all data imported. In this case, tick the box Assign a new source to and choose the
kind of data to source (events, facts...). Fill in the name, repository and type of document of the source.
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Click on Import to start converting your GEDCOM into a Heredis format. This step can take some time depending on
the size of the file, so be patient. Your GEDCOM file will still be available in the GEDCOM format. Heredis extract
the data from the GEDCOM file and converted them into a Heredis format.

Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.

(Windows) Import a GEDCOM in a new file.

From the Heredis Home Page, click on Open a GEDCOM file.
The GEDCOM file must have the extension .ged to be recognized by Heredis. Select the file and click Open.
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Give it a name.
Choose where to store it on your hard drive disk. Click on Modify to change where to keep your file. By default
Heredis puts it in Document > BSD Concept > Heredis > Heredis files.

Validate by clicking on OK and wait while Heredis analyzes the data.
Choose to import or not medias and sources and how to manage given names in quotes. Be aware that a GEDCOM file 
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never contains media, only the name and way to the original of the media. So even if you choose to import a media,
you'll import only the name and way to the original.
Click on Next.

Check the information found in the GEDCOM file (quantity of data, structure of places). All softwares do not manage
all data of places the same way. Click on Select Appropriate Place Elements if you need to reorganize the data and
click on the headings of lines to change them.
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Data are identified in a GEDCOM through the Tags. Every software has its own way to manage some data in GEDCOM
format, so some tags are called Owner Tags and might not be read by other softwares (see also What is a GEDCOM file?). If
Heredis doesn't know a tag, it will ask you what to do with it : Import or Do Not Import. If you do not recognize the meaning
of an owner tag (those with a _), ask the editor of the software used to create the GEDCOM. Choose what you want to do with
those unknown tags in the Heredis screen.

Choose for each tag to Import or Do not import. If you do not import, the data won't be in Heredis.

You may add a source common to all data imported. In this case, tick the box Assign a new source to and choose the
kind of data to source (events, facts...). Fill in the name, repository and type of document of the source.
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Click on Done to start converting your GEDCOM into a Heredis format. This step can take some time depending on
the size of the file, so be patient. Your GEDCOM file will still be available in the GEDCOM format. Heredis extract
the data from the GEDCOM file and converted them into a Heredis format.

Note: Ahnentafel numbering is a mobile data, it can be changed at any time, so it is not a data stored in the GEDCOM format.
You might have to change the root person to get the Ahnentafel numbering woshed. See The Root Person article.
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Import a GEDCOM into an existing file

Warning: Any import into an existing file changes its structure. Consider before this type of operation to save a copy of your
original file if necessary or back up the modified file under another name.

Importing a GEDCOM requires taking its time, don't validate too fast, you won't be able to make any changes after the import.

(Windows) Importing a GEDCOM

From the file in which you want to import the GEDCOM file.

Choose File > Import > GEDCOM file.
Select the file (it must carry a .ged extension to be recognized by Heredis), then click Open.
Choose whether or not to import media and sources, and how to handle quote names.
Click Next

You will probably have to check the places, not all software manages them in the same way. If you see a window like
the one below, check the locations. Click Select appropriate places elements if the order does not match the data
correctly. Click on the title of the column on the left to change the categories. (Example: below, the line Postal Code
should be County)
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Each software has its own way of managing certain data in the GEDCOM format. So there are Owner Tags that may be
unknown to Heredis (see article What is a GEDCOM? for more details). If Heredis doesn't recognize certain tags, it will ask
you what you want to do with them: Import or Do not Import. If you don't know what some owner tags mean (those prefixed
by a _), ask the publisher of the software that generated them for clarification. So choose what you want to do with the
unknown Tags if the screen shows up.

Check the Assign a new source to box and choose which data to add that source to you. Fill the fields out of the source
if you want to assign one. By adding a common source to all the information from this GEDCOM, you'll know where
you get your information from.
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Click Done to validate the import with the settings you've indicated.
After the GEDCOM data is imported, it is necessary to create the links that will link the imported persons to those that

were already present in the main file. To do this, use the  Add features.

A GEDCOM never contains media because it is a text file format. On the other hand, the path and the name of the media are
kept, so you can reintegrate them through the media index (if their name has not changed, Heredis will quickly reintegrate all
of your media in a few clicks). See the article Media > Searching Media for more details.

(Mac) Importing a GEDCOM

From the file in which you want to import the GEDCOM file.

Choose File>  Import > GEDCOM.
Select the file (it must carry a .ged extension to be recognized by Heredis), then click Open.
You will probably have to check the places, not all software manages them in the same way. Click Select Appropriate
Place Elements if the order does not match the data correctly. Click on the header of the column to be changed to
change the categories. (Example: below, the line Postal Code should be County)
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Each software has its own way of managing certain data in the GEDCOM format. So there are Owner Tags that may be
unknown to Heredis (see article What is a GEDCOM? for more details). If Heredis doesn't recognize certain tags, it will ask
you what you want to do with them: Import or Do not Import. If you don't know what some owner tags mean (those prefixed
by a _), ask the publisher of the software that generated them for clarification. So choose what you want to do with the
unknown Tags if the screen shows up.

Choose for each tag to import or ignore the data.
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Choose whether or not to import media and sources, and how to handle quote names.
Check the Associate a Common Source box and choose which data to add that source to you. Fill the fields out of the
source if you want to assign one. By adding a common source to all the information from this GEDCOM, you'll know
where you get your information from.
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Click Launch import to start importing. This may take more or less time depending on the size of the file to be
imported.
After the GEDCOM data is imported, it is necessary to create the links that will link the imported persons to those that

were already present in the main file. To do this, use the  Add features.

A GEDCOM never contains media because it is a text file format. On the other hand, the path and the name of the media are
retained, so you can reintegrate them through the media index (if their name has not changed, Heredis will quickly reintegrate
all of your media in a few clicks). See the article Media > Searching Media for more details.
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Share on the local network

To share the open genealogy in Heredis, select the File menu > Share on the local network or click the Share button in the 

 toolbar, if you've put it. Check out the Customize Heredis article to learn more about customizing the toolbar.

This tool allows you to have your file on multiple remote devices (computer, tablet or phone).

Requirements for sharing

Make sure you have 2 compatible versions of Heredis. For a connection between 2 computers, you must have the same
version of Heredis on both computers. On your phone or tablet, you need the free Heredis app for Android or iOS.

Beware, for versions prior to Heredis 2020, you need the iOS or Android Heredis app without a version number. Since Heredis
2020, each version of Heredis now has its own app. When you change versions, consider downloading the similar version for
iOS or Android.

Make sure your computer and/or Internet box firewall or anti-virus allows Heredis to access your private network.
Open Heredis on both devices.
Turn off 3 or 4G on your phone or tablet. Sharing is done via WiFi only.

Share your file for the first time

Heredis opens a sharing window and displays the list of devices connected to your local network and on which the software is
launched.

If the open genealogy has never been shared, choose a device available from the proposed list and then click Share to link the
genealogy with the chosen device. The remote device then receives a sharing request.

Note: The remote device must have double the volume of the transferred file. Be sure to turn off your device's automatic sleep.

(Windows) Share on local network window

                                536 / 555



[Heredis 2021 Windows EN] - 09-22-2020
[User Guide 2021 Windows EN] - https://help.heredis.com

(Mac) Share on local network window

On the remote device, Heredis asks you for permission to receive the file. When you click the button (Windows) Yes, (Mac) 
Accept, Heredis copies, on the remote device, all the data of the open genealogy as well as the media.
Your genealogy is now linked to two devices, such as your desktop computer and your laptop or your phone.

Share your file again after changes when the link is already made

From Heredis on your laptop or phone or tablet, make changes and save new data in your genealogy.
Then open this genealogy on all your devices with this shared file.

If you're connected to the local private network, Heredis automatically alerts you that a newer version of your file is available
on the device from which you made changes and which is connected to your local network. In this window, the key info in the
remote file is displayed (change dates, number of individuals, last modified individuals) and you can compare them with those
of the open file.

If you click the Receive button, Heredis updates the genealogy with the data entered or changed. Only genealogical data or
media that have been modified, or added will be transmitted.

(Windows) Receive changes
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(Mac) Receive changes

Warning: Remember to update your devices before making any changes. If you've made changes to your phone without
updating your file on your computer, and then make changes to the computer, Heredis will only keep the latest information in
chronological order. So you'll lose the modified data on the phone.

Heredis will always offer you the latest file. If you agree to receive it, changes made to the least recent file will be lost.

If you no longer want to share your file with a remote device:
From the File menu > Share on local network, select the device.
Click the Don't Share button.
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The device in question will no longer receive notifications regarding updates to this genealogy.
You can reactivate this sharing at any time by clicking the Share button again.

Info - For the information to be shared, the genealogy file must be recorded.

A problem with sharing?

Share on the local network no longer works:

Make sure your firewall and/or antivirus doesn't block Heredis. On Windows, there is a built-in firewall, so it may
duplicate if you have one in your anti-virus. Also check the firewall of your Internet box.
Make sure you have 2 similar versions of Heredis. For example, Heredis 2020 for Windows communicates with
Heredis 2020 for Mac, iOS or Android only.
Are you on Windows? Check out the article (Windows) Heredis cannot detect my remote devices – I am getting
Bonjour messages.
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Synchronizing via USB

Heredis can detect removable devices (USB, external hard-drive) connected to your computer.
You are going to your country home? Synchronize your genealogy on a USB flash drive with the Sync button then the
USB button and then connect it to your home computer in the countryside. You can update your file instantly.

Before leaving, synchronize your computer again with the USB flash drive and update your files with all your weekend work
as soon as you return home.

Exchange with another Windows or Mac

Synchronize your genealogy on a USB flash drive or an external hard drive. The synchronization process is the same as for the
devices on the WiFi network.

Click the Sync via USB  button or choose File menu > Sync Via USB....
In the Synchronization window, select the device that you have connected, check the direction of synchronization then click 
Send or Receive according to the synchronizing direction you have selected.

(Windows) Synchronization screen

(Mac) Synchronization screen
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When synchronization is complete, you may plug in the device to another computer (Windows or Mac).

Whether on launching Heredis or during work, Heredis will inform you if a new genealogy or a newer version of the
genealogy exists on the device you have connected and will propose to synchronize your computer with this genealogy. So,
when you work, just think of plugging your USB key or external hard drive disk.
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Transfering to a mobile device without WIFI

You can copy your genealogy in a format suitable for exchange with a mobile iOS (iPhone, iPad, iPod touch) using iTunes or
with a mobile Android device using Google Drive.

Please note that in this case, it is not a synchronization (update of latest data), but a transfer of the complete file (including the
media).

Since Heredis 2020, every year a new app is released to communicate with the newest version of Heredis for Mac or Windows.
Heredis app (without a version number) is to be used only if you still use a version of Heredis desktop for Mac or Windows
before Heredis 2020. If you use a version more or equal to Heredis 2020 on your Mac or Windows computer, you will need to
download Heredis 20xx app corresponding to the version number used on your computer.

Since Heredis 2017, you can share on local network if your devices are connected to the same network, this function is less
tendious than the one bellow. See Share on local network article for further details. 

Share with an iOS device via iTunes

(Windows) To transfer your genealogy to a mobile iOS, prepare the file to be sent via iTunes. Open Heredis and the file to
share. Click on File menu > Prepare for > iTunes. The follow the steps bellow.

Heredis creates a compressed file, recognizable by both iTunes and on your mobile iOS. This file contains all your data and all
your media.

Click Yes to create the file. It has the same name as the original file with an extension .hmwit.
Heredis opens Windows Explorer  to show you where the file is for transfer to iTunes.

(Mac) No need to prepare the file, it is already compatible iOS.

 Launch iTunes.
Connect your iPad, your iPhone or iPod touch and select it in iTunes.
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Click the Apps tab (at the top of the screen), then scroll down the list of applications until you reach File Sharing.
Select Heredis. All genealogies already synchronized are visible. Click the Add button or drag & drop the file.
 The transfer of the genealogy is carried out. If Heredis is not running on the mobile, the file will appear on the
homepage the next time the App is launched.

Recover data from a mobile via iTunes

After a work session on the iPhone or iPad, retrieve the changed data by passing through iTunes again.

Select the .hmw file modified on the Apps - File Sharing tab.
To extract it from iTunes, click Save to… and save the genealogy file recovered to the location of your choice.

Info • Remember to select the same folder if you want to replace the existing genealogy file on your Mac or Windows.

Share with an Android device via Google Drive

Before you can copy your family tree from the Heredis format onto an Android device, you must prepare this family tree.

Prepare your family tree for Android

From your computer:

Launch Heredis
Open your family tree.
Select the menu File > Prepare for > Heredis Android... Heredis creates a compressed file recognizable by the
application Heredis for Android.

(Windows) Prepare for Android

(Mac) Prepare for Android
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Click Yes to start creating the file. It has the same name as the original file with the extension .hmwz
Heredis opens (Windows) Windows Explorer; (Mac) Finder, showing you where to transfer the compressed file in
Google Drive.

Copy a family tree prepared for Android in Google Drive

From your computer:

Launch your internet browser and go to the link drive.google.com
Sign in to your Google Account (Select or add the same account that is associated with the Play Store on your Android
device)
Click on My Drive.
Select the file prepared for Android (it has the .hmwz extension) from the (Windows) Windows Explorer; (Mac)
Finder. Drag it into your browser window in My drive to copy it to your Google Drive account.
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Import a family tree from Google Drive into Heredis for Android

From your Android tablet or mobile, you can proceed in 2 ways:

1st solution:

Launch Heredis
Click the Home menu and select Import family tree.
Click the Continue button and select, in your Google drive account, the family tree prepared for Android.

2nd solution:

Launch Google Drive
Click on the file to load
Click the Continue button The Heredis for Android application will automatically open the file.

Info • If you transfer your file prepared for Android directly to the SD card of your Android device or another online storage
application (Dropbox, OneDrive ….), the procedure to retrieve your family tree in Heredis for Android is identical.
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Any concern or issue when sharing with Heredis?

If you are experiencing a problem with the Share on local network feature, please proceed using the following steps.

Prerequisites
On your main computer:
- you have installed the Heredis application AND you have an updated version of your genealogy file that you wish to share.

Windows

Check the following items before starting to share:

On your main computer:
Make sure the Heredis application has only been launched once. It shouldn't appear more than once in the list of
running applications.
Launch the Task Manager (press CTRL ALT DELETE on your keyboard).
Make sure the antivirus/firewall installed on your computer or included in the settings of your wireless router
does not block the Heredis application.
Make sure Bonjour services are enabled (some Windows updates disable these services which allow your
computer to communicate with other devices such as your printer or phone). See the following article for more
details: https://help.heredis.com/en/windows-bonjour-messages/

On your remote device:
Make sure the remote device is connected to the same WIFI network as the main computer.
If the remote device is a tablet or a cell phone, turn off Bluetooth.
Launch Heredis.
Delete the genealogy file you want to share if it is present on the remote device and older than the version on
the computer.
Stay on the Home page and check that the device does not go into standby mode.

Start sharing your genealogy from the main computer:
- File menu > Share on local network.
- Select the remote device and click the Share button.
- On the remote device, accept the share request.

NOTE:
On mobile applications (Android and iOS), you will not be automatically notified of changes made from Heredis for Windows.
To retrieve the latest updates made on Windows :
- on Android, click on Share on local network > Select remote device > Receive file
- on iOS, click Tools > Share on local network > Select remote device > Receive file

Mac

Check the following items before starting to share:

On your main computer:
Click on the Apple menu > Force quit…
Make sure the antivirus/firewall installed on your computer or included in the settings of your wireless router
does not block the Heredis application.
Check in System Preferences > General > Recent Items => this option should not be set to None

On your remote device:
Make sure the remote device is connected to the same WIFI network as the main computer.
If the remote device is a tablet or a cell phone, turn off Bluetooth.
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Launch Heredis.
Delete the genealogy file you want to share if it is present on the remote device and older than the version on
the computer.
Stay on the Home page and check that the device does not go into standby mode.

Start sharing your genealogy from the main computer:
- File menu > Share on local network.
- Select the remote device and click the Share button.
- On the remote device, accept the share request.

NOTE:
On mobile applications (Android and iOS), you will not be automatically notified of changes made from Heredis for Windows.
To retrieve the latest updates made on Windows :
- on Android, click on Share on local network > Select remote device > Receive file
- on iOS, click Tools > Share on local network > Select remote device > Receive file
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What to do if something goes wrong in Heredis?

Like with any other software, a technical issue may arise. To be prepared for such an event, we advise that you save your work
on a regular basis.

How to back up your work: see the article How to save your file?

Resetting your application preferences might be an easy way to solve potential anomalies.

There are two modes you can use to reset your preferences: Simple Mode and Comprehensive Mode.

Reset - Simple Mode:

1. In Windows

Before opening Heredis, press and hold the CTRL key on your keyboard.
Click on the Heredis icon to launch the software (still holding the CTRL key down).
Heredis is launching; once it is open, release the CTRL key and validate Clear Preferences.

What will be reset:
o Columns and window sizes in reports, indexes, ranking of panels/search windows.
o Sorting preferences
o All connections: Heredis Online and FamilySearch
o Default toolbar
o Sheets and Books options
o All options for the Slideshow
o Family Tree Mapping
o Dashboard General Options
o Heredis theme
o License activation

2. On Mac

Before opening Heredis, press and hold the ALT key on your keyboard.
Click on the Heredis icon to launch the software (still holding the ALT key down)
Heredis is launched; once it is open, release the ALT key.

What will be reset:
o Columns and window sizes in reports, indexes, ranking of panels/search windows.
o Sorting preferences
o All connections: Heredis Online and FamilySearch
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o Default toolbar (displayed again)
o Books and Sheets options
o All options for the Slideshow
o Family Tree Mapping
o Dashboard General Options
o Heredis theme
o Most recent files list
o License activation

Reinitialize – Comprehensive Mode:

3. In Windows

Before opening Heredis, press and hold the CTRL and SHIFT keys on your keyboard.
Click on the Heredis icon to launch the software (still holding the CTRL and SHIFT keys down).
Heredis launches; once it is open, release the CTRL and SHIFT keys and validate the resetting of your preferences.

What will be reset:
o All preferences reset in Simple Mode
o Genealogical preferences in term of consistency, data entry...
o The license activation
o Sync and sharing history

4. On Mac

Before opening Heredis, press and hold the ALT and SHIFT keys on your keyboard.
Click on the Heredis icon to launch the software (still holding the ALT and SHIFT keys down).
Heredis launches; once it is open, release the ALT and SHIFT keys

What will be reinitialized:
o All preferences reset in Simple Mode
o Genealogical preferences in term of consistency, data entry...
o The license activation
o Sync and sharing history

In case of problems and the reset doesn't work

Heredis needs an internet connexion to activate your licence. Often, firewalls and antiviruses are too uncompromising and
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block Heredis. It can provoque white pages while trying to activate Heredis' licence, blocking the installation of the software...

Check that the antivirus/firewall installed on your computer or embedded in your internet box does not block Heredis. If so
desactivate it while installing Heredis and autorize Heredis to access the network, tell those software that Heredis is
trustworthy.

(Windows) You have a black screen when lauching Heredis or when using a functionality?

On the Home page offering "Try", "Buy" and "Login", click on "Try" then follow the steps :

1 - Click on Tools -> Preferences -> Heredis Preferences -> Advanced

2 - Click on the option Deactivate hardware acceleration

3 - Quit Heredis and relaunch it

4 - Now, click on Login

?
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How to ask a question on the Heredis forum?

Heredis' forum allows you to interact with other Heredis' users. They are not managed by Heredis' team. If you encounter a
technical difficulty, you might find answers provided by the forum animators or others users of Heredis. Therefore the best
way to have an answer to your technical difficulty is to contact us through our Contact Form. Your message will be sent to the
person most likely to respond.

It is not necessary to register to view the forum. Access is free regardless of the sub-forum consulted.

You must register only if you want to ask a new question or post a contribution to an existing topic. If you bought Heredis on
Heredis'Shop you already have an account, no need to create a new one. Indicate your email address and password used to buy
Heredis. If your email address changed, you can change it in your Heredis'Shop account under My personnal information
section.

To access the forum use the following link: Heredis' Forum.

How to register

You do not have a Heredis account but want to ask questions on Heredis' forum, you need to create an free account.
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1. Click the Register button to be able to intervene on the forum.
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2. Click I agree to these terms to validate the conditions for using the forum.
3. Complete the registration form with your details. Choose a username (the name under which you appear when your
messages will be displayed on the forum).

Do not forget to answer the antispam question, and then click Submit to submit your entry.
4. Return to the Heredis forum index page by clicking the link.

How to ask a question

1. Log in by entering your user name and password. Tick the box Remember me each visit to allow your browser to identify
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you automatically when you return to the Heredis forum.

2. Choose the topic according to the concerned platform. Post your message (question or support request) by clicking 
NewTopic.

3. Enter the summary of your question in the Subject text box: Entering sources, for example.
The forum animators or other users of the software will come back to you very rapidly.
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Don't forget to click the Submit button.

If your request requires a personalized reply or for confidential information,please contact us through our Contact Form. Your
message will be sent to the person most likely to respond.
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