1 What can Heredis do?

1.1 Entering data 10
- Data ............................................. 10
- Illustrations .................................. 10

1.2 Family tree charts and other documents 10
- Print tree charts ............................... 10
- Print reports, sheets, or fully illustrated books 10

1.3 Making your work known to others 10

1.4 Exchanging 10

2 Your software up-to-date

2.1 Being kept informed of all updates 11

2.2 Reinstalling Heredis 11

3 How to start?

3.1 Launching Heredis 12

3.2 Creating a genealogy file 12
- New genealogy file .......................... 12
- Import a genealogy file .................... 12
- Reopen a family tree ....................... 12

3.3 Overall view 12
- The main Heredis screen .................. 12

3.4 Navigating 13

3.5 Adding and linking persons 14

3.6 Illustrating your genealogy 14

3.7 Deleting 15

3.8 Creating a tree chart 15

3.9 Printing documents 16
- Reports ........................................... 16
- Sheets ......................................... 17
- Books ......................................... 17

3.10 Researching your genealogy 17

3.11 Sharing 18
- Publish to Heredis Online .................. 18
- Import/export data .......................... 18

3.12 Synchronizing 18
4 Going further

4.1 Arranging your work environment 20
- Manage the panels .......................... 20
- Choose the graphics .......................... 20
- Customize your toolbar ......................... 20
- Select data entry method ..................... 20
- Define your preferences ...................... 20
- Select your work screen ...................... 20

4.2 Getting assistance during data entry 20
- Enter data quickly ............................. 21
- Error-free data entry ........................... 21

4.3 Entering a type of event 22

4.4 Entering a family group 22

4.5 Exploring the Indexes 22

4.6 Managing the results of any search 23

4.7 Searching for duplicates 23

5 Heredis architecture

5.1 Heredis files 26
- Manage files on the Home page ............... 26
- Display of genealogies ......................... 26
- Open a genealogy file ......................... 27
- Close a genealogy file ......................... 27
- Save a file ..................................... 27

5.2 Heredis data structure 28
- Persons ......................................... 28
- Relationships .................................. 29
- Events .......................................... 29
- Witnesses ...................................... 30
- Media .......................................... 30
- Surnames – Given Names – Occupations – Places 30

6 Work environment

6.1 Menus and toolbar 32
- The Heredis menus ............................ 32
Customize the toolbar .......................... 32
Redisplay the toolbar by default ............. 32

6.2 Display Tabs 32
Family tabs ..................................... 32
Data tabs ....................................... 32
Lineage tabs .................................... 32
The Search tab .................................. 33

6.3 Removable panels 33
Display or hide the panels ..................... 33
Resize the panels ............................... 33
Arrange the panels ............................. 33

6.4 Adapting the workspace 33
Menus and toolbar .............................. 33
Panels ............................................ 33
Genealogy files ................................ 33
Display more than one genealogy file ....... 33
Display more than one workspace .......... 33

7 Adding, linking and unlinking persons

7.1 Linking an existing person or creating a new individual? 35
Create the first person ......................... 35
Add a person .................................... 36
Delete a person .................................. 37
Merge two persons ............................. 37

7.2 Parents 38
Add a new person ............................... 38
Link an existing person ....................... 39
Unlink a person and parents ................. 39

7.3 Spouses 39
Add a new person ............................... 39
Link an existing person ....................... 40
Information concerning the family .......... 40
Families order .................................. 41
Delete a family .................................. 41

7.4 Children 42
Add a new person ............................... 42
Link an existing person ....................... 42
Order of children ............................... 43
Unlink a child and his/her parents .......... 43

7.5 Witnesses 43
Add a new person with his/her witnesses .. 44
Change a Witness link ......................... 44
8 Adding and changing information

8.1 Data entry mode 47
- Change the data entry mode 47
- Personalize the data entry mode 47
- Check the items not displayed 47

8.2 Identity of persons 47
- Identity fields 47
- Signature 47
- Child status 47
- Flags and their use 47
- User fields 47
- Notes 50

8.3 Placing persons 50
- The Root Person 50
- Genealogy numbering 50

8.4 Events 52
- Add an event 52
- Share a person event 53
- Customize the display of events 53
- Information on the event 53

8.5 Dates 55
- Recognized calendars 55
- Entry of dates 55
- Automatic calculation of birth dates 56
- Conversion tool for dates 57
- The dates of movable feasts 57

8.6 Places 57
- Assign an existing place to an event 57
- Create a new place and assign it to an event 58
- Create a new place to be assigned later 58
- Information for the place 58
- Geolocate a place 58
- Choose the recognized places 59

8.7 Sources 59
- Assign an existing source to an event 59
- Create a new source and assign it to an event 60
- Create a new source and assign it later 60
- Information for the source 60
9 Illustrate your data

9.1 Media 65
What media for your genealogy? 65
What data can be illustrated? 65
Importing media to your file 65
Information on the media 66

9.2 Searching media 66
Check missing media 66
Find a group of media 67
Reassign media 67
Update all media 67

9.3 Unlinking, replacing or deleting media 67
Unlink media 67
Replace media with other media 67
Delete media 68

9.4 Sharing media 68
Export a file containing media 68
Export media files 68

9.5 Photo tool 68
The Media tab 69
The Edit tab 70
The Details tab 70
The Identification tab 70

9.6 The slideshow 71

10 Overall management of data

10.1 Accessing Indexes 73

10.2 Searching and sorting 73
Search for an element in an Index 73
Manage the displayed results 73
Display all the elements of an Index 73

10.3 Consulting usage 73

10.4 Modifying data throughout the file 74
Modify upper or lower case 74
Replace an element with another 74
12.5 Constructing tree charts 95

- Edit a tree chart ........................................ 95
- Tree Chart Screen ..................................... 96
- Format the tree chart ................................. 98
- Print the tree chart .................................. 101
- Export a tree chart .................................. 101
- Save the tree chart .................................. 102

13 Exchanging

13.1 Importing and exporting data 103

- Import data in GEDCOM format .................. 103
- Import Heredis data ................................ 103
- Export data .......................................... 103
- Select the data to be exported .................. 104

13.2 Synchronize with other devices 105

- How to exchange via WiFi network? ............ 105
- How does synchronization work? .............. 105
- How to exchange without WiFi? ............... 106

13.3 Transmit without synchronizing 106

- Exchange with a Mac .............................. 106
- Exchange via iTunes .............................. 106

13.4 Publishing to Heredis Online 107

- Create a Heredis Online account .............. 107
- Managing account information ................ 107
- Managing your publications .................... 107
- Publish a genealogy to Heredis Online ........ 108
- Create and set an album ........................ 108
- Consult an album .................................. 109
- Sharing an album .................................. 110
- Private access ..................................... 110
## Functional Shortcuts

<table>
<thead>
<tr>
<th>Category</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Commands</td>
<td>115</td>
</tr>
<tr>
<td>File Management</td>
<td>115</td>
</tr>
<tr>
<td>Edition</td>
<td>115</td>
</tr>
<tr>
<td>Navigation</td>
<td>115</td>
</tr>
<tr>
<td>Data Entry</td>
<td>115</td>
</tr>
<tr>
<td>Search</td>
<td>116</td>
</tr>
<tr>
<td>Tree Chart Management</td>
<td>116</td>
</tr>
</tbody>
</table>
### 1. What can Heredis do?

#### 1.1 Entering data

**Data**
Who were your ancestors? Heredis will help you find them. Through guided and intuitive progression, you enter all the information that you have gathered on your family. You will note some odd facts: your grandfathers were cousins, a certain great-uncle was a witness to all the marriages in the family, your great grandmother was very young when she lost her parents, one couple had more than 50 years’ age difference...

**Illustrations**
You have found some photos or copies of acts? Every item of data will be shown directly in your genealogy.

Unfamiliar with the area of origin of this family branch? Geolocation will show you that they all lived in neighboring towns.

#### 1.2 Family tree charts and other documents

Your work is taking shape, you cannot wait to print the results of your research.

**Print tree charts**
The Heredis tree charts trace ancestors or descendants in different forms and adapt to all formats.

**Print reports, sheets, or fully illustrated books**
All documents which the genealogist needs are available: working papers for refining your research, index sheets for your filing system and even illustrated books for preparing a family monograph which will bring you pride and happiness to your family.

#### 1.3 Making your work known to others

What could be more simple than the publishing free online of your work on the Internet? Wherever they may be, your family and friends can visit your site and contact you to give you more details. With your family site hosted free on Heredis Online, your family bonds are facilitated, your work valued and your data preserved.

#### 1.4 Exchanging

Genealogy is an act of sharing. Heredis gives you all the tools which you need to communicate with other genealogists, give and receive information and have your work available everywhere, on all your devices (computer, laptop, Windows or Mac, iPhone, iPad).
2 Your software up-to-date

2.1 Being kept informed of all updates

Heredis updates are automatic. You do not need to bother with this. To be kept informed, simply be connected.

2.2 Reinstalling Heredis

You may reinstall the application after downloading it from the www.heredis.com site. You simply enter your license number to be able to continue your work.
3 How to start?

3.1 Launching Heredis

Double-click the Heredis icon to launch the application. For easy access, slide the icon to your task bar, wherever it is convenient for you.

3.2 Creating a genealogy file

New genealogy file
Click New Family File.

Save your new genealogy: give it a name and click OK. Heredis saves the new file in the My Documents/BSD Concept/Heredis/Heredis Files folder.

Click in the center of the square to create the first person.

The proposed data entry screen is ready and easy to fill in. Enter all known information and thus you have created the individual who is at the base of your genealogy: the Root Person.

Import a genealogy file
You have already made or you were given a genealogy created with another software program? Importing a GEDCOM file, a standard recognized in the world of genealogy, is very simple.

Click GEDCOM File in the Home Page or choose File > Import > GEDCOM File. Check the data identified in this GEDCOM file and modify if necessary, the import options by clicking Next. Click Finish to start importing data.

You can now work on your genealogy, add to it, edit it. Heredis will save your data whenever you use the Save button or press Ctrl-S.

Reopen a family tree
Select your genealogy from the list of files recently opened or double-click the .heredis file in Windows explorer.

3.3 Overall view

The main Heredis screen
At the top, menus and buttons provide access to all functions of the software.

Some buttons allow access to more detailed choices: Add (Unrelated Person), Find (Search by Number), Indexes (Given
Names. The toolbar may be modified at any time to meet your work needs: click the Customize button to add, remove or rearrange buttons on this bar.

The central part of the screen displays four tabs.

The Family tab allows you to choose between different views of the immediate family of the primary person. It develops as and when you enter data, each person taking his/her place in the organization of the family.

The Data tab allows you to add information at any time concerning the primary person and his/her immediate family.

The Lineage tab displays the ancestors or descendants of the primary person and allows you to navigate speedily through the generations.

The Search tab provides a helpful research tool to assist you in reviewing your work and evolving your genealogy.

On both sides of the main screen, there are panels which provide access to data lists or tools.

Open or hide the panels, select the display method (one at a time or both visible at the same time).

At the bottom of the Heredis screen, you find the management buttons for each panel as well as all key information concerning the genealogy which is open.

3.4 Navigating

Explore all the family branches and display the people you want to view, edit or print documents concerning to them.

Drag any person displayed on the screen to change their position: select a child and drag to the grandfather box. If this person is indeed a grandfather, a new Immediate Family screen appears.
Drag any person shown in the Tools and Search panels, or on any data entry tab input or from one panel to another: a bookmarked individual as the primary person, an individual from the Persons panel to the Bookmarks panel or as primary person, etc.

Display the Navigation square in the Tools panels, and use it as a compass. A simple click will navigate to the father, the mother, the spouse, a child or sibling. For a list of spouses, children or siblings, right-click their location on the panel.

Navigate according to Ahnentafel numbering with the Next Ancestor - Previous Ancestor arrows.

Click Root Person on the toolbar to return to the person at the base of your genealogy.

To view any person according to his number, click Find (Search by Number...) and navigate directly to the person.

Use the Back and Forward arrows to redisplay those already consulted. For a history of your browsing, hold down the mouse on the arrow next to the button and choose from the list displayed or select Navigation History.

3.5 Adding and linking persons

A click on any empty box on the Immediate Family screen will suffice for creating the parents, spouses, children and even the grandparents of the primary person. The family simply grows.

The data entry screen for a new person displays the most normally required information. Start by entering the surname and given names. They take shape automatically.

As you enter the data, you will see a list of all persons with the same name and given names appear on the right side of the screen. Heredis does all it can for you to avoid duplicates. If you think you have identified the person you want to add, do not continue typing, but select the person from the list and click Choose.

If there is no existing person displayed in the list of individuals, continue filling out the data.

The dates are displayed in full, regardless of the input format.

Most places in Western Europe and North America are made available as you type. Select the place with the Enter key or create a new place.

When the input screen is complete, click Add.

If you add a spouse, make the most of the opportunity to submit all the information concerning the marriage: what type of marriage, date and location and status of this union. Then click OK.

You can also work with other tabs, as and how it suits you. Add the parents on the Ancestors tab, or other family members on the Family Group Data tab and Extended Family tab. Complete or modify known information on the Personal Data tab.

3.6 Illustrating your genealogy

Whenever you see this display area, you may add an illustration: the photo of your great-grandfather, the photo of your christening, the scanned image of a death certificate from
These are not only images that you can attach to your data, but also sounds, videos, PDF documents, files created with your word processor.

Nothing is easier than to associate media: select it your hard drive or on the Media Index and drag to the display area.

### 3.7 Deleting

Sometimes it takes a good deal of trial and error to get things right and you can always recover your mistakes. The toolbar has a Delete button. This feature allows you to detach a person from the family without destroying the data. Permanent removal applies only to the primary person.

If the child is not the right one, cut him out by choosing Unlink Child. He can then be linked to other parents.

### 3.8 Creating a tree chart

You have collected plenty of data and you want to see an illustration of your work in a family tree chart. Heridis proposes a wide variety of tree charts, each of which can be broken down into different graphical themes.

Click Charts and choose a category of tree chart: Ancestors, Descendants or Hourglass.

Ancestors tree charts are displayed in a fixed format (from A4 to A0 or Letter to Quad Demy) and the tree charts are unlimited in size. Of course, they are printable on A4 (or Letter) pages.

When you have selected a tree chart type, scroll through the themes with the arrow keys or mouse.

When you have tested the different themes, you may select your favorites. Click the Add to favorites button at the bottom of the window, the theme is marked with an icon to distinguish it immediately from all the other themes. You have a search filter for favorite themes. Check the box to show only the favorite themes in the selection window.

Choose from the options for the type of tree chart required, indicate the number of generations to be handled, persons to be excluded or hidden, choose the orientation and overall presentation of the tree and then click OK.

The tree chart appears on the screen. Use the buttons and zoom slider at the bottom of the screen to see the entire tree chart or a detail.

Select one or more boxes to change them if necessary. To do this, wrap them by dragging the mouse or use right-click to select a branch or a whole generation.
You can then, depending on the type of tree chart displayed, change the color, change the content, rotate the boxes. All these tools are available in the tree chart panels or by clicking the **Layout** button.

In large tree charts, you may look for someone with the **Persons** panel and double-click on the name to the display the person in the center of the screen.

In the **Print Setup** panel, you can manage the size of your printer paper and resize the final size of the tree chart with ease.

Save the tree chart if you want to keep it.

To print the tree chart, click the **Print** button. You may then assemble the pages as they emerge from your printer.

---

You want your large tree chart to be printed by a professional? From the **Print Setup** panel, choose the **Export PDF** mode for easy transfer.

### 3.9 Printing documents

Heredis will create all the documents which the genealogist may require. From the **Reports** menu, you may print reports, sheets, books to enhance the scope of your genealogy, or to create working papers.

**Reports**

For example, choose **Person reports (By Name...)**.

Make your choice from the options proposed for the type of report you have selected. Click the **Options** tab to determine the information to be handled (select **Males only**). Click the **Styles** tab to define field styles and colors.

Click **OK**.
Heredis launches your normal word processor provided it can handle RTF files.

Changes in presentation can be made in the word processor that is familiar to you, then you may start printing.

A report published by Heredis in your word processor becomes a document independent of the Heredis software. This document can be saved for later re-printing or modifying.

Sheets
Select Reports > Sheets > Person sheet or Family Group sheet. They summarize all the information saved concerning the primary person displayed on the navigation screen.

Define the information you want on the sheet (show notes, mention witnesses of the events, etc.) and the format of the data (dates in full and places with the subdivision, etc.).

Click OK. You can then make even more changes in presentation or print it immediately.

Books
Your family tree has grown and you wish to share your findings with your family. The ancestors or descendants books are perfect for getting the interest of cousins or other relatives, even if they know nothing about genealogy. Choose Reports > Books > Ancestors or Descendants and select the options which suit you. You have many possibilities for presenting the document. Then launch your word processor.

None of the proposed reports suits you? Write your own custom report; you have complete freedom to create it: choice of number, headings and layout of columns, selection of contents in each column, order and style of contents.

The formatting screen of a custom report has an additional button. Click the Modify button to open the construction screen of the report, to change the default report or create your own report.

Modify an existing default report by clicking Save or create your own personal default report by clicking New Report.

You work with sheets? Heredis proposes a series of varied sheets that are easy to personalize.

3.10 Researching your genealogy
You may easily find any information you need in your genealogy by using the different tools of the Search panels. A simple search by Surname – Given Name will bring immediate results.

For a more specific result, Heredis proposes options according to events or other pertinent genealogy criteria.

By selecting the criteria to be considered, you will easily find all the descendants of Edward Brown born in Hull between 1750 and 1780, all the marriages for which you have not cited a source, or all your ancestor branch ends.
Searching by number (Ahnentafel number or User number if you have entered them) is also available by clicking the **Find** menu.

For more advanced search options, choose **Find > Multiple Search** or click the **Find > Multiple Search** button.

### 3.11 Sharing

**Publish to Heredis Online**

Heredis Online creates for you a website hosted for free, to publish your genealogy. With a few clicks, you will obtain a most pleasing site for consultation by your whole family. Anyone may give you more data via the **Contact me** link directly on your website.

Create a website which is in your image: write your own introductory message and select an illustration. All you have then to do is to invite your family and friends to visit the website.

Manage your Heredis Online account directly from your Heredis software or with your Internet browser. Change the display of your online genealogy, delete it, update your personal data, all this without exiting Heredis.

### Import/export data

Heredis is able to communicate with other genealogy applications by using GEDCOM files. Open a GEDCOM file in Heredis and transform it into a new Heredis file on the home page.

Heredis allows you to add to your genealogy all the data contained in another file. Import a GEDCOM file or another Heredis file directly to your genealogy from the **File > Import** menu.

If you wish to submit your genealogy to a correspondent who does not have Heredis, use **File > Export > GEDCOM** and send the resulting file.

In either GEDCOM or Heredis export, you can select the data to be exported: exclude confidential persons, restrict to one branch or exclude living persons.

### 3.12 Synchronizing

Heredis is open to other platforms and can exchange data with any device which has an up-to-date version of Heredis: another PC, a Mac, an iPhone, iPad or iPod touch.
Heredis will recognize all the different devices which are connected to the network, or the removable storage devices you have plugged in to your PC (USB flash drive, external hard drive).

Start the update of data on your PC with the **Sync** button then the **WiFi** button. Heredis will identify what data has been changed.

You have altered a date and added two photos from your iPhone and these changes will be updated on your PC.

Your cousin is visiting you and he has his Mac with him? Connect it to the network and give him your genealogy.

You are going to the Public Archives with your iPad? Synchronize your file first to have to hand all the information fully updated. Then if you add any new data, you will recover them on your return by turning on both devices.

You are going to your country home? Synchronize your genealogy on a USB flash drive with the **Sync** button then the **USB** button and then connect it to your home computer in the countryside. You can update your file instantly. Before leaving, synchronize your computer again with the USB flash drive and update your files with all your weekend work as soon as you return home.
4 Going further

4.1 Arranging your work environment

You may adapt Heredis to your personal work methods.

Manage the panels
Use the buttons at the top of the panels to change their display. The arrow button to the right or left will show or hide the panel.

Select **Open one panel at a time** and the panel which is open will automatically close when another panel is opened. Otherwise the panels will remain open as long as you have not clicked on the open/close triangle.

Change if necessary the width of the panels or height of the **Summary area** on the **Tools** panels. Once the cursor changes form when sliding over the limit, drag to resize the panel.

Choose the graphics
You spend many hours in front of the Heredis screen? Select the graphic environment that is best suited to your eyes and your taste.

Click the **Themes** button to change the color of the main Heredis screens.

Customize your toolbar
Click the **Customize** button to select the tools you need. Choose an icon in the left column and drag it to the desired location on the right.

To delete an icon, select it and click **Hide**.

Drag the icons and place them in the order you want. You can also add dividers between the buttons.

To display the buttons as they were when Heredis was first launched, click **Default Set**.

You need more space; then change the display format of the icons. **Untick Big Icons** and **Icons and Text**.

Select data entry method
Depending on whether or not you have a complete deed or just a mention on a website, you will not need the same input fields. This is why the Heredis data entry fields are modular. Choose between **Basic**, **Comprehensive** or **Customized** formats by clicking on the setting button in all screens dedicated to data entry.

Prepare the data entry screen to your liking by using the **Customize view** menu. Each data entry screen will then display the selected items.

Define your preferences
In the **Tools > Preferences > Heredis Preferences** menu, you may define the formats of all the various input fields. Choose how to display the names, places, numbers. Choose the default options for creating events and set inconsistency alerts.

Select your work screen
Maybe you visualize your genealogy better with the **Extended Family** or study their movements in **Migrations**? Choose this view by clicking the arrow on the **Family** tab. You work more with **Descendants**? Choose this view in the **Lineage** tab.

The view you have last used is stored for each of the **Family**, **Data** and **Lineage** tabs.

When you change a tab, the last used view is displayed.

4.2 Getting assistance during data entry

Heredis does everything to help you enter data as quickly and safely as possible.
**Enter data quickly**

**Data memorized**
Heredis memorizes all your previous data entries, item by item, and will suggest the appropriate data as you type. To validate a proposed entry, press **Enter** or **Return** keys. To choose among several propositions, use the arrow keys and then press **Enter** or **Return** keys.

**Prerecorded data**
The application is supplied with databases of places, given names and occupations.

Choose from the propositions as they appear.

Each new given name entered is automatically added to the **Given Names Index**.

Each new occupation will be added to the **Occupations Index** by clicking the + button in this section after selecting a word or a phrase. The new elements will be proposed in subsequent data inputs.

Where no proposal for a place appears or it is not suitable for you, (different spelling, place in a country not listed), enter the location and type the **Tab** key. Immediately, the **Places Index** opens.

Click + (Create a new place) to record and geotag the new place in the index. Complete the various fields for the place.

Click **OK** to confirm the new location.

**Preferences**
What ever way you may have typed data, in uppercase or lowercase, Heredis will automatically format the entry according to your pre-defined Preferences.

**Automatisms**
The **Gender** field is filled in automatically based on the given name entered, but it may be changed. Multiple given names will be automatically entered according to your initial entry, but may be subsequently altered.

Heredis calculates for you the date of birth of people based on their age at any particular event. It gives them an approximate date which you may confirm later, when you know it.

**Drag and drop**
To speed up your data entries, complete your data by using drag and drop.

Add links to other people by selecting them in the various panels and deposit them in the data field if it is empty. Select a man in the **Persons** panel and drop it as the grandfather in the Immediate Family tab. Select a woman from the **Kinship** panel and drop her over the Personal Data > Event > Christening event to make this person the godmother.

In the same way, you may add information to the Events field. Select a source from the **Sources** panel and drop it on the event you will have selected to associate it with this event. You may do the same for a place selected from the **Places** panel.

Add media already used for other data by choosing from the **Media** panel and drop them into the appropriate entry fields. A group photo can illustrate both a family and a marriage event.

**Error-free data entry**

**Consistency Control**
Heredis will check the validity and consistency of any data entry.
4.4 Entering a family group

The Family Group Data tab is designed to add easily to expanded family groups and is particularly suited for the entry of descendants.

Each generation has an adapted data entry field: parents, spouses and children and their spouses may be entered one after another.

Enter the surname and given name. Then type the date and place of the required events (Birth, Death or Marriage). To avoid duplicates, Heredis will indicate with a red arrow, any existing person who may match the person you are entering. Click the red arrow to see the list of potential duplicates. If you think you have identified the person you wish to add, stop typing and select the person from the list and then click Choose. If no person displayed in the list corresponds to your individual, continue filling out the data fields.

Each data input is validated by pressing the Ctrl Enter keys or as soon as you click outside the line. Thus without displaying any other screen, individuals are simply added generation after generation.

Each field of the Family Group Data tab is equipped with the same tools as the other input screens (modular input modes, drag and drop input, automatic formatting, real-time duplicate control).

4.5 Exploring the Indexes

You may use the Indexes for finding any data, modify or complete them, and simply navigate throughout your genealogy. Each Index gives you an overview of your data, indicates where they are used and permits you to edit them throughout your genealogy file.

As you enter all data, Heredis will record the details to the right place in the appropriate Indexes: surnames, given names, occupations, places, sources, media.
Search all the direct-line ancestors born in Yorkshire after 1800. The resulting list can be used for printing, navigating around these people but also for applying a specific treatment to them: marking them, making them into secondary or confidential persons. Click the appropriate links for defining the treatment to be applied or to print the list of results.

### 4.7 Searching for duplicates

Heredis will control for duplicates at all times during the entry of data; but the importing of data from other genealogists, or a moment of inattention may create duplicates.

This powerful tool is essential for maintaining an impeccable genealogy file. Select **Find > FindDuplicates** or click the **Duplicates** button. Research and verification is carried out easily. Choose the name, given name and event criteria to obtain the list of potential duplicates.

Heredis detects a potential duplicate? Click the **Results** tab. You may check it out in the summary of the information about the persons concerned. If there is indeed a duplicate, click the **Prepare**
Merger button and merge the two persons by selecting the most appropriate information.
5 Heredis architecture

5.1 Heredis files

Heredis creates data files (genealogies), files of tree charts and transmits data to third-party software for printing (documents).

Heredis files contain both genealogical data and media attached to the data and for this reason they take the form of a .hmw folder that contains the data file (with the extension .heredis) and the folder containing the media.

Manage files on the Home page
The Heredis Home page allows access to all types of file that Heredis can handle.

To find this screen during a work session, click the Home button in the toolbar or choose File > Home Page.

Create a new genealogy
Click New Family File. Enter a name for the new genealogy file and click OK. Heredis saves the new file in the folder Documents/BSD Concept/Heredis/Heredis Files.

An empty Immediate Family screen appears, and you may now start entering your data by clicking on the Create the First Person link at the center of the screen.

Open a recently used file
Click the box showing the file to be opened.

Info • To delete a file from the list of recent files, click the right icon and choose Remove from Recent Files.

Open an existing file
Click the file type to be opened in the Open Tree box. You can open Heredis files, including files from earlier versions, GEDCOM files (Genealogical exchange file) or chart files created and saved with Heredis Blue Suite or chart files created with previous versions as from Heredis 11.

Select the file in the explorer and click Open. Only files which match the selected file type are accessible.

Manage your Heredis Online account
Heredis Online is the service for publishing your genealogy data on a dedicated website, hosted for free, searchable by your family and friends. Thanks to this service you launch your research on www.heredis-online.com directly from your software: more than two hundred twenty million data in the online family trees published by Heredis Online users.

From the home page of your Heredis software, you manage your account, you define the parameters of your website.

Discover Heredis
• Click the Learning Center button to access training and learning pages on the www.heredis.com site or to download a sample file if not displayed in the Recent files field. The sample file gives you an overview of the functions of the software and illustrates the main topics encountered in genealogical research.
• Click Search on Hard Drive to find all files created with Heredis or GEDCOM anywhere on your hard drive. Select the file you want to open and click Open. To stop the search, click Stop at the top of the search window.

Display of genealogies
Display a genealogy
The genealogy file will open in a screen. This screen can occupy all available space on the screen, occupy only a part, or may be reduced as an icon.
Several views of the same genealogical file may be opened simultaneously: the main navigation screen, tree charts, documents, the multiple search screen...

**Display several genealogies simultaneously**

Several genealogies may be opened simultaneously with Heredis. Each file can display data differently: in *Family*, in *Data*, in *Lineage* or in *Search*.

The list of open files and all screens open for each file is available in the *Window* menu. Click the name of the file or screen you want to display in the foreground.

**Open a genealogy file**

There are several different ways to open a Heredis genealogy file.

**Open a data file**

- To open a file when Heredis is already running, choose *File > Open* or type Ctrl-O. Select the genealogy file in the explorer, and then click *Open*.

- To open a file from the Home page, click the Home button, then click *Open Tree > Heredis File*. Select the file and click *OK*.

**Info** • By default, your PC opens the *Heredis Files* folder. To find another location, select it with Windows Explorer.

- To open a file you worked on recently, display the *Home page* and select it from the displayed files. You can also select *File > Open Recent*, then the genealogical file in the submenu.

- To open a Heredis file from Windows Explorer, double-click the *.hmw* folder, then double-click the *.heredis* file, or drag it to the Heredis application icon

You may open a Heredis file created with an older version of the software (as from Heredis 2000).

**Open a tree chart file**

You have edited and saved a tree chart created with Heredis? You can reopen it to further edit it or print it.

- To open a tree chart saved when Heredis is already running, choose *File > Open*. Select *Heredis Tree Charts* in the *Open file* screen. Select the tree chart to be opened in the explorer, then click *Open*.

- To open a tree chart from the Home page, click the Home button then click *Open Tree > Chart File*. Select it in the explorer and click *Open*.

- To open a tree chart file when another tree is already open, click the *Open* button in the tree chart toolbar. Select the file in the explorer and click *Open*.

**Close a genealogy file**

When you have finished working with a genealogy file, you can close it without leaving Heredis.

- To close the active document, choose *File > Close* or press Ctrl-F4. You can also click the close button in the upper right corner of the file screen.

- To close all open Heredis documents, press the *Option* (⌥) key, then click the close button of the active document.

**Info** • If you have made changes since you last saved the file, Heredis will invite you to save it.

**Save a file**

Remember to save your file regularly during your genealogy work session. When the file has been modified, a star appears in the file name bar; it needs to be saved.

**Save a genealogy file**

Manually

Click the *Save* button, choose *File > Save* or press the *Ctrl-S*. 

Automatically
For security you can schedule automatic saving of your data.

1. Choose Preferences > Heredis Preferences... from the Tools menu.

2. Click the General tab and tick the Activate every... box in the Automatic Save field. Indicate at what frequency you want the data saving to be performed.

3. Tick the Confirm Saves box for Heredis to warn you before each automatic saving.

Save a file under another name
If, for example, you want to make a copy of your genealogy, or create a back-up copy or make several versions, you can save the file in another location.

Choose File > Save a copy and then change the name and location of the new file if necessary.

Info • You can rename a genealogy file at a later date from the home page. Click the information icon for the file in the Open Recent list and choose Rename the genealogy file...

5.2 Heredis data structure
Heredis manages all types of data related to genealogical research and organizes them logically, in order to deepen your understanding of your ancestors.

Persons
Every individual mentioned in the genealogy file: ancestor, contemporary, witness, is known as a Person.

For each person included in the genealogy file, specify:

• Identity (surname, given names, nickname, occupation, etc.). If you wish to enter information that is not proposed by Heredis, create your own user field.
• Characteristics known as flags: childless, unmarried, confidential, etc.
• A free note.
• Each person is numbered automatically according to his or her position in the genealogy but you may assign a personal number based on other criteria.
• Various events in the person's life, expanding his or her personal story, and citing sources of information.
• Media (photos, videos or other documents) to illustrate the person, unions or events.
• Personal ties. Apart from family ties, Heredis allows noting that people had a special bond. Include friends, tutors, mentors. Create 'witness' links for those present at or quoted at an event.

Surnames, occupations and locations entered may also be discussed and illustrated.

Relationships
As you build your family genealogy, you create new persons with their appropriate relationship. Any relationship can be established retrospectively.

Relationships are of two types: the parent-child and spouse relationships.

Other family ties and the position of any person in the genealogy are determined automatically from these basic links. To create brothers and sisters, you have only to create new children for parents.

• Create direct family links: father, mother or child.
• Create a spouse link (whether the union is official or not). Specify the status of the family: the spouses are married, separated, divorced...? When a person has been married several times, Heredis will number them for easy access, as well as to the children who resulted from them.
• Assign a note, pictures and events to each family created in your genealogy.

Events
To record important events in the lives of your ancestors, you may note person events (christening, military service, will...), or events shared with a spouse, called family events (engagement, residence, etc.). If you cannot find events that are appropriate, create your own definition of events.

• For each event, enter all known details (date, time, place, age stated on the record...) and add a note relating to the event.
• Specify the status of the source of information (Untraceable, found, to be researched), allowing you to edit a report of all sources to be researched.
• Declare an event as private, not to be exported or published.
• Illustrate the event with various media (photos, documents).
• Assign a source to the event, to record the origin of your information.
• Assign witnesses to the event (witnesses, registrars, godparents, etc.).

A visual cue showing the status of main events (Birth or Baptism - Marriage - Death and Burial) appears in the Persons and Branches panels, as well as in the status bar and in the Search screen.

To define the appearance of the icon, select the criteria that you feel are relevant: No missing, approximate or incomplete date - Place mentioned - Source mentioned - No 'Search Record' status in the Preferences screen. According to the criteria checked by you are met or not, the bar symbolizing the event in the icon is in the top, middle or bottom. In this icon, for example, the Birth event is partially filled, the Marriage event is not specified, the Death event is complete.

Sources
The information gathered about your ancestors will be more or less reliable depending on their origin. Assign one or more sources to each event in order to justify the information recorded.

Each source (an act, a website, a historical work...) may be detailed and illustrated at the time of its creation or later.

• For each source, specify in the proposed boxes, the title, reference, author, quality of data... A free text box allows you to enter a note or record the transcript of an act.
• You can mark a source as private in order not to export it when exchanging files, nor to publish it.
• Each source may be illustrated with media.

Once a source has been created, you may assign it to one or more events. Each event can have one or more related sources. When you assign a source to an event, add a comment indicating the link between the event and the source.

All sources entered are managed by the **Sources Index**.

**Witnesses**

Each person involved in the lives of your ancestors can be entered, be they part of the family or not. Heredis will assign persons to events (the witnesses of a marriage, the registrar for a birth, a relative present at the ceremony for a decoration etc.).

• Creating a witness assigns an individual to an event concerning another person. A witness may be assigned to one or more events, and each event can have one or more witnesses.

• Anyone entered in your genealogy plays a role, regardless of its importance and the degree of kinship. When you assign a person to an event, specify the type of link (witness, godfather, declarant...), the age of the linked person at the time of the event, and enter if necessary a suitable comment on the link.

• The information entered for the witness is the same as for any other individual: identity, flags, notes, media...

**Linked Persons**

Sometimes we know of a relationship which existed between two people, without being able to assign it to any event. You know that Paul is the uncle of John, but you do not know if he is the brother of the father or mother of John, or the husband of an aunt. You cannot create this link as a kinship. Create a personal link (Sundry Links) between Paul and John until you find the information you need to create the kinship.

• Create linked persons to declare a relationship between one individual and another person. Every individual may be linked to several other persons.

• The name of the link is determined by choosing the type of relationship and meaning of the link. You can also add a comment to the link.

**Media**

You have photos or documents; use them to complement and illustrate your family tree.

You can assign a digital image (photograph, signature, seal, etc.) sound recordings (interviews, speeches), videos or any other type of file (document prepared with a word processor or spreadsheet, PDF, HTML, etc.) to any data in your file.

• Each item of media is identified by its name, to which you can add a date and a note.

• You can make any media private if you do not want it to be broadcast.

• Media may be assigned to all types of data: person, family, event, source, name, occupation, place.

• The number of media assigned to any data is without limit and every item of media may be linked to several different data.

All media are listed and may be managed in the Media Index.

**Surnames – Given Names – Occupations – Places**

In your genealogy, you will have names, occupations and places that sharpen your interest. When you know more about them (photo of a place, story of a given name etc.), Heredis allows you to keep this information by completing each item.

The surnames, given names, occupations and places that you use in your genealogical file are automatically stored in the Indexes.

Indexes are powerful tools that play several roles: retrieve data by how they are used, link different data by themselves, illustrate your genealogy by management of your documents. Thus you enrich your genealogy and understand all the better the lives of your ancestors.

• In each Index, the surnames and given names, occupations and
places may be illustrated by a note or by media.

- The Indexes can merge similar data. They allow you to declare variants within the same category of data: such spelling of a name is a variant of another name in the file, such given name is a local variant of another given name, such a name is a variant of another occupation saved in the file.
6 Work environment

6.1 Menus and toolbar

The Heredis menus
They provide access to all functions of the software (research, printing, exchanges, backups... They vary according to the screen in the foreground (navigation and data input, indexes, editing of documents or construction of tree charts).

Customize the toolbar
The Heredis toolbar is entirely modular.

- Select Windows > Customize toolbar, or click the Customize button to display the content screen of the toolbar. All available buttons are displayed.

1. Drag the new button or a separator to the desired location in the list of visible buttons or select it and click the Show button.
2. Delete buttons by dragging them to the list of available buttons or select it and click the Hide button.

- Change display options for the icons:

1. Tick or untick Big Icons.
2. Tick or untick Icons and Text.

Redisplay the toolbar by default
1. Select Windows > Customize toolbar, or click the Customize button.
2. Click Default Set to display the original toolbar proposed by Heredis.

6.2 Display Tabs

Heredis memorizes the last viewed screen and will reopen the corresponding tab when you click on Family, Data and Lineage.

Family tabs
They are used to navigate between the different family members and create them if necessary.

The Immediate Family screen displays the family members who are close to the primary person (parents, grandparents, spouses, children).

The Extended Family screen shows the composition of the family with remarriage, stepchildren, stepbrothers and stepsisters, children from other unions of the different spouses ... noting or not when they belong to the direct lineage.

The Migrations screen positions on a map the places of the life of the primary person or any other family member. Pins are numbered to display the sequence of movements. Each place pin indicates the list of events which took place in this place. You can see simultaneously all the events of all members of the immediate family unit.

Data tabs
The Personal Data screen shows all the data entered and allows you to add or complete events for the primary person or the couple. You access the Personal Data tab for any person displayed by double-clicking on the name.

The Family Group Data screen provides a summary of the information entered for the primary person and allows you to add all the members of his/her immediate family (parents, spouses, children, step-children) without having to exit this screen.

Lineage tabs
The screen displays 4, 5 or 6 generations of Ancestors of the primary person. Change the number of generations displayed with the indented wheel icon or you may start printing the ancestry as it is displayed.

This screen is dynamic; click the arrows at the end of the line for the following generations. If necessary, you can create new ancestors.

The Descendants screen shows the number of generations of your choice. You may configure its display, with the presentation of
generations and the data format. Implex highlighting allows you to easily identify consanguine marriages. The information displayed for descendants as well as for its printing are also available from the indented wheel icon.

The Search tab
The Search tab contains a research tool for the primary person. The upper part of the screen displays known or missing information.

The lower part of the screen allows you to launch any online research with the operator of your choice. You can also restart a previous search, enter a research note, check the details of sources, media, or geographic locations for known data.

You can easily manage linear research by using the Branches panel.

6.4 Adapting the workspace

Menus and toolbar
The menus are displayed at the top of the screen as with most applications. The Heredis toolbar occupies the upper part of the displayed screen.

The menus and buttons displayed give you access to all features of the software: search, navigation, printing, exchanging, backups...

Panels
The panels contain search tools for the file or management tools for file data. You may display or hide the panels according to your needs.

Genealogy files
The genealogy file will open as a global screen. This screen can either occupy all available space, or occupy only a part, or be iconized.

Display more than one genealogy file
Each file opened can display data differently: in Extended Family mode, in Personal Data entry screen...

Display more than one workspace
Different workspace screens may be open simultaneously for the same genealogical file: navigation screen, tree chart screen, search screen...

6.3 Removable panels
The removable panels display data and tools.

Display or hide the panels
One can hide or display the Search and Tools panels on one side or the other of the screen.

Click the arrow at the top of the panels to open or close them or choose Windows > Show/Hide Tools Panels, or Show/Hide Search panels or type the Ctrl-3 or Ctrl-4 key.

Resize the panels
They are resizable in width. Click on the line between panel/navigation screen.

The cursor shape will change and you may increase or decrease the proportion of the screen allocated to the panels.

The display area of the panel is vertically adjustable in the same way.

Arrange the panels
They may be positioned to the right or left of the navigation screen. You can change their position by using the menu Windows > Swap Tools and Search panels.

Select Open one panel at a time in the Windows menu. Heredis automatically closes the open panel when you click the arrow to display the other panel.
All the screens displayed for different files open are visible in the **Window** menu.
7 Adding, linking and unlinking persons

7.1 Linking an existing person or creating a new individual?

Create the first person
You have chosen to create a new genealogy: Heredis opens an empty *Immediate Family* screen, which will fill up as and when you enter data. Now create the first person to start your new file.

Click **Create the First Person** in the center of the screen or choose **Person > Add > Add Unrelated Person**, or press **Ctrl-F8**.

The *Entering New Person* screen opens with the data boxes to complete. To move from one box to another, press the **Tab** key or click in the next box.

Heredis includes data entry aids which will save you time and avoid errors.

*Surname*
Type the name of the first person without worrying about upper or lower case. Each new name entered is integrated into the *Surnames Index*, making it available later for help with entering surnames.

*Given Names*
Type in the given names of the person. The list of given names known to Heredis appears and is updated as you type. Once you locate the given name in the list, use the down arrow to select it and then press the **Enter** key to select it. If the usual given name is not the first given name, it may be highlighted. To do this click the arrow which appears to the right of the data input area, and select from the list the usual name, or enter the usual name in quotes.

*Gender*
Gender is automatically inserted by Heredis based on the given name(s). If the given name is multiple, Heredis leaves a ?. For gender selection, click the menu or type M for Male, F for Female. Your choice will be stored for future use of the same given name. If you want to modify it later, you can do so in the *Given Names Index*, without changing the data that you have already entered.

*Occupation*
Enter the occupation of the person. This section is for the sole or main occupation the person held. You may also enter **Occupation** events, dated and detailed for any other activities. The list of recognized occupations with Heredis appears and is updated as you type. When you see the desired occupation in the list, use the down arrow to select it and tap the **Enter** to select it.

In the **Occupation** field, recognized occupations are underlined. If you type a word that is not recognized as a occupation and want to add it as a occupation, with the mouse select the word or group of words and click the + icon to the right in the box. Heredis will create an occupation that is added to the *Occupations Index*. As you leave the field, you will find that it is now a recognized occupation because it will be underlined.

*Child status*
Scroll down the *Child Status* menu and choose the appropriate option.

*Signature*
Scroll down the *Signature* menu and select Yes if the person knows how to sign, No if you have seen that he/she cannot sign, ? if you are not sure of the information.
**Flags**
They can enter additional information relevant to your genealogy.

- Click the **Childless** icon if you know this person had no offspring.
- Click the **Unmarried** icon if you know this person did not have a spouse.
- Click the **Secondary Person** icon to indicate that this person has only a minor role in your genealogy. Secondary persons in your file may be excluded from printouts, exports and publications. For example you can declare as ‘secondary persons’ all children who died in infancy so that they will not appear in your tree charts.
- Click the **Marked Person** icon to highlight the individual and apply specific treatment to him/her. A marked person may be excluded when exporting the file, or highlighted in a search, or may or may not be printed in a tree chart or a list.
- Click the **Confidential Person** icon to prevent publication of information on this person in your printouts, exports and publications.

**Main events**
Heredis distinguishes main events (Birth - Death) from minor events (Communion - Retirement - Will, etc.). The Entering New Person screen gives access to major events only. If necessary you can enter minor events in the **Personal Data** tab at any time.

**Birth**
1. Click the **Birth** event title to bring up the drop-down menu and select **Birth** or **Christening**.
2. Enter the date.
3. To enter the **Place** field, type the name of the town of birth or Christening. Once you enter the first letters of the place, Heredis proposes a list of places that may match your entry. Select a place using the mouse or use the up and down arrows and confirm the location selected with the **Enter** key. When no proposed place appears or it does not suit you (different spelling, place in an unlisted country), enter the place then press the **Tab** key. The **Places Index** opens.

Complete the information on the **Add New Place** screen to store it and confirm with **OK**.

**Death**
1. Click the **Death** event title to bring up the drop-down menu and select **Death** or **Burial**.
2. Proceed in the same way as for **Birth**.

**Further information**
To display further data fields, use the **Choose Data Fields** option (indented wheel icon).

**Validate the creation of the first person**
Click the **Add** button to validate the first person in your genealogy, or press the **Enter** key. The person appears in the center of the **Immediate Family** screen.

This individual is the starting point of your genealogy, the person called the **Root Person** and who will have the Ahnentafel number
1. Continue your genealogy by clicking on the **Add Father**, **Add Mother**, **Add Spouse** links to complete the immediate family.

**Add a person**
Each person in the genealogy file may be linked to others by ties of kinship, as a witness to an event, or as a person related in another way.

Heredis allows you to link any individual already in the genealogy file or create a new person with his/her kinship. In the **Add** or **Choose**... field, enter the surname and given name in the **Personal Data** tab. You will see in the **Matching Persons** column, appear a list of persons already entered with that surname and given name. Step by step, as you enter new letters, the list of corresponding persons will mature.

Select a person from the list and check his/her details. This allows you to compare more effectively the different individuals found.

If it appears that the person you want to add already exists, use the person already created by clicking **Choose**.
If you do not detect a possible duplicate, you can then create the new person by completing the other entry fields and click **Add**.

**Delete a person**
Heredis allows you to delete

- Either the person - then the person will no longer exist in your file.
- Or the links that bind the person to his family or to an event in which he played a role. In this case the individual will always remain in your genealogy file.

**Info** • The Root Person of the file, that is to say the individual numbered Ahnentafel 1, cannot be deleted. To remove this person, you must first reassign the number to another person.

- Place the individual in the primary person position.
- Click the X (Delete) button on the toolbar or choose **Person > Delete Primary Person** to delete the link.

**Merge two persons**
If you find a duplicate in the genealogy file (the same individual entered twice), merge the two persons to get a single person with all the information recorded.

**Merge the primary person with another person**
1. Display one of two supposed duplicates as the primary person.
2. Choose **Person > Merge with Another Person**… or click the **Merge** button on the toolbar. The **Primary Person** appears on the **Merging People** screen.
3. Select the other person by clicking the **Choose Another Person** link.
4. Click **Prepare Merger**.

**Merge as a result of a search for duplicates**
1. Start a search for all duplicates in the file from the menu **Find > Find Duplicates**.
2. In the **Results** tab of the **Search for Duplicates** screen, select the two individuals who are obvious duplicates.
3. Click **Prepare Merger**.

**Select the data to be merged**
Review carefully all the data in the merge screen to retain all relevant information.

**Organize the Merge screen**
The Merge screen contains four columns: the list of topics, one column for each of the two duplicates and one center column indicating = or +. A color code identifies the data to be stored (in blue) and the data which will be lost (in pink).

**Select the data to be retained**
At the opening of the merge screen, by default the preset boxes show the information on the person in the first column and the additional information on the person identified in the second column.

Only single events like birth, baptism, death and burial are placed in direct comparison. For all other events (travel, decoration…), with an individual possessing one or more events of this type, they will not be displayed as parallel in the merge screen.

Only unions with exactly the same spouse for both persons are compared directly. If two unions with a spouse who appears to be identical (same surname, same given name, etc.) are not shown opposite, this is because both spouses are treated as two distinct persons in the file. They are probably also potential duplicates to be processed at a later date.

Some fields allow you to retain both the data of person A and person B, such as given names, occupation or notes.

- To remove any merged data, click the item to be deselected and the topic for the other individual will be automatically deselected and will appear in pink.
7.2 Parents

Add a new person

All tabs

1. Place the person for whom you want to add parents, as the primary person.

2. Create the link.
   - Click the links in the empty boxes for the father or the mother.
   - Choose Person > Add Father or Add Mother or press Ctrl-F9 for the father or Ctrl-F10 for the mother.
   - Click the + button (Add or link persons) on the toolbar and choose Add Father or Add Mother.

3. Enter the new person
   - In the Add or Choose Father or Add or Choose Mother field, complete the entry fields with the information you have. Some items are prefilled such as the father’s surname or gender of the father and mother.
   - To change the surname, click in the field and enter another name.
   - To change the gender, simply select another gender in the drop-down menu.

Info • Click the indented wheel icon at the top right of the screen to change the display mode if all desired fields are not displayed.

Click Add. The parent is created as well as the link with the child.

Info • You can link the grandfather and grandmother in the same way.
**Family Group Data entry**

1. Click the + button at the bottom of the **Parents** entry field.
2. Choose **Add Father** or **Add Mother**.
3. Continue the data input with the information you have. To validate the new individual, click outside the entry field.

**Link an existing person**

**During data entry**

1. Place the person for whom you want to add parents as the primary person.
2. Create the link.
   - Choose **Person > Add Father** or **Add Mother** or press Ctrl-F9 for the father and Ctrl-F10 for the mother.
   - Click the + button on the toolbar and choose **Add Father** or **Add Mother**.
   - Click the links in the empty boxes for the father or the mother on the **Immediate Family** screen.

In the **Add** or **Choose Father** or **Add** or **Choose Mother** fields, select the person to be linked from the list of **Matching Persons** to the right of the screen. To limit the list displayed, you can enter the given name in the **Personal Data** area. Click **Choose** or double-click the name in the list.

**Info** • To access this screen from the **Family Group Data** tab, click the red arrow that appears on the input line.

**Drag and drop**

1. Place the person for whom you want to add parents as the primary person.
2. Drag the father or mother from one of the side panels (**Persons, Bookmarks, Kinship, Links**…), and release on the display area of the screen (Father or Mother box or Parent fields in the **Family Group Data** tab). The parent is then linked.

**Info** • Creating a link to the Father and a link to the Mother will automatically create a union between the father and mother, even if no event has been entered.

**Unlink a person and parents**

When you detach a person from his/her parents, the individuals concerned will always remain in your genealogy file.

**Info** • After you have removed the parent link, you can assign a different mother or father to the primary person.

**All tabs**

1. Place the person as the primary person.
2. Remove the link with the parents.
   - Choose **Person > Delete > Father Link** or **Mother Link** or press Ctrl-F9 for the father and Ctrl-F10 for the mother.
   - Click the X (Delete) on the toolbar and choose **Unlink Father** or **Unlink Mother**.

**Family Group Data tab**

1. Select the parent to be deleted in the Parents data entry fields.
2. Click the - button at the bottom of the field, and choose **Unlink Father** or **Unlink Mother**.

**Info** • If you select the **Delete Father and All Links**, or **Delete Mother and All Links** option, this will remove the person from your genealogy, not just the link.

### 7.3 Spouses

**Add a new person**

**All tabs**

---

**Heredis for Windows**
Enter the spouse
1. Place the person for whom you want to add a spouse, as the primary person.
2. Create the link.
   • Click the + (xx spouse(s)) sign in the display field of the spouse on the Family tab.
   • Choose Person > Add Spouse or press Ctrl-F11.
   • Click the + button on the toolbar and choose Add Spouse.
3. Enter the new person.

   In the Add or Choose Spouse screen, complete the input fields with the information you have, including details concerning the union. Gender is prefilled. To change the gender, simply select another gender from the drop-down menu.

   Info • Click the indented wheel icon at the top right of the screen to change the display mode if all desired fields are not displayed.

   Click Add.

Enter information about the family
See below.

Family Group data tab
1. Click the + button at the bottom of the Families entry fields.
2. Choose Add a Spouse.
3. Continue the input with the information you have about the union. To validate the new person, click outside the entry field.

   Info • For more information on adding the spouse of a child in the Family Group Data tab, see the chapter Enter a family group.

Link an existing person

During data entry

Choosing a spouse
1. Place the person for whom you want to add a spouse, as the primary person.
2. Create the link.
   • Choose Person > Add Spouse or press Ctrl-F11.
   • Click the + button on the toolbar and choose Add Spouse.
   • Click the + (xx spouse(s)) sign in the display field of the spouse on the Family tab.

   In the Add or Choose Spouse screen, enter the surname and given names in the Personal Data field. Select the person to be linked from the list of Matching Persons to the right of the screen.

   Click Choose or double-click the name in the list.

   Info • To access this screen from the Family Group Data tab, click the red arrow that appears on the data line.

Enter the information you have about the union.
See below.

Drag and drop
1. Place the person for whom you want to add a spouse, as the primary person.
2. Take the spouse from a side panel (Persons, Bookmarks, Kinship, Links...), and release on the display area of the screen (display area for spouses on the Immediate Family tab or the Families fields on the Personal Data and Family Group Data tabs).

Information concerning the family
The data input screen for a marriage and the Families fields on the Personal Data or Family Group Data tabs show specific fields to
be completed, as well as a field for family media on the Immediate Family tab.

1. Indicate date and place of marriage and any other information you have on the family event.

2. Specify the family status in the drop-down menu.

3. Click OK: the spouse is created as well as the link to the primary person.

Family status
Status is additional information indicating the last known status of a union. Are the spouses still married, divorced, separated?

The family status is independent of union events. One may enter a marriage event, but not enter other events for the couple, but clarify the family status as «Separated».

Specify the family status in the Add or Choose Spouse screen or Families area of the Personal Data tab.

Family number
The family number, when there are several marriages, appears in the Family Group Data tab. It is assigned automatically according to the dates of marriage. To change the family number, select a spouse and move him/her to the desired position.

Families order
Heredis enters unions based on the date of the main family event.

If you know the sequence of unions without knowing the dates, or if the chronology does not seem exact to you, you can change the families order.

Change the families order
Right-click the box of the union to move or choose Person > Families Order, then use the Before and After buttons on the Order of Spouses screen to position each union in the required order.

Return to the default order
You may cancel a manual order change of families if you have made mistakes or entered new dates. To do this, reopen the Order of Spouses screen and tick the Leave Heredis determine the order box.

Delete a family
Heredis allows you to delete:

- Either the person. In this case the person will no longer exist in your genealogy file.
- Or the family link that links two spouses. In this case both spouses remain in your genealogy file.

Info • If both spouses have had children together, you must first remove the couple’s children for the family to be deleted. When you remove the bond of union, the events that were assigned to this family will also be deleted.

All tabs
1. Place one of the spouses as the primary person.

2. Choose Person > Delete > Selected Spouse Link, or click X.

Personal Data tab
1. Select the spouse to be unlinked in the Families fields.

2. Click - (Unlink the selected spouse from the family) at the bottom of the Families fields.
**Family Group Data tab**

1. Select the spouse to be unlinked on the Families fields.
2. Click - (Unlink the selected spouse from the family) at the bottom of the Families fields.
3. Select the **Unlink Spouse** option.

---

**7.4 Children**

**Add a new person**

*All tabs*

1. Place the person to whom you want to add a child as the primary person. Select the other parent.
2. Create the link.
   - Click the + (xx child(ren)) sign in the display field of the spouse on the **Family** tab.
   - Choose **Person > Add Child** or press **Ctrl-F12**.
   - Click the + button on the toolbar and choose **Add Child**.
3. Enter the new person.
   
   In the **Add** or **Choose Child** screen, complete the entry fields with the information you have. The child's surname is prefilled with the surname of the father or the mother if you did not select a spouse for the mother.

   To change the name, click in the box and enter another name.

   **Info** • Click the indented wheel icon at the top right of the screen to change the display mode if all desired items are not displayed.

   Click **Add**. The child is created and the links with his/her parents.

---

*Family Group Data tab*

1. Click the spouse who is the other parent of the child to select him/her in the Families data entry fields.
2. Click the + button at the bottom of the Children entry fields.
3. Complete the entry fields with the information you have. The child's surname is prefilled with the surname of the father or the mother if you did not select a spouse for the mother.

---

**Info** • If you made a mistake in selecting a spouse as the other parent, simply change the Family number in the first column of the Children fields.

---

3. Continue the input with the information you have. The second part of each Child line contains data fields for the spouse of the child.

   For more information on adding the spouse of a child in the **Family Group Data** tab, see the chapter **Enter a Family Group**.

4. To validate the new person, click outside the entry fields.

---

**Link an existing person**

*During data entry*

1. Place the person to whom you want to add a child as the primary person.
2. If the primary person has several spouses, click the spouse who is the other parent of the child to select him/her.
3. Create the link.
   - Choose **Person > Add Child** or press **Maj-Ctrl-11**.
   - Click the + button on the toolbar and choose **Add Child**.
   - Click the + (xx child(ren)) sign in the display field of the spouse on the **Family** tab.

   In the **Add** or **Choose Child** field, enter the given name in the **Personal Data** field. Select the individual to be linked from the list of **Matching Persons** to the right of the screen.
Click **Choose** or double-click his/her name in the list.

**Info** • Creating a Child link automatically creates a family with the father and mother, even if no event has been entered.

---

**Drag and drop**

1. Place the person to whom you want to add a child as the primary person. Click the spouse who is the other parent of the child to select him/her.

2. Take the child from a side panel (**Persons, Bookmarks, Kinship, Links**...), and release on the display fields of the screen (children display area on the **Immediate Family** tab or **Children** on **Family Group Data** tab). The child is then linked to both parents (the primary person and the selected spouse).

---

**Order of children**

Heredis places children according to their date of birth.

If you know the order of the children without knowing their dates of birth, or if the chronology does not seem exact to you, you may change their order of display.

---

**Change the order of children**

Right-click any box of the children to move or choose **Person > Children Order**, then use the **Before** and **After** buttons on the **Order of Children** screen to position each child in the required order.

---

**Return to the default order**

You may cancel a manual order change of children if you have made mistakes or entered new dates. To do this, right-click the list of children and choose the **Automatically sort children** option...

---

**Unlink a child and his/her parents**

**All tabs**

1. Place the child or one of the parents as the primary person.

2. Delete the parent-child link.

   - If the primary person is a parent, select the child to be unlinked from the list of primary person’s children. Choose **Person > Delete > Selected Child Link** or click the **X** button in the toolbar and choose **Unlink Selected Child**.

   - If the primary person is a child, choose **Person > Delete > Father Link** or **Mother Link** or click the **X** button on the toolbar and choose **Unlink Father** or **Unlink Mother**.

---

**Family Group Data tab**

1. Select the child to be unlinked from the Children fields.

2. Click the **-** button at the bottom of the field, and choose **Unlink Child**.

   **Info** • If you select the **Delete Child and All Links** option, you will remove the person from your genealogy file, not just the link.

---

**7.5 Witnesses**

Based on the act or document that you possess, indicate who are the persons who attended the event, or who are cited (witnesses, those present, registrar, etc.).

Witnesses are displayed on the **Personal Data** tab. For each selected event, you may access them by clicking the **Witnesses** tab. If at least one person was linked to the event, a visual indicator (blue bar) is displayed on the **Witnesses** tab, in the list of events, and in the **Links** panel.

---

**Add a new person**

1. Click the **Witnesses** tab in the event information fields.
2. On the button bar at the bottom of the Witnesses fields, click + (Link a witness to the event).

3. The **Associate a witness to**... fields open. Enter the information you know about the person.

4. Click **Add**.

**Link an existing person**

**During data entry for an event**

1. Click the **Witnesses** tab in event information fields.

2. On the button bar at the bottom of the Witnesses field, click + (Link a witness to the event).

3. The **Associate a witness to**... screen opens. Enter the surname or first name in the **Personal Data** field and select the person to be linked from the list of **Matching Persons** to the right of the screen. Click the **Choose** button or double-click the name in the list.

4. Complete the information field on the link and press **OK**.

**Drag and drop**

1. Select the event concerned on the **Personal Data** tab.

2. Take the person to be linked from a side panel (**Persons, Bookmarks, Kinship, Links**...), and release him/her on the information fields of the event.

3. Complete the link information fields and press **OK**.

**Add a new person with his/her witnesses**

To add witnesses to an event during the data entry for a new person, use the **Comprehensive** or **Customized** display mode by clicking the indented wheel icon at the top right of the **Add or Choose**... screen...

1. Disclose the **Witnesses** field (click the disclosure triangle if it is folded).

2. In the button bar at the bottom of the Witnesses field, click the + button.

3. The **Associate a witness to**... screen opens. Enter the information you know about the witness and click **Add**. Or select an existing person and click **Choose**.

4. Provide information on the link with the witness and press **OK**. The witness is added to the Witnesses fields of the input screen.

5. Enter another witness or continue typing the data for the primary person.

**Change a Witness link**

Every person in the genealogy file may be assigned to one or more events. Enter the information known about his/her role in the event.

Change or supplement this information on the **Personal Data** tab.

1. Select the event and click the **Witnesses** tab.

2. Select the **Witness link** to be changed and click the **Edit and modify the link with the selected witness** button (shown as a pencil), or double-click the line.

3. Edit the information of the link.

**Role**

Specify the role of the person in the selected event: it may be a participant in the event (witness, religious officiant, godfather, etc.) or be quoted as not having participated (deceased relative, lawyer who has registered a contract, etc.).

Choose the role to assign from the drop-down menu.

**Age**

- **Age on record**: many acts indicate the age of the witness on the day of the event. Fill in the field **Age/Record**.

- **Effective Age**: to help you verify the choice of an existing person as a witness, Heredis calculates and displays their actual age on the
day of the event. If it is very different from the age on the record, you have probably selected a homonym. Cancel the link and select another person or check the dates which may be incorrect.

If the witness has no known date of birth, the age on the record allows Heredis to calculate the date of birth automatically.

Comments
Type a comment on the link between the person and the event. In most cases, you will use here references to occupation, residence and kinship as shown on the acts.

Once you have validated the entry or modification of the witness, the comment appears in the list of witnesses.

Unlink a witness and an event
1. On the Personal Data tab, select the event and click the Witnesses tab.
2. On the bar at the bottom of the event, click - (Unlink the selected witness from the event).
3. Press OK to validate and the person is detached from the event but remains available in your genealogy file.

7.6 Other linked persons

The concept of a linked person allows you to specify a link between two persons when:

- The kinship is uncertain. You know that Paul is the uncle of John, but you do not know if he is the paternal or maternal uncle, or the husband of an aunt. Create a personal link between the two individuals until the exact kinship may be determined.
- There are no events to link the two persons. You know that Jeannine was a friend of Maria. Create a personal link (Sundry Link) Friend between these two persons.

Linked persons are displayed on the Tools panels. Click the Sundry Links tab to add, edit or delete them. When at least one person is linked, a chip is displayed on the Links tab. The personal link appears in the Links panel of both related persons.

Add a new person
1. Click the Links tab of the Tools panels.
2. In the button bar at the bottom, click + (Add a link to the primary person).
3. The Linking a Person to... screen opens. Enter the information you know about the person.
4. Click Add. You may access the detailed data of that person later if you wish to expand on the information about the person.

Personal links with an existing person

Personal Data tab
1. Click the Links tab of the Tools panels.
2. On the button bar at the bottom, click + (Add a link to the primary person).
3. The Linking a Person to... screen opens. Enter the surname and given name in the Personal Data fields and select the individual from the list of Matching Persons to the right of the screen. Click the Choose button or double-click the name in the list.
4. Complete the information fields for the link and press OK.

Drag and drop
1. Click the Links tab of the Tools panels.
2. Drag the person to be linked from the Immediate family tab or in the Persons tab of the Search panels, and release on the Links tab.
3. Complete the information fields on the link and press OK.
Change a personal link

Every person in the genealogy file may be linked to one or more individuals by a personal link. Indicate the information known about the nature of the link in the input fields.

Change or supplement the information in the **Links** tab of the **Tools** panels.

1. Click the **Links** tab.
2. Select the link to edit by clicking the name of the related person. If the link is closed, click the arrow to display the name of the linked person.
3. Click the **Edit and modify the selected link** (indicated by a pencil), or double-click the line.
4. Edit the information concerning the link.

*Type of link*

Choose the type of link between the two persons from the drop-down menu.

The position of the two persons may be meaningful (Mark is the heir of Peter therefore Peter is the testator of Mark), or non-differentiating (Maya and Brenda are friends).

**Info** • You can rename an existing link by entering a different type of link in the **Modifying the Link** screen. For example, type Spiritual Leader in place of Another link, or Universal Legatee in place of Heir.

*Direction of the link*

Check the link in the window title (Is Mark really said to be the heir of Peter, or the testator?).

To change the link, click the **Swap the link** icon (directional arrows).

*Comment*

Type a comment justifying the link between these two people.

Once you have validated the entry or modification of the linked person, the comment will appear on the **Links** tab once the individual has been selected in the list of links.

The appropriate type of link is specified in the **Links** tab for each of the two persons and the comment of the link is identical.

**Unlink a person**

1. On the **Personal Data** tab, open the **Links** tab of the **Tools** panels.
2. On the button bar at the bottom, click `-` (Unlink the selected person).
3. Validate with **OK** and the personal link between these two people no longer exists, but both persons remain available in your genealogy file.
8 Adding and changing information

8.1 Data entry mode

Heredis allows you to display only the information that you commonly use. This visual selection mode in no way changes your data, which are still preserved whether or not you display them. You can change the display mode at any time.

There are three display modes (Basic – Comprehensive – Customized) that you may use in different ways depending on the data input screen (Add or Choose... screen, Personal Data tab, Family Group Data tab).

In Basic mode, the information displayed is by default. This mode displays only the main fields. You can change the data input mode at any time.

Change the data entry mode
1. At the top right of the input screen, click the indented wheel icon (Choose data fields you wish to use).
2. Select the desired mode.
   • To show only the main fields, use the Basic mode.
   • To make use of all the input fields, use the Comprehensive mode.
   • To display only the information that interests you, select the Customized mode. This mode will display only the items you have selected in the Customize personal data view screen.

Personalize the data entry mode
1. Click the indented wheel icon (choose data fields you wish to use).
2. Choose Customize View.
3. Tick the items of information to appear in the Add or Choose... screen. You will proceed in the same way for data entry and display on the Personal Data tab or the Family Group Data tab. The items chosen may be different in the various screens. Confirm with OK.

Check the items not displayed
If you choose the Basic or Customized display modes, it may happen that certain information entered does not appear. Heredis alerts you by displaying an alert triangle next to the indented wheel icon (Choose data fields you wish to use).

Click the alert triangle: the display is changed temporarily and all saved data items are displayed.

When you navigate to another person, the data items are again hidden in accordance with the mode you have chosen.

8.2 Identity of persons

Identity fields

Surname
Type the surname of the person, without worrying about upper or lower case. Heredis includes various data entry aids which allow you to save time and avoid errors. Each new surname entered is added to the Surnames Index.

Prefix
The Prefix is used to specify an attribute found often in an old act, such as Lord, Sir, Reverend..., or in more recent documents, such as Professor, Master, Doctor...

Suffix
The suffix specified is assigned only to the surname of the person being entered. You can add references such as ‘Senior’ or ‘Junior’ or assumed names.
**Given Names**
Type the different given names of the person. The list of given names known to Heredis appears and is updated as and when you type. Once you have located the given name in the list, use the down arrow to select it and then press **Enter** to select it.

If the usual given name is not the first given name, it can be highlighted. To do this, click the arrow to the right of the field for entering given names, and select the usual name in the list.

**Info** • The usual given name may also be highlighted by entering it with quotation marks.

**Gender**
The gender of the person is automatically filled in by Heredis, according to the given name entered. If you want to change it, or if you typed a given name unknown to Heredis or for a multiple given name, type **M** for Male, **F** for Female, or leave ? for persons whose gender is unknown.

**Nickname**
The display of a nickname will be preceded by aka.

**Occupation**
Enter the occupation of the person. This item should contain the sole or main occupation he/she held. You may also enter as events any other dated and detailed occupations, for other activities. The list of recognized occupations with Heredis appears and is updated as and when you type. When you see the desired occupation in the list, use the down arrow to select it and press **Enter** to select it.

In the list of Occupations, recognized occupations are underlined. When you type a word not recognized as an occupation, you may add it to the list of occupations available. Select the word or phrase with your mouse and click the arrow to the right in the input field. Heredis will add the occupation to the **Occupations Index**. When you leave this field, you will find that the occupation is now recognized as it is underlined.

**Title**
Indicate here any title of nobility or honorary title.

**User number**
This number corresponds to any personal numbering system you may wish to set up (numbering by genealogical areas, identification numbers...).

**Automatic formatting of data**
When you enter a surname or given names, you can type them in either uppercase or lowercase. If the **Uppercase** option has been selected in **Preferences**, a surname or a given name typed in lower case will be automatically converted to uppercase, including accented characters. If the name contains a particle it will remain in lower-case.

If you have chosen in **Preferences** the **Initial Caps** option, the surname or given name's first letter will be automatically converted to upper case, including accented characters.

**Automatic filling of fields**
Heredis includes databases of several thousand names and occupations. In addition, Heredis stores all the information you enter, item by item.

Type the first letters: immediately appears the list of already stored data that may match your entry.

Continue with new letters, the list is updated.

Use the keyboard arrow keys to select the desired item and press **Enter** or click the proposed item with the mouse.

The Auto-fill tool is available for all input fields, with the exception of notes and comments.
**Signature**
Scroll down the **Signature** menu and select:
- **Yes** if the person knows how to sign,
- **No** if you have observed that the person does not know how to sign,
- **?** if you do not have any information.
You can choose which option is the default for each new person entered in **Tools > Preferences > Heredis Preferences > Format**.

**Child status**
Scroll down the **Child Status** menu to choose the appropriate option.

**Flags and their use**
Placed alongside the **Child Status** field, the clickable flags icons correspond to various characteristics of the person. They allow you to enter additional information relevant to your genealogy.
You may change the flags assigned to a person or to a list of individuals.

**Childless**
Click the **Childless** icon if you know that the person had no offspring.

**Unmarried**
Click the **Unmarried** icon if you know that the person never married.

**Secondary Person**
Click the **Secondary Person** icon to indicate that this person has only a minor role in your genealogy. Secondary individuals in your file may be excluded from printouts, exports and publications. You may, for example, declare secondary all children who died in infancy so that they are not in your tree charts.

**Marked Person**
Click the **Marked Person** icon to highlight an individual and apply specific treatment to this person. A marked person may be ignored when you export the file, may be selected with specific research tools, may or may not be printed in a tree chart or a report.

**Confidential Person**
Click the **Confidential Person** icon to avoid publishing information on this person in your printouts, exports and publications.
Click again the icon to deactivate.

**User fields**
On the **Personal Data** tab, you may display up to 13 different user fields for data entry that Heredis has not covered.

1. On the **Personal Data** tab, click the **User Fields** tab. Click the **Edit and modify user fields** icon shown in the form of a pencil.
2. Tick the items you wish to use in this genealogy.
3. Enter a field name.
4. Using the drop-down menu, indicate the type of information that you enter in each field displayed. The data that you enter in these fields will be recognized and treated accordingly with GEDCOM format exchanges.
5. Confirm with **OK**.
   In the **User Fields** tab, you may complete the additional fields that you have created for this file.

**Delete user fields**
1. Click the **User Fields** tab, then the **Edit and modify user fields** icon shown in the form of a pencil.
2. Untick the fields you no longer wish to be used in this genealogy.
8.3 Placing persons

**The Root Person**

The root person is the individual who is at the base of your genealogical research. By default, Heredis defines the first person entered in the genealogy file as the root person, with Ahnentafel No. 1.

**Access the Root Person**

- Click the **Root button** on the toolbar.
- Choose **Find > View Root Person** or press **Ctrl-1**.

**Change the Root Person**

1. Display the new person to be at the base of the open genealogy file.
2. Choose **Person > Modify Root Person**...

The new root person will carry the No. 1 and all Ahnentafel numbers are redefined accordingly by Heredis.

**Genealogy numbering**

A genealogical research can lead to the processing of thousands of people, some bearing the same name and sometimes the same given name over several generations.

In order to identify ancestors and position them with relation to other persons, various numbering systems have been developed and are commonly used by genealogists.

**Ancestor numbering**

The method for numbering ancestors is called Ahnentafel. The number assigned to a person will identify the gender and position of any individual in direct descent (it does not apply to collaterals).

The three basic rules for Ahnentafel numbering are:

1. Even numbers are assigned to men and odd numbers to women.
2. For every couple, the woman’s number is the equivalent of the number of the man + 1.

3. For every father, a number is assigned equal to twice that of his son or daughter.

The person whose ancestry is being researched bears the N°. 1 (irrespective of gender). This is the person who is at the base of the genealogy file. He/she is called the Root Person.

The father of the root person is N°. 2 (twice the N°. 1), his mother N°. 3 (N°. 2 + 1). His paternal grandfather is N°. 4 (double the N°. 2), his paternal grandmother N°. 5 (4 + 1). His maternal grandfather is N°. 6 (double the N°. 3), his maternal grandmother N°. 7 (6 + 1), etc.

Thus each ancestor is traceable from his/her number: No. 599 is a woman (odd N°. and is the wife of N°. 598. She is the mother of N°. 299, who is a woman, and who is the mother of N°. 149, etc.

This numbering is displayed on the data entry and navigation tabs, in the panels and in the different documents and tree charts. It is automatically calculated by Heredis.

Identifying the Ahnentafel lineage
You may identify persons who belong to the Ahnentafel lineage by the symbol preceding their names.

Heredis identifies each person with an icon indicating its gender (blue for men, purple for women and green for persons whose gender is unknown). If the person is a direct ancestor of the root person, the head of the icon is yellow.

The primary person’s number is displayed in the status bar. If a marriage between blood relatives in his/her ancestry has created a duplicate line (implex), the primary person’s number is followed by the ++ signs. Click the Ahnentafel number to display the list of all the number the primary person bears.

Navigating in the direct lineage
The direct line navigation buttons are available in the Navigation panel.

If the primary person displayed is part of the direct lineage of the root person, the View previous direct-line ancestor and View next direct-line ancestor arrow buttons allow you to move up or down the genealogy, generation by generation, without overlooking a single ancestor.

Descendant numbering
Heredis uses d’Aboville numbering to treat individuals listed in a descending genealogy.

The three basic rules for d’Aboville numbering are:

1. Each child bears the number of his father or his mother followed by the number of his/her order of birth.

2. Then one proceeds by adding the order number of birth for each generation.

3. A letter distinguishes the different unions.

D’Aboville numbering allows you to know the number of generations separating an individual from his/her ancestor and from which branch of the family he/she comes.

Thus you will identify the progeny of a person: the eldest is N°:1, the next youngest N°:2, the very youngest N°:3, etc. The two children of the eldest are numbered N°. 1-1 and N°. 1-2. The child of the first husband of the youngest bears the number N°. 2-1a, those of the second husband are numbered N°. 2-2b, N°.2-3b and N°.2-4b. The only child of the youngest is numbered N°.3-1.

D’Aboville numbering may be displayed on the different descendant documents and tree charts.

Implex
The same person may appear several times in an ascendancy, and appear in several branches of a tree. This is due to consanguineous marriages.

The ratio between the total number of ancestors and the number of ancestors that really exist (smaller) is called the Implex rate. One person may therefore bear several Ahnentafel numbers.
Imagine that Jack marries Marianne. However, Jack’s father was the brother of the grandfather of Marianne. Jack and Marianne therefore have common ancestors, which will appear in two different branches of the family tree.

Heredis manages the different numbers automatically.

### 8.4 Events

Click the **Personal Data** tab to view, enter or modify the events in the life of the primary person.

Heredis distinguishes between individual events which the person has lived and the events he/she has experienced with each of his/her spouses.

The list of events displays chronologically all events in the life of a person and the family events may be identified by the order of families concerned.

After creating an event, you may complete or modify it at any time.

#### Add an event

##### Add a person event

1. Click **Add a person event** on the bar below the list of events. To facilitate the selection of the event, Heredis displays at the top of the list, the major events, then the other events already in use in your genealogy file, and finally the events not yet used.

2. Select the desired event, for example, Will. Will is added to the list of events of the person.

**Info**  •  You can also add major events by clicking the **B, C, D or B** buttons (Birth - Christening - Death - Burial) placed below the events list. If these buttons are not visible, change the input mode of the screen.

---

#### Add a family event

1. Select the spouse of the event from the list of families.

2. Click the + button on the bar below the list of events.

**Info**  •  You may also add the main events of the family by clicking the **M, rM, Mc** buttons (Marriage - Religious Marriage - Marriage Contract) below the events list. If these buttons are not visible, check the display mode of the screen.

3. Select the desired event, such as Engagement. Engagement is added to the list of events of the person.

**Info**  •  The family events also appear in the input and navigation screens of the spouse.

---

#### Create events not proposed by Heredis

You may add events that are not mentioned in the list of events proposed by Heredis.

1. Click the + buttons on the bar below the list of events.

2. Choose **Ready-to-use events**, then the neutral event called **Event Misc**.

3. Double-click the event that has appeared in the list of events. The **Edit Event...** window opens.

4. Enter the new name of the event.

Now this new type of event will automatically appear in the list of events to create. However, you can choose not to display it from the events management screen.

**Info**  •  If the nature of the event to create already exists, modify an existing type of event in the same way. For example you can create a Estate event by renaming a Will event. You will find this event in a submenu of the original event. By selecting Will, you can choose between Will and Estate.
Share a person event
Heredis allows you to share a minor person event with other persons in your genealogy. This event and all information relating to it will be automatically available to all participants in the event.

Select a person event in the list of events displayed in the input screen > Person event and then click the Share button below this list. The Witnesses tab is replaced by the Participants tab and allows you to add the other persons sharing this event.

It is possible no longer to share an event. With this operation, the event no longer to be shared remains associated with the primary person on the screen. Other participants become mere witnesses and the “unshared” event no longer appears in their list of events.

In the list of events for a person, the letter S, displayed in front of an event, indicates that this event is shared.

Info • the major person events - Birth, Baptism, Death and Burial - are not shareable. The Domicile couple event is also shareable.

Customize the display of events
Heredis can present the list of available events according on your work habits. Thus, you will have easy access to the events that you create most often.

The customization affects only the list of events to create and there is no risk to your data, events already created remaining always displayed.

Modify the list of events displayed
1. Click the Add a person event or Add a family event buttons on the Personal Data tab, in the events list.
2. Choose Customize...
3. Untick rare events, those which you rarely use, to lighten the list when creating a new event.

Heredis always shows major events at the top of the list, and events that you have not yet used at the bottom of the list. You see now that the Other Used Events part no longer contains the items you have unticked.

You may always tick any new hidden events to make them reappear.

Information on the event
The detail of each selected event is available on the Personal Data tab. If you do not see all the events, change the display mode of the Personal Data tab.

Date
To enter the date, numerous input options are available, whatever the period concerned, in four different types of calendars: Gregorian, Julian, Hebrew or Republican.

Time
Time may be specified as 05:30 or 5:30. To separate hours and minutes, you can type either : or H or h, with no spaces.

Age on record
Enter the age stated on the deed if it exists, by entering the number of years in numbers. Any other word may not be recognized.

If the birth date of the primary person is known, you may compare the age on the act with the actual age shown in the list of events.

If the date of birth is unknown, Heredis will automatically complete the field with an approximate date calculated from the age on record that you entered.

Place
Indicate the location where the event took place.

Entering a new place
1. Type the name of the city in the Place field, not bothering about upper or lower case. With the first letters, Heredis proposes a list of places that may match your entry.
Place Subdivision
The Place Subdivision field is to specify a more precise location than the city: the hamlet, parish, district or borough of a large city.

Cause/Information
The Cause/Information field allows you to specify the cause of the event (as for Death, Divorce, Professional transfer events) or any useful precision.

Event Note
Enter your comments about the event directly into the note field. To embellish the entered text, click the pencil icon. Heredis opens the note in a separate screen containing all the formatting tools. Tick the Private Note box to exclude the Event Note from exports or printed documents.

Other elements linked to the event
The Details tab of events displays a Private Event box. When this box is ticked, all data in the event may be excluded from exports or hidden in printouts.

To help track your research, for each event, Heredis proposes what action you should take. Specify the status of the source in the drop-down menu. Choose No Search Record, Search Record, or Untraceable Record, whichever corresponds to the event entered. You may choose the default option for each new event in Tools > Preferences > Heredis Preferences > Format.

Each event may be completed with witnesses, sources, media and an interactive map showing where the event took place. Each of these elements is available in a tab on the Event screen.
Recognized calendars

Heredis treats dates entered in 4 different calendars: Gregorian, Julian, Hebrew and Republican. The dates must be between the year 4712 BC to the year 3454 AD of the Gregorian calendar.

The Gregorian calendar used today in most countries of the world, was promulgated in 1582 and applied at widely varying dates in different countries (from the fourteenth to the twentieth century). Dates prior to the promulgation of the Gregorian calendar are considered as being expressed in the Julian calendar.

The Julian calendar was abandoned in favor of the Gregorian calendar. Certain countries retained it until the twentieth century.

The Hebrew calendar is used in documents of the families of Jewish faith, regardless of the country where they live.

The Republican calendar was used only in France and covers the period from September 22, 1792 to January 1, 1806.

Entry of dates

Heredis handles dates expressed in numbers (using the separators . or /, or spaces), or the dates expressed with the month in letters (entered in full or abbreviated).

A date may be entered in the Gregorian, Julian, Hebrew or Republican calendars. If there is no month name which is characteristic of a Hebrew or Republican calendar, Heredis considers that the date entered is expressed in the Gregorian calendar.

To enter an incomplete date in the Hebrew calendar, precede it with the letter H (1987).

To enter a date expressed in Julian after December 10, 1582, precede it with the letter J (J June 23, 1654).

To enter a date expressed in the French Republican calendar, enter the year in numbers, Roman or Arabic, preceded or not by the word «An». Enter comp for additional days (for example, 6 comp An III for the sixth complementary day of the year III of the Republic).

Recognized formats

For Heredis to decode the date according to your desired entry order, choose Tools > Preferences > Heredis Preferences > Format and select the order of elements of the date you want (Day/Month/Year or Month/Day/Year).

The date of 2 February 1794 may be entered in the following way, if you have determined the order day/month/year.

Gregorian calendar
• 2 February 1794
• 2 Feb 1794
• 02/02/1794
• 02.02.1794

Julian calendar
• 2 February 1794
• J 2 Feb 1794
• J 2 /02/1794
• J 02.02.1794

Hebrew calendar
• 2 ADAR1 5554

Republican calendar
• 14 Pluviôse an 2
• 14 pluv an II
• 14 pluv 2
• 14 pluviôse II

Info • For every printed document and for each exported file, tick the Use Gregorian Dates option. Some other genealogy programs do not deal with the different calendars in their GEDCOM imports; it will thereby be compatible with all programs.

Approximate dates
Heredis manages the chronology of events based on the dates entered, exact or approximate. Use keywords to express the approximate dates.

**Before**
Type the word *before* or the symbol `<` followed by a space or the symbol `/` with no space and then type the full date or not, in numbers or in words.
- before 23 August, 1845
- `< 23/8/1845`
- `/23.08. 1845`

**After**
Type the word *after* or the symbol `>` followed by a space, then type the full date or not, in numbers or in words. Or type the symbol `/` with no space after the date.
- after 6 June, 1774
- `after 6/6/1774`
- `6.6.1774/`

**About**
Type the word *about* or the abbreviation *abt* or the symbol `~` followed by a space, then type the full date or not, in numbers or in words.
- about February 1811
- `abt 2 1811`
- `~2.1811`

**Between / and**
Type the words *between* and *then* and or the symbols `<>` and `&` and then type the full date or not, in numbers or in words or type the symbol `//` between the two dates with no spaces.
- between 11 October 1914 and April 1917
- `between 11/10/1914 and 4/1917`
- `<> 10 November 1914 & 04 1917`
- `11.10.1914//4.1917`

Before any date, complete or incomplete, you may add the following keywords:

- **Estimated** or **est** to indicate that a date is a mere guess. In this case it is displayed preceded by the **estimated** or **(est)**. It is taken into account in chronology screening (e.g. order of families, order of the children...) but it is excluded from printouts.

- **Calculated** or **cal** to indicate that a date has been obtained by calculation. For example if you do not know the birth date of a person but you have found the age at death on the death certificate, the software automatically displays a calculated date of birth. The user may also enter a date named **calculated**, being the result of deduction. The calculated dates are displayed and printed preceded by the words **calculated** or **(cal)**.

**Automatic calculation of birth dates**
Heredis automatically calculates the date of birth of persons whose age is known at any given event. The age of the father, mentioned in a birth certificate, allows you to create or complete the father indicating the probable year of birth. This will make it easier to find the birth certificate of the father, thus advancing your genealogy.

*For the person living the event*

1. Create an event and specify the date.
2. Add the witnesses (witness, declarant, etc.), and specify their age in the **Age/Record** field of the input screen for the link.

*Info* ● Remember to choose the **Customized** or **Comprehensive** input mode to display this field.

*Witnesses to an event*

1. Create an event and specify the date.
2. Add the witnesses (witness, declarant, etc.), and specify their age in the **Age/Record** field of the input screen for the link.
8.6 Places

Heredis attaches considerable importance to the places where your ancestors lived. By its structured data entry, it identifies places in many countries and views them on an interactive map. You get closer to the lives of your ancestors by discovering their geographical environment. Did they live in a forest, near a river, in a large city or small village?

Info • You were using software that did not have a defined structure for places? Heredis studies your GEDCOM file and identifies the largest possible number of locations, offering you this essential feature for effective knowledge of your past.

Places assigned to events are displayed in the Personal Data tab. You can consult the list of all places in your genealogy in the Places panel or in the Places Index.

Assign an existing place to an event

Drag and drop

1. Select the event from the Personal Data tab.
2. Drag the place from the Places panel and drop it on the display area of the event. The place is displayed in the Place field. Other details of the location are displayed above the Place field.

In the Details fields of the event

1. Type the name of the place in the Place field, without bothering about upper or lower case. With the first letters, Heredis displays a list of places that may match your entry. The displayed list offers in the upper part, places already registered in this genealogy, and below the places recognized by Heredis.
2. Select a place using the mouse or use the up and down arrow keys and confirm the place selected with the Enter.
Create a new place and assign it to an event
If no proposed place matches the place you want to enter, enter the full name of the place then press the Tab key.

Heredis opens the Places Index and the data entry screen for a new place. Complete the various administrative details of the new place, and press OK. The new place will be added to the Places Index.

Input fields for the place
Each administrative item has a separate input field. This organization method allows you to edit documents by town, region, country and facilitates the geolocation of the place where your ancestors lived.

Complete the fields City – Postal Code – County – State/Province – Country.

If you know them, you may also complete the Latitude and Longitude fields. However they will be filled automatically when the geolocation of the town will be done on the Map tab.

Create a new place to be assigned later
1. Display the Places panel or open the Places Index.
2. Click + (Add New Place).
3. Enter the name of the place. With the first letters, Heredis proposes a list of known places which may match your entry. By choosing one of these known places, the different administrative fields and geolocation of the place will be filled in automatically.

Info • Remember to tick the countries for which you would like suggestions for places using Tools > Preferences > Heredis Preferences > Countries.

If no place corresponds to the place you want to enter, complete the input field with the various administrative levels of the new place and press OK.

A new place has been created but it is not yet assigned to an event. This place will now be proposed in the list of existing places when you type in the Places field of an event.

Information for the place
The input and modify screen of the place contains items to be filled in, a zone for display of media associated with the place, a Note tab and a Map tab.

Input fields for the place
Each administrative item has a separate input field. This organization method allows you to edit documents by town, region, country and facilitates the geolocation of the place where your ancestors lived.

Complete the fields City – Postal Code – County – State/Province – Country.

If you know them, you may also complete the Latitude and Longitude fields. However they will be filled automatically when the geolocation of the town will be done on the Map tab.

Place Note
Enter information about the place in the Note field, for example the history of this place. You have available the text editing tools to format the note.

Tick the Private Note box to exclude exports of the note or printed documents.

Media assigned to the place
To assign one or more media to a place, click the + (Add a Media) button or the access button to the Media Index in the display field of the media.

Geolocate a place
When the place is recognized by Heredis, it is geolocated. In this case, the latitude and longitude are inserted automatically and the map of the location is displayed in the Map tab of each event where it is used and in the Places Index.

Info • View places not geolocated in the Places Index by clicking on the Latitude or Longitude fields. If these fields are empty, you will have to create the geolocation manually.

1. Double-click the place in the Places Index or click the pencil icon (Modify Selected Place) to open the entering/modifying screen for the selected place.
2. Click the Map tab and select one of the places proposed by Heredis in the Suggestions field. Heredis searches in various global databases to identify the place you entered.

If no proposal is displayed, type the name of the place in the Suggestions search field or the name of a nearby location, then click Search.

Info • This function is only available if you are connected to the Internet.

3. Click each of the proposals and observe the map that is displayed to clearly define which corresponds to the place you entered.

As you check the different proposals, the empty input fields (especially the longitude and latitude fields) will be simulated in blue.

4. Refine your entry.
   • Click Fill up to geolocate the place with the appropriate proposal while retaining the elements that you had already entered.

Info • This will retain your original entry for the old name of a province or administrative division that has been changed.

• Click Replace should you have entered incorrect data for this place. Heredis replaces the contents of input fields with the information found online.

Validate the input/modify screen by clicking OK to complete the changes to the geolocation of the place.

Choose the recognized places

Because your ancestors probably lived in your home country or are from a limited number of other countries, you can limit the list of countries for which places will be suggested during the data entry.

1. Choose Tools > Preferences > Herdis Preferences > Countries.
2. Check the different countries where you are likely to have places to enter.

The places proposed during data entry in the Add or Choose..., Personal Data, Family Group Data or Places Index tabs will be limited to those countries.

8.7 Sources

Heredis may assign any number of information sources to each event.

Each source is an independent element, which is then assigned to one or more events. Heredis allows you the flexibility to create a source and then assign it to the events in question, or at the same time to create both the source and its link to the event.

Sources assigned to the events are displayed in the Personal Data tab. If at least one source is assigned to the event, a visual indicator (green bar) appears. Select the event and click the Sources tab.

Info • You may consult the list of all sources in your genealogy in the Sources search panel or in the Sources Index.

Assign an existing source to an event

By drag and drop
1. Select the event from the Personal Data tab.
2. Drag the source in the Sources panel and drop it in the display field of the event. The source is then assigned.

Info • Remember to scroll to Recently Used Sources in the Sources search panel to assign the source to a series of events.

Choose the recognized places

Because your ancestors probably lived in your home country or are from a limited number of other countries, you can limit the list of countries for which places will be suggested during the data entry.

1. Choose Tools > Preferences > Herdis Preferences > Countries.
2. Check the different countries where you are likely to have places to enter.

From the Sources tab of the event
1. Click the + (Link a source) button to open the list of sources registered in the Sources Index.
2. Select the source from the list then validate by clicking Choose. The source is assigned to the event.
Create a new source and assign it to an event
1. Select the event from the Personal Data tab.
2. Click the Sources tab.
3. Click the + (Link a source) button to open the Sources Index.
4. Click the + (Create new source) button at the bottom of the list.
5. Enter the information for the source and press OK. The new source is assigned to the event.

Create a new source and assign it later
1. Display the Sources search panel, or open the Sources Index.
2. Click the + (Add New Source) button.
3. Enter the information for the source and press OK.
   A new source has been created but it is not assigned to any event. You may use this source later to assign it to an event.

Information for the source
The input/modify screen for a source is composed of fields to be completed, a Note field that can be used for full or partial transcription of the document and a display field for the media assigned to the source.

Type
Specify the type of information that allows you to advance in your genealogy. Is it an act? A family document? A historical work? Etc.

Source Name
Type a pertinent title for recognizing the document. The title of the source appears in the Sources search panel and in the Sources tab of events, as well as in the genealogy documents you may print.

Document
Specify the type of act (death certificate, marriage contract, etc.) or what document, official or private, which contains the information (census, invitation, family book, etc.).

Repository
Indicate where the original source is archived or the place where you found the information.

Call Number
If the document is from an archive or library and is listed, enter this here. Specify the volume and page number if it is a published book.

Date
Enter the date of the document that allowed you to find the information. Indicate the date of publication for a book, the date of dispatch for correspondence.

Info
Remember to specify the date of the source if it differs from the date of the event to which it relates (date of birth certificate issued 20 years after the event).

Author
Enter the author of the document that allowed you to find information.

The author of the source can be very different depending on the source. Quote a journalist for an article in a magazine, an amateur genealogist for a GEDCOM file, a ministry department or local authority for an administrative document, a parent who took a photo...

Email
Note the email of the person or organization that holds the information.
**URL**
Specify the address (URL) of the Internet website where you found the information.

**Medium**
Select the medium where you store information or where you saw it.

Do you have the original family book? Do you have a copy of the original or do you have a scanned image of the act? Have you seen the information by consulting a microfilm? Have you found the information in an online genealogy?

**Archive**
This section concerns only you and allows you to specify where the document is in your personal archives: in a specific file, in a specific folder of your hard disk, etc.

**Quality of Data**
To qualify the validity of the information, set the certainty of the source by using the cursor, from 0 (not sure) to 3 (completely certain).

**Note**
In the Note field, enter the information on the source: the details of the genealogist who gave you the information, the circumstances when you collected it by interviewing an old aunt, etc. You can type in the partial or complete transcript of the act. You have available the text editing tools for formatting.

Tick the Private Note box to exclude the note from exports or from printed documents.

**Private Source**
 Declare that a source is private for all information contained in the source to be excluded from exports or printed documents.

1. Open the data input screen for the source.

- Click the Personal Data tab, then select the event and click the Source tab.
- Display the Sources search panel.
- Click the Sources Index button, or choose Tools > Sources Index.

2. Double-click the source or click the Edit and modify the selected source button (shown as a pencil).

3. Tick the Private Source box, at the top right of the field.

**Info** • In the Sources Index, you may declare a source as private directly in the list of sources. Tick the box in the column P (Private Source).

**Media and interpretation of the source**
The quality of the information contained in a source is often confirmed by a reproduction of the original document. Heredis can assign one or more media to each source.

**Assign media to a source**
1. Select the source from the list of sources and use the media zone displayed on the right side of the window or double-click the source to open the entry/modification screen.

2. Assign the media to the source
At the bottom of the media display zone:
- Click the + (Add media from hard disk) button.
- Click the access button to the Media Index if you are certain that the media to be assigned is already saved in the genealogy file.

**Aid for interpretation**
Heredis understands the difficulty of your work in deciphering the acts and proposes a Display mode get the best possible display of the media and of the note.
Open the enter/modify screen. Click the **Display Mode** button to see on the same screen, both the note and the source image.

- Click the **Horizontal** button to see the entire width of the scanned document, even if you have already zoomed the image. You may then enter the text to be displayed above the lines.
- Click the **Vertical** button to see the document as a whole, including marginal notes. You may enter the text to the left of the displayed image.

**Info** • The deciphering of an act may often be long, so remember to click **Save** regularly to save the information you entered in the note of the source.

### 8.8 Checking of data

**Permanent control for duplicates**

When adding a new person to your genealogy, you may risk creating a duplicate, that is to say, create two distinct persons for the same ancestor. Heredis provides a tool, available in all entry fields for individuals, to avoid creating a person already saved in your file.

**Info** • For even more pertinence, Heredis includes in the list of potential duplicates, those persons already entered bearing a variant of the name you typed.

**In the Add or Choose… screen**

With the first letters typed in the **Surname** or **Given Names** fields, you see, in the **Matching Persons** column, the list of individuals already entered who may match the person. Step by step, as you enter new letters, the list of duplicates is updated.

**In the Family Group Data tab**

When you type in one of the fields of this screen, the full name of a person already entered, the **Enter New Data** icon (gray arrow) turns red. Click this icon to see a list of individuals who may correspond to the person.

**Check if a proposed person is in fact a duplicate**

Select the person from the **Matching Persons** list or check in the **Summary** panel. Here you have more information for more effective comparison.

If it appears that the person you wish to create already exists, select him/her from the **Matching Persons** list and click the **Choose** button. This will cancel the creation of a new person, and thus avoids a duplicate in your genealogy.

If you do not find a duplicate, continue.

**Validity Control**

Heredis analyses all information and will block any erroneous data entry.

**Dates**

Dates should be entered properly. See the chapter **Dates** for possible formats.

**Links**

Links created between people must be consistent. Heredis prevents the entering of incoherent links: one person cannot be entered as the son of another if he is already his grandfather. A message will indicate why the link may not be validated.

**Consistency control**

In order to avoid errors, with each data entry, Heredis checks that the information entered is logical in relation to the persons and events already known. It alerts you to any anomalies which you may either correct or confirm.

Heredis notifies you when you enter an event date which is later than that of the death of such person. You may fix the date entered
if you made a mistake, or confirm a post-mortem event, such as the transfer of ashes or an act concerning the deceased’s estate.

Heredis also checks for possible inconsistencies if you have created a link with a person bearing the same name as the person you are entering; it will inform you, for example, if you link a possible father, that he was 143 years old at the birth of the child, or if the wife assigned to the primary person had died before her wedding.

Check if a person is coherent

The consistency check is systematic. When incoherent information is detected, a message alerts you immediately at the data entry. On the toolbar, the Consistency button is highlighted displaying a red cross.

Understanding incoherences

1. Choose Person > Check Consistency or press the Consistency button on the toolbar.

2. Review the summary of the inconsistencies shown for the primary person. These controls are only indicative and it is your responsibility to rectify the anomalies detected or not.

Check all persons in the file

Heredis provides a tool for detecting all inconsistent data in your genealogy file.

1. Select Find > Multiple Search or type Ctrl-Shift-M or click Find > Multiple Search.

2. Select the Persons criteria from the first drop-down menu.

3. Select Consistent Data from the second drop-down menu, then No from the drop-down menu below. Then click Start Search.

4. Click on each of the persons shown in the results list to verify the data on the Summary panel.

5. Double-click a person to access his/her Personal Data tab and make any necessary changes.

6. Return to the Multiple Search screen using the Windows menu or by typing Shift-Ctrl-M.

Info • To do this at a later date, you may store the list obtained by marking all the people displayed. Click Mark Selection in the right part of the search screen. You can also keep the results displayed by printing the list of inconsistent persons. To do this select Print or Print Personalized Report.

No longer consider a person as incoherent

After checking the data of the primary person and to keep the information as it was entered, choose Person > Check Consistency or press the Consistency button on the toolbar and select the Mark as Consistent option.

The Consistency button changes its appearance and displays a green tick mark. This person will no longer be displayed in the list of a search for inconsistent information.

Change the coherence criteria

Heredis allows you to set your own criteria for checking the consistency of data.

1. Choose Tools > Preferences > Heredis Preferences.

2. Open the Consistency tab.

3. The controls relate to the age of spouses at marriage, age at death, parental age at birth of children, the gap between two dates for successive births, the age gap between spouses.

Indicate the minimum or maximum values (expressed in years) you wish to apply to your genealogy file. It may be interesting to change temporarily the minimum age for marriage for the furthest ancestors, for until the seventeenth century it was common to get married by contract between 5 and 14 years.

These amendments are effective immediately.
Completeness of data

The icon indicates whether or not essential information for major life events is complete (Birth, Marriage, Death).

This icon concerns the completeness of information for the primary person in the Status bar and in the Search tab. It appears also in the Persons and Branches panels for all individuals displayed.

The icon display is defined in Heredis> Preferences> Appearance. You can choose what information is required for an event to be complete: the accuracy of the date, place, the presence of a source and the status of the search for the event.

Regardless of the information collected in Heredis, you may determine that certain individuals will not require further research. Open the Search tab and click the Consider that this individual is complete button. The icon changes color.

When using the Branches panel, choose the Complete Persons Only option, and the results take into account both the completeness of the events and the individuals for whom you had determined that they be considered complete.
9 Illustrate your data

9.1 Media

Assign to your data any type of media to illustrate your genealogy.

What media for your genealogy?
Besides the usual media (images, sounds and videos), Heredis can assign files that can be opened directly from your genealogy software by launching the application that was used to create the media.

- Assign a text file created with Pages and Heredis opens your word processor to read it.
- Assign a numbers document and either Excel or another spreadsheet program on your hard drive will open it to read it.
- Integrate PDF files and Adobe Acrobat will open as soon as you double-click the media.
- A Heredis tree chart effectively illustrating a branch? Assign the tree chart file to your ancestor. This tree chart may be opened from the Media tab of the person displayed.
- Drag an information email from one of your cousins to the display field of the media and Heredis will open your mail program to read it.

Info • To select these types of media, select All Files (*) from the drop-down menu of the Open screen.

What data can be illustrated?

- A person: in the media display field of the primary person in the Immediate Family, Personal Data or Family Group Data tabs. You may also add media to the Personal Data field of Add or Choose... screen.
- A couple: in the Family field of the Personal Data tab.
- An event: on the Personal Data tab, click the Media tab after selecting an event.
- A surname: in the Surnames Index, either in the display field of the selected surname or directly in the Entering Surname screen.
- A given name: in the Given Names Index, either in the display field of the selected given name or directly in the Entering Given Name screen.
- An occupation: either in the Occupations Index, either in the display field of the selected occupation or directly in the Entering Occupation screen.
- A place: in the Places Index, either in the display field of the selected place or in the Entering Place screen.
- A source: in the Sources Index, either in the display field of the selected source or in the Entering Source screen.

The quantity of media assigned to each item of data is unlimited. Each media may be assigned to several items of data.

When media have been assigned in your genealogy file, they are visible in the Media search panel or in the Media Index.

A date and/or a note may be added to the Media.

Info • All media assigned to your genealogy are integrated into your file. You may synchronize your file with your mobile phone or another computer without worrying about the media. They will be automatically transferred.

Importing media to your file
You can add one or more media simultaneously to your genealogy file.

Adding media to the file is done either from the media display field for each selected data, or directly into the Media Index or the Media search panel. In this case the media are integrated into the
file but not yet assigned to data. They are classified as **Unused Media**.

**In the media display field for each data item**
- Click the button to access the **Media Index** if you are certain that the media required is already saved in the genealogy file.
- Click the **+** (Add media from the hard disk) button. Select one or more media using the Windows Explorer tools and then click **Open**.

**Info** • To display the button bar for media management, move the mouse over the display field of the media.

In the **Media** search panel or in the **Media Index**:
1. Click the **+** (Add Media) button.
2. Select one or more media using the Windows Explorer tools and then click **Open**.

**Information on the media**

**Link between media and data**
At any moment, you may assign new media to an item of data, or unlink media assigned by error. Heredis lets you also replace one media with another.

**Info** • You can change the main displayed image. Roll over the display area of the media with the mouse to display the media button bar. With the **Previous Media** – **Next Media** arrows, display the image you want to set as the **Preferred Picture**. Click the **Preferred Picture** button (shown as a star).

**Media details**
In the **Media Index** or **Media** search panel, double-click a media and display its entry/modify screen

**Date**: The date of the media is a useful guide to illustrate the lives of ancestors, and allows the classification by date of the various media assigned to a person.

**Note**: Enter your comments in the notes field. The note may be formatted with tools for text editing, it may also be defined as a **Private Note**.

**Private Media**: Tick the **Private Media** box to exclude it from export of a file or printing of a document.

**Information on the media file**
By opening the **Media Index**, you may access other information. Select a media then check the information displayed.

**Path**: Find here the original location of the media, before it was assigned to your genealogical file.

**Uses**: See the list of data that is associated with the selected media.

**Info** • Media are copied to the genealogical file and the format is slightly modified to optimize the file size. Their original location is given as an indication, there being no longer any connection between the media at the original location and media in your genealogy file.

**Display order of media**
Heredis displays media according to their date. With no date, they are classified in the order in which they were attached to the data.

### 9.2 Searching media

**Check missing media**
You have imported a file from an earlier version of Heredis or GEDCOM? If the original location of the media was changed at the time of import, or if a folder containing the media did not accompany the GEDCOM file, the media may be missing.
They are displayed differently depending on whether Heredis had a thumbnail display or not.

- When a Heredis file has a thumbnail image, you will see its representation.
- In the case of a file where there was no thumbnail image, the icon **media not found** (a cross over the Polaroid) is displayed in the place of the media.

**Find a group of media**

Open the **Media Index**.

1. Click the **Option** button (indented wheel icon) on the toolbar of the index.
2. Select **Locate Missing Media**.
3. Select the folder that contains one or more media not found, and press **OK**.

**Info** • Heredis will find the media with the same name as that carried during their assignment in the genealogical file. Heredis will widen the search to all subfolders in the named folder, provided they have the same name as that when assigned to genealogical file.

**Reassign media**

In the edit screen of the media or in the **Media Index**, click the **Update the selected media** icon (shown as a folder) in the button bar of the media display field.

- To process a media not found, locate the media through Windows Explorer. You may have changed its name or its location. It will be copied to the genealogical file and can no longer be lost.
- To reassign a media, select it using the Windows Explorer tools. If you had made changes to the media by resizing or by changing the framing of an image, or if you have changed the text of an assigned document in your word processor, it is copied to the genealogy file and you will see its latest updated version.

**Update all media**

You have associated with your genealogy Microsoft® Word documents and you wish to continue adding to them? You have tweaked a lot of photos of acts with an image management program? You have worked on documents stored on your hard drive, in your **Pictures** folder, or your current **Genealogy** folder...

Any media that you have already associated with your Heredis data will not be impacted by these changes as they have been copied to your file in the state they were in when you entered them.

To be sure that you have the latest versions of all your media in Heredis, open the **Media Index**.

1. Click the **Tools** button at the bottom of the index.
2. Select **Update media files from the originals**.

**9.3 Unlinking, replacing or deleting media**

**Unlink media**

In all the display fields for media, right-click the media concerned and choose **Unlink Media**, or click the - button on the toolbar for media management.

On the screen displaying all media assigned to a person or data:

- Select the media in the left column, right-click and choose **Unlink Media from**..., or click the - (Remove Selected Media) button at the bottom of this column.
- Click the media in the left column and then, in the display field of the media, right-click and choose the **Unlink Media from**... option.

The media is unlinked from the person or data but remains available in the **Media Index** and may be assigned to other.

**Replace media with other media**

You may have assigned two different media but they were the same (an image of a source saved with two different names, the same
image selected from your hard drive and in your iphone photo library...). You may keep one media only but use it several times.

1. Double-click the media displayed or open the Media Index and select the media to be replaced.

2. Click the Updated... icon (shown as a folder).

3. Select the media to be kept and click the Choose button.

### Delete media

Display the Media search panel, or open the Media Index.

1. Click the - (Delete the selected media) button on the toolbar for media management.

2. Confirm the deletion of the media with OK.

This will delete the media from your genealogy file. If it had been used, it will no longer appear in the illustrations of data or persons to whom it was assigned.

### 9.4 Sharing media

#### Export a file containing media

Media are integrated in your genealogy file. When you export a part of your file by creating a new Heredis file, the media assigned to the exported data are integrated into the new file, unless you had unticked the Media box of the Heredis Media export screen.

When you synchronize your genealogy file with your iPhone or with another computer, they are also integrated in the data.

#### Export media files

You can extract one or more media from your genealogical file for transmission to other people or for another use on your own computer.

- In the edit screen of the media,

1. Click the Save (the picture) as icon on the button toolbar of the media.

2. Choose the destination location for the exported media, its name remaining unchanged.

- In the Media Index,

1. Make a selection of media using the display filters for different types of media or uses. Display for example images used for sources in the submenus.

2. Click the Tools button at the bottom of the Index and choose Export Selected Media....

3. Select the destination folder for the exported media.

### 9.5 Photo tool

Heredis offers an ideal tool for enriching your Genealogy. Very simple to use, it allows for example, for all genealogists to identify persons in a group photo or in an act and capture faces or signatures.

If the pictures or captures of acts are not perfect, you may correct them with the photo editing tool.

The photo tool is available in your software from the Immediate Family, Extended Family, Personal Data and Family Group Data tabs but also from the Media research panel and from the various indexes.

Select for example the Immediate Family in the Family tab and double-click on the media of the primary person or click the button  and the button 📷.
If you run the tool from a picture of the union in the Immediate Family, Heredis will only list the media for that union.

A zoom slider at the bottom of the tab to the right of media counter allows you to adjust the size of the thumbnail displayed.

You have a series of buttons to act on the media displayed:

- **button**: You can add a media from the hard disk, the index or the clipboard.
- **button**: press this button to detach the media of the Primary Person without removing it from the Media index.

**Info** • and **buttons are not displayed if you launch the photo tool from the Media index.

- **button**: the star symbol identifies the photo you have selected as a favorite. It is this photo which will illustrate the person in question in all documents. Select a thumbnail from the list and click this button to place it as the favorite.

- **Show all media linked to primary person** button: this button will display all the media concerning the person and you will see the wedding picture or pictures of the Primary Person, as well as those associated with his or her name...

**Info** • the Star and All Media buttons only appear when you display the media of the Primary Person.

- **Indented Wheel** button: to find a media more easily, click this button to replace it with another media saved on your computer.

- **Folder** button: if you have made a mistake in adding a media, click this button to replace it with another media on your computer.

- **Reload** button: you have made changes to a photo which do not suit you and you want to go back to the original version of this

---

**Photo Tool**

This tool consists of four tabs, Media, Edit, Details and Identification, a display area for the image and input fields to complete media information.

You have information concerning a photo: enter in the input fields the date and notes, to clarify the context and thus complement your genealogical data.

If necessary, indicate that this is a private media. Thus you can avoid transmitting it when exporting or publishing your file: tick the **Private Media** box.

**The Media tab**

A list of media appears in this tab in the form of photo thumbnails. This list will depend on the context of launching of the photo tool.

For example, if you run the tool from the thumbnail of the Primary Person in the Immediate Family, the media displayed will be those of the Primary Person.
The Details tab
With this tab, Heredis informs you of the different uses of the image displayed and shows you where the original is located on your computer. If you click on the displayed path, Finder will open.

The Identification tab
From this tab, you can identify persons in a group photo or persons named in an act by cutting out their photos or signatures. If you then navigate through your software, you will see that the cut portraits or signatures illustrate persons with whom they are associated.

Using your mouse, enclose the people on the picture in the display area. Position the mouse cursor over a person, hold down the left mouse button and draw a cut-out frame around the person. When you release the left click, Heredis instantly offers to search the index of persons of your genealogy for the person in question.

If you know this person, type in the name or surname or both immediately Heredis displays the list of persons with this name and forename or variations in your file. Select the person from the list and click Choose.

If you know this person, but he is not present in your genealogy, click the Create Person button to create the person directly from this screen.

If you do not recognize this person, click the Unknown Person button to indicate that this person is an unknown person. Should you publish this group photo at a later date, an internaut may identify this person and communicate the information to you.

A frame appears around the person. You can always adjust this frame at any moment.

When you place the mouse pointer on the contours of the frame, it changes its appearance. By holding down your mouse, you can move the frame. By touching the corners of the frame, you can enlarge it or reduce its size to make it fit perfectly.

The Edit tab
If your photo is not perfect, you can easily modify it. For example, crop the image to remove unwanted parts with the Crop button. When you click the button, the form of your mouse cursor changes. Position the cursor to the point where the image must be readjusted, hold down the left mouse button and drag the selection window to encompass the desired area. When you release the mouse, the Crop button appears in the image: click the button. Your picture is now framed.

If you want to orientate your photo in any other way, rotate the image in the right direction by using the orientation buttons - Rotate Left button, Rotate Right button. You may flip the image horizontally with the Horizontal Flip button but also vertically with the Vertical Flip button.

With Heredis, you do not need any other software to embellish your photos. You can adjust brightness, contrast, or definition to sharpen an image to its true value.

You can also change a color photo to black and white by clicking the button but also reverse the colors of the photo by clicking on the button.

Do not hesitate to try different changes, because you can always return to the original photo with the Cancel button.

Once your image is satisfactory, you may confirm the changes by clicking the Apply button.

• Save As button: You can save a copy of the displayed picture to the Photo tool on your computer.

photo: click the Reload button. Heredis will automatically reload the original picture saved on the computer.
To the left of the photo, the list of numbered frames appear progressively as you identify the different persons in the photo.

An indented wheel 🔄 appears when you move your mouse over the media in the list. If you click this button, you have access to the following functions:

- **Delete Frame**: you have made a mistake, select this menu to simply remove it. Note that all the frames are automatically renumbered.

- **Rename the picture frame**: Heredis automatically assigns a name to the media which you have just created and if the name does not suit you, you can change it.

- **Identify or re-Identify**: if you have identified a person as unknown or you have made a mistake concerning the person, you can always assign to this frame the right person in your genealogy file.

- **Save as**: You can save the newly created image managed by Heredis to your computer.

All images are stored directly in the Media Index. They are also assigned automatically to the media of the identified person.

Click the Hide Frames button 🔄 at the bottom of this tab to display only the frames numbers in the display area of the image.

You can print the picture as displayed in the image display area by clicking the Print button 📄. Specify the print options and click OK. The document opens in your usual word processor.

Take this printed document along with you during visits to your family: the people around you will enjoy your work and perhaps identify unknown persons in the group photo.

Once you have identified all persons in a group photo, share it in your online photo album on Heredis Online through the Publish button 📷. If you want more information on the publication of the photos, see the Publish photo album paragraph on Heredis Online.

---

**Info** • When you browse and launch the photo tool for a person with whom you have associated a signature for example, Heredis indicates above the display area of the image that the media selected has been cut from another picture. If you click the Display the Original link, it will be displayed in the image display area. If you want to hide it, click the Hide Original link.

You cannot recut a picture that has already been cut out.

Some editing functions are not available for a group photo if you have already identified persons in this picture.

If you close your genealogy file without saving, all edits, cut-out photos and signatures ... will be lost.

---

### 9.6 The slideshow

With Heredis, the slideshow scrolls through the life of your ancestors in images. This tool presents your photos in a family album, composed of different chapters resuming life of the primary person and his/her immediate family.

To launch it, click the Slideshow button 📽 under the screen of the primary person from the Immediate family tab, extended family tab or even the person's data entry tab or launch it by clicking the 📷 button and select 📷.
Let the pages of the photo album scroll through and enjoy your work. Click the **Pause** button on the top right of the screen to stop on a picture and read the comments on the photo, for example.

Click the **Chapters** menu to display all the chapters of your album. By clicking on one of the chapters, you navigate directly to the selected chapter and you can then restart the slideshow by clicking the **Play** button at the top right.

By default, the slideshow appears with the **Retro** theme but you can change it. Click the **Themes** menu and choose a different one from the 4 themes available.

At the bottom of the screen, you have an audio player for playing music. As you watch this family slideshow, the photos parade with the music. Click the **Sound** icon to cut the sound.

To exit the slideshow, simply click the **Exit** button at the top right.
10 Overall management of data

As you enter data, Heredis groups data by type and creates the corresponding Indexes: Surnames - Given names - Occupations - Places - Sources - Media.

Each Index groups all data entries of the same type and provides tools to illustrate, edit or delete data throughout the genealogy file.

10.1 Accessing Indexes

Indexes are permanently available.

- On the Heredis toolbar, click the Indexes button and select the Index to be opened.
- Choose Tools > Indexes...
- Display the Places, Sources or Media search panels to view all data of this type identified in your genealogy file. The panels show the same content as the Indexes.

To access all the tools of the Index, click the Open an Index... button on the panel toolbar.

10.2 Searching and sorting

Search for an element in an Index

Each Index has a search field at the top left of the screen. Enter the word or phrase to be searched. The search is performed in real time and the displayed list is updated.

Click the Search icon to select the Search mode: «Search Contains» the word, or «Search Starts With» the entered letters.

You also have display filters to refine your search. You can exclude items that are not used in your genealogy by ticking the Unused... box.

In the Media Index, choose a drop-down menu to display media type (All media - Private media...) and use (Sources - Persons...).

Only results that match your search criteria are displayed.

The number of results obtained compared with the total number of elements is shown in the screen title of the Index.

Manage the displayed results

You can sort the list of elements in the Index according to the type of information.

Click the column header to rank sites by County, to classify sources by type, to classify given names according to the principal given name....

The Media Index may be displayed sorted either by file name or by date. Click the buttons on the toolbar of the index.

Display all the elements of an Index

To see the complete list of all items in an index, make sure you have no active search criteria or filters.

To cancel a search, click the Delete icon (symbolized by a cross) to the right of the search filters.

To cancel the filter, uncheck the options. In the Media Index choose All Media and Whole Index in the drop-down menus.

10.3 Consulting usage

Visualize easily all the locations where an item appears in your genealogy, and navigate with ease from the Indexes.

1. Open the desired Index.
2. Select the line corresponding to the desired item.
3. Heredis indicates the number of entries in the right side of the screen. Click Details to view them.
4. Select the name of the required person, then click View to display
him/her on the navigation tabs.

Each Index item is analyzed to make you know better the contents of your genealogy.

Click the Statistics tab to see usage statistics for the selected item. Heredis shows graphically the number of uses and their distribution in time.

The Index will remain open until you close the screen. You can return at any time to search for another use or to carry out another search.

10.4 Modifying data throughout the file

You have mistakenly added the occupation Lawyer instead of Solicitor? You want the given name of LaToya to be written with a capital T? You realize that you have entered two different sources for the same document?

No need to spend time editing each person in your genealogy. By using the Indexes, you manage globally Surnames, Given Names, Occupations, Places, Sources and Media, and any change is automatically applied wherever the element is used in your file.

1. Select the item to be modified. If necessary run a search or sort to find it easily.

2. Edit the item:
   • by entering directly on the right of the Index screen,
   • by double-clicking on the line,
   • by clicking the Edit and modify... button (shown as a pencil) on the toolbar of the list to open the editing screen.

Modify upper or lower case

Most data managed in the Indexes are automatically formatted when entered. The automatic formatting is defined in Tools > Preferences > Heredis Preferences > Appearance. You can choose to display the surnames, given names and places in uppercase, or with only the first letter in capitals.

However Heredis allows you to change the formatting for a single item and then apply the changes to all uses of this element.

You want to make an exception for a surname, a given name or a place where the spelling is unusual.

1. Open the Index and find the item in question to be changed.

2. Open the editing screen and tick Handle Characters Manually.

3. Edit the item. You may type upper and lower case wherever you want for the word. The automatic formatting will not apply to this element that will keep the format that you have chosen.

Replace an element with another

After many data entries, you may have created duplicates: this source is identical to another, such an occupation was spelled in two different ways. Tidy up in the Index in question by using the Replace... function.

1. Open the Index and find the item in question to be replaced.

2. Click the Replace... (shown as a double arrow) on the toolbar of the list.

3. Select the replacement item in the list. Click Choose to confirm the replacement.

The element is replaced in the Index, and therefore wherever it has been used in your genealogy. The Index now contains one element less than before.

Manage variants

The notion of a variant allows you to assign several elements to an Index entry. You can define variants of Surnames, Given Names, Occupations and Places.

Place names have sometimes changed over the centuries. As part of your genealogical research, you may find a number of variants for the same place. New Amsterdam was renamed New York in 1665, Philipstown (Leinster) became Daingean in 1929. Similarly, you may encounter a name spelled differently depending on the date of the
act found: the Taylor family is sometimes noted with the spelling Taylour or Tayler.

Specify the variants
1. Open the Index in question.
2. Select the item
   • Double-click the surname, given name, occupation or place, or click the Modify selected... button (shown as a pencil).
   • Click Edit on the right of the screen.
3. In the variants field on the right of the create/modify screen, click the + (Link a variant...).
4. Select the item to be the variant and press the Choose button.
   You can repeat this as necessary to add several variations to the main element.

Unlink variants
To unlink a variant, click Edit on the right side of the Index. Select it in the variants zone of the create/modify screen and click the - (Unlink the selected variant) button.

To remove all variants of a group: click the indented wheel icon in the Variants field, and choose Remove this group of variants.

To remove from your genealogy file at one go all variants in the Index, click the Tools button at the bottom of the Index and select Remove all variants...

Info • Deleting a variant does not remove the item from the Index. Only the link of the element in the Index is deleted.

10.5 Deleting data throughout the file

Delete an element from an Index
1. Open the Index in question and select the item to be deleted.
2. Click - (Delete). Confirm by clicking OK.

Info • Surnames, Given Names and Places cannot be deleted if they are used.

Delete unused data from an Index
You can delete at one go all the elements that are not used in your genealogy file.

As a precaution, review first the list of unused data by ticking the Unused... box in the search field.

1. Click the Tools button at the bottom of the Index and select Delete All Unused...
2. Confirm the deletion by clicking OK.

10.6 Consulting Place maps

Heredis does everything for you to visualize the places where your ancestors lived.

The Places Index will display an interactive map for the selected place. If Heredis has been unable to identify the place, you can yourself indicate where it is by using the geolocation tool.

Visualize the map
1. Display the map of the selected place.
   Open the Places Index then click the Map tab on the lower part of the screen to display the interactive map of the selected place.
2. Browse the map using the navigation tools. Zoom or shrink to get a better understanding of the geography of the place.

Geolocate unrecognized places
If no map appears on the Map tab, you must specify the coordinates of the place.
See the chapter Places to find how to ensure that Heredis recognizes this place and displays the map.

**Info**  •  You may also access the map of the Place on the Personal Data tab. Click the Map tab for each event provided that a place has been entered in the Details tab of the event.

## 10.7 Family Tree Mapping

Heredis helps you to understand better the lives of your ancestors, their geographical distribution and their migrations.

Select the Tools Menu > Family Tree Mapping or click the button and then select to display the events of your genealogy on interactive maps.

Maps may be displayed at multiple zoom levels and may be presented as a slideshow to view the geographic mobility of persons in your family tree through time and generations.

At the first opening, Heredis defaults to the major events of the ascendants of the primary person.

### Filters and display options

You can change the filters at any time on the left side of the screen, to view all the persons in your file, only the descendants of the primary person or persons that you have previously marked in your genealogy.

By default, Heredis pre-selects the mode of representation by Density to display your data. If you want a glimpse of the mobility of persons in your family tree, select the mode of representation By period. You will see a timeline above the map whose limits correspond to the extreme dates of your file. Click the Play button to scroll through the events on the map according to the selected period.

**Info**  •  the display and playback of the timeline are calculated automatically based on the extreme dates of your file.

If you want to study a particular period in detail, move the sliders to the start and the end of the required period. The events displayed on the map only concern this period.
Heredis also offers a mode of representation **By generation**, the operating principle of which is the same as for the method of representation **By period**. On the timeline displayed above the map, the dates are replaced by generation numbers.

**Map display**

With regard to the display of the map, different themes are available: the Heredis theme, a Gray theme and a Black and White theme.

Choose the one that will make the best of the map information.

You can easily change the zoom level of the displayed map by clicking on the + or - buttons or by using the mouse wheel. Thus you can examine a geographical area in detail or conversely, return to an overall view of the displayed map by zooming out.

To move on the map, hold the click on your mouse (left, right or click on the mouse wheel), and drag the mouse in the desired direction to center your map on a different area.

You will note that markers of different colors and shapes are pinned to the map. The caption displayed at the bottom left of the screen allows you to easily understand to what they correspond.

Three shades of blue allow you to identify the markers from 1 to 9 events, from 10 to 99 events and those that represent more than 100 events. Using these markers, you appreciate the concentration of ancestors in a particular area by the intensity of the blue color.

The form of the markers give you an indication of the number of places. The simple marker indicates the presence of events in a single place and the multiple marker, the presence of events in an group of places. When you click on a multiple marker, Heredis zooms automatically to display a more detailed level of the map.

The number of events in a place or group of places is displayed on the markers. When nothing is specified, there is only one event for the place in question.

If you click on a single marker, a summary is displayed on the right part of the map, with the list of persons who have events for this location.

**Research lists**

The research lists placed on the right of the screen allow you to carry out searches on places or persons.

In these lists, Heredis indicates the number of events found, to the right of the person’s name or the place.

Select the **Places** or **Persons** tab and enter a name in the search box to obtain a selective list of matching places or people. The list is automatically updated as you type.

On the **Places** tab, if you click on one of the names in the list, Heredis refocuses the map on this place and displays the events associated with it in the summary.

On the **Persons** tab, the same action refocuses the map on the places for the selected person and displays the events in the summary.

On the **Places** tab, you also have search filters. By default, Heredis pre-selects the **All places** filter. You can change it by displaying the drop-down list and choosing the available options:
• **Most represented places**: the list is displayed in descending order of the number of events found by place.

• **Non-geolocated places**: the places displayed in this list are not precise enough to be mapped (to complete these places, see paragraph **Geolocate a place**).

• **Visible places**: this list displays only the places visible on the map on the screen.
11 Searching for information

11.1 Searching by type of information

Search for persons

Find the Root Person
The Root Person is the individual who lies at the base of your genealogical research and who bears the Ahnentafel Number 1.

• Click Root on the toolbar.
• Choose Find > View Root Person or press Ctrl-1.

Search for a direct-line ancestor
If the person is a direct-line ancestor in the lineage of the Root Person, Heredis has automatically assigned an Ahnentafel number to this person.

1. Click Find > Search by Number on the toolbar or choose Find > Search by Number or press Maj-Ctrl-S.
2. Click the Ahnentafel Number in the data entry field and type the number to be searched.
   You can type any one of the numbers carried by the person you are searching for if there is more than one (implex).
3. Click OK to display the person corresponding to the selected number as the primary person.
   If no person corresponds to the number typed, try another number. Click Cancel to abandon the search.

Search for a person by his/her personal number
You may perhaps have indicated a personal number to some persons in your genealogy. You can find these people with this number.

Info • Use the Comprehensive or Customized input mode to view the User Number input field.

1. Click the Find > Search by Number button on the toolbar or choose Find > Search by Number or press Maj-Ctrl-S.
2. Click the User Number in the data entry field and type in the number to search.
3. Click OK to display the person corresponding to the number as the primary person.

Search for a bookmarked person
Display the Bookmarks Tool panel that will display a temporary list of persons you require to access frequently.

Double-click a person in the list to view as the primary person.

Info • To add a person to the Bookmarks list, use drag and drop, or click the + (Add primary person to bookmarks) button on the panel toolbar.

Search for people linked to the primary person
Display the Links tab in the Tools panels. It will show all individuals who have a link with the primary person; they are related, they are cited in one of the events, they played a role in his/her life or you have established a personal link between them.

Unfold the fields according to the type of relation linking the individual and the primary person: Descendant of, Godfather to, Witnesses to, etc.

Info • When a category contains persons connected with an event (godfather, declarant, witness...), it is marked with a blue symbol.

Double-click the person sought to display him/her as the primary person on a new Immediate Family screen. Double-click the event to open it directly in the Personal Data tab.
Search for duplicates in the file

The search for duplicates identifies persons entered several times in the genealogy file.

1. Choose Find > Find Duplicates... or click Duplicates on the tool-bar.

2. Select your search criteria.

Criteria for comparing the given names

Ignore the given names: the search will consider only surnames.

The First Given Name is identical: an individual with the same surname and the same given name as another individual will be considered as a potential duplicate.

Common Given Names: a person whose given names are all included in the given names of another individual with the same surname will be considered as a potential duplicate.

Tick the box One Given Name of One parent is identical to narrow your search by including this criterion.

Criteria for comparing events

Ignore Events: the search will consider only given names and surnames.

Dates Strictly identical: when an event has been detected and assumed to be an identical date, it must be displayed exactly in the same way in both files (Birth about 1801 and 01/1801 may not be considered as two identical events).

Years Strictly identical: when an event has been detected and assumed to be an identical year for the event, it must be identical in both files.

Define a Range of Years: if you do not require exactly the same dates as the criterion for comparison, indicate how many years from a date to be tolerated for considering two events as identical. If you specify range as «10», events that took place 10 years before or after another event may be considered as potential duplicates.

Look for any kind of link between two persons

The Find > Find Relationships menu function analyzes all connections in your genealogy file to find how two people may be linked, even if they are not relatives, nor related by marriage.

The primary person is proposed by default as the first individual to be analyzed. You can change this by clicking on the magnifying glass (Choose a person).

Click on the magnifying glass to choose a second person. Then click Search to search for relationships.

Heredis will search for potential common ancestors. By selecting common ancestors found, a table displays the parallel paths of each selected individual leading to this ancestor.

Heredis will then check if they have a relationship by blood or by marriage: maternal great-uncle, brother-in-law, spouse of a cousin.

Heredis finally looks for any non-family links: Is there a person who was a witness at their marriage, or who declared their death?

Whatever type of relationship, it is displayed as a table where each line determines the relation: son of, mother of, declarer of the death of, etc. You will easily find the link that connects the two individuals.

All the tables showing links are printable.
Heredis will open the **Branches** tab by clicking the **Display Family Branch** icon on the **Search** tab of the primary person displayed. Both functions are truly complementary and allow you to work through each family branch and carry out all the necessary research.

Click the **Ancestors** or **Descendants** button to display the required lineage in the **Branches** tab.

Each person displayed in the branch has an icon showing the completeness of data for the three main life events: Birth or Baptism in violet / Marriage in yellow / Death in black. Double-click any person to display the details.

You have a display filter available in a drop-down menu. You may choose between **All people**, **Treetops**, **Hide Complete Persons**, **Search Status is ‘Search Record’**, **Complete Persons Only** and **Sort by Change Date**. As an example, you will display **Complete Persons Only** to display a positive status of your work on this branch. If you **Hide Complete Persons**, you will have a clear idea of the work still to be done on the branch.

If you decide that there is much more work to be done on the descendants of a given ancestor, you may select **Memorize This Branch**.

The list of persons displayed in the drop-down menu corresponds to the family branches you will have memorized, both ancestors and descendants. Select the name to redisplay the memorized branch.

When you select a memorized branch from the drop-down menu, it will replace the previous branch displayed. You may also display the branch of the primary person by clicking the button to the left of the drop-down menu.

Do not overlook to suppress the memorized branch once you have finished your research of this lineage. Open the drop-down menu and select **Clear This Branch**.

### Search for Sources

Find a source simply among all the sources assigned to events in your file.
With the Sources search panel

Use the search box in the Sources tab to type a word contained in any input field for the source selected: its title, the document, the depository, etc.

The number of items found matching your search is displayed at the top of the panel.

To cancel a search on any word, click the Delete icon (symbolized by a cross) to the right of the search box.

Refine the search by selecting sort criteria from the drop-down menu: Recently Used Sources, Unused Sources, Private Sources, Sources Linked to Primary Person. The list is updated according to the selected criteria.

To cancel the sort criteria, select All Sources from the drop-down menu.

With the Sources Index

Open the Sources Index from the Tools menu or click the Indexes button on the toolbar.

In the search box, type any word contained in any input field of the source desired.

The number of items found matching your search is displayed on the title bar of the Index.

Click the Search icon to select Search mode: «Search Contains» the word entered, or ‘Search Starts With’ the entered letters.

To cancel a search on any word, click the Delete icon (symbolized by a cross) to the right of the search area.

You will limit the search to unused sources by checking the Unused Sources box.

The results can be classified by Title, Document, Origin... by clicking the column header.

For a list of events in which this source is used, click Details on the right side of the Index screen.

In the Source Usage screen,

• Select the name of the individual and click View to display the individual as the primary person of a new Immediate Family.
• Select an event and click View to display the details of the event.

Search for Places

You know that the person has lived in this city or region? Consider using the event places to find someone in your genealogy.

To find a place among the places of your file, you have several options:

With the Places search panel

Use the search box on the Places panel to type a word in any entry field for the place you are looking for: the city, postal code, county, state, country.

The number of items found matching your search is displayed at the top of the panel.

Limit the search by ticking the box: Unused Places

To cancel a search on one element of the place, click the Delete icon (symbolized by a cross) to the right of the search box.

With the Places Index

Open the Places Index from the Tools menu or by clicking the Indexes button on the toolbar.

In the search box, type any word contained in any input field of the source being searched.

The number of items found matching your search is displayed on the title bar of the Index.

Click the Search icon to select Search mode: «Search Contains» the word entered, or ‘Search Starts With’ the entered letters.

To cancel a search on any word, click the Delete icon (symbolized by a cross) to the right of the search area.

You will limit the search to unused places by checking the Unused Places box.

For a list of places in which this source is used, click Details on the right side of the Index screen.
In the Media Index

Open the Media Index from the Tools menu or by clicking the Indexes button on the toolbar.

- In the search box, type all or part of the name of the desired media. The number of items found matching your search is displayed on the title bar of the Index.

- Limit the search based on the type of data to which the media is assigned by selecting from the second drop-down menu: Persons, Families, Sources, Events, Surnames, Given Names, Places or Unused Media.

- Limit the search to a type of media by selecting from the drop-down menu: Private Media, Media not found, Other Media, etc.

To better identify the media selected,

- Sort the list or thumbnails by media name or by the date that you entered. Make your choice with the buttons on the toolbar of the Index.

- You can enlarge the thumbnails by using the zoom slider.

When the media is selected, check the list of data to which the media is associated.

Search for other data types

The Indexes list the information you have entered and display the uses for each type of data. By using the Indexes, you can find sources, places, media, but also occupations, surnames or given names. Each item of data can be illustrated or commented, which brings infinite richness to your genealogical research. What village was part of the Pencader Hundred? What was the family crest of Bolgan? What is the origin of the name Andrew? What was a balancer? You have taken care to note this information relating to the life of your ancestors and you will find them by searching in the Index in question.

1. Open each of these Indexes, from the Tools menu, or clicking the Indexes button on the toolbar.
11.2 Searching for individuals

Rapid Search
Heredis offers a simple and rapid search for persons based on their Surname, Given Names and Gender. If this research does not easily isolate the person you are looking for, you have available other search criteria corresponding to all the information you have entered. These advanced research criteria are grouped in the Persons tab and are classified by research theme (Personal Data, Relations, Events, etc.).

1. Open the Persons tab in the Search panels.

2. Enter if needed the Surname, Given Names and Gender.

The list of corresponding individuals is updated as you enter details.

When you click the name of an individual in the list, his/her summary appears in the Summary Tool panel. To view an individual as primary person in a new Immediate Family, just double-click the name.

To start a new search, click Delete the selected person icon. All individuals in the file are displayed again.

3. When the list of results is too long and fails to isolate the search person, click the Show/Hide Advanced Criteria arrow to unfold the advanced search criteria.

4. Select from the drop-down menu which data is to apply to the search: Search Entire File, Search Ancestors, Search Descendants, Ascendancy and Descendancy, Inconsistent data, Multiple Search Results.

5. Combine the following criteria to refine your search:
   - a place. You can either enter a town, a county, a full or partial zip code, a region or a country.
   - the surname of the spouse
   - a range of years, for example, between 1850 and 1870
     By typing 1850 only the first zone, Heredis will show persons with an event in 1850 or after.
     By typing 1870 only in the second zone, Heredis will show persons with an event in 1850 or before.
   - a type of event selected from the drop-down menu,
   - events without a source
   - Direct-Line ancestors (Sosa line)
   - Childless Family, Single Parent Family or treetop branches.

To display the individuals corresponding to these Advanced criteria, click the Search button to update the list.

Search by Name
Select Find > Search by Name, type Ctrl-F or click the Find button on the toolbar and then click Search by Name.

1. Type the first letters of the Surname in the Surname input field. Heredis will display all persons with this surname and variations that you will have defined in the Names Index.

The search is carried out in the mode you have chosen. To change it, select Tools> Heredis Preferences. Select the Search option on the first letters of the name (Search Starts With) or Search the name (Search Contains) in the General tab.
2. In the **Given Name** box, type the first letters of the given name to narrow your search.

3. Tick the boxes **M, F or ?** to limit the search to men, women or persons of indeterminate gender. Tick the **Direct-Line Ancestors** box to limit the search to direct ancestors.

**Info** • In front of each individual, a colored square indicates the gender of the individual: blue for men, pink for women and green for individuals whose gender is not determined. If a square appears with yellow in the center, it is that of a direct ancestor bearing a Sosa number.

4. To be sure to correctly identify the person you want, select him/her and check all the information that appears in the Summary area.

Click View or double-click the name to display the selected individual as the primary person in a new Immediate Family.

**Info** • To print or export the result of the search, click the **Print** box.

**Multiple criteria Search**

You can search for individuals by combining the information in the different seizure fields.

Choose **Multiple Search** in the **Find** menu or press **Shift-Ctrl-M** or click the **Find** button in the toolbar and then click **Multiple Search**.

**Define the first search criteria**

**Choose what type of information to be searched**
First, specify the type of information sought. Do you want to search for persons, events, unions ...? The type you choose will determine the choices.

**Information about individuals**: These are criteria concerning the identity, gender, kinship and known links, personal topics or labels (confidential, marked individuals...).

**Event information**: Indicate the type of event to be searched.

**Witness information**: This is to select individuals according to the roles they played in this or that event.

**Information on Unions**: This search may focus either on family notes (specific to each union), or type of union.

**Search criterion based on calculated data**: Heredis will select individuals based on the number of children, the number of unions, or age. One can also select individuals according to the dates of creation or modification of their file.

**Choose the category in which to search**
The items on which you want to base the search depend on the type of search you have previously selected. To search for individuals exercising a given occupation, you must have selected the Persons type. From the Events type, you perform a search on baptism and a date or a specific place ...

**Select the factor of choice**
The different choice factors are proposed according to the category in which you are searching. In the case of a search based on the occupation, choose one of the following factors: Is Empty – Is Not Empty - Contains - Begins with....

**Combine several criteria**
After setting the first search criterion, activate the following criteria by clicking the + button to add a new criterion.

Define the following criterion. It is possible to apply a combination of four different criteria.

You can remove criteria by clicking the - button.

To combine multiple criteria, tick the **All criteria** button or **At Least One Criterion** button.

**Start Search**
Once you have determined the different search criteria, click the **Start Search** button. The result of the selection is displayed on the
lower part of the screen. The total number of selected individuals is indicated above this list.

Add other individuals to the initial search
The selection of individuals that you have obtained is not sufficient? You can search again by using other criteria and add individuals found in the previous search.

Specify the new search criteria, as above, and click the Add to Selection button. The list of individuals found expands on the lower part of the screen. The total number of individuals found has been increased.

Search in a selection of individuals
The selection of individuals that you have obtained is too large? To refine the list, select new criteria that will apply only to individuals already in the list displayed.

Specify the new search criteria, as above, and click the Search in Selection button.

11.3 Handling information found

Handle the results of search for persons

Check the results
To view an individual found by the multi-criteria search,

1. Select the individual in the list to display information in the main Summary panel.
2. Double-click an individual on the list to view as the primary person.

Info • To have on screen the outcome of your criteria search as well as the navigation screen, use the Search by Name panel. Unfold the advanced search by clicking the arrow. Select Multiple Search from the drop-down menu.

Heredis displays the search result, allowing you to navigate directly to the individuals found.

Exploit the search
You can work on all individuals found and displayed in the Multiple Search.

1. Click Mark Selection, Confidential Selection or Secondary Selection. Each individual contained in the selection is updated and the corresponding operations are enabled.
2. Print the search results displayed by clicking Print to obtain an alphabetical list of individuals or Print Personalized List to obtain a list at your convenience.

Info • With Multiple Search, you can apply specific treatment to the entire genealogy file. Click Unmark the Genealogy File, All Not Confidential, All Not Secondary, before applying a new search based on .

Manage duplicates

Check for duplicates
Review the list of potential duplicates found by Heredis and choose the treatment to be applied to them. You can either merge two duplicate persons, or mark them, or print them.

To check the reality of the duplicate:

1. Click the Results tab and select an individual A, in the left column. A potential duplicate B appears in the right column of the screen.
2. Compare the summaries corresponding to individual A and individual B.
3. Continue the display of all potential duplicates of the individual A.

Once they have been checked, you can merge the duplicates found. Or you can also declare that the two persons proposed by Heredis are not duplicates.
Merge duplicates
1. Select a proven duplicate of individual A.
2. Click the Prepare Merger button.

Mark potential duplicates
Click Mark Duplicates. All individuals shown on the left side of the Results tab will be defined as Marked.
Print the potential duplicates
Click Edit Duplicates Report. Heredis generates an alphabetical list of all potential duplicates, with your usual word processor.

11.4 Searching online data
Click the Search tab to get a real research tool.
Heredis displays known data for the primary person, but also for his/her immediate family, to help in your research. It highlights missing information, makes suggestions for online research and connects you to your favorite data provider.
It keeps a record of the research you have undertaken and allows you to create research notes.
The research tool will be displayed for the primary person, but you can also use memorized branches to manage your research of different lineages.
The Search tab is divided into two areas. In the upper part, Heredis displays a list of all events of the primary person and relevant events of his/her relatives. At a glance, you know if there are missing dates or places. You immediately know if you have associated with the event a source, witnesses, media, a note. An icon also shows the status of your research for each event. It is clickable and editable.
The list of events displayed is configurable by clicking on the indented wheel icon.
In the lower part, you will find the various elements for analysis and the availability for online research.

• The Sources tab shows all sources related to the events shown in the upper part. Select an event to see if one or more sources are associated with it (they are displayed in bold).
• The Map tab positions all known events on a map, distinguishing between those of the primary person and those of the immediate family.
• The Research Note Tab displays a text box for notes. Any research note will be included in the Notes window of the primary person.
• The Web Search tab provides online research on websites of your choice, taking into account all relevant elements already known (identity, location, time, etc.). These elements may be changed taking into account your own analysis of your data. The record of previous online searches allows you to return easily to your required research.

Choose from the different research sites proposed by Heredis. Click the indented wheel icon to add your own research sites. Click the + button and enter the site to be displayed in the list and the URL you will have copied from the address bar of your browser.
Heredis Online contains all the genealogies published by Heredis users. You can run searches across more than one hundred million data items already referenced in the genealogies of the Heredis Community.

11.5 Search in Online Archives
The Search in Online Archives tool allows you, from your software, to access the online archives portal. Heredis facilitates your research and also allows you to integrate acts you have found and cut into your family tree, by creating the event and the associated source for example.
Click on the button and then the button
or choose from the menu **Find > Search in online archives...**

**Access and navigation in online archive sites**

Heredis displays the online archives search portal in a real web browser.

![Online Archives](image)

You have a button bar with the following options:

- **Archives** Button: displays the home page of the online archives.
- **Bookmarks** Button: lists the sites you have added as bookmarks and allows you to manage the list of bookmarks.
- **Previous, Next** Navigation buttons: they give you an indication of the history of your browsing and allow to re-display pages already consulted.

- **Update** Button: updates the page displayed on the screen.
- **Capture** Button: Captures the whole page displayed in the browser. If you have already made a capture, this button opens a menu either for you to make another capture, or see the list of already captured but not processed sites.

As in any internet browser, you can add a new tab by clicking the + button on right side of tabs bar or close a tab by clicking the cross to the right of the title of the displayed tab.

The Archives portal concerns the archives of France but also those of other countries. For France, they are classified as follows: **Departmental Archives**, **Municipal Archives** and the **National Archives**.

In the **Departmental Archives**, the list of archive sites mentioned is large. To easily find a website in this list, you can search by entering a department number or name in the search box in the footer panel. Enter 69 for example to access the archives of the Rhône. The resulting list offers the DA of the Rhône, but also those of Lyon, part of the Rhône department. By clicking on the **»** button on the button bar, you return to the home page for a list by Country.

Use the **» »** navigation buttons to navigate as on a website.

The Archives of France portal also offers Municipal Archives and the National Archives (military records, libraries ..).

If a site appears to be missing from the list, share it via the **button at the bottom right of the footer band.**
Each proposal will be submitted to the Heredis team. If accepted, it will appear on the portal and will be permanently accessible to all users.

Your research will often focus on a given territory: select the sites you visit most frequently and add them by clicking the **Add Bookmark**. To make changes to your bookmarks, click **Edit Bookmarks**: you can add other sites and delete them with the + and - buttons. By clicking on a line, you may change the name or address of the sites.

![Captures window](image)

When you capture a deed or any other document, you capture all of the displayed page in the browser.

To capture an act, click the **button. Crop the image to remove unwanted parts with the **button: When you click this button, your mouse cursor changes shape. Place your cursor at the spot where the picture should be adjusted. Hold down the left mouse button and slide the selecting window to encompass the desired area. When you release the mouse, the **Crop** button appears on the image; then click this button. Your image is now framed.

If you have managed to capture all of the act, click **Process my capture**, or on the **Capture the rest of the act** button in order to cover the act in its entirety.

When you have captured several images, the **Previous** and **Next** buttons allow you to scroll through the list of your captures. If you want to save a copy to your computer, click the **Save** button and choose the location on your computer. Rename the image with the **Rename** button if the name does not suit you. The **Delete** button will delete the capture displayed in this window.

You can edit the capture by clicking the **Edit** button. Your image is displayed in the **Photo tool** and you can edit the image to make the document more readable (see paragraph Photo Tool to see the details of this feature). Once the editing parameters are right for you, close this window and treat your captures.

**Info** • All the captured images are declared as being private by default in order to respect the terms of use of the archives.

Remember that if you close the **Archives online** tool without managing your captures, they will be retained in the list of captures only as long as the Heredis session is still open.
**Processing captures**

Heredis allows you to process the capture of acts to associate them with an event of your genealogy and save the information concerning the act.

Two choices are available to you for treating these captures: If you do not have the time, tick the **Save only in the media index** box for treating it at a later date, or **select Associate with an event**.

**Associating with an event**

Select **Associate with an event** and select or create the person to whom the captures are to be associated. Then unfold the dropdown list to select an existing event or create one if it has not already been created. Heredis by default ticks **Add a Source** to the event to create a source for the act captured. By unticking this box, the image or images of the act will be associated with the event in the Media tab and not in the source.

When you click **Validate**, Heredis opens the source and prefills known information, the type of the source, the title of the source, the Archive depository, the nature of the source, its quality, the website and automatically associates the capture or captures with the source.

Fill in any missing information if necessary and click **OK** to create the source.

The **Online archives search** tool may be launched directly from the file of the person.
From the Data Entry tab, select the event you want to complete. Start the online archives search by clicking the Online Archives button below the list of events. Heredis displays directly the list of available archives from the town for the selected event provided you have previously entered this information. When you have found and captured the act of the event to be completed, Heredis prefills the treatment of captures with the relevant information on the person and the event selected in the Data Entry tab.

It remains for you to validate and possibly complete the missing information for the source.
12 Creating documents

Take a look at the wide variety of print outs offered by Heredis. Most tree charts or documents concern the primary person displayed, but sometimes the couple. Some lists relate to the whole of your genealogy.

Save and print your tree charts directly from Heredis. To edit, change or save your reports, sheets or books, you will use your normal word processor. This method keeps you in a familiar environment, facilitates any manipulation you wish to carry out, allows complete reshaping of the presentation of data and if you so wish, saves the documents displayed as independent files.

12.1 Editing reports, sheets and books

Heredis will edit standard reports included in the software or create your own report templates. Each displayed report may be changed simply. You can also save or print it directly.

You can edit individual reports or family reports.

You can also edit real illustrated books to tell the story of your genealogy. The ancestors or descendants books will cover the number of generations you require.

Create a predefined report
1. Choose the report to edit from the Reports menu.
2. Select the report type from the menu or sub-menu.
3. Determine the Options for the report.
   - Tick the appropriate options to determine the persons you wish to include in the report (men, women, witnesses...) according to the genealogical role they play.
   - Determine the limits which you wish to apply to the report (confidential, Ahnentafel number bearers...).

The options vary according to the type of report you are editing.

4. Click the Styles tab to indicate your choice of data formatting.
   - Determine the field styles options for the report: given names (all, usual, etc.), name order, dates format, places format (full place name, city only, etc.), the way you wish to mention sources...

   Choose font and letter size. Indicate what should appear in the header:
   - any personal text which you may enter in the title field.
   - the total number of items in the report.
   - the name of the genealogy file.
   - the date of edition of the report.
   - the page number.

   Give a distinct color to important elements in the report. The elements are different according to the type of report required.

   Choose page format:
   - Document margins
   - Print grid to border all information displayed with grid lines and with separations between persons mentioned.
   - Click on the Print setup button to display the printer dialog panel and select the printer, paper orientation and paper size.

5. Click OK.

The document appears in your usual word processor. If you want to operate differently, you may export it in a particular file format by clicking Export instead of OK.

Compose a book

Options for presentation and content are selected from different tabs. Any changes to a theme are saved for future use of the same theme.

1. In the Structure tab, select the information to be included in the book, photo album, number of generations, location of notes, etc.
2. Click the Front Cover tab of book to choose titles and illustrations for the cover page.
3. Click the **Persons** tab.
   - Choose the surname and given name format. Tick the boxes to add **Prefix**, **Suffix** and **Nickname** if you entered corresponding data.
   - Tick the boxes to indicate what information to be included in the book: images, child status, signature, flags (confidential, childless...), user fields, calculated data, etc.
   - Children options: tick the boxes to add the spouses of each child in the document and indicate whether or not there was an offspring.

4. Click the **Events** tab to choose which events to include: witnesses, sources, notes, minor events, etc.
   - Choose the formats for date and places of events. Select the place format from the drop-down menu. Select which place items you want to show in the report from those you have entered.
   - For each event indicate witnesses, sources and notes.
   - Add the minor events (other than the event of birth, the life-ending event and the event of marriage).

5. Click the **Style** tab and select the formatting for the book: font, size and text color, specific colors for men, women and numbers, colors for titles and banners of the document.

6. Click **OK** to start. Default format for the reports is .docx.

---

**Info** • In the book, a personal text for the **Dedication**, **Acknowledgments** and **Introduction** sections may be written directly in your word processor.

---

**Compose a Custom Report**

The setup screen for a custom report has an extra button. In the **Options** tab, click the **Modify** button to open the building screen for the report. You can change the default report or create your own report.

To build a custom report, you have the following options:

- **Columns**: Add or remove columns, change their width, their title and fill each column with the fields you want.
- **Fields**: Most of the fields included in the input screens are usable as well as some calculated fields (age at death, number of children...).
- **Field formatting**: Each field you include in the report can be formatted (headings, alignment ...). You can also assign a prefix and a suffix to each selected field.

When you first open a customized report, Heredis displays a default report that you can use as it is or modify it. Customized reports that you have changed may be saved.

Click the **New Report** button to create a personal report composed entirely by yourself.

---

**Columns**

The columns are displayed at the bottom of the screen that represents the usable width of the page. The columns are divided between the two margins in the same proportions as the screen regardless of the chosen print format (portrait or landscape). You may create up to 32 columns in the limit of space available for printing.

- **Add Columns**: Click the **Add** button to create the desired number of columns to the personal report under construction.
- **Swapping columns**: Click in the column to move, then click the arrow buttons left or right until the column reaches the desired location.
- **Delete a column**: Click in the column to select it and click the **Delete** button.
- **Give a title to a column**: Click in the column to select it. Type the title chosen for the selected column in the **Title** box. Specify the alignment for the title of the column by checking the boxes **Left**, **Center** or **Right**. Indicate in the same way the alignment chosen for fields contained in this column.
- **Change the width of columns**: Place your mouse over the right edge of the column you want to enlarge or shrink. The cursor turns into a double arrow. Hold the left mouse button and drag the right
edge of the column to the desired width.

**Fields**

1. Depending on the type of information to be placed in the column, click on the tabs containing data for the individual, his father, his mother, his spouses, and calculated data. Click in the list of fields on the one you want to include.

2. Click the **Add** button for it to be inserted in the selected column or double-click the name of the field in the list so that it falls in the selected column.

**Formatting fields**

Indicate the required character attributes for the added field by ticking the Bold, Italic or Underline boxes.

The fields will be presented side by side in the published report. To print one below the other, insert a line skip by clicking the **Line skip** button.

The total number of fields and line skips are limited to 32 per column.

- **Swapping the order of the fields on a line or in a column**: Select the field to be moved. Click on the **Up** or **Down** arrow buttons until the field has reached its required position.

- **Delete a field in a column**: Select the field to be deleted. Click the **Delete** button.

- **Add a suffix or prefix to a field**: Select the field to be modified in the column. Click the **Prefix** box and then type the prefix to be applied to this field. Click the **Suffix** box and type the suffix to be applied to this field.

To indicate the age at death of an ancestor for example, select the **Age at Death** field in the Calculated Fields tab and insert it. Then click in the **Prefix** entry field and type aged. This will give you the words: aged <age at death>.

**Save a custom report template**

Modify an existing report

You have changed the report on which you are working? Your changes are saved for later use.

You can create another template for a custom report, based on the formatting that you just defined:

1. Click the **Save** button.

2. Give a name to the report template that you have created. It will be saved in the folder *Documents/BSO Concept/Heredis/Heredis Custom Reports*.

This template will be available for any type of custom report.

Create a new custom report template

To create an entirely new report, click the **New Report** button.

Heredis displays a new empty report, to be completed with the required columns and fields.

Open a Custom Report Template already saved

To recall all templates of custom reports that you have created:

1. Click the **Open** button.

2. Choose the existing template to be reused.

This template is displayed on screen and will open by default at the next application of a custom report.

**12.2 Saving a document**

A sheet, a report or a book edited in your word processor becomes an independent document in the Heredis software. This document can be saved for later reprinting or modifying. To keep the document displayed in your word processor, use the saving feature of your software. It is generally found in the **File** menu.
Heredis has created a *My Documents/bsd Concept/Heredis/ Heredis Genealogy Reports* folder to help you consolidate all your genealogy documents.

To change the name of the document proposed by Heredis, enter another name in the **File Name** field.

### 12.3 Printing a document

You will start printing from your word processor having made changes if required.

1. Choose **File > Print** or press **Ctrl-P**. These commands are generally the same in all word processors.

2. Select the printer you wish to use from the list of available printers. If your printer does not appear, select **Printer set-up** in the Windows Print command.

*Info* • For more information on adding a printer, type **Add a printer** in Windows Help.

3. Click **OK** to start printing.

### 12.4 Exporting a genealogy document

Exporting the document you have created will enable you to apply specific treatment with other programs. Share your documents with others by using a file format that they are likely to use on their computers or other devices in the format of a universally readable file.

1. Click the **Export** button in the formatting screen of the document.

2. Give the export document a name.

   Documents are exported in simple text format (ASCII Files).

3. Click **Save**.

   The exported document may be read by any text editor. It may also be opened as a spread-sheet as with Microsoft Excel on either a Windows or Mac machine.

*Info* • The table layout and certain typographical peculiarities may possibly not be retained in the exported document.

### 12.5 Constructing tree charts

You can create as many graphical representations of your genealogy as you wish. A tree chart may be saved with the data it contains and its layout. It can then be reopened, modified in its presentation, printed again. It has become independent of the Heredis data file.

Choose from the different types of tree charts proposed in the **Charts** menu or click **Charts** on the toolbar to visually select the tree charts proposed by Heredis.

**Edit a tree chart**

The printing of a tree chart takes as its starting point the primary person displayed and will display his/her ancestors, descendants or both as an hourglass tree chart.

**Choice of tree chart**

In the **Charts** menu or in the displayed selection screen, choose the type of tree to build from the list to the left.

Heredis proposes various types of tree charts, the size of which is predefined (from A4 to A0 or Letter to Quad demy) but also tree charts of unlimited size. Whatever the type of tree chart selected, you can print it or have it printed over several pages or a single long strip of paper.

When a tree exceeds the size of your printer, each page is printed with an overlap to facilitate mounting of the chart.
Choice of theme

Click a theme in the viewer. To facilitate your choice, Heredis displays an overall preview of the tree to be edited with this theme or a preview of a box. Scroll through the different themes by pressing the arrow keys or with the mouse.

The last used themes are preset for each type of tree chart.

After testing the different themes of tree charts, you may define your favorite themes. Click the Add to the Bookmarks button and the theme is marked with an icon that allows it to be recognized.

Info • You have a search filter for bookmarked themes. Thus you can display only the themes that you commonly use.

Chart Settings

Specify the construction parameters that suit you for the selected theme: number of generations, people to be displayed or not on the tree chart.

Tree charts of unlimited size

1. Indicate the number of generations. It is unlimited for ancestors as well as descendants.

2. Choose the orientation of the tree chart, building from bottom to top, from left to right or from right to left.

3. Choose a method for automatic construction according to the space you want to allocate to the tree chart.
   • The Default tree chart is built with all boxes of the same size, that is to say that the box of the central character has the same size as that of persons shown in the third generation or 10th generation. In this tree chart, generations will be located one above the other without overlapping.
   • In the Optimized tree chart, boxes gradually decrease in size with the higher generations and they slightly overlap.
   • In the Minimized tree chart, the boxes will diminish in size and content and their position can be rotated at the end of the branch to save even more room.

4. Select the persons for inclusion on the tree chart. By default all persons appearing in the ancestry or descent of the primary person are displayed on the tree chart. You may untick secondary persons, or marked and confidential persons, for them not to be displayed on the tree chart. You may also hide all the data you have declared to be private (events, pictures, etc.).

Click OK to start the construction of the tree chart according to the theme selected and with the chosen parameters.

Tree charts of a predetermined size

1. Indicate the number of generations, which may range from 4 to 8 depending on the type of tree chart and the theme selected in the Chart Settings field.

2. Select the persons to be included on the tree chart. By default all persons included in the ancestry of the primary person are displayed on the tree chart. You may untick marked, secondary or confidential persons. You may also not display private data.

Click OK to start the display of the tree chart.

Tree Chart Screen

Heredis displays a tree chart representing the lineage of the primary person and which is printable immediately. If you want to make changes to the tree chart, you have tools in the specific Tools panels of the various tree charts.

Toolbars and menus

When the tree chart is displayed, the menus and buttons are different from those for data management.

You may use the buttons for normal actions: Save, Pages, Print. Display only the buttons you use most often by choosing Windows > Customize Toolbar.

Use the tree chart menus to manage also the layout of the screen or the selection of people on the tree chart.
Persons displayed in the tree chart

The Search panel of the tree chart contains a list of all persons included in the chart. Clicking a person in the list previews that person's box in the tree chart. A double click navigates through the tree, if its size exceeds that of the screen, to display the box for a selected person.

To quickly find a person in the list of individuals on the tree chart, enter the surname or given name. Refine the search by selecting from the drop-down menu, the gender of the person sought if the name is multiple.

When there are marriages between blood relations (implex) on your tree chart, certain ancestors may be included more than once. By default, Heredis will only display one complete branch and duplicate branches are cut off. If you want to repeat the implex branches, tick the option in the settings screen of the tree chart prior to construction.

Click the name of the ancestor in the Search panel and Heredis displays the various positions of the person in the tree chart. Click on the first position to see the entire branch displayed. The different boxes for the ancestor have identical lettering.

Preview of the selected box

The Tools panels displays the selected box. At the opening of the tree chart, Heredis displays a complete view of the document, whatever its size. The preview is very useful in large tree charts, when the content of the boxes is not readable on the screen. This visualization immediately displays any changes that you apply to the box.

Tree chart formatting

You may modify the unlimited tree charts to give them a more personal graphical appearance. In the fixed size tree charts, the changes apply only to the content of the boxes. The overall environment is not editable.

The different Tools panels allow either changes to be applied to the whole tree chart or changes to a given selection (one or more boxes).

Display screen

The central area of the screen shows all the boxes of the tree chart, the title of the tree and any images that you have added.

To help you check and estimate the size of your tree chart, materialize the pages on the screen.

In the toolbar, click Pages > Show/Hide Page Breaks or choose View > Show/Hide Page Breaks.

The number of pages depends on the chosen page format for your printer. To change the format and page orientation in your printer, click the Page Setup button in the Print panel or choose File > Page Setup.

To move around the tree chart, use the horizontal and vertical bars, or change the zoom factor or double-click the name of a person from the Persons panel to display his/her box directly.

Zoom

You can increase (zoom in) or reduce (zoom out) the display of the tree chart. It is often necessary to reduce the display of a tree chart to visualize all required generations.

Choose Display > Zoom > Increase Magnification or View > Zoom > Decrease Magnification. To return to the actual size of the tree, choose Display > Zoom > 100 %.

You may also select different levels of zoom on the bottom bar of the tree chart screen.

• Click the arrow and select a value from the drop-down menu or use
the slider to change the zoom level. Heredis indicates the factor used to reduce or enlarge to the left of the bar.

- Click the 100% button to return to the real size of the tree.
- Hold down the Alt key. With a left click, the tree chart grows, with a right click, the tree chart is reduced. You may also use the mouse wheel up or down to enlarge or reduce.

**Info** • Remember to fold back the Search and/or Tools panels to have the maximum available space for display of the tree chart.

### Selection

Before making changes to a tree chart, first select the boxes to which they will apply. Depending on the type of change to be made, make individual selections or selections of a genealogical order.

- To select all boxes of the tree chart, choose Select > Select All (or press Ctrl-A). From anywhere in the tree chart, you can right-click the mouse and choose Select All.
- To select one or more boxes of the tree chart, drag the mouse cursor over the boxes to be selected.

To select more boxes that are not contiguous, select the first box, and then, holding down the Shift key, the additional box or boxes.

To make genealogical selections from any box in the tree, right-click the mouse and choose Select Men Only (or Women Only, or Person and All Ancestors, or Person and All Descendants or Generation).

**Info** • Persons corresponding to the selected boxes are also selected in the Search panels.

### Format the tree chart

To make changes, use the tools in the tree chart Tools panels. To go further in the formatting of the boxes, click the Layout button.

---

**Tree chart of predetermined size**

The changes apply to the selected boxes. The formatting of the text is customizable, but the visual environment cannot be changed.

**Modify the contents of selected boxes**

- Choose the content formats that suit you for surnames, given names, dates, places and genealogical headings from the drop-down menus.
- Tick the Show Ahn./User Number and Show Preferred Picture boxes to add this information, if it exists, in the selected boxes.

**Change the text formatting**

Without delay, change the font, size, color and text alignment with the drop-down menu, the cursor and the buttons of the Layout panel.

**Info** • Do not forget that you can make a selection of all men in the tree chart, then all women, to apply different text colors. For this, use the Select menu or right-click of the mouse.

**Modify the fan tree charts**

The fan tree charts offer the particular feature allowing the number of generations to be displayed (from 4 to 12), varied graphic charts and formatting according to the generations, the quarters of ancestry or the gender of persons, as well as limitations on the individuals to be displayed.

1. Select the fan theme from the Templates drop-down menu.
2. Choose the number of generations and the angle. The angle may vary between 180° and 300°.
3. Choose the color base for the theme.
   - Click the By Quarters box to materialize the quarters of ancestry.
   - If the By Quarters option is ticked, the number of Quarters to differentiate in the tree is editable. This number can range from 4 (for a 180° angle) to 16. To change this, move the cursor.
   - Click the Males/Females box to distinguish the box color by gen-
Click the **By Generations** box to apply a different color to each generation.

Tick the **Gradient Fill** box to spread the colors at start and at end that you have selected throughout the fan chart. If the **Gradient Fill** box is not ticked, click on each zone of the fan chart to select the color to be applied to it.

**Info** • When you have made personal changes to a template, the formatting is saved until the next personal change you may make to the fan chart. You may test the different models but also return to Latest Layout in the Template drop-down menu.

4. Format the contents of the boxes of the tree chart.
   • Change the data format (names, dates, places) with the drop-down menus.
   • Display boxes containing more or less information by selecting 4 lines or 6 lines in each box of the tree chart.
   • Change the text formatting depending on the type of data (males, females, other text).
   Click **OK** to display the fan chart according to your determined layout.

**Unlimited tree charts**

Change the layout of the tree

1. In the **Layout** panel, change the spacing between boxes or the spacing between generations by clicking the arrow buttons.

2. Tick the **Display Empty Lines** box for all boxes to be filled with the same number of lines, even if you do not have information.

3. Click the **Pages > Center Tree Chart** button to reposition it optimally after modifications.

Move elements in the tree chart.

After selecting boxes, several methods for moving them are available. Choose the one that suits you best.

• Mouse: Drag the selection to its destination by holding the mouse button pressed.

**Info** • Hold down the **Shift** key to prevent any movement off the generation axis. Each box moved will remain aligned with the other boxes in the same generation.

• Arrow keys: press the arrow keys to move to the position you wish to select.

To cancel the moving of the selection, press **Ctrl-Z** or choose **Edit > Undo**.

To restore the move, press **Shift-Ctrl-Z** or choose **Edit > Redo**.

Change the design of the tree chart

Change the graphical appearance of your tree charts with a few clicks. Some graphical changes apply to the whole tree chart, others apply only to the boxes you selected.

1. Select the boxes to be modified or choose **Select > Select All**.

2. In the **Layout** panel, change the overall font, size, alignment and text color.

3. The display of boxes on the tree chart is defined by three elements: box styles, content types and connecting line styles. The different themes that come with Heredis contain several presets for each of these elements. They are available in the **Tools > Layout** panel of the tree chart.
   • Choose a preset to be applied to the selected boxes in the drop-down menus. A preview screen shows you the appearance of available presets.
   • You can change each preset of box styles, contents or connecting lines. Click the **Layout** button in the toolbar, use the right-click menu on the selected box, or click the **Edit...** box shown as a pencil to the right of each menu to access all the changes.

**Info** • By clicking on the pencil, you open the setup screen of the preset. To change the presets of box style, contents and connecting lines at the same time, click the **Layout** button.
• The box preview contains a tick box in the top left of the preset edit screen, for applying a modification to the males and females simultaneously.

**Change the box style**

Change the Box style preset displayed or choose a different preset from the Box Styles drop-down menu to form a base for your custom formatting.

1. Click the border of the box to change border, shading, box background, orientation and size of the box including padding.

2. Click on an item, eg. name, to access the formatting of this item. When a line contains two distinct elements, they may be changed independently of one another, for example Surname – Given Name or Date - Place.

3. Click on the picture to determine its size, its border and its eventual position in the box.

**Info** • One can only change the borders of the drawn boxes. If you choose an image for the box background, the outline must be included in the image.

All changes are immediately displayed in the preview of the box.

**Info** • To see better the changes made in the preview box, use the zoom slider at the bottom of the window or click the magnifying glass icon and choose a zoom percentage.

Click **OK** to apply the changes to all selected boxes on the tree chart.

**Modify the content**

Change the **Content type** preset displayed or choose a different preset from the drop-down menu as a base for your custom formatting.

Click on each item displayed in the box to change the data formats. For example, click the name to indicate management of the particle, whether to include the prefix and suffix of the name. Click on a date to indicate the desired format (long, short, in numbers or letters, etc.).

**Info** • One can materialize the presence of a source for each event mentioned in the boxes. Select the date field and tick the Mention source box to add the symbol (s) following the dates shown.

Click **OK** to apply the modified contents of the selected boxes on the tree chart.

**Modify connecting lines**

Modify the Line style preset displayed or choose a different preset from the drop-down menu as a base for your custom formatting.

1. Click the border of the box or on the connecting line to display the **Line** tab.

2. Choose the type of line to connect the selected boxes from the drop-down menu: right angles, rounded corners or curves.

3. Specify the width of the connecting line with the cursor and click the color box to choose a color.

Click **OK** to apply the modified lines to the selected boxes.

**Edit the text of a box**

1. Right click on the box to be edited and choose Edit Text to open the editing field.

**Info** • You can only edit one box at a time.

2. Enter changes to the displayed text.

3. Click OK to apply changes.

**Edit the tree chart title**

The tree chart title is a modifiable text zone.
Heredis proposes a title containing the name of the primary person. Double-click the title to open the text editor and make the necessary content changes and formatting of the text.

**Add a Picture**

Select the Edit > Add Picture menu or click the Add button on the toolbar to add a graphic illustration to your tree chart.

The picture is added at the top left of the tree chart displayed.

- It is possible to add several pictures. If they must overlap, there are options for stacking images. Right-click the image to move the selected image forward, backward or to the background if it is a background image for the tree chart. Whatever option chosen, the boxes of the tree chart remain in the foreground.
- When the picture is enlarged or reduced manually with the mouse, it is possible to restore the proportion between the picture and its frame by using the right-click Resize Image Proportionally option.
- The right-click Resize Image to Fit Frame and Default Picture Size options allow to resize the image in its display area.
- The image is an object that can be formatted. Click the Layout button on the toolbar or select Modify Properties from the right-click menu on the image. Only box style changes are possible. As with the tree chart boxes, you have available presets applicable to the surround of the image.

**Print the tree chart**

Adjust the size of a tree chart

Before printing, you must make sure that the size and orientation of the paper are set as you wish.

1. Choose File > Page Setup or click Page setup in the Print Setup panel.
2. Select the printer you will use in the Name menu.
3. Choose a standard paper size in the Paper Size menu. If you want to select a customized paper size, choose Personalized Paper Size in the drop-down menu.
4. Click the round button corresponding to the desired orientation.
5. Click OK to confirm the print size.

If the tree is too large, you may change its size by reducing the number of pages in the Print Setup panel.

1. Select Display > Show/Hide Page Breaks or click the Pages > Show/Hide Page Breaks button. Heredis displays how many pages corresponding to the selected paper size will be needed to print the tree chart.
2. Change the number of pages in width and/or height.
3. To enlarge or reduce the overall size of the tree chart, enter a percentage in the Scale field or move the cursor. A value below 100% reduces the size of the tree chart, a value greater than 100% enlarges it.

It only remains to launch the printing of the tree chart.

**Launching the print-out**

Depending on the printer you are using, you can print the tree on one page or series of pages to be assembled together.

1. Click the Print button on the toolbar or choose File > Print.
2. Select the printer you want to use from the list of available printers. If your printer does not appear, select Find Printer in the Windows Print screen.

**Info** • For more information on adding a printer, type Add Printer in Windows Help.

3. Click OK to start printing.

**Export a tree chart**

Export the displayed tree to get it printed by a professional or share your Heredis trees with people who do not have the software.
Heredis constructs a tree chart using a file format that is likely to be used on other computers or devices in the form of a readable file.

1. Choose **Edit > PDF File Mode** or choose **PDF File** from the **Print Setup** drop-down menu.

2. The **Print** button changes form and name. Click the **Export** button on the toolbar.

3. Choose the location where the tree file in PDF format will be saved, if you do not want to save it in the default folder. If necessary, change the name of the tree proposed by Heredis in the **File Name** field.

4. Click **Save**.

**Save the tree chart**
Save the tree charts created with Heredis. You may modify or print them later.

**Saving a tree chart for the first time**

1. Click the **Save** button, choose **File > Save** or press **Ctrl-S**.

2. In the **File name** field, change the name of the tree chart if necessary.

3. Choose the location where the tree chart should be saved, if you do not want to save it in the default folder.

4. Click **Save**.

   After saving your tree chart for the first time, click again the **Save** button or press **Ctrl-S** to save it as you work.

   To obtain a copy of the tree chart and make further changes, select **File > Save a Copy**...

**Reopen a saved tree chart**
To reopen a saved tree chart and make further changes or print it, choose **File > Open** in a tree chart screen.
13 Exchanging

13.1 Importing and exporting data

Import data in GEDCOM format
The GEDCOM exchange format stands for Genealogical Data Communication. Almost all genealogy software programs recognize this universal format.

Import to a new file
1. From the Heredis Home Page, choose Open Tree > GEDCOM File.
2. The GEDCOM file must have the extension .ged to be recognized by Heredis. Select the file and click Open.
3. Save the new Heredis file to be created and wait while Heredis analyzes the data.
4. Check the information found in the GEDCOM file (quantity of data, structure of places). Open each field of places, to change, if necessary, the type of data it contains.
5. Complete the import options by ticking the information you want to find in your Heredis file (images, sources). You may add a source common to all events imported. In this case, tick the box and fill in the name of the source.
6. After importing the GEDCOM data, you must create the links that will connect imported persons to those already present in the main file.

Import Heredis data
Importing Heredis data to an existing file allows you to connect a new branch created in a separate file by yourself or by a family member.
2. Select the Heredis file. Only files created with the Blue Suite may be merged (Mac file or Windows folder with the extension .hmw).
3. Click Open.
4. After importing the new data, you must create links that will connect the imported persons to those already present in the main file.

Export data
You export your data to exchange them. If you want to transmit data to other genealogists who do not have Heredis for reading them, or if they are using an older version of Heredis, use the GEDCOM format. To share with other users of Heredis 2014 or to create branch files for your own use, use the Heredis export.

Info • Use the Sync function to transfer complete files to other people who have their device near to you or on a removable storage device (USB flash drive or external hard drive).

Export in GEDCOM format
2. Indicate the persons and types of data to be exported.
Info • Tick the Create a folder for media box to accompany the GEDCOM file with a folder containing all media attached to the exported data. The paths of the media listed in the GEDCOM file match the media in this folder.

3. Complete the information concerning the sender of the file. This allows the person receiving the file to identify you and to be able to contact you if necessary.

4. Choose the character set for data to be exported:
   - Mac: characters readable by all Mac software.
   - Windows (ANSI): use this format if you know the recipient of the file uses Windows software.
   - UTF-8: use this format to preserve all special characters. This is a recent universal file format. But note, some genealogy software programs do not support this format.

5. Click Export.

6. Give a name to the new file and choose where the file should be saved. Heredis proposes the same folder as your genealogy file. To select a different location, choose a location in your file directory, then click the Save button.

Export a Heredis file
2. Identify the persons and types of data to be exported.
3. Click Export.
4. Name the new file and choose where the file should be saved.

Select the data to be exported
The options for the exported file in GEDCOM or Heredis format are identical. They concern the persons included in the file and the type of data considered.

Select the types of data for export
1. Tick the boxes to include the different types of data in the exported file.
2. If you want to include notes (person notes, family notes or event notes), specify the export format of the text depending on the software to be used by your recipient.
   - Preserve Text Format (RTF)
   - No Formatting (Plain Text).

Select the branches concerned
1. Indicate if you export the entire file or a branch starting from the primary person by selecting Entire File or Branch from the drop-down menu.
2. Select the type of branch in the Branch Options drop-down menu: Ancestors - Descendants – Ancestors & Descendants.
3. Choose the number of generations of ancestors, of descendants, or both.
4. Specify the number of collaterals for the ancestor branches. Heredis goes back down the branch line for each direct ancestor to include them in the exported file.
   - 0 = only direct ancestors are exported (with spouses).
   - 1 = you export the direct ancestors with all their children and their spouses.
   - 2 = you export the direct ancestors, their children and grandchildren, along with their spouses.
   - 3 = you also add their great-grandchildren, etc.

Info • Remember to check who is the primary person displayed before making a branch export.

Select the persons to be included in an export file
1. Choose Export All Persons in the Limits drop-down menu to include all persons saved in the file.
2. To prevent the export of certain persons, choose **Exclude marked persons** or **Export Marked persons only**.

3. To protect the privacy of your data, please indicate your choice in the following drop-down menu:

   **Confidential Persons**: you may export all the information of confidential persons, or their surname only, or their surname and given names. You can also export all people by hiding the data. The recipient of your file will only know that such a person in a given place in the line existed, without knowing any information about him/her.

4. Tick the **Exclude Secondary Persons** box if necessary.

   **Info** • It is possible to exclude a branch from the exported file. Declare the person at the base of this branch as **Marked**, then choose the **Exclude Marked Persons** option in the export screen.

---

### 13.2 Synchronize with other devices

Today you frequently use your WiFi network to connect to the Internet. Heredis proposes to use it also to dialogue between your various devices (PC - Mac - iPhone - iPad - iPod touch) and transfer your data from one to the other.

Your computers are not on a WiFi network? You can also synchronize your genealogy via a removable storage device (USB flash drive or external hard drive).

Is there another version of the file on the WiFi network? Is it more recent? Heredis shows you all the devices where the Heredis software is open, as well as all removable storage devices plugged in to your computer.

How does synchronization work?

You may trigger a synchronization whenever you want.

Click the **Sync** button then the **WiFi** button or choose **File > Sync > Via WiFi**... Heredis opens the synchronization window for you to give your instructions and checks what other devices are present on the network.

If the genealogy file which is open has never been synchronized, choose an available device from the list and click **Send** to start the exchange. All your genealogical data and your media will be copied to the other device.

**Info** • Please note that the first synchronization copies all of your genealogical data and associated media to your other device. **Do not copy your file first**. This function only can mark your data as being duly synchronized.

If the open genealogy file has already been synchronized, choose the device with which you wish to synchronize. Depending on the most recent file date, Heredis will propose synchronization in one direction or other.

Heredis displays key information (change dates, number of persons, persons last modified) for comparison with those of the open file. If necessary, click the arrow to select the other direction for synchronization.

Click **Send** or **Receive** according to the direction of the synchronization. Only genealogical data or media that have changed are transmitted.

If the genealogy has been modified on both devices since the last synchronization, the synchronization is not possible until you have selected which file to keep and which to synchronize.

Click the arrow to select the appropriate direction then click **Send** or **Receive** according to the synchronizing direction which you have selected.

**Info** • To be synchronized, the genealogy file must have been saved. If it has been changed and not saved, Heredis will ask you to save it.
How to exchange without WiFi?

Those who have no WiFi network or do not have their devices in the same premises can synchronize their genealogy by connecting a removable device (USB flash drive or external hard drive).

Exchange with another PC or Mac

Synchronize your genealogy on a USB flash drive or an external hard drive. The synchronization process is the same as for the devices on the WiFi network.

Click the Sync button then the USB button or choose File > Sync > Via USB....

In the Synchronization window, select the device that you have connected, check the direction of synchronization then click Send or Receive according to the synchronizing direction you have selected.

Info • Do not forget to tick the Ensure compatibility with Heredis Mac box if your file is to be opened with a Mac.

When synchronization is complete, you may plug in the device to another computer (PC or Mac).

Whether on launching Heredis or during work, Heredis will inform you if a new genealogy or a newer version of the genealogy exists on the device you have connected and will propose to synchronize your computer with this genealogy.

13.3 Transmit without synchronizing

You can copy your genealogy in a format suitable for exchange with a Mac by using the Prepare for Heredis Mac function, or to a mobile iOS (iPhone, iPad, iPod touch) using iTunes.

Please note that in this case, it is not a synchronization (update of latest data), but a transfer of the complete file (including the media).

Exchange with a Mac

You want to send your genealogy file to a Mac? Heredis allows you to create a fully compatible file and transfer your data and media created on your PC to a Mac.

1. Select the menu File > Prepare for > Heredis Mac...

2. Choose the destination folder for the PC-Mac compatible file and press OK.

Heredis creates a copy of the original folder to which name it adds «-Mac». When saving the compatible file is finished, Heredis will open Windows Explorer to show you where the copy was made.

3. Transfer this folder to any user whose Mac has the Heredis Blue Suite installed; it will be recognized immediately and can be opened without conversion.

Info • If you do not use the Prepare for > Heredis Mac function, no Mac will recognize your genealogy file as a Heredis file.

However, Heredis for Windows will open directly any genealogy file from Heredis Blue Suite for Mac.

Exchange via iTunes

To transfer your genealogy to a mobile iOS, prepare the file to be sent via iTunes.

1. Choose File > Prepare for > iTunes...

Heredis creates a compressed file, recognizable by both iTunes and on your mobile iOS. This file contains all your data and all your media.

2. Click Yes to create the file. It has the same name as the original file with an extension .hmwit.
3. Heredis opens Windows Explorer to show you where the file is for transfer to iTunes.

   Insert the file into the iTunes application

1. Launch iTunes.

2. Connect your iPad, your iPhone or iPod touch and select it in iTunes.

3. Click the Apps tab (at the top of the screen), then scroll down the list of applications until you reach File Sharing.

4. Select Heredis. All genealogies already synchronized are visible. Click the Add button or drag & drop the file.

5. The transfer of the genealogy is carried out.
   If Heredis is not running on the mobile, the file will appear on the homepage the next time the App is launched.

Recover data from a mobile via iTunes
After a work session on the iPhone or iPad, retrieve the changed data by passing through iTunes again.

• Select the .hmw file modified on the Apps - File Sharing tab.
• To extract it from iTunes, click Save to… and save the genealogy file recovered to the location of your choice.

Info • Remember to select the same folder if you want to replace the existing genealogy file on your PC.

13.4 Publishing to Heredis Online

Heredis includes the creation of a personal online website for displaying your genealogy. No need to use a service provider, your data is hosted for free on Heredis Online. You have a real website dedicated to your genealogy, searchable by your family, friends and other genealogists, who will all have an overview of who your ancestors were, places where they lived and the various documents that you have found concerning them. In addition, Heredis allows you to be contacted by any person who is interested in your genealogy.

Create a Heredis Online account

You must create a Heredis Online account before publishing your genealogy, allowing you to access your account, to modify or delete published genealogies and to be identified as a person hosted by Heredis Online.

1. Click the Heredis Online button and choose My account or choose File > Heredis Online > Manage My Account from the menu. You can manage your account from the home page too.

2. Click the Create A Free Account button. Enter your email address, your username and your password. Complete the identification data and check out the Heredis Online Terms of Service and then tick the box.

3. Click OK your account is created.

Managing account information

Log in by entering your username and password. Do not forget to tick the Remember me box for the data to be stored for future use.

The Account Management screen allows you to change your login information and your address. Click the Edit button to access it.

Once you have published genealogies, they will appear in the lower part of the window.

Managing your publications

Click on the Visit Website link to view your online genealogy.

Click the indented wheel icon to change your settings for publication. There is no need to republish in order to view notes in your online genealogy, or to hide data which is less than 150 years’ old. Once you have changed the settings, they are applied to your personal website.

Click on the X button to delete the genealogy from your personal website.
Publish a genealogy to Heredis Online

Click the **Heredis Online button** and choose **Publish**.

Customize your site by giving it a name. Heredis will place by default that of your genealogy file. You may change the name because it will be included in the URL that you will communicate to your relatives and friends.

From the Your Website tab, add an illustration to your homepage to make it more attractive. You can display the main image associated with your root person, or select a photo from your hard disk: the village where your ancestors originated, a shield. Browse your hard disk to select an image.

Fill out the host text area; anyone who connects to your site must have an idea of what he will find there!

You have the choice of data you publish from the **Privacy tab**:

- Manage the display of contemporary persons by choosing the number of years to set the privacy level and decide if you want to display the full forename and name only or not to display at all.
- Display or not individuals who are declared as confidential or private in your genealogy file (individuals, events, notes ...)
- Choose to display or not all notes
- Display or not all sources
- You may also tick the Protect this publication with a password box, and enter a password in the corresponding text box and click OK. Thus, only the holders of a visitor password can access your publication. Other visitors will contact you by email to get the password.

Heredis Online displays a list of your published genealogies. You may follow the progress of moving your genealogy to your personal website. When publishing is complete, click on the link to launch your Internet browser and visit your site.

You will arrive on the home page of your genealogy. Click the Facebook button to share your genealogy on your Facebook page or click the Email button to send an email and share your genealogy website with your family and friends.

### 13.5 Publish group photos to Heredis Online

Heredis allows you to publish group photos on your personal site, as you do for your genealogies.

You will certainly have photos in which you have not been able to identify all the persons present in the photo. Heredis offers tools for identifying these persons and then for publishing the photo in a photo album.

This online album may be viewed by your family, your friends and other genealogists. Thus, visitors to your site may not only view your photos but contact you if they have recognized people in the photo.

In Heredis, you access this functionality from the **Identification tab** in the photo tool (for details on this tool, refer to the section **The photo tool** in Chapter 9).

**Create and set an album**

Once you have identified all the persons in a group photo, you may now share your photo album online by clicking the **Publish Button** at the bottom right on the **Identification tab**.

A simple interface allows you to connect to your account or create it if it is the first time you use Heredis Online (see paragraphs **Register** and **Log in** to publish your genealogy on Heredis Online).
When first published, you can change the title of the photo in the **Title** field. If you want to publish this photo in another album, unfold the dropdown list and choose the appropriate album, or create a new one by using the + button.

To personalize this album, click the indented wheel to the right of the + button and you can:

- give it a name that will be included in the URL that you will communicate to your family or to other genealogists. Do not worry about spaces, Heredis replaces them automatically by underscores.

- add artwork to make your homepage more attractive.

- give details of the content of this album in the Description text box. The person who visits your site will have an idea on what he or she will find in it!

You can protect your album by a password. Net users who know the password may view your album online and others will contact you by email to get the password.

When all the settings of your publication are satisfactory, click the **Validate** Button. Your photo is now published on Heredis Online.

**Info** • When you publish a photo which has been declared as private in Heredis, a message alerts you and asks for confirmation before continuing the publication.

**Settings and management of your albums**

You can at any time access the albums published from the **Album** tab in your account with Heredis Online.

Click the indented wheel to change the publishing settings for an album or on the cross to delete it. Please note that you will delete all the photos attached to this album.

**Info** • You can carry out these operations from a distance, even if you do not have your computer to hand, by logging into your Heredis Online account from any Internet browser.

Click the album name to display a list of all the photos in this album. You can edit or delete each picture individually.

**Consult an album**

By clicking on the link **Visit album**, Heredis opens the home page of the album selected in your internet browser.

In the left sidebar, you have the name of the album and its author, a clickable link to contact the author and immediately below, two tabs **Photos** and **Persons**.

In the **Photos** tab, a list of photos in the album is displayed and the total number of photos, (in brackets) next to the name of the tab.

In the **Persons** tab, the list and the number of persons identified in the various photos in the album are displayed, specifying, for each identified person, the number of times he/she has been identified in the various photos of the album. You also have a search box to locate any person in the list.
The central part allows for 3 different views of the album based on the tab selected in the upper part.

From the **Home** tab, you get an overview of your album where you will find the description text, any selected artwork and the pictures of the album in the form of thumbnails. To the right, Heredis displays the date of the last update of this album as well as a list of your genealogies and other albums already published on Heredis Online.

A single click allows you to open a new tab in your browser with the publication of the selected album.

The **Photos** tab displays each photo in the album in full screen. To the right of the photo, you find the list of numbered persons and below, the commentary and the date if they have been added from the Heredis program.

A button under the photo, also allows you to hide or show the frames numbers on the photo. Hover the mouse over any person identified in the photograph and the list shows the person concerned and vice versa.

Clicking on a person allows you to display him/her in detail in the **Persons** tab. You will then see the information collected for that person and a link to the publication if he/she is present in a genealogy previously published on Heredis Online, as well as photos, in the form of thumbnails, in which he/she has been identified.

When you click on a photo from the **Photos** tab in the left sidebar, Heredis automatically switches to the **Photos** tab in the central area and displays the details of the photo. If you are on the **Person** tab in the left sidebar, click on any person and you will move to the central area of the persons tab this time to display all known information concerning this person.

To go back to the general presentation of the album, click **Home** in the banner at the top.

**Sharing an album**

If you want to invite your family and friends to check out an album, send them the URL by email, or share it on Facebook. Use the ☮ or ☮ Buttons located in the upper right panel.

As a visitor to a Heredis Online album, you can easily send additional information or indicate an error to the author of the photo albums. Perhaps you have recognized an unidentified person. Click **Contact the author** in the left sidebar under the **ALBUM** area or in the footer and you will thus advance the work of the author.

**Private access**

You may protect your Heredis Online site with a password. Only visitors who know the password will be able to view details of your online genealogy. When any new web user visits your site, we will invite the person to contact you to obtain your password.

To implement this password: from your Heredis Online account, select the publication concerned and click the indented wheel x to access the settings for this publication. Then, tick the **Protect this publication with a password** box, enter a password in the corresponding text box and click **Validate**.
Available buttons

The buttons give you access to the principal management functions of the genealogy file.

<table>
<thead>
<tr>
<th>MAIN SCREEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
<tr>
<td>![Icon]</td>
</tr>
</tbody>
</table>

<p>| | Displays the Root Person of this genealogy |
| | Returns to the Heredis Home Page and allows management of genealogy files |
| | Saves the current genealogy file |
| | Synchronizes the open genealogy file with other devices turned on on which the Heredis software is open |
| | Selects which person to be added |
| | Selects which person to be deleted |
| | Creates or selects the father of the primary person |
| | Creates or selects the mother of the primary person |
| | Creates or selects a spouse for the primary person |
| | Creates or selects a child of the primary person and selected spouse |
| | Selects a new person not linked to the primary person |
| | Adds a personal connection between the primary person and another individual in the file |</p>
<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deletes the primary person</td>
<td>Removes the primary person from the genealogy.</td>
</tr>
<tr>
<td>Deletes the father link with the primary person</td>
<td>Removes the father link from the primary person.</td>
</tr>
<tr>
<td>Deletes the mother link with the primary person</td>
<td>Removes the mother link from the primary person.</td>
</tr>
<tr>
<td>Deletes the link with the spouse of the primary person</td>
<td>Removes the link with the spouse of the primary person.</td>
</tr>
<tr>
<td>Deletes the child link with the primary person</td>
<td>Removes the child link from the primary person.</td>
</tr>
<tr>
<td>Merges the primary person with another person</td>
<td>Merges the primary person with another person.</td>
</tr>
<tr>
<td>Displays notes on the primary person:</td>
<td>Shows notes for the primary person.</td>
</tr>
<tr>
<td>the Person note or the Family note for each of his/her spouses</td>
<td>Notes for the primary person's spouses.</td>
</tr>
<tr>
<td>Displays the data consistency analysis for the primary person</td>
<td>Checks the consistency of data for the primary person.</td>
</tr>
<tr>
<td>Launches a search for any person in the genealogy file</td>
<td>Searches for any person in the genealogy.</td>
</tr>
<tr>
<td>Allows to search for a person by surname and given name</td>
<td>Searches for a person by surname and given name.</td>
</tr>
<tr>
<td>Launches a search for any person by his/her genealogy number or user</td>
<td>Searches for a person by genealogy number or user number.</td>
</tr>
<tr>
<td>number assigned by you</td>
<td></td>
</tr>
<tr>
<td>Opens the Search tab to analyze data and launch Web Search</td>
<td>Launches a search for any person by genealogy number or user number assigned</td>
</tr>
<tr>
<td></td>
<td>by you.</td>
</tr>
<tr>
<td>Searches for duplicates in the open genealogy file</td>
<td>Identifies duplicates in the genealogy file.</td>
</tr>
<tr>
<td>Searches for all types of links between two persons</td>
<td>Searches for all types of links between two persons.</td>
</tr>
<tr>
<td>(common ancestors, kinship, other links)</td>
<td></td>
</tr>
<tr>
<td>Launches Search Status Report</td>
<td>Displays the search status report.</td>
</tr>
<tr>
<td>Accesses the different Indexes by type of data entered in the file</td>
<td>Views the different Indexes by type of data entered in the file.</td>
</tr>
<tr>
<td>Manages surnames in the file</td>
<td>Manages surnames in the file.</td>
</tr>
<tr>
<td>Manages given names in the file</td>
<td>Manages given names in the file.</td>
</tr>
<tr>
<td>Manages occupations in the file</td>
<td>Manages occupations in the file.</td>
</tr>
<tr>
<td>Manages places in the file</td>
<td>Manages places in the file.</td>
</tr>
<tr>
<td>Manages sources in the file</td>
<td>Manages sources in the file.</td>
</tr>
<tr>
<td>Manages media in the file</td>
<td>Manages media in the file.</td>
</tr>
<tr>
<td>Opens the tree chart construction screen</td>
<td>Opens the tree chart construction screen.</td>
</tr>
<tr>
<td>Selects another graphical theme for the application</td>
<td>Chooses a different graphical theme for the application.</td>
</tr>
<tr>
<td>Icon</td>
<td>Function</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------------------------</td>
</tr>
<tr>
<td>?</td>
<td>Opens the Help manual in PDF format</td>
</tr>
<tr>
<td>Wrench</td>
<td>Launches the customization of the toolbar</td>
</tr>
<tr>
<td>Gear</td>
<td>SCREEN FOR MANAGEMENT OF TREE CHARTS</td>
</tr>
<tr>
<td>Gear</td>
<td>Allows to change the display settings of the tree chart</td>
</tr>
<tr>
<td>+</td>
<td>Adds an illustrated image to the tree</td>
</tr>
<tr>
<td>-</td>
<td>Deletes the selected illustrated image</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the displayed tree chart</td>
</tr>
<tr>
<td>Gear</td>
<td>Opens the formatting screen for the selected boxes</td>
</tr>
<tr>
<td>Printer</td>
<td>Launches the printing of the displayed tree chart on a printer</td>
</tr>
<tr>
<td>PDF</td>
<td>Launches the export of the tree chart in PDF format</td>
</tr>
</tbody>
</table>
### Functional Shortcuts

#### General Commands
- **F1** Help
- **Ctrl F4** Close active window
- **Ctrl 2** Show/Hide search reports
- **Ctrl 3** Show/Hide work reports
- **Ctrl Q** Quit Heredis
- **Alt F4** Quit Heredis

#### File Management
- **Ctrl N** Create new genealogy
- **Ctrl O** Open a genealogy file
- **Ctrl S** Save a file or tree chart

#### Edition
- **Ctrl X** Cut
- **Ctrl C** Copy
- **Ctrl V** Paste
- **Ctrl A** Select All
- **Ctrl Z** Cancel action in a text zone
- **Ctrl Maj Z** Redo typing in a text zone

#### Navigation
- **Ctrl 1** Display Root Person
- **F9** Display Father
- **F10** Display Mother
- **F11** Display Selected Spouse
- **F12** Display Selected Child
- **F5** Display Family tab
- **F6** Display Data tab
- **F7** Display Lineage tab
- **F8** Display Search tab

#### Data Entry
- **Tabulation** Move from field to field
- **Ctrl F8** Enter a new person
- **Ctrl F9** Add the father
- **Ctrl F10** Add the mother
- **Ctrl F11** Add the spouse
- **Ctrl Maj F11** Add a Spouse of the child in the Family Group Data tab
- **Ctrl F12** Add a child
- **Entrée** Validate choice or entry of a person, name, place, source or media
- **Ctrl H** Tag the primary person as Childless
- **Ctrl J** Tag the primary person as Unmarried
- **Ctrl K** Tag the primary person as Secondary
Ctrl L  Tag the primary person as Marked
Ctrl M  Tag the primary person as Confidential

Search

Ctrl 1  Display the Root Person
Ctrl F  Launch Search by name
Maj Ctrl S  Launch Search by number (Ahn # or User #)
Maj Ctrl M  Launch Multiple Search

Tree Chart Management

Ctrl A  Select All
Ctrl O  Open a tree chart
Ctrl S  Save chart
Ctrl P  Print chart
Ctrl F4  Quit chart
Ctrl Z  Cancel movement in chart
Ctrl Y  Restore movement in chart
Maj Click left  Widen the selection or deselection
Ctrl Click left  Widen the selection or deselection
Alt Click left  Zoom in on a chart zone
Alt Click right  Zoom out on a chart zone
Ctrl wheel  Zoom in or Zoom out on a chart zone
Space  Display Hand to move around the chart
Ctrl Left-click  Mark a theme as bookmarked in the theme selection screen